Announcements :  K-Meleon Forum
 

Pages: 12345...LastNext
Current Page: 1 of 37
Results 1 - 30 of 1083
Yesterday
JohnHell
I'm lost, what are you replying me about? If you mean javascript working after toggle javascript that's a GRE feature, happening too in Firefox.
Forum: Bugs
2 days ago
JohnHell
That doesn't work either. For me doesn't crash as for JamesD, just shows the alert but with 3 unknown characters (you know, the bolded tall line characters when unknown).
Forum: Bugs
2 days ago
JohnHell
Okay, thanks! I read about it, just wasn't quite sure how far that fix helps. And it also helps to return again a variable into a macro var? Not fully working. JamesD tested it, and I tried too, but no luck. Read about it here: http://kmeleon.sourceforge.net/forum/read.php?8,131009,131398,page=4#msg-131332
Forum: Bugs
2 days ago
JohnHell
BTW I didn't asked to the mozilla community yet about javascript working after disable it after load the page. It's driving me crazy. In K-meleon 75. Yeah, it's a no-go for me too. Just hoping dorian or someone figures out how to change that again. Just curious, did you try if injectjs can overrule it now? Yes, injectJS was fixed in K-meleon 75 beta 1 update 1
Forum: Bugs
2 days ago
JohnHell
Never used CAPS and when I decided to, they removed XD So I can't confirm that. Off topic: BTW I didn't asked to the mozilla community yet about javascript working after disable it after load the page. It's driving me crazy. In K-meleon 75.
Forum: Bugs
2 days ago
JohnHell
Global javascript.enabled preference, when set to false, has been over per site options ever, or am I wrong? I'd bet for has been this way ever.
Forum: Bugs
3 days ago
JohnHell
I've been all the week without even switching on the PC, so, I hope is not late: Are you having the same issue that, quite often, but not much, K-meleon process keep open and, therefore, you can't open again unless you kill the process? In the last minutes I had happening to me 3 times visiting groups.gooogle.com and the global stats page of statcounter gs.statcounter.com. Are you
Forum: Announcements
6 days ago
JohnHell
Yes, I'm on Windows 2000. But with some kind of errors, unless I forgot to, I test them in the XP SP2 virtual machine I have and this error happens on XP too. And it's quite annoying to go, open the virtual machine, test with its damn slowness, and report, and if I forgot to test it and I'm writting something here to report, I spent time in open the VM, run it, test, back, confirm and ask yo
Forum: Announcements
7 days ago
JohnHell
Another issue, or completing it, I just found with the # symbol in one of my url cleaning macros. It happens that if it is placed in between two macro code lines, the next line is not executed. If we have this is the difference between have an alert or don't have. whatever{ # alert("hello"); } whatever{ alert("hello"); } Looks like works as it was pla
Forum: Announcements
7 days ago
JohnHell
I've been all the week without even switching on the PC, so, I hope is not late: Are you having the same issue that, quite often, but not much, K-meleon process keep open and, therefore, you can't open again unless you kill the process? In the last minutes I had happening to me 3 times visiting groups.gooogle.com and the global stats page of statcounter gs.statcounter.com. Are you a
Forum: Announcements
12 days ago
JohnHell
In the macro language, when there is a line with just a single #, no more, no less, causes a parsing error. The only way it fixes is when you add two lines with # conscutive, or removing them: Perhaps I don't correctly understand but I cannot confirm. The following code exists and I ran the macro. As expected, nothing happened and nothing showed in console 2. _Snippet_RunCode {
Forum: Announcements
13 days ago
JohnHell
Are you having the same issue that, quite often, but not much, K-meleon process keep open and, therefore, you can't open again unless you kill the process? In the last minutes I had happening to me 3 times visiting groups.gooogle.com and the global stats page of statcounter gs.statcounter.com.
Forum: Announcements
14 days ago
JohnHell
Two last suggestions (for today, sorry for the flood): - error warning with a hint where on skin.cfg is the error causing no icons - explain or remove the feature that if the size of the bars is, for example 48, the icons get streched out to the bar if are defined smaller or get shrink if bigger. I'm not against toolbars of the same size, but is useless to specify an icon size when they a
Forum: Announcements
14 days ago
JohnHell
Another issue: the toolbars button aren't synched unless you move the mouse in the window or hover on those icons when you use an accelerator (obviously, not clicking on them ;) that works as ever).
Forum: Announcements
14 days ago
JohnHell
Another thing: The security icon in the right bottom corner vanishes quite randomnly when switching from full screen to normal window and vice versa and opening new windows. Looks related from going to a unsecure site to a secure site and vice versa when opening new windows. Can't describe an exact pattern to reproduce. Just browse from one to other pages switching from full to normal. ED
Forum: Announcements
14 days ago
JohnHell
When I right clicked on a an image and chose Zoom In or Zoom Out that one image. it did not work a all on images from different websites. Right click on an image and selecting Zoom In or Zoom Out does seem to work for me after the update 1 is applied. It doesn't work for me. In fact, it randomnly crashes when treating the image in different ways, but for zoom in and out the crash is gu
Forum: Announcements
14 days ago
JohnHell
Update 1 The update fixes injectJs and other things mentionned in the thread YAY!!! injectJS works! Here I come joining the beta users troop :D @Dorian, the skinning problem of black backgrounds with the new skin system still persists under Windows 2000, but, if you keep the old system, I have no more problems as the old have transparent icons. So, I'll keep the old skinning on my s
Forum: Announcements
16 days ago
JohnHell
@ Yogi I went back and re-saved the images with the transparent blocks un-checked. Saving with png still loses a lot of definition. @ adodupan Both the green flag and the restart button, next to the throbber, are created with macros. However I cannot swap the green flag for red one. http://dl.dropboxusercontent.com/u/1522294/Klassic_in_75_no2.png Oh..., yeah, that greenish...
Forum: Development
16 days ago
JohnHell
Tested and PNGs+magenta background result in transparent background, so it's fine, as remove any deal with alpha channels and transparency selections. Just a conversion from BMPs to PNGs, even it is not needed, it's enough. So there isn't any need of adaptation of current skins beyond skin.cfg and toolbars.cfg. And I see them as Yogi. No difference :-?
Forum: Development
16 days ago
JohnHell
Fixed. Sometimes, when I select more than one file to share (by default all are private) Mediafire tells all were made public to share, it changes the icon from private to public and, then, happens this :/ Sorry.
Forum: General
16 days ago
JohnHell
Just to note, the Klassic images without magic pink are really bad. Mmmmm, what do you mean? Any screenshot to compare? What is funny here is that your PNGs with magenta background are taken as transparent background, even they don't have an alpha channel or a transparency color, at least it is being taken as transparent (aka black background) in Windows 2000. Later I'll check in XP, just
Forum: Development
16 days ago
JohnHell
You were right 4td8s. It is... nothing, just a minor "whatever", but it is the difference from watch a choppy 480p flash video in some sites and watch it quite fluid, even on both the CPU is at 100%. So: NPSWF32_13_0_0_259.7z NPSWF32_16_0_0_235.7z And as some sites keep complicating the download task of their videos... I'll stick for the ESR. Note that these versions ar
Forum: General
16 days ago
JohnHell
Big question is if there is some cache with the skin.cfg information that I should empty? I had the wrong name for png file that I had named tools1.png. It should have been zoom.png. I made that change to your file, then restarted KM 75. I still get the pictures from tools1.png. All I have done are tests, as in Windows 2000 it isn't working the background transparency, as I guess you re
Forum: Development
17 days ago
JohnHell
In XP the C++ error also happens so, just discarding windows 2000. Also, @Dorian, I think that if there is not dead or cold or whatever image (the second and third rows), shouldn't create this effect, in my opinion: http://s19.postimg.org/pop46uyq9/km75newskinbuttons.gif Regardless of the window title, that is K-meleon 75b1, not K-meleon 74 ;)
Forum: Announcements
17 days ago
JohnHell
Your MyKlassic2 skin.cfg. I corrected several commas where shouldn't be, a "name" lost and other similar errors. As I didn't change anything in toolbars.cfg I don't know if it will work as you want, but at least it shows icons on my system, so, for me, looks fixed. Skin.js is only for the default position. I don't have it and it isn't a problem. As well as skin.dat you created (
Forum: Announcements
17 days ago
JohnHell
You need the {} because you have 3 property/value pairs. Properties/values are ever inside {} What could be removed should be the [ ] but, if you remove them, you get a C++ error. Aren't you having that error? At least it happens in Windows 2000. Haven't tested further. Probably the code by Dorian is expecting an array (of images declaration) checking for its length (the length of the arr
Forum: Announcements
18 days ago
JohnHell
For all who use use Notepad++, try this: http://www.sunjw.us/jstoolnpp/download.php @Siria, you should use the ascii version to work on Windows 98. It is not strictly coloured, but helps a little.
Forum: Development
18 days ago
JohnHell
For all who use use Notepad++, try this: http://www.sunjw.us/jstoolnpp/download.php @Siria, you should use the ascii version to work on Windows 98. It is not strictly coloured, but helps a little.
Forum: Announcements
18 days ago
JohnHell
Yes, the toolbars.cfg in root\browser\defaults\settings is paired with skin.cfg in the Default skin. All skins need both, a skin.cfg and a toolbars.cfg, unless you reuse the default toolbars.cfg. But skin.cfg must be unique for every skin, at least, so it uses the images of its skin directory. @Siria, that wasn't made with an editor, but with an image editor to make the image and it wasn't e
Forum: Announcements
18 days ago
JohnHell
Has anyone converted a skin to the new system. I have been trying but seem to have a problem. I suspect that I have a few too many or less of the "[ ]" or "{ }" symbols in my cfg file. If someone could point out my error, I would be greatfull. https://copy.com/9SJ3OwA0AVyDqBhx Yes, you have some lost ], if I'm not wrong. I'll create a tree structure to under
Forum: Announcements
Pages: 12345...LastNext
Current Page: 1 of 37

K-Meleon forum is powered by Phorum.