Development :  K-Meleon Forum
K-Meleon development related discussions. 

Pages: 12345...LastNext
Current Page: 1 of 120
Results 1 - 30 of 3595
Yesterday
JamesD
The code in my extension should pass for a work-a-round. see http://kmeleonbrowser.org/forum/read.php?9,140309
Forum: General
Yesterday
JamesD
I have made a small work-a-round for Print Preview. Since version 74 or 75 Print Preview has not worked in K-Meleon. Reference http://kmeleonbrowser.org/forum/read.php?1,138874 The attached file is not all a user must have for this to work. One needs a portable SumatraPDF. It should be placed in the KMroot\browser\plugins folder. I was able to obtain this one from the author's site.
Forum: Extensions
Yesterday
JamesD
This works. You don't need Sumatra installed but portable exe should be in KM plugins folder... Great! Thanks. That works. I just never used the portable before. Now, if my wife does not need me for a little while, maybe I can get the macro put together.
Forum: General
3 days ago
JamesD
Looks like the operating system might be preventing my work a round from finding Sumatra. I have a 64 bit system and so the SumatraPDF is loaded in Program Files (x86). The DLL is from an older version of Sumatra than the one I am using. Either it is looking in the Program Files folder or for the earlier version. I have the "npPdfViewer.dll" file in both root\plugins and in root\br
Forum: General
3 days ago
JamesD
Does anyone know if the KM versions 75.x or 76.x still have the ability to read a dll file in the plugins folder? If so, where should I have the plugins folder? It does not work in browser\plugins. What if I try root\plugins?
Forum: General
3 days ago
JamesD
I have Win 10 operating system and it comes with Microsoft Print to PDF and Microsoft XPS Document Writer. I am not sure what was in my Win 7, but I had something there also. I hate to waste paper printing an online receipt so I use writing to a PDF quite a lot.
Forum: General
5 days ago
JamesD
I just went to www.getthelabel.com and the dropdown menus work for me. I tried 75.1 and 76RC2 versions. Both work OK. I tried with Javascript on and off. The site is cleaner with js but the menus work in either case. What do you see or not see for menus?
Forum: Bugs
4 weeks ago
JamesD
It works for new written links (if configured so) - but not for ctrl-t, a mouse gesture, or right-click "open in new tab" Check and see if your "menus.cfg" file has the lines in red below. I am using KM 76 RC2 and I can right click and choose Open in Background. If you do not have this code, just copy these lines into your menus.cfg file and save it. LinkOpen{
Forum: Improvement requests
4 weeks ago
JamesD
Sessions are handled by a Dynamic Link Library (DLL) file. I think only the developer could change that. I will try to research some and see if there is a way achieve your goal by another method.
Forum: Improvement requests
5 weeks ago
JamesD
There are two ways to obtain the print function. One is to use the acellarator keys "CNTL P", and the other is to turn on the menu. To turn on the menu, I just use the F2 key and go to toolbars under GUI Appearance. In the General tab there a checkbox to "Hide the menu bar". If you un-check that box and restart KM, you will be print from the FILE menu. Note that there are
Forum: Bugs
5 weeks ago
JamesD
I used "horses" without the quotes and the URL returned was: https://www.startpage.com/do/search They submit your search to Google and strip out some stuff. I don't know.
Forum: Extensions
5 weeks ago
JamesD
Luys There are two files needed plus 7-Zip must be installed. There is a macro (kmm) and a javascript (js) which I place in the macros folder in my profile. Since I need access to files usually held by K-Meleon when it is running, the method is to run the macro and exit KM. Upon exit the js file runs and creates a 7z file. To import one only needs to use 7-Zip to extract the information int
Forum: General
5 weeks ago
JamesD
Sessions are snapshots of the URLs in windows and tabs when the session is saved. The data in the URLs may or may not have changed when one views the session later.
Forum: General
6 weeks ago
JamesD
It depends. If your search engine uses the "urlkey" like Google and Bing, then it should work. However, if you use another search engine then the "urlkey" might be different. I use DuckDuckGo and my "urlkey" is "/?q=" instead of the "/search?q=" that is automaticly included in the test version of the macro. If using DuckDuckGo change the fol
Forum: Extensions
6 weeks ago
JamesD
And just so that you hear from the other side, I never reuse a profile. I export, using my own method, all the passwords, etc. and import into a new profile which KM builds on its first run. When I tried to import my 75.1 passwords, my system failed. I then looked and found that the storage method had changed. My solution was to run both 75 and 76 at the same time and use View Data passwords
Forum: General
6 weeks ago
JamesD
I think I may know the problem. It is the urlkey. My search from DuckDuckGo is "https://duckduckgo.com/?q=copper&ia=web". The default key is "/search?q=". I will edit my config and change to "/?q=". Edit:: That works. I have item in Find in Page field. Edit #2 :: Suggestion Check pref "kmeleon.general.searchEngine" after line 47 "$_
Forum: Extensions
6 weeks ago
JamesD
not sure about macros lineorder bug: can setclip sw1 work if value deleted at almost same time?? I don't think it is a problem. The following works for me. _findtry_oper1 { macroinfo = "Run the findtry test." ; $_findtry_CurrClip = getclipboard(); id(ID_EDIT_COPY); id(ID_EDIT_FIND); id(ID_EDIT_PASTE); setclipboard($_findtry_CurrClip); id(ID_EDIT_FINDNEXT); alert($_f
Forum: Extensions
6 weeks ago
JamesD
siria Perhaps I do not test correctly, but in KM 75.1 and in KM 76RC2, I do not get any value in the "Find in page" field. I tested this way. 1) Copy macro to macros folder in my profile. 2) Start KM and saw the new macro notice. 3a) Type one word in the search input field. 3b) Type one work in URL bar. 4a) Click OK to run search and get results in a new tab. 4b) Press Ente
Forum: Extensions
6 weeks ago
JamesD
siria This is another way the user might try to put a value into the field. findtry.kmm # K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage2) # # ---------- findtry.kmm K-Meleon Macro Language --------------- # ---------- verify that selected text can be put into "find" field # # Dependencies : - main.kmm # Reference
Forum: Improvement requests
6 weeks ago
JamesD
siria I was wrong. Your testclip does work. I copied the name line but did not put an * to make it a comment.
Forum: Improvement requests
7 weeks ago
JamesD
siria As written, testclip, does not run on KM76. Have an idea that the new "popupmenu" macro statement with prompts can be used. I will try to make something, but can promis no timeframe. Age, bad eyes, and disabilities are slowing me down.
Forum: Improvement requests
7 weeks ago
JamesD
The RC version has had more bugs fixed than has the beta. I do almost all of my browsing using the K-Meleon 76RC2. That is the RC with one update. I am not sure that the 2 in the name is official. That is just what I call it.
Forum: General
2 months ago
JamesD
I'm confused about its unavailability in 75,1 I just used my KM 75.1 to access the system. They have added one more book by Mary Jo Putney since yesterday. I think the 'tor' stuff allows a user mask where he is and tell the server the computer is in another place. I tried to use Tunnel Bear to make it seem like I was in Europe when I actually am in North Carolina, USA. I just have
Forum: Development
2 months ago
JamesD
I am sure the I must not understand the problem. I do not have an ID for the library system, so when I try to log on to the system, I get the following message. You have entered an invalid barcode/username or password. Please try again. Don't forget that the password is case sensitive. You have used 1 out of 10 login attempts. After 10 have been used, you will be unable to login for 5 mi
Forum: Development
2 months ago
JamesD
I think this is what I have now. Sorry for any extra data. The first section is from my KM 76 config and the second is from my registry. It is the output from Regscanner with the search parameter set to 'cleartype'. I don't understand the registry stuff about Internet Explorer. I think that I have only Edge, KM-75.1 (default), and KM-76RC2 loaded. gfx.font_rendering.cleartype.always_us
Forum: Off-Topic
2 months ago
JamesD
So, you have cleartype in windows display settings and in K-meleon settings disabled, I guess. If not, have a look to them and check what do you find better. I made my choice by looking at the images in your post. I do not know what my machine's settings are. I am on Win 10 and I stay confused by the settings there. In display settings there is a check mark in the "Turn on clear t
Forum: Off-Topic
2 months ago
JamesD
The normal font seems better for me. I have bad eyesight and requires the 1280x720 resolution. The GeForce 210 and the 2269 monitor can display much more, but then it is too small for me to read text. Graphics Monitor Name 2269W on NVIDIA GeForce 210 Current Resolution 1280x720 pixels Work Resolution 1218x720 pixels State Enabled, Primary Monitor Width 1280 Monitor
Forum: Off-Topic
2 months ago
JamesD
Yeah the phorum software is definitely a very special case. Since Dorian finally installed the plugin that lists all new postings of all subforums in a single overview page, I've been using only that one. Had badly missed that for years. http://kmeleonbrowser.org/forum/addon.php?0,module=recent_messages WOW! That is a good thing to know. This goes in my hotlinks for sure. If this b
Forum: Announcements
2 months ago
JamesD
Mark Your post is the first I have heard of PDF.JS. I have downloaded the stuff and can open viewer.html in K-Meleon. I have not been able to figure out how to change the pdf file to a local one. Any idea on how to use this such that the file to which one links in the browser is shown? I rarely show PDF files in the browser and I have adapted an old dll from SumatraPDF for my purpose.
Forum: Improvement requests
2 months ago
JamesD
I have noticed that when using KM-76RC2 that I am not taken to the correct place in the forum if I click on the "NEW" or "Last Post" links. These seem to work fine in KM-75.1 version. When I clicked on "NEW" for this thread I should have been taken to the previous post. see below: Re: K-Meleon 76 RC new Posted by: Mercury048 Date: September 19, 2016 05:55AM
Forum: Announcements
Pages: 12345...LastNext
Current Page: 1 of 120

K-Meleon forum is powered by Phorum.