Off-Topic :  K-Meleon Forum
All which isn't K-Meleon related. 

Pages: 12345...LastNext
Current Page: 1 of 94
Results 1 - 30 of 2818
2 days ago
JamesD
There is a text only button on the right end of the privacy bar. If anyone can tell me what it is and from where it comes, that would certainly help out. I have found the source. I have a macro file named "Flash74.kmm" in my profile. It comes from there. I don't remember when I got that file or why. If I stop it from loading, the text button is gone. I worry that some of the
Forum: Development
2 days ago
JamesD
I have loaded my personal skin in the new KM 75 format to a server for any who would like to look at the code. Please note that the 7z file should be extracted to the KM root because it includes a new macro. I could have added a few lines to main.kmm, but I did not want users who were just testing to be required to do that. https://copy.com/9SJ3OwA0AVyDqBhx It works, but I am not entirel
Forum: Development
2 days ago
JamesD
@ JohnHell Do you think it is possible for the '# alone' problem to be related to the operating system? I am on Win 7 (32 bit) and it does not happen to me on KM 75b1u1. My memory is hazy, but are you still on Win 2000?
Forum: Announcements
3 days ago
JamesD
Regarding all my previous posts and pictures, it looks like I was the architect of my own destruction. My skin.cfg file was lacking one pair of brackets. Once found and fixed, the skin is working much better. My thanks to all who provided input to help me. Dorian, I am sorry if I made extra work for you. I will post the skin as soon as I complete a bit more work on the graphics.
Forum: Announcements
8 days ago
JamesD
One more problem with the skin running update one. I clicked on a link in Daily Rotation with the skin looking correct. The link opens in a new window. http://dl.dropboxusercontent.com/u/1522294/KM75b1u1_newWindow.jpg I had previously moved the green flag slightly to the left to get the throbber to show. When the new window opened, the flag was as far left as it could go and the entire
Forum: Announcements
8 days ago
JamesD
In the macro language, when there is a line with just a single #, no more, no less, causes a parsing error. The only way it fixes is when you add two lines with # conscutive, or removing them: Perhaps I don't correctly understand but I cannot confirm. The following code exists and I ran the macro. As expected, nothing happened and nothing showed in console 2. _Snippet_RunCode {
Forum: Announcements
8 days ago
JamesD
the toolbars button aren't synched unless you move the mouse in the window or hover on those icons Confirmed.
Forum: Announcements
9 days ago
JamesD
I have both a success and a failure to report. I am not an expert on injectJS() so the failure may be mine. I ran a macro with the following code. The first alert was correct and showed the datetime. Before the second alert could display my KM 75 failed with an error. $_Datetime_Value = injectJS( "Date()"); alert( $_Datetime_Value, "datestring", INFO); $_Datetim
Forum: Announcements
9 days ago
JamesD
One more update on my missing throbber. When I started KM 75b1u1 tonight, it was gone again. http://dl.dropboxusercontent.com/u/1522294/throbber_position_02.png It does not show well on the photo, but there is slight shadow where the throbber should be. It is right below the right half of the window close button and right above my app exit button. A second item is that when I looked at
Forum: Announcements
10 days ago
JamesD
Something in the update has taken away the throbber. I don't remember what the throbber looked like in default, but it now does not display in Klassic, MyKlassic, and MyKlassic2. I have an update to the above statement. The throbber was not gone. It was offscreen. When I was testing some movement of items and their positions after a restart, I would at times recover the throbber. I was
Forum: Announcements
11 days ago
JamesD
When I right clicked on a an image and chose Zoom In or Zoom Out that one image. it did not work a all on images from different websites. Right click on an image and selecting Zoom In or Zoom Out does seem to work for me after the update 1 is applied.
Forum: Announcements
11 days ago
JamesD
InjectJS seems to be working. I am no expert but the JStest macro by siria did do the the tests one and four for me.
Forum: Announcements
11 days ago
JamesD
Something in the update has taken away the throbber. I don't remember what the throbber looked like in default, but it now does not display in Klassic, MyKlassic, and MyKlassic2. The problem where changing to or from default makes the background appear or disappear immediately upon making the choice and before restarting KM remains. The problem of the title not being updated in, or being ab
Forum: Announcements
11 days ago
JamesD
@ Dorian Thanks ever so much.
Forum: Announcements
11 days ago
JamesD
http://dl.dropboxusercontent.com/u/1522294/Klassic_in_75_no3.png Hard drive space is cheap. These images are the arrays as bitmaps. My old eyes like these much better.
Forum: Development
12 days ago
JamesD
@ JohnHell I seem to be able to change skin.cfg now and get the results to show in KM 75b1. I don't know what I was doing wrong before. @ Yogi I went back and re-saved the images with the transparent blocks un-checked. Saving with png still loses a lot of definition. @ adodupan Both the green flag and the restart button, next to the throbber, are created with macros. However I c
Forum: Development
12 days ago
JamesD
Can't confirm on Win7. I can't see no difference between magic pink BMP and transparent PNG. I believe that I have said before, "I am not a graphics expert." I used Infranview to make magic pink transparent. http://dl.dropboxusercontent.com/u/1522294/Klassic_in_75_no1.png @ adodupan If you mean macros creating bars and buttons, I have done that. The problem that I
Forum: Development
12 days ago
JamesD
Thanks for the info. I am going to go back to the original of the skin that you sent, and try again. Just to note, the Klassic images without magic pink are really bad.
Forum: Development
12 days ago
JamesD
I have moved the skin discussion to: http://kmeleon.sourceforge.net/forum/read.php?2,131277
Forum: Announcements
12 days ago
JamesD
@ JohnHell, Per your suggestion I am moving this discussion from the Announcement forum to Development. I got the skin that you posted and it did work. I had really balled up the one that I posted. Big question is if there is some cache with the skin.cfg information that I should empty? I had the wrong name for png file that I had named tools1.png. It should have been zoom.png. I made
Forum: Development
13 days ago
JamesD
I added the {} inside the [] but there was no change. No, I have not gotten a runtime error in C++. I had high hopes that when I removed the skin.js file from the folder then the code for skin.cfg would be read. Unfortunately there was no change.
Forum: Announcements
13 days ago
JamesD
@ JohnHell If I have only one image for each "image & command" group, do I need the braces within the brackets for the image? { "images": [ "name":"tools1.png", "width":16, "height":16 ], "commands": [ "sessions(Undo)", "macros(LoadTime_RunCode)",
Forum: Announcements
14 days ago
JamesD
@ JohnHell Thanks, I am work it using your picture. I did find that I had many errors. So far, I have not found them all. I still see no buttons at all. I am making the assumption that a file in the skin overrides the one in root\browser\settings.
Forum: Announcements
14 days ago
JamesD
Has anyone converted a skin to the new system. I have been trying but seem to have a problem. I suspect that I have a few too many or less of the "[ ]" or "{ }" symbols in my cfg file. If someone could point out my error, I would be greatfull. https://copy.com/9SJ3OwA0AVyDqBhx
Forum: Announcements
15 days ago
JamesD
I have tried auto clear cache on shutdown on both 7431 and 75b1 and I have not gotten a trash folder.
Forum: Bugs
17 days ago
JamesD
If you don't want to modify your main.kmm then this should help. http://kmeleon.sourceforge.net/forum/read.php?3,129936,130931#msg-130931
Forum: Bugs
17 days ago
JamesD
I have made changes in MacroLanguage and Command IDs to include the "command name" alternate identification for Command Ids. I also now have a Spanish translation for the menu. https://dl.dropboxusercontent.com/u/1522294/LocalDocs74.7z
Forum: Development
22 days ago
JamesD
Yogi and JujuLand Agreed that cookies not shown. Also check out the Preferences > Privacy & Security > General > Currently Stored Cookies. Nothing is shown but when I tried clicking the button a second and third time the entire preferences panel was reduced in size.
Forum: Announcements
22 days ago
JamesD
am having a little trouble understanding two of the Command IDs from the list Dorian referenced in the first post of this thread. The IDs are: ID_HIGHLIGHT ID_MATCH_CASE Of the 85 IDs in the cpp, these are the only two for which I can find no documentation. I have determined that they have to do with the text/buttons associated with the "Find in Page" item from the edit menu.
Forum: Announcements
24 days ago
JamesD
I am having a little trouble understanding two of the Command IDs from the list Dorian referenced in the first post of this thread. The IDs are: ID_HIGHLIGHT ID_MATCH_CASE Of the 85 IDs in the cpp, these are the only two for which I can find no documentation. I have determined that they have to do with the text/buttons associated with the "Find in Page" item from the edit menu
Forum: Announcements
Pages: 12345...LastNext
Current Page: 1 of 94

K-Meleon forum is powered by Phorum.