Graphics :  K-Meleon Forum
All about K-Meleon icons, skins and throbbers. 

Pages: 12345...LastNext
Current Page: 1 of 101
Results 1 - 30 of 3030
Yesterday
JamesD
But comparing the features between Firefox and K-Meleon, to reset the zoom, Firefox uses Ctrl-0, and K-Meleon Ctrl-Kp_Multiply Nice, except I don't know were is this key ... Ctrl-Kp_Multiply I tested wit Ctrl-* on keyboard and numpad, but it seems not to be that, or it don't work under Linux ... The Ctrl-Kp_Multiply ( keypad *) works under Win 7 for text zoom. The Ctrl-0 thru Ctrl-9 ke
Forum: Announcements
3 days ago
JamesD
how to move menu item using just a index (without deleting menu item) If by 'move' you mean up or down in the list, I think you must swap the index of the items and rebuild the list. It would be cumbersome to do.
Forum: Announcements
3 days ago
JamesD
How to remove separator from the menu? In the setmenu statements I think removing the menu item to which the separator was attached will remove the separator. setmenu( MENU_NAME, SEPARATOR, "SOME MENU ITEM"); Removing "SOME MENU ITEM" also removes the separator.
Forum: Announcements
4 days ago
JamesD
This file is important. browser\components\KmeleonMain.js The menu item came from it and there are observers set also. This may be well beyond my knowledge. I will give a little more time and see if I get any results. I do not plan to make it my life's work.
Forum: Development
5 days ago
JamesD
PageInfo option doesn't need such a registration (as it's called as a separate XUL-window not as about:-page). But it may need some dependencies in all that stuff, added by naruman. The goal is to find it, clear from unneeded stuff and add to regular KM's omni.ja. Not too sure about the registration. I got a message about "no chrome package registered" until I put the following
Forum: Development
5 days ago
JamesD
@ rodocop Disregard my previous post. While I have not found the menu item in naruman's code, I can make a menu item to call the pageInfo.xul file. How does one put code from this path:: "browser\chrome\browser\content\browser\pageinfo" into this path (omni):: "chrome\kmeleon\content\pageinfo" and get other, internal paths to match? I do not understand the repeat
Forum: Bugs
5 days ago
JamesD
@ rodocop I have gotten and installed naruman's code. I see the "View Page Info" in the document popup menu. I just have not yet been able to trace the origin of that item. The string "View Page Info" does not appear in menus.cfg or main.kmm. Do you know where that menu item is coded?
Forum: Bugs
6 days ago
JamesD
This unofficial update is ONLY for users who have toggled their "consoleservice.enabled" to TRUE. This update contains two zero byte files needed to suppress notifications about being unable to read them in the Error Console. It also contains a new omni.ja file. Two files in chrome have been changed such that there are no longer the four CSS errors in console2 chrome. Special not
Forum: Announcements
6 days ago
JamesD
CHROME I will try to have a look. I seldom have success working with the chrome. I don't think that I kept a 74 from naruman.
Forum: Bugs
6 days ago
JamesD
What is the reason that a report with columns will display differently in an alert box and a text file? It does not seem to matter if I use tabs or spaces to produce the columns. If the columns line up in one place, then they do not line up in the other. I know that alert boxes use variable character spacing but why do tabs not work?
Forum: General
7 days ago
JamesD
This one along with 'PageInfo' and 'newtab' features are most needed (IMHO) in order to make KM more attractable for mass user. Can you explain more about the 'PageInfo' and 'newtab' features you desire? Just to note that the injectJS() items run without the need for the page itself to have JS enabled.
Forum: Bugs
7 days ago
JamesD
Session file is fine. Can you send me all the macros you're using? I'm going to recheck this. Sorry for the size of the files, but this happened on my main system. Macros folder: https://dl.dropboxusercontent.com/u/1522294/root_macros.7z User Macros: https://dl.dropboxusercontent.com/u/1522294/user_macros.7z I think the following macros were marked not to load: eventorder.kmm pag
Forum: Announcements
7 days ago
JamesD
@ Dorian The previous post for JohnHell required me to restart the session in order to get my new macro read and the old one marked not to load. I had the Bing site in tab two. When restarted that tab required a 'Reload' in order to see the Bing site. I have a copy of the sessions files here: https://dl.dropboxusercontent.com/u/1522294/Bing_session.7z
Forum: Announcements
7 days ago
JamesD
@ JohnHell I think it must be your system. I changed a group of 'command' setmenu statements and moved them into a popup. I have the Bing site in another tab now and I can see my new popup appear whenever the cursor is on the popup name. I will include my code so that you can check your code against it. page_js_switchp.kmm # K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.
Forum: Announcements
7 days ago
JamesD
tested right now and happens with all kind of items attached to DocumentPopup. Does this only happen to popup and inline items? I have several macro and command items in my DocumentPopup and they all appear at the Bing site. What about Page Properties and Send Page to popups? I am seeing those. Could this relate to your Ops Sys? I am using Win 7.
Forum: Announcements
8 days ago
JamesD
I can't speak for Dorian, but it likely is possible to fix. It might become a matter of the resources required. If ten is possible now, twenty should be also if one wants to commit twice as many counters, variables, etc. all the time. It might be prudent to have a pref which could default to ten but allow the user to set to higher number. Setting to a higher number would commit the user's KM
Forum: Extensions
8 days ago
JamesD
@ Zero3K I did not notice a problem. There was a long wait time after clicking flashblock symbol until the advertisement loaded.
Forum: Announcements
8 days ago
JamesD
I do not know why the change, but I am very happy that you have discovered it and found a fix. Datetime functions and reporting them back to the macros are a bit tricky. Some functions are zero based. I will post my revised macro so novice users who read this might understand better. Datetime.kmm # K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage2) #
Forum: Bugs
8 days ago
JamesD
@ JohnHell You are spot on right. I made the change of adding "+''" to each variable to be returned in my test macro and I got an answer every time. That 'string only' type of requirement has only just started in KM 75. My old code ran in an earlier version. 1.6 ver, I think. I think this information should be added to the MacroLanguage2 documentation. Most people will not r
Forum: Bugs
8 days ago
JamesD
I did some more testing and everything works with the two items in Tabbed Browsing set to default with one very specific exception. I have saved a group consisting of wiki Macrolange2 and Command ID pages. If I open KM to the start page and load the group then I have three tabs which display correctly. If I then set sessions to load the last session, close KM by File - exit and restart KM, I
Forum: Announcements
8 days ago
JamesD
Update 5 Apart the fixes for JamesD macro, there is also a change for SetButtonImage so that changing cold image doesn't change the hot one. Very close to perfect now. I have a clean install thru update 5. My only addition is Groups2.kmm. Group saved in one session can be loaded in another and has correct URLs. Automatically loading the last session works. The only problem is that
Forum: Announcements
10 days ago
JamesD
@ JohnHell I just now saw your post. I will work on strings as soon as I can, but that may be a couple of days. Thanks for the info.
Forum: Bugs
11 days ago
JamesD
@ Dorian The fix for sessions, the two prefs, does not help the problem with Groups.
Forum: Announcements
11 days ago
JamesD
I have narrowed the problem with sessions down to two prefs in tabbed browsing. I did another clean install and ran tests without any macros of my own. I did all the pref changes, one by one, and retested each time. All was just fine and the last session was restored OK until I changed the two prefs in tabbed browsing > tab bar the set the loading to show in tab icon or tab title. I un-c
Forum: Announcements
11 days ago
JamesD
@JamesD: try the attached plugin for the group macro. OnStartup can happen after OnLoad, why not using OnSetup? About js_flag, restore on demand does not like id(ID_NAV_RELOAD) in OnLoad, but I should be able to fix that. I did change the event for the item in mysetup. The alerts are in the correct order. However the action to set mysetup not to load is not working. Should I try toggle
Forum: Announcements
11 days ago
JamesD
I had planned to test all morning, but got stuck with a new problem. I was trying to automate some of the settings so I could test new versions quicker. I made the following macro but things don't seem to happen correctly. I should be a 'do once and stop' situation, but it does not stop. I do not know if it is my macro or a bug. I have tried on a clean install and one with all four updates. So
Forum: Announcements
11 days ago
JamesD
What issue do you mean? I have pictures and code often that flow past the normal text area, but no one has complained they could not see my posts.
Forum: Off-Topic
11 days ago
JamesD
@ Dorian I found something. I am just not sure what I have found. I was going to begin to make the 'raw' KM75 more like what my regular KM75 contained. I made some changes to the 'Tabbed Browsing' panel. They are described below. I think I ran into some problems after that change. I then decided to expedite my testing and use Groups2.kmm to build the last three tabs, rather than do it
Forum: Announcements
12 days ago
JamesD
Quote JamesD The #2 tab becomes a copy of the #1 tab. It was not a copy, you have to go back to get to the correct page. See the session history of the tab. Did you retry with a clean profile? I can't really figure out the "empty tab" thing. Anyone else have seen "empty tab" on restart? It looks like another item in my $OnLoad list. This problem
Forum: Announcements
13 days ago
JamesD
About the JamesD issue with downloads, I don't have that issue with update 3, nor with update 2. And I cannot make it happen again. Was likely something that I did.
Forum: Announcements
Pages: 12345...LastNext
Current Page: 1 of 101

K-Meleon forum is powered by Phorum.