General :  K-Meleon Forum
General discussion about K-Meleon. 

Pages: 12345...LastNext
Current Page: 1 of 101
Results 1 - 30 of 3009
2 days ago
JamesD
@ JohnHell I just now saw your post. I will work on strings as soon as I can, but that may be a couple of days. Thanks for the info.
Forum: Bugs
3 days ago
JamesD
@ Dorian The fix for sessions, the two prefs, does not help the problem with Groups.
Forum: Announcements
3 days ago
JamesD
I have narrowed the problem with sessions down to two prefs in tabbed browsing. I did another clean install and ran tests without any macros of my own. I did all the pref changes, one by one, and retested each time. All was just fine and the last session was restored OK until I changed the two prefs in tabbed browsing > tab bar the set the loading to show in tab icon or tab title. I un-c
Forum: Announcements
3 days ago
JamesD
@JamesD: try the attached plugin for the group macro. OnStartup can happen after OnLoad, why not using OnSetup? About js_flag, restore on demand does not like id(ID_NAV_RELOAD) in OnLoad, but I should be able to fix that. I did change the event for the item in mysetup. The alerts are in the correct order. However the action to set mysetup not to load is not working. Should I try toggle
Forum: Announcements
3 days ago
JamesD
I had planned to test all morning, but got stuck with a new problem. I was trying to automate some of the settings so I could test new versions quicker. I made the following macro but things don't seem to happen correctly. I should be a 'do once and stop' situation, but it does not stop. I do not know if it is my macro or a bug. I have tried on a clean install and one with all four updates. So
Forum: Announcements
3 days ago
JamesD
What issue do you mean? I have pictures and code often that flow past the normal text area, but no one has complained they could not see my posts.
Forum: Off-Topic
3 days ago
JamesD
@ Dorian I found something. I am just not sure what I have found. I was going to begin to make the 'raw' KM75 more like what my regular KM75 contained. I made some changes to the 'Tabbed Browsing' panel. They are described below. I think I ran into some problems after that change. I then decided to expedite my testing and use Groups2.kmm to build the last three tabs, rather than do it
Forum: Announcements
4 days ago
JamesD
Quote JamesD The #2 tab becomes a copy of the #1 tab. It was not a copy, you have to go back to get to the correct page. See the session history of the tab. Did you retry with a clean profile? I can't really figure out the "empty tab" thing. Anyone else have seen "empty tab" on restart? It looks like another item in my $OnLoad list. This problem
Forum: Announcements
5 days ago
JamesD
About the JamesD issue with downloads, I don't have that issue with update 3, nor with update 2. And I cannot make it happen again. Was likely something that I did.
Forum: Announcements
5 days ago
JamesD
Update 3 (requires previous update) fixing xul windows size, the last session problem, and the download dialog. Reporting mixed results- Sessions restore does not appear to change the outcome of the same test that I sent before. I have not looked at the JASON file, but I still lose the #2 tab and have tabs #3 and 4 empty until clicked on. The #2 tab becomes a copy of the #1 tab. Ses
Forum: Announcements
7 days ago
JamesD
The updated page for Command IDs is complete. The sandbox is clear.
Forum: Development
7 days ago
JamesD
There are several ways this can happen. As siria said they become outdated quickly. Do you happen to know which is the most current version? I ask that because there at least two available. One is by desga and I have that in local documents. The other comes with KM and is found as "Commands List" under EDIT - CONFIGURATION. If you do a translation of the one in Local Documents,
Forum: Development
7 days ago
JamesD
With this last update, I can no longer download a PDF file. When I click on the March bank statement the browser stops working. I tried both checking and savings accounts. KM stops responding. I will go now and try my brokerage site. Same problem there.
Forum: Announcements
8 days ago
JamesD
I may have a fix for the second tab in your example. But I can't reproduce the empty ones. Maybe I should look at $OnLoad to see if I have other things happening? They are there. They just don't load until I click on the tab.
Forum: Announcements
8 days ago
JamesD
There may be something useful in this old (2010) project. https://dl.dropboxusercontent.com/u/1522294/training.7z
Forum: Development
8 days ago
JamesD
When K-Meleon is stopped abnormally there is usually an opportunity to request your last session upon the next start. If you answer YES to the question the browser will attempt to restore your last session. This may result in the same situation which caused the original problem.
Forum: General
9 days ago
JamesD
If possible send me sessions.json, with a session that doesn't load properly. Here is the information about the first problem that I reported. https://dl.dropboxusercontent.com/u/1522294/SessionsTest_1%20.7z
Forum: Announcements
9 days ago
JamesD
I have another little problem with the update 2. When I have a new page load in a tab the "stop loading" icon stays red, the status bar is saying, "Read kmeleon.sourceforge.net", and the title of the tab says "loading...". I had a second tab with the same conditions. When I change focus between tabs, the statusbar goes to "Ready", but the other two item
Forum: Announcements
9 days ago
JamesD
Not a bug, only a new setting to help speed. Actually not a K-Meleon invention but a genuine Mozilla setting, was introduced with Firefox (as I learned just yesterday cool smiley) Hopefully there will be a visible switch in the prefs in new versions. If not, no prob: type "about:config" in the adress bar or click Edit>Configuration>Browser Configuration. Ignore the warning.
Forum: Announcements
9 days ago
JamesD
Using the update 2, I have good results reloading a session with four tabs if the 'restore_on_demand' pref is false. With it set to true, the #2 tab is wrong. It got the same URL as #1 tab. Some tabs did not load until I clicked on them. I am running the EaseRead.kmm module with the shorted code by siria.
Forum: Announcements
10 days ago
JamesD
The 2 firsts, the nav* commands, do, but the page*, don't. Thanks, I was unsure about the three for page. I think that I will include this information.
Forum: Development
10 days ago
JamesD
@ JohnHell OK, that is what I thought. Is there any need to mention that they also change the js enabled pref?
Forum: Development
10 days ago
JamesD
Since we are getting close to a release of KM 75, I have started an upgrade to the wiki Command IDs page. see this thread: http://kmeleon.sourceforge.net/forum/read.php?2,130307,133093,page=3#msg-133093
Forum: Announcements
10 days ago
JamesD
I have put into the wiki sandbox a possible update for the wiki Command IDs. http://kmeleon.sourceforge.net/wiki/SandBox The current wiki command IDs page is here: http://kmeleon.sourceforge.net/wiki/CommandIDs The format is generally complete. I do need some help on the descriptions for six of the newest items. While I have a general idea of what each of the six do, this documentatio
Forum: Development
11 days ago
JamesD
You need this pref if you have 100+ tabs open like me And here I thought I was being busy with three tabs open. @ siria Do you think it possible to achieve the function of EaseRead using just CSS? That might remove one of my items from the $OnLoad event.
Forum: Announcements
12 days ago
JamesD
Anyway, suggestion to test this instead: _EaseRead_AutoRun { $URLBAR=="http://www.gmx.com" ? $TextZoom=10 : $TextZoom=12; } Your code is better. I don't get a "hang" situation now. First tab is not what is was before restart, but that happened with no easeread running at all.
Forum: Announcements
12 days ago
JamesD
Since a restart with sessions did not hang in KMs without my macros, by the process of stopping all my macro and starting then one by one, I have found the one which causes the browser to hang. I hope there is a work-a-round. With my old eyes, I really need this one. easeread.kmm # K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage2) # # ---------- Ease
Forum: Announcements
12 days ago
JamesD
Updating my previous post on session autostart, I have run a completely different test. I installed 75 RC2 on another computer. There are no other copies of KM on that computer. I put no macros or skins into that install of KM. I changed only a couple of preferences. I have the menu showing, no tab bar unless more than one tab, loading shows in tab title, not showing x to close on tab, favor
Forum: Announcements
12 days ago
JamesD
This one works fine on my 'buggy' system! Great! I will report that to the person who suggested the change. Now if I just knew if it was the added quotes or the & that fixed the problem. Of course it could have required both.
Forum: Extensions
13 days ago
JamesD
So we have: 1) session did not handle unicode path correctly 2) crash when sessions.json is not found and kmeleon not in english (triggered by 1) 3) crash when restoring sessions with pages without icon (and therefore local files) The problem extends beyond just local pages. The test depicted in the following images had three tabs and all were KM forum or wiki. I will include also the
Forum: Announcements
Pages: 12345...LastNext
Current Page: 1 of 101

K-Meleon forum is powered by Phorum.