Extensions :  K-Meleon Forum
All about K-Meleon extensions. 
Windows Media Player Not Working
Posted by: johnywhy
Date: October 17, 2009 09:41PM

hey

pages containing embedded avi video display "Click here to get the plugin" instead of Windows Media Player.

i installed the KM WMP NT extension but that did not help.

any suggestions?

thanks



Edited 1 time(s). Last edit at 10/17/2009 09:41PM by johnywhy.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: desga2
Date: October 17, 2009 11:44PM

Also you need ActiveX plugin for Mozilla or here; WMP Activex

K-Meleon in Spanish



Edited 1 time(s). Last edit at 10/17/2009 11:48PM by desga2.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: johnywhy
Date: October 18, 2009 01:38AM
Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: guenter
Date: October 18, 2009 02:23PM

Quote
johnywhy
thanks, i did it. still not working for this file:
http://blip.tv/file/2732633?filename=Scvdotnet-2FramesBoostPerfSoundHiPri2k4k461.avi

Not working in IE nor K-Meleon. Calls plugin but only shows "contacting... "

Verbindung wird hergestellt. Since I use a German system

Go here to check whether Media player is loaded at all: http://home.htp-tel.de/sterntaler/test.html#plugins

Also look in menu: Help -> About : Plugins



Edited 1 time(s). Last edit at 10/18/2009 02:29PM by guenter.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: johnywhy
Date: October 18, 2009 04:26PM

here's the info in Help>About Plugins:

Windows Presentation Foundation

File name: NPWPF.dll
Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

MIME Type Description Suffixes Enabled
application/x-ms-xbap XAML Browser Application xbap Yes
application/xaml+xml XAML Document xaml Yes

WMP does not load in http://home.htp-tel.de/sterntaler/test.html#plugins



Edited 2 time(s). Last edit at 10/18/2009 04:53PM by johnywhy.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: siria
Date: October 18, 2009 04:33PM

No idea if this plays a role here, but in general avis are tricky. They can contain all sorts of internal codecs, and if one is missing on a computer, WMP won't play it, even stand-alone. If the avi could be downloaded it would be interesting to test this. If it doesn't play in IE either, that might be a hint...

Wondering, does the WMP-plugin play all the codecs that WMP-standalone knows, or must each codec be somehow included in the plugin?



Edited 1 time(s). Last edit at 10/18/2009 04:34PM by siria.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: johnywhy
Date: October 18, 2009 04:55PM

this plays for me in ie and locally-
http://blip.tv/file/2732633?filename=Scvdotnet-2FramesBoostPerfSoundHiPri2k4k461.avi

but not in km



Edited 1 time(s). Last edit at 10/18/2009 04:55PM by johnywhy.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: siria
Date: October 18, 2009 06:31PM

Oh pity, so plugins seem to need every codec themselves, urgh..

According to GSPOT it's an xvid-mp4 avi.
I've read that those plugins are universal, not browser-related, so wondering, would it work in FFox?? On my old system not, and when I click on "get plugin", FF tries then gives up: Plugin not found. But that need not mean much, I'm on win98 and have very little clue about FF myself ;-P Point of this being, it's probably easier to find a working plugin searching it for FF (if it exists) than for (hardly known) KM, but the FF-one should then be copy-able into KM ;-)



Edited 1 time(s). Last edit at 10/18/2009 06:33PM by siria.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: desga2
Date: October 18, 2009 07:48PM

Read blip.tv requiriments in FAQ.

Are you tried to change the User Agent string to Firefox?
Tools -> User Agent -> Firefox

K-Meleon in Spanish



Edited 1 time(s). Last edit at 10/18/2009 07:48PM by desga2.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: siria
Date: October 18, 2009 09:13PM

The flv-version plays fine, just not the avi.
After some research now, does anyone have quicktime installed? On my old system it runs only a very outdated version, but in the meantime xvid seems to have been added to quicktime. My old plugin is "npqtplugin.dll", may be the same name for newer versions. Actually it's a whole bunch, the others have numbers at the end. Anyone has a newer one, to put in the KM-plugin-folder and try?



Edited 1 time(s). Last edit at 10/18/2009 09:15PM by siria.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: siria
Date: October 19, 2009 06:26AM

There's a slightly complicated workaround for firefox (+KM), but if it helps or not depends on which windowsmedia-player-plugin one has:
http://www.krunk4ever.com/blog/2007/05/14/missing-codecs-in-firefox-to-play-video-in-gallery2/

It's also posted in this several years long thread with more details:
http://gallery.menalto.com/node/35788

To put it short, and if I read that right, it seems that for some odd reason microsoft has forgotten to include in its plugin for other browsers the version "x-msvideo"/avi, that is, the plugin actually can play it, it just suffers a bit from Alzheimer: "Oh, that video is meant for me?? Oops..." tongue sticking out smiley This can be cured with the workaround above.
But some say quicktime-plugins supposedly would also be able to play it? Can't confirm this on my old machine, but looking at the file properties of the newer plugins I found (up to qt7.45), neither of them lists x-msvideo or avi or even xvid...
But am afraid a second complication is the xvid-format, so the "fix" may only work for some avis, not all...

There are two version of the WMP-plugin, just a short info:
http://support.mozilla.com/en-US/kb/Using+the+Windows+Media+Player+plugin+with+Firefox



Edited 1 time(s). Last edit at 10/19/2009 06:48AM by siria.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: guenter
Date: October 19, 2009 11:02PM

Quote
johnywhy
WMP does not load in http://home.htp-tel.de/sterntaler/test.html#plugins

I am sure that it does on my system.



Depending on what setup You have installed the test will either play the music in the embed tag. With activeX support installed it will play the standard compliant code. I have the Media Player but no activeX installed in the screenshot.

The later code is used the play music with any IE or Netscape mp3 plugin on the linked applet page "Imaginary Seascape". It contains/shows both the object and the embed legacy code.

<object classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95" width="0" height="0" title="Playing: Gulls MP3 Sound">
<param name="filename" value="./3seemoeve.mp3" />
<param name="volume" value="55" />
<param name="autostart" value="true" />

<param name="loop" value="-1" />
<embed src="./3seemoeve.mp3" type="audio/x-mp3" autostart="true" width="0" height="0" loop="true"></embed>
</object>



Edited 2 time(s). Last edit at 10/19/2009 11:07PM by guenter.

Attachments: MediaPlayer.gif (32.6 KB)  
Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: Yogi
Date: October 20, 2009 12:32AM

Quote
siria
According to GSPOT it's an xvid-mp4 avi.
It is a MPEG-4 compression format.
All codecs using the same compression format will basically be able to also handle it.

VideoCodecs

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: guenter
Date: October 20, 2009 01:29AM

Maybe Video Lan Plugin is easier to configure to alternative browsers than WMP.
http://www.videolan.org/

supported mimetypes:

audio/mpeg 	MPEG audio 	mp2,mp3,mpga,mpega 	Yes
audio/x-mpeg 	MPEG audio 	mp2,mp3,mpga,mpega 	Yes
video/mpeg 	MPEG video 	mpg,mpeg,mpe 	Yes
video/x-mpeg 	MPEG video 	mpg,mpeg,mpe 	Yes
video/mpeg-system 	MPEG video 	mpg,mpeg,vob 	Yes
video/x-mpeg-system 	MPEG video 	mpg,mpeg,vob 	Yes
video/mpeg4 	MPEG-4 video 	mp4,mpg4 	Yes
audio/mpeg4 	MPEG-4 audio 	mp4,mpg4 	Yes
application/mpeg4-iod 	MPEG-4 video 	mp4,mpg4 	Yes
application/mpeg4-muxcodetable 	MPEG-4 video 	mp4,mpg4 	Yes
video/x-msvideo 	AVI video 	avi 	Yes
video/quicktime 	QuickTime video 	mov,qt 	Yes
application/x-ogg 	Ogg stream 	ogg 	Yes
application/ogg 	Ogg stream 	ogg 	Yes
application/x-vlc-plugin 	VLC plugin 	vlc 	Yes
video/x-ms-asf-plugin 	Windows Media video 	asf,asx 	Yes
video/x-ms-asf 	Windows Media video 	asf,asx 	Yes
application/x-mplayer2 	Windows Media plugin 		Yes
video/x-ms-wmv 	Windows Media video 	wmv 	Yes
application/x-google-vlc-plugin 	Google VLC plugin 		Yes
audio/wav 	WAV audio 	wav 	Yes
audio/x-wav 	WAV audio 	wav 	Yes
audio/3gpp 	3GPP audio 	3gp,3gpp 	Yes
video/3gpp 	3GPP video 	3gp,3gpp 	Yes
audio/3gpp2 	3GPP2 audio 	3g2,3gpp2 	Yes
video/3gpp2 	3GPP2 video 	3g2,3gpp2 	Yes



Edited 1 time(s). Last edit at 10/20/2009 01:30AM by guenter.

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: siria
Date: October 20, 2009 02:29AM

WHOW - now that's a nice list!! And all those also work in a browser window? Can't find it on their site, blind as usual *sigh*
Would love to try it, except that now that test video has been deleted, argh! :-(

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: siria
Date: October 20, 2009 03:27AM

Crazy, I had no idea there are that many plugins in the extensions center!! I may well have come across when checking out the site, but if at that moment my head was too busy with other stuff, I tend to forget it again
Btw, I just downloaded today the new VLC 1.0.2 player. Would suppose the plugin is updated too, since the properties say so and it lists many more file formats as the one from kmext-site, just how in the world can a (zipped) 70kB file play so many video formats? Oh well, that's just too "high" for me, am used to that ;-) Anyway, have attached that plugin-102 if anyone is interested.
Don't forget to scan it for safety, mine isn't quite up-to-date...



Edited 1 time(s). Last edit at 10/20/2009 03:28AM by siria.

Attachments: VLC--plugin-from-v102_from-folder-mozilla.zip (70.1 KB)  
Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: guenter
Date: October 21, 2009 03:04AM

Thx for info about new version smiling smiley

Options: ReplyQuote
Re: Windows Media Player Not Working
Posted by: disrupted
Date: November 05, 2009 12:35AM

wmp mozilla plugin isn't supposed to play avi or mpg..only wmp specific formats like wmv, wma , asf etc. to make wmp play all supported formats by wmp in gecko(like in ie), you will need the special km wmp, download from there:
http://kmext.sourceforge.net/mplug.htm

this adds more formats. in case of avi, you might need some codecs to be installed if the avi used unregular (compression) format

if you don't have the required codec installed, then your best bet is the videolan plugin , also on the same page: (vlc multimedia plugin)
http://kmext.sourceforge.net/mplug.htm

Options: ReplyQuote


K-Meleon forum is powered by Phorum.