Extensions :  K-Meleon Forum
All about K-Meleon extensions. 
Pages: Previous12
Current Page: 2 of 2
Re: Search+
Posted by: jsnj
Date: May 05, 2010 03:34AM

Quote
forever
Quote
jsnj
Couple questions: Do you have Attach Tab/Window Buttons to the tab bar checked in Preferences?[...]
have you changed the name of the Search Buttons toolbar in the toolbars.cfg file?

no to both questions......

it worked fine the first days and then the icon changed its place without having changed settings....

Well I don't know what the cause is. Something about the Search Buttons Sync portion of the Search+Icon macro module may not be working properly with your settings. But since you're using KT3, if you don't mind not having the engine icon seen in the button, you can just disable the Search+Icon macro module in Preferences - K-Meleon Plugins - Macro Extension. KT3 has the same Web Search menu attached to the search button, so everything will be the same except for the button not showing the search engine in use. If you do want the changing engine icon, let me know and I'll walk you thru editing the macro text.



Edited 1 time(s). Last edit at 05/05/2010 03:36AM by jsnj.

Options: ReplyQuote
Re: Search+
Posted by: forever
Date: May 05, 2010 04:35AM

now i had to restore all my files because of a "new version of ad-block...." message and now everything is fine.....

so now i have the same configuration as 1 week ago.
the only difference is, that i haven't installed "k-meleon extensions manager 5.5" now.

Could that caused the problem?

Options: ReplyQuote
Re: Search+
Posted by: jsnj
Date: May 05, 2010 04:46AM

Quote
forever
now i had to restore all my files because of a "new version of ad-block...." message and now everything is fine.....

so now i have the same configuration as 1 week ago.
the only difference is, that i haven't installed "k-meleon extensions manager 5.5" now.

Could that caused the problem?

I have KEM 5.5 installed with no conflict w/Search+, so I don't think so.

Options: ReplyQuote
Re: Search+
Posted by: forever
Date: May 05, 2010 04:54AM

well that was the only thing i've changed.....

now everything is fine but i will keep an eye on that

Options: ReplyQuote
Re: Search+
Posted by: forever
Date: May 08, 2010 11:38PM

update:
after i had restarted my computer the icon changed its place again :-(

Options: ReplyQuote
Re: Search+
Posted by: SoerenB
Date: May 09, 2010 12:35AM

Hi,

I have AdBlockPlus 1.0.1 on KM 1.54. on XP SP 3.5 - no problems here.
I never see an update notification - does anybody else? which versions ABP/KM?

Cheers
SoerenB

is: I'm back, on wine in some (!) linuxes - speaking of addiction ...

was: No more own machines, because of addiction.
Don't know when I'll be back to normal ...

Options: ReplyQuote
Re: Search+
Posted by: forever
Date: May 09, 2010 05:06AM
Options: ReplyQuote
Re: Search+
Posted by: jsnj
Date: May 09, 2010 05:06AM

Quote
forever
update:
after i had restarted my computer the icon changed its place again :-(

Do you keep the default engine unchecked/unlocked and use different engine icons? If you don't then just disable Search+Icon in Preferences - K-Meleon Plugins - Macro Extension. The default search button in KT3 has the correct Web Search menu attached, so it'll work the same. See if that Search Button stays in its place.

Options: ReplyQuote
Re: Search+
Posted by: forever
Date: May 12, 2010 01:23PM

you already gave me that advice but last time it didn't work. Don't know why

now i reinstalled search+, disabled Search+Icon and everything works fine

after 4 reboots the icon is still at its place

thanks a lot :-)

Options: ReplyQuote
Re: Search+
Posted by: panzer
Date: July 08, 2010 01:25AM

My icon is moving to the bottom upper right no matter what I do (I have made a clean install-portable version). I have Search+Icon and searchbarext installed.

I will survive. smiling smiley



Edited 1 time(s). Last edit at 07/08/2010 02:02AM by panzer.

Options: ReplyQuote
Re: Search+
Posted by: jsnj
Date: July 08, 2010 01:03PM

Quote
panzer
My icon is moving to the bottom upper right no matter what I do (I have made a clean install-portable version). I have Search+Icon and searchbarext installed.

I will survive. smiling smiley

See if this helps:

Open the Search+Icon macro module(Edit - Configuration - Macros - Search+Icon.kmm)

Place # before the following line located towards the bottom of the file:

$OnQuit=$OnQuit."_SearchButtonsSync;";

Save and restart KM. Move the icon to where you want it to be. Restart again and see if it sticks. I can't reproduce the bug, so I can't be sure that's what's causing it, but it would seem to be the only logic explanation. Let me know.

Options: ReplyQuote
Re: Search+
Posted by: panzer
Date: July 08, 2010 02:22PM

I tried it and it has still moved to the bottom upper right. Thanx anyway.

Options: ReplyQuote
Re: Search+
Posted by: forever
Date: July 08, 2010 05:33PM

Did you lock your toolbars?

it is always unlocked by default.

sorry if that's a stupid answer but i disabled Search+Icon and locked my toolbar and now everything's fine ;)



Edited 1 time(s). Last edit at 07/08/2010 05:35PM by forever.

Options: ReplyQuote
Re: Search+
Posted by: jsnj
Date: July 09, 2010 11:42AM

Quote
panzer
I tried it and it has still moved to the bottom upper right. Thanx anyway.

I forgot this part. Place # in front of the following lines under _SearchPlusToolbar and try again.

$_Search_Break=getpref(INT,$_Button." Buttons.break");
$_Search_Index=getpref(INT,$_Button." Buttons.index");
setpref(INT,$_Button."+.break",$_Search_Break);
setpref(INT,$_Button."+.index",$_Search_Index);

Options: ReplyQuote
Re: Search+
Posted by: panzer
Date: July 13, 2010 10:18PM

Houston, problem solved. Thanx.

Options: ReplyQuote
Re: Search+
Posted by: panzer
Date: July 20, 2010 02:29PM

I tried portable Km on my sister's netbook and new icon for your extension is not shown, only the old one. No biggie. grinning smiley

Options: ReplyQuote
Re: Search+
Posted by: jsnj
Date: July 21, 2010 12:06AM

Quote
panzer
I tried portable Km on my sister's netbook and new icon for your extension is not shown, only the old one. No biggie. grinning smiley

What do you mean new icon vs old? There are 40+ icons in the extension. As of last update, only a few were updated: Google, Bing, Yahoo and a couple others. Which one are you referring to?

In any case, it sounds like it may be a "Cache website icons on disk" problem. Not sure about caching in portable km, but if that's an option in preferences, then uncheck it, clear cache, restart and and see if it solves the problem. I found that pref can cause problems with macro created toolbar buttons/icons.



Edited 1 time(s). Last edit at 07/21/2010 12:22AM by jsnj.

Options: ReplyQuote
Re: Search+
Posted by: panzer
Date: July 21, 2010 01:13AM

I mean this icon for toolbar button. On laptop I see small earth, and everywhere else this blue, green, red, yellow one.

It is probably my profile's fault, but everything else looks fine except this.

Options: ReplyQuote
Re: Search+
Posted by: siria
Date: April 24, 2011 11:52PM

Perhaps in the laptop the toolbar "search buttons" is enabled and the toolbar "search+" hidden? Or perhaps the icon gets only changed after first switching an engine, or perhaps it may be related to locked default engine, no clue, just wild guessing. In the menu "Search Options", the first entry locks or unlocks the "default engine". Well possible that it's locked in the default KM profile, and if it's locked, my icon is locked too.

Anyway, those extended options in Search+ look very promising, and I wish that extension could be included by default with the browser. But don't hold much hope for any default changes soon, seeing how the privbar is still off by default since so many years, and the globe button in the default skin also still shows only the short version of the engines menu, missing the "set as default" and Configuration links :-/

Have a little improvement suggestion, quite hopeful that it could be realistic... The prob is that in my folder skins/default are already a bunch of macro pics, and throwing 50 new images inside makes me lose overview completely, just way too many to mix up in that big heap. First thought about renaming them all with a prefix "search_", but then did a bit experimenting, and found that it's actually possible to have subfolders in skins/default! smiling smiley Now all my search plus pics are moved into the new subfolder "skins/default/SearchEngines"
Only left a copy of "search.bmp" in skins/default.
For this to work only needed to change two lines in the macro "Search+Icons.kmm":
pluginmsg(toolbars, "SetButtonImage", "&Search+, macros(SearchPlus), HOT,". $_SearchIcon."[0]");
to
$_SearchFolder="SearchEngines/";
pluginmsg(toolbars, "SetButtonImage", "&Search+, macros(SearchPlus), HOT,". $_SearchFolder . $_SearchIcon."[0]");


BTW, in the kmext version that I just downloaded today (link in first post here) there's only the german translation file, it's not in the de-DE folder but just in locales, and no other languages are included.
Hmm, and wonder if the KEM-Manager can actually restore the original search.kmm at uninstallation, or if it not rather deletes the backup, but no idea, haven't tried yet ;-)



Edited 4 time(s). Last edit at 04/25/2011 12:07AM by siria.

Options: ReplyQuote
Re: Search+
Posted by: disrupted
Date: April 25, 2011 12:39AM

"Hmm, and wonder if the KEM-Manager can actually restore the original search.kmm at uninstallation, or if it not rather deletes the backup, but no idea, haven't tried yet"

since 5.9(last update for win9x)
http://kmeleon.sourceforge.net/forum/read.php?9,109838,109871#msg-109871

Options: ReplyQuote
Re: Search+
Posted by: siria
Date: April 25, 2011 03:42AM

Ah okay, cool feature! smiling smiley
And the german kml has moved into DE folder, but the other languages are still missing, see previous page near the bottom, attached by jsnj, v104.exe unzipped ;-)

And uhm, am now searching how to configure the Web Search menu... In F2/FindingWebsites the tab for choosing the MENU entries seeems to be vanished - or is it me?? Anyone else...?
Actually two, "Web Search" and "Multisearch" config sheets. Tried to undo all my gimmicks, but still, with Search+ those tabs are missing, and without it, they appear again *confused*. If I click on another config sheet, and then on "Finding Websites" again, the two missing tabs appear for a second and then poof... icon.kmm has no influence, on or off...
Is that only on my machine, some profile messed or somehow?? Just can't imagine how a pref sheet could vanish just by macro commands or a pref, that's not really possible is it... *reallyconfused*



Edited 4 time(s). Last edit at 04/25/2011 05:12AM by siria.

Options: ReplyQuote
Re: Search+
Posted by: siria
Date: April 25, 2011 05:13AM

Found it, OOPS - there was one gimmick that I did not undo, had changed the name of the kmm-file to searchplus.kmm. Renamed back to "search.kmm" and all is fine again! surprised smiley Didn't imagine this one would refer back to itself somehow, but looks like that preftab "Finding Websites" xul code (or whatever) somehow checks if "search.kmm" exists in macros... Actually it seems to work fine with a "searchplus.kmm" too, as long as there's just any file "search.kmm" too, even if that's completely empty.
Learning new stuff every day... cool smiley

Options: ReplyQuote
Re: Search+
Posted by: jsnj
Date: April 25, 2011 05:31AM

Quote
siria
Ah okay, cool feature! smiling smiley
And the german kml has moved into DE folder, but the other languages are still missing, see previous page near the bottom, attached by jsnj, v104.exe unzipped ;-)

I may be mistaken but I believe that may be the result of disrupted unpacking the exe file with 7zip. For some reason 7zip doesn't recognize the individual locale folders in the locales folder. It lists all the search.kml files in one weirdly named folder. So when unpacking you can either overwrite the extracted search.kml file with the subsequent files or cancel extracting the other search.kml files leaving the first extracted one which is the german. I no longer use NSIS exe installation method for my extensions since KEM is easier and smaller. So we should no longer run into this problem.

Options: ReplyQuote
Re: Search+
Posted by: jsnj
Date: April 25, 2011 05:35AM

Quote
siria
Found it, OOPS - there was one gimmick that I did not undo, had changed the name of the kmm-file to searchplus.kmm. Renamed back to "search.kmm" and all is fine again! surprised smiley Didn't imagine this one would refer back to itself somehow, but looks like that preftab "Finding Websites" xul code (or whatever) somehow checks if "search.kmm" exists in macros... Actually it seems to work fine with a "searchplus.kmm" too, as long as there's just any file "search.kmm" too, even if that's completely empty.
Learning new stuff every day... cool smiley

Yes, I found that out when originally creating the extension. I wanted to avoid replacing the original search.kmm file, but there was no realistic way. Disrupted's KEM backup method is a good alternative.

Options: ReplyQuote
Re: Search+
Posted by: jsnj
Date: April 25, 2011 05:39AM

Quote
siria
Have a little improvement suggestion, quite hopeful that it could be realistic... The prob is that in my folder skins/default are already a bunch of macro pics, and throwing 50 new images inside makes me lose overview completely, just way too many to mix up in that big heap. First thought about renaming them all with a prefix "search_", but then did a bit experimenting, and found that it's actually possible to have subfolders in skins/default! smiling smiley Now all my search plus pics are moved into the new subfolder "skins/default/SearchEngines"
Only left a copy of "search.bmp" in skins/default.
For this to work only needed to change two lines in the macro "Search+Icons.kmm":
pluginmsg(toolbars, "SetButtonImage", "&Search+, macros(SearchPlus), HOT,". $_SearchIcon."[0]");
to
$_SearchFolder="SearchEngines/";
pluginmsg(toolbars, "SetButtonImage", "&Search+, macros(SearchPlus), HOT,". $_SearchFolder . $_SearchIcon."[0]");

That's a tidier solution particularly for those users/extension creators who'd be inclined to go digging around into folders smiling smiley I don't know if KEM accommodates sub-folders of the default skin directory though.

Options: ReplyQuote
Re: Search+ v1.0.4
Posted by: ndebord
Date: December 08, 2011 06:19AM

jsnj,

I really need something like this. I'm doing non-profit grant writing these days (I am now officially too old to get back into the computer magainze biz) and I desperately need to save keyword searches.

Is this the right macro to use?

Much thanks,

Nick

N

Options: ReplyQuote
Re: Search+ v1.0.4
Posted by: jsnj
Date: December 12, 2011 08:53AM

Quote
ndebord
jsnj,

I really need something like this. I'm doing non-profit grant writing these days (I am now officially too old to get back into the computer magainze biz) and I desperately need to save keyword searches.

Is this the right macro to use?

Much thanks,

Nick

Sorry for the delay. I spend most of my online time using FF on Kubuntu Linux these days so I haven't been visiting the forums daily. Re: your question, I'm surprised you never used this extension. IIRC one of the reasons for creating this extension years ago was in response to one of your requests to have the option to make multisearch the default engine. Anyway, the previous searches function saves any and all searches made with the KM macro search function including the keyword searches the user created via this macro. Keyword searches created with the bookmarks plugin via nickname won't be saved. Is that what you mean?



Edited 1 time(s). Last edit at 12/12/2011 09:02AM by jsnj.

Options: ReplyQuote
Re: Search+ v1.0.4
Posted by: JamesD
Date: December 12, 2011 09:52PM

@ ndebord

There is the possibility this could help you. It is not as fancy as this extension, but it works for me.
http://kmeleon.sourceforge.net/wiki/KmmSearchH

Options: ReplyQuote
Re: Search+ v1.0.4
Posted by: ndebord
Date: December 13, 2011 08:43AM

Quote
jsnj
Quote
ndebord
jsnj,

I really need something like this. I'm doing non-profit grant writing these days (I am now officially too old to get back into the computer magainze biz) and I desperately need to save keyword searches.

Is this the right macro to use?

Much thanks,

Nick

Sorry for the delay. I spend most of my online time using FF on Kubuntu Linux these days so I haven't been visiting the forums daily. Re: your question, I'm surprised you never used this extension. IIRC one of the reasons for creating this extension years ago was in response to one of your requests to have the option to make multisearch the default engine. Anyway, the previous searches function saves any and all searches made with the KM macro search function including the keyword searches the user created via this macro. Keyword searches created with the bookmarks plugin via nickname won't be saved. Is that what you mean?

jsnj,

Yes, I didn't go whole hog, but did go with that multisearch option you wrote and have been using that ever since with great success and much thanks. Why I didn't pick up on this one is a mystery to me. <sigh>

P.S. There is Fred and Wine available to you anytime you wish. More power to you with FF and Linux.... I have both and use neither most of the time. IF I need a more modern Gecko, I tend to go to SeaMonkey instead.

N



Edited 1 time(s). Last edit at 12/13/2011 08:45AM by ndebord.

Options: ReplyQuote
Re: Search+ v1.0.4
Posted by: ndebord
Date: December 13, 2011 08:53AM

Quote
JamesD
@ ndebord

There is the possibility this could help you. It is not as fancy as this extension, but it works for me.

http://kmeleon.sourceforge.net/wiki/KmmSearchH


JamesD,

Thanks, that too will help. <g>

N

Options: ReplyQuote
Pages: Previous12
Current Page: 2 of 2


K-Meleon forum is powered by Phorum.