kem 5.9 -update
Posted by: disrupted
Date: August 24, 2010 12:25AM

kmeleon extensions manager has been updated to 5.7. the update adds a new feature to enable reverting to original or default pref settings pre install

e.g. when installing an extension like multipagine, it sets itself as homepage... the new feature enables to set back the homepage to default after uninstalling the extension so the user won't be faced with 'page not found' on the startup page.
few extensions can make use of that feature but it an be extremely useful for extensions that modify important or ebvn minor settings and can cause inconvenience for the user when the extension is uninstalled and when those settings are not reverted

here is the template for 5.7 compatible uninstall ini
http://kmext.sourceforge.net/keih/template5.7.ini

you'll notice the new entry:
[defaultpref]


this should not be confused with the [pref] entry which removes the extension defaults pref file (*.js)

the defaultpref should have raw prefs corresponding to original prefs in kmeleon that has been modified after that extension was installed.

for example in multipagine, i want the homepage to revert back after an uninstall so i add the value like this:

[defaultpref]
1=user_pref("browser.startup.homepage", "resource:///readme.html");


this tells the extension manager that when this extension is uninstalled, this value has to be written exactly as is in prefs reverting back the homepage to readme

there can also be other usages for this value and not necessarily just for reverting default prefs..for example when an extension is uninstalled and you want to make sure it uses original values if it's reinstalled etc.

e.g
[defaultpref]
1=user_pref("my.extensionhasbeeninstalledbefore", true);


you can enter as many [defaultpref] values as you wish with no limitations

no extension needs to be updated to use the new template if it has no use for it..using the old template will not cause any problems with 5.7, defaultpref is a 'convenience feature for the benefit of the user and making the extension better

for now only 5 extensions make use of the defaultpref feature
multipagine
speeddial
restart3
bbc iplayer proxy
family filter proxy

kem 5.7 can be downloaded from kmext.sf.net/kem.htm



Edited 1 time(s). Last edit at 08/25/2010 04:21AM by jsnj.

Re: kem 5.9 -update
Posted by: disrupted
Date: August 25, 2010 03:29AM

kmeleon extensions manager has been updated to 5.9. this update adds the ability to restore original kmeleon files that have been modified or replaced by an extension after uninstalling it.

this can be useful when your extension requires that a default km file like a macro needs to be replaced for your extension to function properly.. after uninstalling the extension, the mod file can cause problems, conflicts or just missing features due to missing additional macro etc. this new feature ensures that original km files are restored after the extension was uninstalled.

template for 5.9:
http://kmext.sourceforge.net/keih/template5.9.ini

the new entry is:
[defkmfiles]

this is how to make use of the new feature if your extension needs it:

inside your 7z package, create a new folder called 'defkmfiles'
inside that folder add the original kmeleon files that your extension will replace..be it a macro or config or anything but you need to add it with the proper path. for example if i make an extension that replaces the sendto.kmm, i'll create the defkmfiles folder inside the package and then create a subfolder called macros because that's where the original file belongs and then inside the macros folder i'll include the original sendto.kmm macro..
defkmfiles\macros\sendto.kmm

after that you will need to add the entry in the uninstall ini e.g:
[defkmfiles]
1=macros\sendto.kmm


this will tell kem that upon an unistall it needs to find that file inside the defkmfiles folder and replace the coresponding one in the macro folder with it. after that kem will remove the defkmfiles because it becomes of no use

currently only 2 extensions make use of that new feature:
searchplus
agentswitcherplus

please take a look inside those 2 updated extensions to get a better undersyanding of how that feature works

kem 5.9 can be downloaded from kmext.sf.net/kem.htm

Re: kem 5.9 -update
Posted by: jsnj
Date: August 25, 2010 04:20AM

Haven't tested it yet, but nice smiling smiley

Re: kem 5.9 -update
Posted by: disrupted
Date: August 25, 2010 05:20AM

i made a few tests some even with bogus files, it's working very good smiling smiley

the 9x(98,95,me) version had a regression bug due to compiler error.. please download again kem 5.9 for 9x from this link:
http://kmext.sourceforge.net/keih/kem9x-5.9.zip

for nt, kem has been updated to 7.0. this adds better progress for the local installer and realtime download progress for the online installer. the uninstall bits of nt version 7.0 and 9x kem 5.9 are identical


both versions are on kem page http://kmext.sourceforge.net/kem.htm
note: kem 7.0 is for nt systems only(xp, nt, 2k, vista, 7, 2003.NET, 2008 etc)

Re: kem 5.9 -update
Posted by: duffy2009
Date: September 20, 2010 10:43PM

disrupted ... just found out about the new KM Ext Manager version for Windows 9x. I may have missed it but I have a question ... do I have to unistall the older version first? I think I have v5.5 installed now on KM 1.5.4 ... can I just install v5.9 over the older version or should the older version be uninstalled first? I have 6 plugins installed, will the install of v5.9 pick those up? I see this version has something new added and I will read your post again, to better understand the addition. Also, I asked this question in another thread concerning the newer KM 1.6 version. Will the Ex Manager work with this newer KM 1.6 version? ... thanks

... another question ... I was able to install the 1.6 desga's cp4-version on my Win 98SE notebook using the newer KernelEx version. Had help over the weekend from siria, Matt and others in the General thread. My question about your plugins ... as I said, I have the newer KM version on a Win 98SE machine but I had to use KernelEx to change KM compatabilty to XP SP2. Since Win 9x was not suppose to work with the newer K-Meleon and some of your plugins have Win 9x and NT versions for download. For instance, KM Extentions Manager has 9x and NT versions. Will the 9x version work in the newer KM v1.6 version and also all the other plugins that have both a 9x or NT version. Would you also have some knowledge on what flash version to use. I am using Flash Player 9.0.277.0 (9x) on KM v1.5.4, should I use the same version on KM 1.6? ... thanks



Edited 3 time(s). Last edit at 09/21/2010 06:49PM by duffy2009.

Re: kem 5.9 -update
Posted by: disrupted
Date: September 22, 2010 06:15PM

you can update kem normally over an existing version.. no need to uninstall. existing extensions will still be accessible through updated kem without problems. you should use the 9x version(5.9) with 1.6

regarding autoit extensions, you should keep using the 9x versions as usual even on 1.6 they will still work. there's no need to use nt versions because it will require launching them through kernelx and they are both the same only 9x is ansi complied because some autoit commands do not function properly on nt unless they are compiled in unicode... when using 1.6(unicode) the ansi versions will still be able to work on 9x.

flash plugin 9.0 will work on 1.6 and 1.6 will accept them without problems...recent versions for nt will not work on 9x and don't know if they can work through kernelx as a library dll, will probably cause crashes

Re: kem 5.9 -update
Posted by: duffy2009
Date: September 22, 2010 09:40PM

Thanks so much for all the information ... I will be using the 9x versions, just wanted to be sure with the new KernelEx installed.

Re: kem 5.9 -update
Posted by: disrupted
Date: October 09, 2010 10:57PM

kmelen extensions manager NT version has been updated to 7.2
this version adds better support for vista/7/2008 server. you needn't update if you're not using those oses

K-Meleon forum is powered by Phorum.