Extensions :  K-Meleon Forum
All about K-Meleon extensions. 
Speeddial Not working?
Posted by: Mtestlab
Date: August 08, 2010 09:58AM

Hi all.
Updated to v1.54 and now my speeddial dosen't work. I had speeddial (my12) as my default homepage and it worked great on v1.53 (set to "open in new"). Now (with 1.54) I can load an address into any of the 12 boxes and it will work, but not "open in new" only "open in this" regardless of which option I choose. If I open a new tab/window/browser session (to default speeddial homepage) My speeddial is blank of any entered addresses.

Any help would help. Thanks!

Other info:
Windows ME, cough, cough
I also have Opera 1.54 (1.60 dosen't take, had to uninstall 1.60 and reinstall 1.54)
I use opera speeddial
K-Meleon is my default browser and I use it approx 98%. I have IE 6 but only for offline viewing.



Edited 1 time(s). Last edit at 08/08/2010 10:50AM by Mtestlab.

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: disrupted
Date: August 08, 2010 07:35PM

it sounds like js is globally disabled which speeddial needs to setup pages..it could also be related to cookies since it needs to store a cookie for your settings.. check it js is enabled and make sure to accept all cookies in preferences>privacy>allow all cookies.

you might also be interested in multipagine which is similar to speeddial but doesn't rely on cookies or external service to generate thumbnails

multipagine can be found there:
http://kmext.sourceforge.net/ext4.htm

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 09, 2010 02:23AM

Thanks for the help. it is appreciated.

My Js is enabled and I am accepting all cookies.
Problem still there.

As I think of it, around the same time I installed Safer Networking (spybot) filealyz.exe which was very quirky and I uninstalled it. Is it possible there is a corruption somewhere (e.g. registry) that I'm not seeing?

If no one else is seeing this problem after the 1.54 update, I'd surmize that it is very possible I have a different (non- 1.54) issue. But I'm still in the dark.

Is therre a place/way to find out what speeddial is dependent on?

Thanks
smiling smiley

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 10, 2010 12:01PM

Quote
disrupted
you might also be interested in multipagine which is similar to speeddial but doesn't rely on cookies or external service to generate thumbnails

multipagine can be found there:
http://kmext.sourceforge.net/ext4.htm

Didn't mean to gloss over this point. I did try it but had problems. Most due to that I am a novice "K-meleoner" having been on it only since v1.5.3

That said, I was hooked on K-Meleon the minute I opened it. It's not so bad that I have this little problem since it's forcing me to get under the hood a lot more.

To update: I got Extensions manager 5.5 and used it to install speeddial. Still no go. The more I tinker with this the more I think this is a little thing since everything else is running smooth.

Any other ideas anyone? Is this a candidate for a bur report? I wonder if there is a corruption when I tried to update Opera?

For sure if I do find the answer I'll post it. Thanks.

Hmmm...

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: disrupted
Date: August 10, 2010 10:21PM

i couldn't make it open in new either..on several old and new kmeleon, are you sure it worked before? if it did work before, that probbaly means the service has changed some js


what problems did you have with multipagine? it was updated several times to fix many bugs, please try the latest one and see if it works as expected

you can't report an extension bug to the bug tracker..unless it's an indication of a k-meleon core problem which isn't in this case.

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 17, 2010 05:23AM

Sorry for late reply, I was out of town camping.

Quote
disrupted
i couldn't make it open in new either..on several old and new kmeleon, are you sure it worked before? if it did work before, that probbaly means the service has changed some js

I can only say that in 1.5.3 it worked fine. I don't know what "the service has changed some JS" means.

Quote
disrupted
what problems did you have with multipagine? it was updated several times to fix many bugs, please try the latest one and see if it works as expected

I'm learning as I go, I did like the speed dial since I was an opera user for years it was very comfortable for me. I'll try it (multipagine) again but it expresses a possible issue with non "www." (I can't remember wherer I saw it)addresses which would not work for me.

Quote
disrupted
you can't report an extension bug to the bug tracker..unless it's an indication of a k-meleon core problem which isn't in this case.
So I presume its a JS problem? what can I do?

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: disrupted
Date: August 17, 2010 06:13AM

it doesn't work anymore on 1.5.3 or .4 or 1.6 or 1.1.x, because speedidal relies on a server-side cookie and apparently they have disabled their cookies feature..so not only does the open in new doesn't work..your settings and thumbnails are not stored..and everytime you open the speedial page or reload it; it will appear without any configuration showing all blank thumbnails..unfortunately there nothing you can do about it

the mulipagine www prefix issue has been resolved..try it again, just make sure to download the proper version for your os. the nt version is for xp, 2000,vista,7 etc and the 9x is for 98 and me
http://kmext.sourceforge.net/ext4.htm

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 17, 2010 06:49AM

Quote
disrupted
the mulipagine www prefix issue has been resolved..try it again, just make sure to download the proper version for your os. the nt version is for xp, 2000,vista,7 etc and the 9x is for 98 and me
http://kmext.sourceforge.net/ext4.htm

I thank you for confirming the speed dial problem. At least it will stop me from trying to fix it.

Downloaded it (mulipagine 9x). Used extension manager this time too. No Go. Dosen't seem to work.
Will trouble shoot if you can give me suggestions. I did not re-boot yet. so there is one more try on my end.

I may create my own homepage in FrontPage with static speed dial links.

Thanks again!!

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 17, 2010 07:11AM

Update:
Okay, the reeboot was not the issue. My fire wall needed to allow mulipagine TCP-> out. mulipagine 9x is now "programable" but the thumbnails remain blank e.g. www.google.com will come up but the thumbnail says "no preview avaialable.

Side note: it's cool and I'd use it but the embedded search engines I find annoying since I can't change them and Bing is not very good IMO.

That said, if I can get the thumbnails, I'd use it.



Edited 1 time(s). Last edit at 08/17/2010 07:13AM by Mtestlab.

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: disrupted
Date: August 18, 2010 05:31AM

it sounds like your firewall is blokcing sitteshoter which is the application used for creating the thumbnails..for a quick test, try to disable the firewall for a moment and see if thumbnails are created. if it works, then you will need to add siteshoter in your firewall whitelist..even manually if the firewall doesnt prompt you.

even try to use siteshoter standalone to see if its able to capture websites.
run siteshoter from kmeleon folder\tools\multipagine\siteshoter.exe and create a test thumbnail.

note that siteshoter depends on internet explorer libraries for capturing websites..if you have previously removed internet explorer with utilities like 'eliminateie' etc..then siteshoter will definitely not work. you can still create your thumbnails manually for multipagine by capturing the website with extensions like super screenshot or faststone etc and saving it to the corresponding url as site01.jpg site02.jpg etc and save them to the mulipagine folder (take a look at the multipagine folder, you will get the idea)

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 19, 2010 07:15AM

Quote
disrupted
it sounds like your firewall is blokcing sitteshoter which is the application used for creating the thumbnails..for a quick test, try to disable the firewall for a moment and see if thumbnails are created.

Tried it, no go.

Quote
disrupted
even try to use siteshoter standalone to see if its able to capture websites.
run siteshoter from kmeleon folder\tools\multipagine\siteshoter.exe and create a test thumbnail.

Siteshooter dosen't want to open standalone at all. In the nirsoft help it says:
"This utility works on Windows XP, Window 2003 Server, and Windows Vista. You can also use this utility in Windows 2000, if GDI+ is installed." I went to nirsoft to see if he has a 9x freindly version but there is none. I whitelisted it in my (Kerio tiny) firewall anyway but still no go. I have gdiplus.dll in Windows\system and I put a copy in the tools\multipagine folder but no go. I'm sending nirsoft a query about a 9x version to see if it is a available.


Quote
disrupted
note that siteshoter depends on internet explorer libraries for capturing websites..if you have previously removed internet explorer with utilities like 'eliminateie' etc..then siteshoter will definitely not work.

I do have IE installed.

Quote
disrupted
you can still create your thumbnails manually for multipagine by capturing the website with extensions like super screenshot or faststone etc and saving it to the corresponding url as site01.jpg site02.jpg etc and save them to the mulipagine folder (take a look at the multipagine folder, you will get the idea)

Super screen shot or faststone.. which do you recommend? And much thanks for the help.

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Matt
Date: August 19, 2010 01:06PM

Speedykm by Hao (I only edited the default website list)



Edit the file speedykm.html in a notepad to change thumbnails.

Setting speedykm.html as home page: F2 > Browsing > At startup, check Load home page and browse for speedykm.html.

To change the default background image, copy your image to speedykm folder, than open speedykm.html in notepad, scroll to the bottom, in the last line you will see background-image:url(logo.jpg) and edit to background-image:url(your_image_name.jpg). It can be a jpg, bmp, png , etc.

Websites inculed in the attached file:

K-Meleon
Twitter
YouTube
Digg
MozillaZine Forums
Delicious
PortableApps
Deviantart
Wikipedia
eBay
IMDb
MapQuest
Yahoo!
Flickr
Bing
facebook

Attachments: speedykm.7z (25.3 KB)  
Options: ReplyQuote
Re: Speeddial Not working?
Posted by: disrupted
Date: August 20, 2010 07:30AM

siteshoter does work on 9x.. i tested it several times without problems. using windows 98 and ie 5 and it creates captures normally either through multipagine or separately.. theoretically there shouldn't be differences between 98 and me or ie5 and ie6 that prevent siteshoter from working.

the problem doesn't seem that siteshoter isn't able to connect and therefore not in IEOLE object calls but there seems to be another thing that doesn't allow it to run all together ..maybe an antivirus flagging it by mistake?

both faststone and super screenshot are good extensions, it's a matter of personal preference.. faststone is a local app and superscreenshot relies on an online service. i think for thumbnails superscreenshot is a better choice

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Alex.Tarantul
Date: August 20, 2010 11:20PM

I announce that I also have a problem with SpeedDial. It began with the first or second of August.

My blog about K-Meleon
http://kmeleon-ru.blogspot.com/

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 20, 2010 11:49PM

Quote
Alex.Tarantul
I announce that I also have a problem with SpeedDial. It began with the first or second of August.

What version of K-Meleon do you have?

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 21, 2010 12:14AM

Quote
Matt
Speedykm by Hao (I only edited the default website list)



Edit the file speedykm.html in a notepad to change thumbnails.

Setting speedykm.html as home page: F2 > Browsing > At startup, check Load home page and browse for speedykm.html.

To change the default background image, copy your image to speedykm folder, than open speedykm.html in notepad, scroll to the bottom, in the last line you will see background-image:url(logo.jpg) and edit to background-image:url(your_image_name.jpg). It can be a jpg, bmp, png , etc.

Websites inculed in the attached file:

K-Meleon
Twitter
YouTube
Digg
MozillaZine Forums
Delicious
PortableApps
Deviantart
Wikipedia
eBay
IMDb
MapQuest
Yahoo!
Flickr
Bing
facebook

Interesting, I downloaded it viewed it and will try it out.

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 21, 2010 12:20AM

Quote
disrupted
siteshoter does work on 9x.. i tested it several times without problems. using windows 98 and ie 5 and it creates captures normally either through multipagine or separately.. theoretically there shouldn't be differences between 98 and me or ie5 and ie6 that prevent siteshoter from working.

the problem doesn't seem that siteshoter isn't able to connect and therefore not in IEOLE object calls but there seems to be another thing that doesn't allow it to run all together ..maybe an antivirus flagging it by mistake?

both faststone and super screenshot are good extensions, it's a matter of personal preference.. faststone is a local app and superscreenshot relies on an online service. i think for thumbnails superscreenshot is a better choice

It is very possible if not certain that you are correct. I run a very modified version of Me. Running siteshoter on dependency walker shows this error:
GetProcAddress(0xBFF60000 [KERNEL32.DLL], "IsTNT") called from "OLEAUT32.DLL" at address 0x7FE8D090 and returned NULL. Error: The specified module could not be found (126).

I recall stripping out certain OLE functions. Perhaps that is it?

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: ndebord
Date: August 21, 2010 07:51AM

Aside from changing your choice of websites to use in SpeedDial (sly grin), it works just fine on my XP PRO SP3, KM 15.4 browser. My choice was to not make it my home page, but instead to load it up in hotlinks as Ctrl 1:


file:///C:/Program%20Files/K-MELEON/speedykm/speedykm.html

N



Edited 3 time(s). Last edit at 08/21/2010 07:53AM by ndebord.

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: disrupted
Date: August 21, 2010 12:15PM

Quote
Mtestlab
I recall stripping out certain OLE functions. Perhaps that is it?

yes, this would certainly cripple siteshoter but don't worry about it..speed dial has been fixed, thanks to tarantul and nde

the first problem was in one of the js files with an expired cookie date set
if you look in the old speeddial files, there is a file common.js with this string:
function Set_Cookie(name,value) {
var cookieString = name + "=" +escape(value) +
";expires=Fri, 3 Aug 2010 20:47:11 UTC" +
";path=/";
document.cookie = cookieString;
}

so naturally that cookie was over..this has been fixed and extended to 2125 so that should give us enough time before we worry about it again

the second problem , thanks to nde for the tip ..but i don't have an explanation for it. when speed dial was set with the usual path resource:/// it failed to save settings when a conventional path with drive and folders e.g. file:///I:/speeddial.htm it was able to save settings..

so both those limitations will have caused problems.. first cookie limitation is definite ofcourse

speeddial has been updated to fix all that and also updated as an extension with an uninstall ini to remove its files and will now set itself automatically as your homepage with the proper path

please download the updated version:
http://kmext.sourceforge.net/files/speeddial.7z
(make sure to clear cache first to avoid downlosading the old file from your cache)

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: disrupted(unlogged)
Date: August 21, 2010 05:47PM

update adds menu in view>home/ home button context to easily set speed dial as homepage when something changes that. download from same link



Options: ReplyQuote
Re: Speeddial Not working?
Posted by: ndebord
Date: August 21, 2010 10:47PM

disrupted,

When I use this on hotlinks, the only thing I have to remember to do after settings up all my favorite speeddial homepages it to save the page as to c:\program files\ k-meleon\tools\speeddial.html. <g>

N

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: siria
Date: August 22, 2010 12:29AM

Just regarding siteshoter, I dimly remember when I tried it last year in another extension it did work on Win98, but only after having it started one time directly from its exe. It had something to do with the empty ini. Haven't used it anymore since I found FastStone, but when I now look into compatibility tab, it is set to NOT use kernelex, just in case you may have that installed ;-)

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 22, 2010 08:36AM

Just want to send out a
BIG THANKS!smiling smiley

to disrupted, tarantul and nde and everyone else here who took part in this particular issue. I really appreciate it. Yeah, I'm patronizing it a bit especially since you all came to my aid but I am sincere too!grinning smiley

I have speeddial up and running and I believe it is the best solution for me. In trying to fix this problem I doubled my awareness to both working with K-Meleon and finding out what it can do. Even learned more about the alternate versions. Very interesting.

Okay that all said, can "our" speeddial be customized for more boxes like opera?:
http://operawatch.com/news/2008/06/how-to-add-more-speed-dials-in-opera.html
12 boxes is great, 16 or 20 would be the bomb!

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Alex.Tarantul
Date: August 25, 2010 11:51PM

Quote
Mtestlab
Okay that all said, can "our" speeddial be customized for more boxes like opera?:
http://operawatch.com/news/2008/06/how-to-add-more-speed-dials-in-opera.html
12 boxes is great, 16 or 20 would be the bomb!
Yes, it is possible. Unfortunately, this is done only by hand: you have to edit the script code (change the size of previews, the thickness of the borders, the distance between the windows) ...
P.S.: I am sorry for awful English. I think that you have understood me...

My blog about K-Meleon
http://kmeleon-ru.blogspot.com/

Options: ReplyQuote
Re: Speeddial Not working?
Posted by: Mtestlab
Date: August 26, 2010 12:31AM

Thanks for everything you've done Alex. English is finesmiling smiley

I started a new thread on this topic here:

http://kmeleon.sourceforge.net/forum/read.php?9,109870

Options: ReplyQuote


K-Meleon forum is powered by Phorum.