Extensions :  K-Meleon Forum
All about K-Meleon extensions. 
Pages: 12Next
Current Page: 1 of 2
adblockplus update(no k-plugin)
Posted by: disrupted
Date: June 20, 2010 04:24AM

http://kmext.sourceforge.net/files/adblockplus.7z

this update adds features though macro file instead of adblockplus.dll k-plugin. due to a memory leak in the abp k-plugin; users are advised to disable adblockplus.dll(edit>preferences>k-plugins) and update to this extension.. you can also delete the k-plugin adblockplus.dll without problems.

added features:
image context>adblock image, adblock domain
frame context>block frame (page context>frame)

toolbar button
tools>?adblock plus>toggle extension|toggle tabs on java/flash|prefs

some features are assisted with an autoit script, like when first installed(no subscriptions)..autoit script updates subscriptions instead of relying on the k-plugin (as always autoit source is included)

- missing features that cannot be added:
status bar icon/toggle from statusbar icon

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: jsnj
Date: June 20, 2010 01:03PM

Tried it out on KMv1.5.4 that I'm using to test one of my macros. Couple problems:

Line 77 causes problems with the toolbars list under View - Toolbars. Changing it to:

pluginmsg(toolbars,"AddButton","Adblock Plus,adblockplus,macros("."adblockplus_tog"."),"."Adblock Plus".",".$abptip.",16,16,"."adblockplus.bmp[1],adblockplus.bmp[0]","");

resolves the problem. Also the ABP Preferences window immediately closes upon opening. Error Console chrome errors "has no properties" appear after attempting to open it.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: disrupted
Date: June 21, 2010 12:33AM

thanks, i'll fix the toolbar line but i don't understand why prefs is closing..i don't have tht error. where does it open and close when opening from menu tools>adblockplus>prefs or when open from image context menu>block image?
make sure to use the chrome jar files with the updated extension not just the macro..other versions may require different command.
i'll test again.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: jsnj
Date: June 21, 2010 12:48AM

Just tested on a 1.5.3 I had and didn't get those errors with the ABP prefs window, nor the problem with the toolbar line. Not sure why it barked in my 1.5.4. Did find that pesky missing semicolon at the end of line 70 though. smiling smiley

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: disrupted
Date: June 21, 2010 12:54AM

almost drove me nuts trying to find that problem.. i found that missing semicolon(no macro is complete without a missing semicolon grinning smiley)

J MAYBE THAT CHROME ERROR WAS DUE TO UNREGSITERED NSADBLOCKPLUS COMPONENT..TRY TO DELETE XPTI.DAT AND COMPREG.DAT .. TYPING IN CAPS WAS NOT INTENTIONAL(BAD FINGERS DO CRAZY STUFF,too tired to retyoe



Edited 1 time(s). Last edit at 06/21/2010 12:55AM by disrupted.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: jsnj
Date: June 21, 2010 01:20AM

Just tested again on 1.5.4. Had to uninstall. Ran into a problem with reinstalling which I think clued me into what I believe the problem was to begin with. When I initially installed, subscribing didn't take. It for some reason didn't restart the way I now know it's supposed to . Maybe my RAM was clogged at the time I don't know. But because the subscription wasn't set, the "no properties" error occured and I couldn't open the abp prefs window. I guess the abp prefs window doesn't stay open if a subscription isn't set. Just guessing here. Anyway, I had to manaully get rid of those firstrun & firstsubs prefs to be able to get to the subscription window after reinstallation. Otherwise I kept getting the quick close abp prefs bug. BTW, line 77 still had to be changed to what I posted above in order to avoid the toolbars list bug in 1.5.4.



Edited 1 time(s). Last edit at 06/21/2010 01:21AM by jsnj.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: disrupted
Date: June 21, 2010 05:01AM

i fixed the semicolon, i think..maybe you've downloaded from cache. i tried your line but when i did, there was no longer a toolbar adp icon or the toolbars view menu.. i think the toolbar needs to be declared first before the button, not entirely sure..desga should know. what's the list bug?

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: jsnj
Date: June 21, 2010 07:03AM

Well, I don't know what to tell you. PC crashed. After a restart, I can't reproduce the View - Toolbars list error. Basically it just listed the URL Bar and no other toolbars. Now with either version of line 77, all the toolbars are listed. The only difference between the 2 versions of line 77 is that yours creates the variable $abpbutton and defines it with the add button line. It's not needed. I'm curious why you defined it. I don't see it referenced anywhere else in the file. But anyway, it appears to no longer be doing any harm.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: disrupted
Date: June 22, 2010 05:34AM

bad habit..probably cause of autoit
updated without button variable

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: Mr. Cooper
Date: June 22, 2010 09:40PM

I don't know if this is helpful or not, but I just switched to the abp kmm. I am running KM 1.6.0a4 on Windows 7. Everything works great except abp. It won't let me add any filters to block stuff. I type something in, hit Enter, and the abp screen closes. I've tried several methods, including starting KM as Administrator. I tried the subscription list too, and that doesn't seem to work either. Am I doing something wrong? Or is there a problem when adding to the block list?



Edited 1 time(s). Last edit at 06/22/2010 09:52PM by Mr. Cooper.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: jsnj
Date: June 22, 2010 11:52PM

Quote
Mr. Cooper
I don't know if this is helpful or not, but I just switched to the abp kmm. I am running KM 1.6.0a4 on Windows 7. Everything works great except abp. It won't let me add any filters to block stuff. I type something in, hit Enter, and the abp screen closes. I've tried several methods, including starting KM as Administrator. I tried the subscription list too, and that doesn't seem to work either. Am I doing something wrong? Or is there a problem when adding to the block list?

Sounds like the same problems I ran into initially when installing on 1.5.4. I haven't tried it on 1.6a4. Try uninstalling using KEM. Then before reinstalling, go to about:config and look for the following prefs:

extensions.adblockplus.firstsubs
extensions.adblockplus.firstrun


Right-click each pref and reset it. Then reinstall ABP. After installation is complete and KM has been restarted, the subscription page should come up. Once you've selected your subscription list and clicked on OK or SUBMIT or whatever that button is at the bottom, you'll know it has worked if KM auto-restarts again. Then the ABP preferences window should stay open.



Edited 1 time(s). Last edit at 06/22/2010 11:53PM by jsnj.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: disrupted
Date: June 23, 2010 12:08AM

xurrent adp for kmeleon will never work on 1.6, the jar and components files are not compatible with gecko 1.9.x. use only on 1.1.x and 1.5.x

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: panzer
Date: June 23, 2010 03:56AM

Disrupted, make ABP for Kmeleon 1.0.2 and not 1.0.1. Or this can not be made? If I saw correctly, you made 1.0.1 version.

And please add an option (if you can) disable ABP on this page only like the previous version have had.



Edited 2 time(s). Last edit at 06/23/2010 04:07AM by panzer.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: desga2
Date: June 23, 2010 04:07AM

I think this line is wrong:
pluginmsg(toolbars,"AddButton","Adblock Plus,adblockplus,macros("."adblockplus_tog"."),"."Adblock Plus".",".$abptip.",16,16,"."adblockplus.bmp[1],adblockplus.bmp[0]","");

Right line must be:
pluginmsg(toolbars,"AddButton","Adblock Plus,adblockplus,macros(adblockplus_tog),Adblock Plus,".$abptip.",16,16,adblockplus.bmp[1],adblockplus.bmp[0]","");

Remember documentation about it:
pluginmsg(toolbars, "AddButton", "<ToolbarName>, <ButtonName>, <Command>, <MenuName>, <TooltipText>, <ButtonWidth>, <ButtonHeight>, hot.bmp[0], cold.bmp[0], dead.bmp[0]","");

The third parameter is a long string with button definition and you only have to cut the string to add with dots some text in a variable, for example $abptip, but in this case the rest aren't variables you not need cut the string and add it with dots.

K-Meleon in Spanish

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: Mr. Cooper
Date: June 23, 2010 07:35AM

jsnj: Oops! I was setting up some defaults in user.js and inadvertantly included those lines!

disrupted: Drats. Good to know, though. Is it expected to be compatible by the next stable release?

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: disrupted
Date: June 23, 2010 06:50PM

ok, updated to use 1.0.2 chrome files..there aren't much differences i think between 1.0.1 and 1.0.2. main difference is the k-plugin which isn't used now. also fixed toolbar command in macro.

i'm not sure if i can disable for current page.. it adds special filter lines in the adblock.ini filter, will need extensive autoiting.. i'll do some tests

cooper, hopefully when 1.6 becomes a beta or stable, palant(author for abp) will update it for kmeleon

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: jsnj
Date: June 24, 2010 01:56PM

Quote
desga2
I think this line is wrong:
pluginmsg(toolbars,"AddButton","Adblock Plus,adblockplus,macros("."adblockplus_tog"."),"."Adblock Plus".",".$abptip.",16,16,"."adblockplus.bmp[1],adblockplus.bmp[0]","");

Right line must be:
pluginmsg(toolbars,"AddButton","Adblock Plus,adblockplus,macros(adblockplus_tog),Adblock Plus,".$abptip.",16,16,adblockplus.bmp[1],adblockplus.bmp[0]","");

Remember documentation about it:
pluginmsg(toolbars, "AddButton", "<ToolbarName>, <ButtonName>, <Command>, <MenuName>, <TooltipText>, <ButtonWidth>, <ButtonHeight>, hot.bmp[0], cold.bmp[0], dead.bmp[0]","");

The third parameter is a long string with button definition and you only have to cut the string to add with dots some text in a variable, for example $abptip, but in this case the rest aren't variables you not need cut the string and add it with dots.

That's what I thought too awhile back when I first saw example codes in a couple macros that added a button, but your example above which seems to make sense to me too, causes problems. Even though it does add the button, that same View - Toolbars bug reappears with that code, but not with the original one I posted which is based on just about all the other macro buttons available in modules including your old flashblock macro module.

BTW, the latest ABP kplugin which Wladimir Palant just posted places a weird immovable toolbar just below KM's toolbars. So until that's remedied, disrupted's version should still be available.



Edited 1 time(s). Last edit at 06/24/2010 01:57PM by jsnj.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: panzer
Date: June 24, 2010 02:23PM

When I tried to subscribe to some filters, Km crashed and opened without my profile. I tried to restore backed up profile, but it failed. Then I restarted it again and then it was fine.

I tried again and now it is OK. Can someone recommend some good filter to subscribe? I use Ares and Dr. Evil.

Is it even good to be subscribed to any filter?



Edited 2 time(s). Last edit at 06/24/2010 02:30PM by panzer.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: disrupted
Date: June 25, 2010 12:41AM

i'm not sure why it happens because couldn't reproduce..could be that the inital subscribing requires a profile where abp hasn't been used before..no special prefs, not sure. anyways, it's not that important now since palant has updated the official extension/

i only use 2 subscriptions and they are enough for my surfing in blocking ads:
easy list (usa)
and cedrics liste (de)

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: panzer
Date: June 27, 2010 02:14AM

Quote
disrupted
ok, updated to use 1.0.2 chrome files..there aren't much differences i think between 1.0.1 and 1.0.2.

It is all about perfection, my dear Watson. Perfection!

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: panzer
Date: June 27, 2010 02:59AM

Disrupted, I deleted all your ADB files and unzipped Palant's version. I also unzipped profilebackup (update). When I tried to open Km, it has found corrupted profile. It auto-restored it OK, but ADB icon was on the left below Bookmarks and it cannot be moved even when I had unlocked toolbars. The icon was not fully seen (like 95 % of it). The next time I tried to opened Km again it found corrupted profile. It has auto-restored it, but my profile was gone (not from the USB, though). I could not restored it anymore.

It does not matter since I had a suspicion that this would happened so I coppied my whole Km to HD. But, was it all corrupted profile's fault or is something wrong with Palant's icon in ABP? Otherwise, ABP worked just fine.

I will pass on new profilebackup for now. I trust the old one better. grinning smiley

i will try to use both of it on a clean version of Km. Will see what happens.



Edited 3 time(s). Last edit at 06/27/2010 03:04AM by panzer.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: disrupted
Date: June 27, 2010 03:21AM

it's not profilesbackup fault.. nor corrupted profile, you can still use the updated profiles backup and disable auto backup and auto restore and it will be exactly like the old one (creates backup or restores manually only)

but if you prefer the old one, it can still be downloaded from
(multiple profiles/users %appdata only))http://kmext.sourceforge.net/files/profilebackup-all.7z

portable kmeleon or single profile(profile.ini or usual/appdata% path)
http://kmext.sourceforge.net/files/profilebackup-portable.7z


adp button bug happened after update, i noticed it(with a default test profile 1.5.4, 1.1.4) and already emailed palant about it


please post this bug at adp forum, thanks panz
https://adblockplus.org/forum/viewforum.php?f=1&sid=b73c353e99ade50dd4fa75efa81196e4

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: 4td8s
Date: July 01, 2010 12:10AM

Quote
disrupted
adp button bug happened after update, i noticed it(with a default test profile 1.5.4, 1.1.4) and already emailed palant about it

so it was that silly ABP button bug that's causing problems with KM. interesting.
we'll wait for a response from Palant and see what he has to say.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: snuz2
Date: July 01, 2010 02:55PM

as mentioned in another thread, I also got this toolbar problem with new release only. I posted to ABP, and Wladimir says he can not reproduce it under fresh profile.

well, I fresh installed a KM 1.5.4 and added the latest ABP release, and it still kills the toolbar. no changes at all. default everything. I told Wladimir, waiting to see if he can confirm it.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: panzer
Date: July 01, 2010 03:11PM

I also tried it in a brand new version and still got it.

I hope he can fix it. I do not understand how it is not working if he only fixed adblock.dll.



Edited 1 time(s). Last edit at 07/01/2010 03:13PM by panzer.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: panzer
Date: July 08, 2010 01:46AM

Disrupted, I have found why my profile is not loading properly. I have set a new clean portable version, installed all extensions from previous Km and after first restart the same problem occured. For a split second I thought I will be switching to Opera soon. grinning smiley

Bookmarks were gone,icons were all over the place since cache files and icons to disk were checked in preferences, skin was set to default and so on. No major problem, just it nagged me to do this every time I opened it. Profilebackup did not solve the issue, as you know.

Since at opening Km asked me about spellchecker and a searchbarext and since I recently installed Search 1.0.4, I uninstalled all three of them. I installed searchbarext back - all was Ok. With spellcheck - same problem. I uninstalled it and installed Search. All OK.

It looks like spellcheck does not like one of the new extensions (Readability, capplus, alexapps, url_void, rsautovait, filesindexer, linksextractor, ...). Now, without it (i. e. K-Ext110_SpellCheck.exe), Km loads without problem (I several times tried and managed to open and close it without partially loss of profile. I do not know. Maybe I'll have a problem tomorrow. I will see if I can open it normally on a different - public - computer).

Just to let you know. If some of you have the same problem, try to uninstall spelchecker. But I do not think a lot of people would have the same problem since they do not have as many macros installed as I do. grinning smiley



Edited 2 time(s). Last edit at 07/08/2010 01:58AM by panzer.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: panzer
Date: July 08, 2010 02:25PM

Just tried it on a public comp. It still wants me to locate bookmarks, but everything else is OK.

The second thing I did not like at profilebackup-portable:

I made a backup. Then I added some new bookmarks and made another backup. When I restored the profile, not the last, but that before the changes was restored (All was OK but changes in bookmarks were gone). Now, when I am doing backup, I just delete everything in backup file and then do backup (no overwriting).

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: disrupted-unlogged
Date: July 08, 2010 08:25PM

i don't think it's a spellcheck k-plugin problem..normally macros don't cause conflicts with k-plugin., not those kind of macros.. i do have spell check installed and all those extensions on the test version but didn't notice any problems, so it could be something else, i'lldo more tests.

profile backup update will work exactly the same as the previous version ifyou disable the auto backup/restore and just do it manually when you make certain changes.. personally; like you prefer doing it manually. the update was meant for ff users who are new to kmeleon and being the spoilt brats they are; they expect the browser to fix them coffee in the morning so it was an attempt to stop their whining when they corrupt their profiles and lose bookmarks..so it had to be automated backup/restore, assuming the user an ex-firefoxer as not being able to backup themselves..hopefully that will help stop the complaints about lost bookmarks but then again there was always a xul-based profile backup ported by alain and gunter and that one can specifically backup the bookmarks only but naturally they never used it.

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: km2
Date: February 28, 2011 02:47AM

Hey disrupted,
how to delete on-off function (on the left click) in the macro?

Options: ReplyQuote
Re: adblockplus update(no k-plugin)
Posted by: 4td8s
Date: March 05, 2011 06:26AM

are u guys still talking about the ABP version supported under K-meleon versions 1.1 to 1.5x?

for those using K-meleon 1.6 betas, a new dev build of ABP was made available on Feb. 28, 2011.

Options: ReplyQuote
Pages: 12Next
Current Page: 1 of 2


K-Meleon forum is powered by Phorum.