Errors in kmm
Posted by: panzer
Date: January 23, 2010 12:43AM

Could some of you give me corrected lines:

Error: ; expected but found <name>.
Source file: I:\Km 1.5.3\macros\veloz.kmm
Line: 43
----------
Error: ; expected but found <name>.
Source file: I:\Km 1.5.3\macros\veloz.kmm
Line: 63
----------
Error: Unfinished string.
Source file: I:\Km 1.5.3\macros\veloz.kmm
Line: 77
----------
Error: ) expected but found <name>.
Source file: I:\Km 1.5.3\macros\veloz.kmm
Line: 78
----------
Error: ; expected but found <name>.
Source file: I:\Km 1.5.3\macros\veloz.kmm
Line: 78
----------
Error: ) expected but found ;.
Source file: I:\Km 1.5.3\macros\veloz.kmm
Line: 82
----------
Error: Invalid expression.;
;
$_dest_path=getfolder(R
Source file: I:\Km 1.5.3\macros\profilebackup.kmm
Line: 12
----------
Error: Function Alert is not defined.
Source file: I:\Km 1.5.3\macros\quicknote.kmm
Line: 35

Re: Errors in kmm
Posted by: disrupted
Date: January 23, 2010 01:09AM

i checked profilebackup, there are no errors..the macro might have got corrupted or rewritten for some reason, reinstall profilebackup-portable..or replace line12 with that line:

$_dest_path=getfolder(RootFolder)."\\profilebackup";

quicknote has an undefined function..not sure why, perhaps an older 1.1.x command..alain should know how to fix it

what's veloz?

Re: Errors in kmm
Posted by: panzer
Date: January 23, 2010 01:11AM

Yup, they got corrupted. Veloz is this kmm (I do not know original name of it):

# K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage)

# ---------- Page Load Speed-Up ------------------------------------------------------------------------------------
#
# Dependencies : -
# Resources : -
# Preferences : -
#
# ------------------------------------------------------------------------------------------------------------------

SpeedUp_Toggle{
menuchecked=(getpref(BOOL,"network.http.pipelining")==true);
getpref(BOOL,"network.http.pipelining")==true?&_SpeedUp_Disable:&_SpeedUp_Enable;
}

# ----- PRIVATE

_SpeedUp_Enable{
statusbar(sub("%s",$on,_("SpeedUp %s")));

# TURN ON TIMER BASED REFLOW MANAGEMENT
setpref(BOOL,"content.notify.ontimer",true);

# SETS THE ALLOWED TIME BETWEEN REFLOWS IN MICROSECONDS
setpref(INT, "content.notify.interval",1000000);

# SET THE NUMBER OF REFLOWS TO DO BEFORE WAITING FOR THE REST OF THE PAGE TO ARRIVE
setpref(INT, "content.notify.backoffcount",10);

# ENABLE IMPROVED PIPELINING
setpref(BOOL,"network.http.pipelining",true);
setpref(INT, "network.http.pipelining.maxrequests",100);
setpref(BOOL,"network.http.proxy.pipelining",true);

# INCREASE MULTI-THREADED DOWNLOAD PERFORMANCE
setpref(INT, "network.http.max-connections",60);
setpref(INT, "network.http.max-connections-per-server",32);
setpref(INT, "network.http.max-persistent-connections-per-proxy",16);
setpref(INT, "network.http.max-persistent-connections-per-server",8);

# CONFIG BY XGRIND
setpref(INT,"nglayout.initialpaint.delay", 0)
setpref(BOOL,"network.dns.disableIPv6", true);
setpref(BOOL,"content.interrupt.parsing", true);
setpref(INT,"content.max.tokenizing.time", 2250000);
setpref(INT,"content.switch.threshold", 750000);
setpref(INT,”browser.cache.memory.capacity”, 65536);
setpref(BOOL,"browser.xul.error_pages.enabled", true);
setpref(INT,"network.http.keep-alive.timeout", 30);
setpref(INT,"network.ftp.idleConnectionTimeout", 60);
setpref(INT,"network.dnsCacheEntries", 256);
setpref(INT,"network.dnsCacheExpiration", 86400);
setpref(BOOL,"browser.turbo.enabled", true);
setpref(BOOL,"plugin.expose_full_path", true);
setpref(BOOL,"network.prefetch-next", false);
}

_SpeedUp_Disable{
statusbar(sub("%s",$off,_("SpeedUp %s")));

# RESTORE DEFAULTS
setpref(INT,"nglayout.initialpaint.delay", 250)
delpref("content.notify.ontimer");
delpref("content.notify.interval");
delpref("content.notify.backoffcount");
delpref("network.http.pipelining");
delpref("network.http.pipelining.maxrequests");
delpref("network.http.proxy.pipelining");
delpref("network.http.max-connections");
delpref("network.http.max-connections-per-server");
delpref("network.http.max-persistent-connections-per-proxy");
delpref("network.http.max-persistent-connections-per-server");
delpref("network.dns.disableIPv6");
delpref("content.interrupt.parsing");
delpref("content.max.tokenizing.time");
delpref("content.switch.threshold");
delpref("browser.cache.memory.capacity”);
delpref("browser.xul.error_pages.enabled");
delpref("network.http.keep-alive.timeout");
delpref("network.ftp.idleConnectionTimeout");
delpref("network.dnsCacheEntries");
delpref("network.dnsCacheExpiration";
delpref("browser.turbo.enabled");
delpref("plugin.expose_full_path");
delpref("network.prefetch-next");
}

_SpeedUp_BuildMenu{
# tools menu
setmenu(Settings,macro,"SpeedUp",SpeedUp_Toggle);
}
$OnInit=$OnInit."_SpeedUp_BuildMenu;";

# ------------------------------------------------------------------------------------------------------------------
$macroModules=$macroModules."SpeedUp;";



Edited 1 time(s). Last edit at 01/23/2010 01:15AM by panzer.

Re: Errors in kmm
Posted by: disrupted
Date: January 23, 2010 01:20AM

mostly missing semicolons, try this one

http://kmext.sf.net/tests/veloz.kmm

Re: Errors in kmm
Posted by: desga2
Date: January 23, 2010 07:15PM

Hi panzer,
Like disrupted sayd errors in "I:\Km 1.5.3\macros\veloz.kmm" are semicolons missing.
disrupted's file must work fine.

About "I:\Km 1.5.3\macros\profilebackup.kmm" is like disrupted said in above post an incomplete line.

And about:
Error: Function Alert is not defined.
Source file: I:\Km 1.5.3\macros\quicknote.kmm
Line: 35

This is because in 1.5.x macro functions are case sensitive (in olders 1.1.x not).
Go to line 35 and change "Alert" macro function name to "alert".
Documentation:
alert( MESSAGE [, TITLE [, ICON]] );

K-Meleon in Spanish

Re: Errors in kmm
Posted by: panzer
Date: January 24, 2010 02:02AM

I made a profile backup now and got this:
Warning: Selector expected. Ruleset ignored due to bad selector.
Source file: file:///I:/Km%201.5.3/Tools/backed.htm
Line: 8
----------
Warning: Unexpected end of file while searching for closing } of invalid rule set.
Source file: file:///I:/Km%201.5.3/Tools/backed.htm
Line: 8

I restarted Km and it opened with Phoenix skin. Aditional errors appeared:
Warning: Selector expected. Ruleset ignored due to bad selector.
Source file: file:///I:/Km%201.5.3/Tools/restored.htm
Line: 8
----------
Warning: Unexpected end of file while searching for closing } of invalid rule set.
Source file: file:///I:/Km%201.5.3/Tools/restored.htm
Line: 8

So, if I now go for restore, it will retore my old profile and not a backed one so the errors are back again.

Btw, if I open Km without net connection, then Km tries 3 times to open it, and if I "say" no, it gives me this mesage:
Autoit error
line -1:
Error: Subscript used with non_Array variable.

This is the penalty for using my old USB, I guess. Bad sectors and all.

Talking about Km:
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284
----------
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284
----------
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284
----------
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284
----------
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284
----------
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284
----------
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284

Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284
----------
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284
----------
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284

Who's fault is this? smiling smiley



Edited 4 time(s). Last edit at 01/24/2010 02:23AM by panzer.

Re: Errors in kmm
Posted by: desga2
Date: January 24, 2010 04:04AM

Quote
panzer
Btw, if I open Km without net connection, then Km tries 3 times to open it, and if I "say" no, it gives me this mesage:
Autoit error
line -1:
Error: Subscript used with non_Array variable.

[...]

Talking about Km:
Warning: Expected ',' or '{' but found 'html'. Ruleset ignored due to bad selector.
Source file: http://kmeleon.sourceforge.net/forum/templates/kmeleon/default.css
Line: 284

[...]

Who's fault is this? smiling smiley

AutoIt error is due to some autoit tool trying connect to internet.
What tools/extensions have you installed in K-Meleon?

About default.css error in Forum is normal, due to css code for IE;
Quote
default.css
*html .PDDiv {width:100%;}
/* new class for layouting the submit-buttons in IE too */
.PhorumSubmit {
border: 1px dotted #808080;
color: Black;
background-color: #EEEEEE;
font-size: 12px;
font-family: "Verdana", "Lucida Sans Unicode", "Lucida Grande", Arial;
vertical-align: middle;
}

K-Meleon in Spanish



Edited 1 time(s). Last edit at 01/24/2010 04:05AM by desga2.

Re: Errors in kmm
Posted by: siria
Date: January 24, 2010 06:09AM

Quote

*html .PDDiv {width:100%;}

So the missing blank between * and html is required for IE?
But then it makes not much sense, now that rule is missing for all other browsers tongue sticking out smiley

Re: Errors in kmm
Posted by: panzer
Date: January 25, 2010 01:53AM

Quote
desga2
AutoIt error is due to some autoit tool trying connect to internet.
What tools/extensions have you installed in K-Meleon?

There is too many of them. Never mind that, I will make my 1.6 from scratch. It is not that big of a deal anyway. ;). But can you tell me what is wrong with my restore and backed.htm and why I cannot make a backup anymore?

I unzipped profile-portable again, but no good came out of it.

One more thing: After I post in this forum, a blank page appears. So I have to delete a part of URL- enter-to get back.



Edited 3 time(s). Last edit at 01/25/2010 02:04AM by panzer.

Re: Errors in kmm
Posted by: disrupted
Date: January 25, 2010 04:01AM

it's either weatherman or liveip extreme, those 2 extensions call for a connection at kmeleon startup.

to find out for sure, use cmdline tool from ease xp
http://t1ny.us/giw4o

when you get the error message, open cmdline and hover over the error message and it will show you which autoit exe is causng that error

i remeber i tried with weatherman to suppress connecting when no connection is available because this can be annoying with dialup connections but i didn't find such function in autoit

Re: Errors in kmm
Posted by: JujuLand
Date: January 25, 2010 03:20PM

Quote
disrupted
i remeber i tried with weatherman to suppress connecting when no connection is available because this can be annoying with dialup connections but i didn't find such function in autoit

It probably be possible by inspecting a registry value ... or perhaps inspecting ip values ...

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: Errors in kmm
Posted by: panzer
Date: January 25, 2010 09:03PM

Quote
disrupted
it's either weatherman or liveip extreme, those 2 extensions call for a connection at kmeleon startup.

to find out for sure, use cmdline tool from ease xp
http://t1ny.us/giw4o

when you get the error message, open cmdline and hover over the error message and it will show you which autoit exe is causng that error

i remeber i tried with weatherman to suppress connecting when no connection is available because this can be annoying with dialup connections but i didn't find such function in autoit

This happens only on my comp with dial-up. Otherwise i do not get that message. I will try it later in the week and report back.

Re: Errors in kmm
Posted by: disrupted
Date: January 25, 2010 10:47PM

panz, it's probably weatherman..open km prefs >macro modules and unckeck weatherman.kmm when you're using it at home..disabling the weather toolbar from the toolbars menu will not prevent the script from trying to update the weather so you will need to disable the macro temporarily

Quote
JujuLand
It probably be possible by inspecting a registry value ... or perhaps inspecting ip values ...

A+

there's an non-official function called winhttp that could facilitate checking network stats before connecting... i will try to implement it into weatherman
http://www.autoitscript.com/forum/index.php?showtopic=84133&st=0

Re: Errors in kmm
Posted by: panzer
Date: January 25, 2010 10:55PM

Nope, I do not have weatherman. Or liveipextreme. Not that I know of.



Edited 2 time(s). Last edit at 01/25/2010 10:59PM by panzer.

Re: Errors in kmm
Posted by: disrupted
Date: January 26, 2010 01:48AM

what about weathergirl grinning smiley

those are the only 2 i can think of that call a connection, extreme wouldn't call for a connection if it's a local file opened in kmeleon..so it can be easily be suppressed by getting workoffline pref from kmeelon.. the others that require connection are launched when invoked by the user like sitestats, maybe there's another one..the only way to find the culprit now is by using ease-xp cmdline tool and hover over the error message

Re: Errors in kmm
Posted by: panzer
Date: January 26, 2010 02:03AM

I will do it on Thursday.

Re: Errors in kmm
Posted by: panzer
Date: January 26, 2010 09:10PM

I tried it. It is liveipplus. Is this the same as liveipextreme ...



Edited 1 time(s). Last edit at 01/26/2010 09:10PM by panzer.

Re: Errors in kmm
Posted by: disrupted
Date: January 26, 2010 10:39PM

yes, they all have the same name binary and same macro to avoid users using several of them so they wouldn't conflict.. the version you have is either super or extreme, just disable its macro constip.kmm when using at home. i'll work on incorporating winhttp to check connection status prior, this way it won't initiate a dialup connection dialog when it isn't connected.

K-Meleon forum is powered by Phorum.