mediabar
Posted by: disrupted
Date: January 22, 2010 01:15AM

listen to online radio channels or play local mp3, audio files and playlists right from kmeleon




Edited 1 time(s). Last edit at 01/26/2010 03:45AM by disrupted.

Re: mediabar (preview)
Posted by: slayer
Date: January 22, 2010 02:23AM

Looks interesting, can it play any online stream ?

Re: mediabar (preview)
Posted by: disrupted
Date: January 22, 2010 03:59AM

online radio streams etc..yes, i hope so
i'll try to finish it this weekend, first awaiting feedback on skin manager beta2 so can start localisation for final version

Re: mediabar (preview)
Posted by: disrupted
Date: January 23, 2010 01:25AM

popup song notification:


online radio:


most online radio will be supported including media player streams mms://
it doesn't appear that rtsp or realaudio will be supported

Re: mediabar (preview)
Posted by: disrupted
Date: January 23, 2010 03:00AM

possible implementation: display mediabar at bottom


Re: mediabar (preview)
Posted by: disrupted
Date: January 24, 2010 01:42AM

mediabar for 1.5.0-1.5.3 (it has not been tested on 1.1.x- it should work but i can't guarantee it, please test)

NT: http://kmext.sourceforge.net/tests/mediabarMFE.pre154-NT.7z
9x: http://kmext.sourceforge.net/tests/mediabarMFE.pre154-9x.7z

updates:
to make for minimum space, the paly and pause button have been combined in one button.. mute has been removed, openurl has been combined as the right click menu for openfile button. popup song notifications has been removed to keep memory usage low.

supported formats: mpeg audio, wave, windows media audio(wma), module trackers, midis, compressed modules, real audio(not streaming), playlists (m3u, pls)
for streaming/online radio: all streams except for real including asx
for wm streams, mci commands are passed through wmp and i'm not sure if it will work on very old versions of wmp..but should work fine if you have wmp 7.x and above installed.




how to install:
mediabar-readme

mediabar for 1.5.x (excluding 1.5.4)

you can only use the mediabar for 1.5.0-1.5.3 versions by attaching the tab/window buttons to the tab bar..you can do that by going to kmeleon preferences>browsing>tabbed browsing>tabbar:
check the option:
attach tab/window buttons to the tab bar

to first test the mediabar, open kmeleon preferences and gui appearance and select lofigreen skin (supplied with the media bar). this skin has been modified to work with mediabar

restart kmeleon

mediabar buttons should display at the ned of your tabbar
after you have got familiar with the mediabar and decided whether you like and want to keep it, you can use it with your own preferred skin by doing the following

go to your skins folder inside kmeleon and browse to your favourite skin, expand it and you will find a file called toolbars.cfg. open that file in notepad or any text editor and append the lines at the end of this readme to your toolbars.cfg: (you may also want to remove the skins default window/tab buttons..you can do that by hashing out the previous window/tab enteries like for example:

#example of sharping out(removing previous window/tab enteries your toolbars.cfg
#Tab/&Window Buttons{


# Prev{
# %ifplugin layers
# layers(Prev)|Prev
# Previous Layer. Right-click for more options.
# %else
# ID_WINDOW_PREV
# Previous Window
# %endif
# layerwindowhot.bmp[0]
# layerwindowcold.bmp[0]
# }
# Prev{
# ID_TAB_PREV|Prev
# Previous Tab. Right-click for more options.
# layerwindowhot.bmp[0]
# layerwindowcold.bmp[0]
# }


#beginning of the mediabar buttons append==========
Tab/&Window Buttons(16,16){

openmedia{
macros(openmedia)|Open Media
open media file|right click for more
mediabar.bmp[9]
mediabar.bmp[0]
}

play{
macros(play)|play
play/pause
mediabar.bmp[12]
mediabar.bmp[2]
}



stop{
macros(stop)|stop
stop
mediabar.bmp[13]
mediabar.bmp[4]
}

previous{
macros(previous)|previous
previous
mediabar.bmp[14]
mediabar.bmp[5]
}

next{
macros(next)|next
next
mediabar.bmp[15]
mediabar.bmp[6]
}


channels{
macros(getchannels)|Channels
Channels|right click for menu
mediabar.bmp[17]
mediabar.bmp[8]
}
}
=end of mediabar buttons append==========

=====================================================================

this procedure is due that kmeleon(pre 1.5.4) does not support adding several buttons to the same custom toolbar. when 1.5.4 is released there will be another edition for 1.5.4 or you can simply use that one by opening the mediabar.kmm macro and locate this string:
#$OnSetup=$OnSetup."mediabar_BuildToolbar;";
remove the sharp so it becomes:
$OnSetup=$OnSetup."mediabar_BuildToolbar;";

do not remove the sharp on other 1.5.x versions as the toolbar will only display the first icon, 1.1.x does not permit several buttons at all and removing the sharp may cause it to crash.

mediabar comes with preconfigured channels you can test/try..you can always add new ones or listen to your preferred radio(open url). special thanks go to fred for the playlists.

button functions:
open: open file> local files or playlists
open: open url> enter stream link to parse

play: plays your local playlist, also pauses if a file is being played (affects local playlist only: invoking on stream will call your last opened local playlist/file)

previous/next: affects only local playlist-(has no affect on streams)


tutorial snaps:
























Re: mediabar (preview)
Posted by: jsnj
Date: January 24, 2010 05:42AM

Quote
disrupted
you can only use the mediabar for 1.5.0-1.5.3 versions by attaching the tab/window buttons to the tab bar..you can do that by going to kmeleon preferences>browsing>tabbed browsing>tabbar:
check the option:
attach tab/window buttons to the tab bar

Works without that setting, just not at the bottom of the window.

Re: mediabar (preview)
Posted by: slayer
Date: January 24, 2010 10:31AM

Hi disrupted, I got this error when left-clicking the open button
AutoIt Error
Line-1:

Error: Invalid file filter given.
With:
Mozilla/5.0 (Windows; U; Win98; es-ES; rv:1.8.1.23) Gecko/20090825 K-Meleon/1.5.3

Re: mediabar (preview)
Posted by: disrupted
Date: January 24, 2010 07:31PM

sorry, i should have tested on 9x or alteast tested ansi on nt but i didn't think there will be any problems, the main difference between the 2 versions is that the nt just supports unicode characters passed.
it appears that the ansi version has a limit to file filter formats it has now been updated to fix that bug and will display only 3 lists(all-all supported formats, mp3 and playlists) you can use all to display all formats it can support- this will not affect the nt version which will still categorise the formats in the open dialog

open dialog for ansi(9x):


j, you are right..it can still be displayed as window/tab button i overlooked it as i was focusing to display the bar at the bottom..the readme has now been updated..you can show the mediabar by using the viw?toolbars.tab/window buttons..if you need to display the mediabar attached to the tabbar especially at the bottom then set to attach tab/window buttons in km preferences browsing>tabed browsing>tabbbar

they has been an update fix to the script and macro(previous didn't display in the media services menu) also added 2 new menus under channels opens fred's playlists on xhosts and another menu to search for mp3 songs using beemp3 service(thanks to panzer) and a lyrics finder

download from same links




Re: mediabar (preview)
Posted by: slayer
Date: January 25, 2010 05:19AM

OK, what I did first was installing using the Extension manager, but I think that it doesn't overwrite the files, so I installed the mediaBar manually.
The file-dialog works now. But I can't hear anything, whatever I try local mp3 or a stream playlist. The program is running in the background but no sound. My firewall didn't alert me, so I suppose that the kmampa.exe\kmplayerc.exe are not trying a connection.
Hope that helps.

Re: mediabar (preview)
Posted by: siria
Date: January 25, 2010 06:11AM

Quote

this procedure is due that kmeleon(pre 1.5.4) does not support adding several buttons to the same custom toolbar.
Err... *shock* Can you guys elaborate a little, sounds like a new bug in 154? Or will it be fixed in the final version? And what exactly are "custom toolbars"??

Re: mediabar (preview)
Posted by: forever
Date: January 25, 2010 06:17AM

it works great, thanx

the only problem is that the volume is much lower than when i am listening with winamp

of course i know that i can turn the volume higher but then all the other sounds are too loud


Edit:
when i try to start a pls file that i get this error


after clicking "ok" it works...... that's a little bit strange



Edited 1 time(s). Last edit at 01/25/2010 06:22AM by forever.

Re: mediabar (preview)
Posted by: JamesD
Date: January 25, 2010 07:07AM

Quote
siria

Quote

this procedure is due that kmeleon(pre 1.5.4) does not support adding several buttons to the same custom toolbar.

Err... *shock* Can you guys elaborate a little, sounds like a new bug in 154? Or will it be fixed in the final version? And what exactly are "custom toolbars"??

KM version 1.5.3 and earlier versions have the bug. It is supposed to be fixed in 1.5.4. Still waiting on 1.5.4, I think.

Re: mediabar (preview)
Posted by: jsnj
Date: January 25, 2010 07:13AM

Quote
siria
Err... *shock* Can you guys elaborate a little, sounds like a new bug in 154? Or will it be fixed in the final version? And what exactly are "custom toolbars"??

Not a new bug. Filed & labeled fixed in BTS. PRE 1.5.4 meaning before 1.5.4 smiling smiley Right now you can only create one button on its own toolbar through macros. You can't create a true toolBAR with multiple buttons through macros.

Re: mediabar (preview)
Posted by: siria
Date: January 25, 2010 11:53AM

OUF... And oops grinning smiley Thanks for enlightening me, really relieved now!
I'm very much aware of that "filed and solved" bug, but had completely misunderstood that:
Quote

mediabar for 1.5.x (excluding 1.5.4)
you can only use the mediabar for 1.5.0-1.5.3 versions by attaching the tab/window buttons to the tab bar..
And alarmed, obviously started reading "pre154" as some sort of "pre-release 154" meaning beta154!! LOL!

Re: mediabar (preview)
Posted by: disrupted
Date: January 26, 2010 02:51AM

slayer, the no sound problem is with streams not with local played files.. it happened to me aswell on windows 98, it has now been fixed. if it's happeneing with local files , make sure to open a local playlist or a file first time you use it before pressing the play button, this will create new default playlist, to save the playlist..simply click the stop button.

please note that on some streams especially music radios that use high bitrate and on slow connections like slow broadband or dialup; it will take a few seconds before it starts playing..for first test, open a bbc radio stream, those are transferred on low bandwidths. also on windows 9x and nt4, wmp 7 or above is required

after downloading the update, select a radio channel and check your connection montior at the systray at the top or your router is blinking.. if it's blinking, that means it's negotiating a connection and the file should play fine in a few seconds..if no blinking, it's almost certainly a firewall block, if the firewall doesn't prompt you..open its' prefs and add windows media player (c\program files\windows media player\wmplayer.exe) in its include list

the streaming audio volume is tied to the last volume setting in wmp..to change this(make it higher)..simply go to wmp installation folder and run wmp- normally c:\program files\windows media player\wmplayer.exe

increase the volume and close it..the streams in mediabar will play just as high


the error on stream with pls files happens to few pls but not all, i'm not really sure what's causing it and could possibly be a kmamapa(special winamp) error.. but this is the best verison(2.75) to use with media bar, it's the least buggy..best sound engine along the 2 series and low memory consumption..i tried with the latest 2 series 2.95 but the sound engine(in_mp3.dll) sounds terrible. ofcourse winamp 1(no proper vbr support),3 and 5 versions(memory hogs) are out of the question. pls's can't be parsed directly from its website and have to be downloaded first..i increased a bit the delay before passing the file, hopefully this will fix the problem, i tested it with a pls(think was swiss radio from fred's) file that frequently gave me the error and it doesn't anymore.

the update addresses the version mismatch error nd stream problems on 9x ..few other bug fixes for nt as well and macro update.

mediabar is available in 2 versions each in 2 editions:

for k-meleon 1.1.x
NT: http://kmext.sourceforge.net/files/mediabarMFE.1.1.x-NT.7z
9x: http://kmext.sourceforge.net/files/mediabarMFE.1.1.x-9x.7z

for k-emelon 1.5.0-1.5.3
NT: http://kmext.sourceforge.net/files/mediabarMFE.1.5.0-1.5.3-NT.7z
9x: http://kmext.sourceforge.net/files/mediabarMFE.1.5.0-1.5.3-9x.7z

alll above versions have been tested with kmeleon on 98 and xpee
p.s you can use extensions manager to reinstall/update an extension..it overwrites files without problems

Re: mediabar (preview)
Posted by: forever
Date: January 26, 2010 05:41AM

great

now it works.

thanks a lot ;)

the only "quite little" problem is that i don't get streaming information (song/artist)

therefore i need to listen with the regular winamp.
But that doesn't really matter



Edited 1 time(s). Last edit at 01/26/2010 05:59AM by forever.

Re: mediabar (preview)
Posted by: slayer
Date: January 26, 2010 06:23AM

OK, thanks disrupted. I don't have WMP-7 so probably that's the problem. I will try to install it.

Re: mediabar (preview)
Posted by: forever
Date: January 29, 2010 01:35AM

is there something i can do to get the volume louder?
of course... boost my speakers but then the windows sounds are too loud

the stream played with the normal winamp is about 50% louder

i put volume of kmampa and windows media player to 100% but it is still not loud enough.

are there any options to change it?

Re: mediabar (preview)
Posted by: disrupted
Date: January 29, 2010 10:54PM

kmampa;s volume is set to 100% by default, the thing is..both classic winamp or wmp sound output uses directx directly without any gimmicks..the new winamp probably preamplifies output through plugins..like surround or 3d sound. i think that's what makes it have a higher output.

you can set the volume even higher in classic winamp(kmamapa) by adjusting preamp value by opening the file kmampa.ini in notepad -it's read-only so make sure to uncheck that in file properties first and make it writable

look for a value called preamp, i think default is 31 which means 0 (no preampification) set it to lower value to increase sound output..where 0 is the max
(avoid any higher setting than 31 which will mess up your sound..after 31 you will need negative values)
e.g
preamp=31
(default=no over ride)

change it to

preamp=0
(maximum preamplification)
save the file and set it back to read-only

it should sound much higher now but not necessarily desirable.

you can't do the same for wmp unless you install some 3rd party wmp plugin that preamplifies its output..i'm not aware of such plugin but they most probably have one.

the best way in my opinion to make them both at par is to turn down winamp's volume to match kmampa and wmp

Re: mediabar (preview)
Posted by: disrupted
Date: February 13, 2010 09:40AM

update to fix a conflict qwtih foolproof terminator, you needn't update if you don't use foolproof terminator

1.1.x- 1.5.3
9x: downloadhttp://kmext.sourceforge.net/files/mediabarMFE1.1-1.5.3-9x.7z
nt: downloadhttp://kmext.sourceforge.net/files/mediabarMFE1.1-1.5.3-NT.7z

1.5.4- 1.6.x
9x: download for 98 etchttp://kmext.sourceforge.net/files/mediabarMFE1.5.4-9x.7z
NT: DOWNLOAD FOR 2K AND ABBOVEhttp://kmext.sourceforge.net/files/mediabarMFE1.5.4-NT.7z

Re: mediabar (preview)
Posted by: Rapido
Date: October 13, 2010 09:52PM

Hi! I wonder if it's possible to add your own playlist to this mediabar? And is there a way to change the macro to create your own playlists? And there is also a minor bug because the toolbar is invisible. It is there but the buttons is not visible you can drag your mousepointer over the buttons but you can't see them.

Yours: Rapido

P.S. I'm running under WinXP prof and K-M 1.5.4
D.S.



Edited 1 time(s). Last edit at 10/13/2010 09:53PM by Rapido.

Re: mediabar (preview)
Posted by: disrupted
Date: October 14, 2010 03:25AM

this is most probably related to your skin, try with a different skin or with the skin background disabled. the mediabar bitmap is 8bit to avoid any conflicts with any skin regardless of colour-depth.. there's also a windows redraw bug in toolbar32 that might cause such problems in xp and below..that could be related to ram usage, but that bug occurrence is very rare and usually affects the entire skin in the toolbar and not just specific buttons so it's most likely the skin background. can you post a snapshot

regarding custom playlists.. i did think about it back then either by using autoit to generate a playlists menu macro or by adding readable values in prefs populated by a macro but the problem lies in editing those entries later or removing them which has to be done manually so i skipped that since there's no easy way to edit or remove then it's better for a savvy user to edit the macro to add more channels and this becomes the user choice to add/edit/remove instead of adding a limited feature which translates to a shortcoming in the extension

here's a quich tutorial to add more playlists:

for example if i want to add a music playlist for classic jazz with this address htp://classicjazz.com:8080/playlist.m3u

open the mediabar.kmm macro in notepad etc
create a new entry like this:

classicjazz{
exec($_tool_path."\\mediabar\\kmampaplus.exe htp://classicjazz.com:8080/playlist.m3u");
}


now you need to add the menu entry in the playlist menu..for example under music so inside the mediabar_buildmenu part and under the music section i add new entry:

setmenu("Music",macro, "classic jazz", classicjazz);

save the macro and restart kmeleon, the new entry should appear under the music sunbmenu

Re: mediabar (preview)
Posted by: Rapido
Date: April 20, 2011 02:34AM

Hi! I can't get this mediabar to work! I need some sort of how to get this to work file or helpfile that will tell me how to get it to work.

Yours: Rapido

Re: mediabar (preview)
Posted by: disrupted
Date: April 23, 2011 11:37PM

it's pretty straightforward, remember though mediabar wis intended for 1.5.4 and 1.6. 1.5.3 or previous version can be troublesome in setting the toolbar-each command has own toolbar which can be confusing so it's best to use it with 1.5.4 or 1.6-download that version on kmext/ext7

first time, you will need to set up your playlist, there's no playlist editor so you should have a playlist ready created with your regular mp3 player. click on the eject button and browse to where the playlist is saved(*.pls or m3u accepted) and it should start playing or use the play/pause button.. after that click on the stop button. the stop button will ensure your playlist is saved as main mediabar playlist so next time you open kmeleon you will not need to browse to a playlist again unless you want to play a different one. for online radio there are preset stations but you can play any one by rightclicking on the eject button and select open url from the menu

Re: mediabar (preview)
Posted by: disrrrrrupted
Date: April 24, 2011 02:08AM

quick turotial

first you install the extension, here manually..you can also use extension manager

simply extract the 7z into kmeleon's folder\ here i'm installing the 1.5.4 version which also supports kmeleon 1.6


now open or restart kmeleon, the media bar will show, you can move it around to preferred position


click on eject button and browse for media file like mp3 or playlists(m3u or pls)


select file and click open and songs will start playing from the playlist

now if you want the mediabar to play that same file or playlist when you reopen kmeleon(i.e save the current playlist as default) simply click the stop button.

mediabar will stop playing and save the playlist, click play again to resume playing

Re: mediabar (preview)
Posted by: Rapido
Date: April 26, 2011 10:30PM

Hi! Finally i got it to work for k-m1.54 but when clicking on channelsbutton winamp crashes and i have to restart winamp to listen to my music. So what i want to know is this a bug or is it just the way it suppose to be? Perhaps a short cut to close winamp to listen to channels instead? I'm just curious about this. I haven't tried the version for k-m1.6 yet so I don't know if it's the same there.

Yours: Rapido

Re: mediabar (preview)
Posted by: disrupted
Date: April 26, 2011 11:30PM

you shouldn't use mediabar while your regular wnamp is playing ..that's because mediabar is simply a media front-end (MFE) which has it's own version of winamp..although the executable is renamed, commands passed from the mediabar may conflict and crash an existing instance of winamp... also some commands will deliberately close instances of winamp 1.x.. it was a convenience thing when i wrote it and i suppose it's a bug but i didn't think someone will still be using winamp 1.x

that bug has been fixed now, clear your cache and download again
http://kmext.sourceforge.net/extensions/mediabarMFE1.5.4-NT.7z
(also works with 1.6)

here's another version you can test if you want, frontend for nad which may appeal to some users-limited VBR support but quite crisp and will not conflict with instances of winamp
http://kmext.sourceforge.net/extensions/mediabar+NAD.7z

Re: mediabar (preview)
Posted by: Rapido
Date: April 27, 2011 04:31AM

Hi! I'm using winamp5x but it's not installed at my c-drive so is it possible that i must configure the path to your version of kmampa.exe or what? Because it's working with exception of the fact that i can't get your version to work without starting my winamp first.

Yours: Rapido

Re: mediabar (preview)
Posted by: Rapido
Date: April 27, 2011 05:00AM

I got it to work correctly now so i'm so sorry that i didn't figure out how to get it to work and for taking precious time from you.

Yours: Rapido

K-Meleon forum is powered by Phorum.