Announcements :  K-Meleon Forum
 
Pages: Previous12
Current Page: 2 of 2
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: kko
Date: August 01, 2008 01:54AM

Quote
JohnHell
For example... what is wrong here? I just followed the macro language statements:

yahooimage{
$conteoimgurl = index($linkurl, imgurl)+7;
$conteosize = index($linkurl, "\%".26rurl)-$conteoimgurl;
$urllimpia = substr($linkurl,$conteoimgurl,$conteosize);
}

$conteoimgurl = index($linkurl, imgurl)+7;

Have you assigned a value to $linkurl outside the macro or is that meant to be $LinkURL? (reserved words are case-sensitive now)

$conteosize = index($linkurl, "\%".26rurl)-$conteoimgurl;

What is "\%".26rurl meant to be? "\%".$26rurl or simply "\%26rurl" ?

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: sufi
Date: August 01, 2008 02:27AM

Quote
sufi
I've been trying out the 1.5RC and every time I open it, it says it cannot connect. I have it set to open my home page. A simple reload always brings up my home page fine, but this is quite annoying.

Well, the solution that Terry suggested was apparently temporary. This annoying behavior has returned, though it doesn't happen *every* time I open KM, just enough to be annoying.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: JohnHell
Date: August 01, 2008 02:34AM

Quote
JamesD
@Johnhell

26rul is not a valid variable name in KM 1.5. The following will run. I don't think KM liked %26rul either. Think it must have $ followed by letter. The underscore is optional.

yahooimage{
$_A26rul = "x" ;
$conteoimgurl = index($linkurl, imgurl)+7;
$conteosize = index($linkurl, "\%".$_A26rurl)-$conteoimgurl;
$urllimpia = substr($linkurl,$conteoimgurl,$conteosize);
}

No man, 26url is not a variable, is text, just text. I know what is a var and why should be preceded by $ ;)

Quote
kko
$conteoimgurl = index($linkurl, imgurl)+7;

Have you assigned a value to $linkurl outside the macro or is that meant to be $LinkURL? (reserved words are case-sensitive now)

It is meant to be $LinkURL.

This makes a lot of sense, because I never used the global variables case sensitive.

I'll try that later.

Quote
kko
$conteosize = index($linkurl, "\%".26rurl)-$conteoimgurl;

What is "\%".26rurl meant to be? "\%".$26rurl or simply "\%26rurl" ?

It pretends to be escape bar for the % symbol followed with 26url text. Why is like this? Simple, when I created this macro it was the only way to accept the % symbol.


Kko, another thing, what means now that a var (that wasn't the previous) should be initialited, I mean, where and how. I created the variable at the beginning of the macro file text and it displayed the same error.



Edited 1 time(s). Last edit at 08/01/2008 02:36AM by JohnHell.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: JujuLand
Date: August 01, 2008 02:40AM

A variable to be global must be created out of any macro. No importance where, before, after, but out of a macro.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr





Edited 1 time(s). Last edit at 08/01/2008 02:40AM by JujuLand.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: kko
Date: August 01, 2008 03:12AM

Quote
JohnHell
Kko, another thing, what means now that a var (that wasn't the previous) should be initialited, I mean, where and how. I created the variable at the beginning of the macro file text and it displayed the same error.

What JujuLand says above. You just have to assign a value to a variable before you can use (=read) it.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC PROBLEM SOLVED
Posted by: JohnHell
Date: August 01, 2008 03:41AM

Quote
kko
Quote
JohnHell
Kko, another thing, what means now that a var (that wasn't the previous) should be initialited, I mean, where and how. I created the variable at the beginning of the macro file text and it displayed the same error.

What JujuLand says above. You just have to assign a value to a variable before you can use (=read) it.

JujuLand is talking about global variables (for me those are the default as $URL, $LinkURL, etc), I'm just talking of a simple variable. Ok, used in more than one macro, but not global, I mean that the variable is totally independent inside each macro and in some macros I directly reset any possible value in the var.

But, it must have a value, yes or yes?. Because I created the variable like:

$changed = "";

It hasn't any value beyond nothing (0 or not text), but the variable is being created, right?

Or it should be like:

$changed = " "; #note the space
or
$changed = "x";
or
$changed = 1;

Nothing, I already did the above and still the same error:



Ok, going back to the previous problem, the macro I posted (yahooimage), is fixed, but the case of the $LinkURL wasn't the problem. The problem came for the texts and not being between quotes "" ('' for you).

Like this work, but with $LinkURL, I think it would be better ;)

yahooimage{
$conteoimgurl = index($linkurl, "imgurl")+7;
$conteosize = index($linkurl, "\%"."26rurl")-$conteoimgurl;
$urllimpia = substr($linkurl,$conteoimgurl,$conteosize);
}

In bold the changes and with no reports for problems on those lines.


EDIT EDIT EDIT SOLVED SOLVED SOLVED

Ok, finally the case sensitive of the global variables was needed so fixed.

I also fixed the $changed variable mistake that was because it was inside a macro with the name "blabla-bla" with a minus sign inside, removed and disappeared the error.



Edited 4 time(s). Last edit at 08/01/2008 04:41AM by JohnHell.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: SamCoyote
Date: August 01, 2008 04:30AM

I, too have had problems with increasing memory usage. I'm currently using 1.1.5, and if I leave it open with a few tabs memory usage continues to grow. Right now I have 4 tabs open on pages with only text (no flash, only a few fixed images, no javascript unless this page has it); once I minimized then opened it again it went from ca 6Mb to 20Mb and is now at 46,220Kb. About every 30 seconds is uses another 8-20 kb. I tend to leave it open for a few days and it starts slowing down once it gets to 300-400Mb -- I just reopened about an hour ago as it had grown to over 800Mb! I'm about to go back to 1.1.4 as I didn't see this issue there. (while I typed this message usage went from 46,220kb to 46,336kb).

thanks
Sam

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: kko
Date: August 01, 2008 04:40AM

Quote
JohnHell
$changed = "";

It hasn't any value beyond nothing (0 or not text), but the variable is being created, right?

Yes.


Quote
JohnHell
Or it should be like:

$changed = " "; #note the space
or
$changed = "x";
or
$changed = 1;

The value can be whatever you like. An empty string "" and 0 are values too.


Quote
JohnHell
Nothing, I already did the above and still the same error:


Well, then I'd say that you are looking in the wrong place.

To avoid conflicts between separate kmms: Macro Coding Guidelines
This is even more important in km 1.5 since it allows to redefine macros.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC PROBLEM SOLVED
Posted by: JohnHell
Date: August 01, 2008 04:43AM

Ooops, crossed posts smiling smiley

I solved the problem kko. All problems. Read the edited post above smiling smiley

Now I have a question. Aren't there now two preferences/options windows? Now all preferences are in the old advanced, right?

Nothing else, I asked it because I couldn't find the cookie manager.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: desga2
Date: August 01, 2008 05:15AM

Tranquilo JohnHell, podemos ayudarte con tus macros. smiling smiley
Así sin ver el código es algo difícil, pero normalmente es por la falta del uso de las "" en los parámetros de las funciones.

En el código que pones: imgurl ¿qué es? Sies una variable te falta el $ delante si es una cadena en sí deberías poner "imgurl" entre comillas.

Si me mandas el fichero "mis_macros.kmm", podría ayudarte algo más para adaptarlo al 1.5.

K-Meleon in Spanish

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: JohnHell
Date: August 01, 2008 05:24AM

Tranquilo desga que tengo bastante experiencia en las macros (llevo usando km desde la version 0.8) el problema venía porque ahora el parser de las macros es super-restrictivo y no permite ningún error, lo que me ha vuelto un poco loco, pero ya las he arreglado todas, salvo que ahora no se acepta InjectJS y otras tantas cosas, pero problemas menores.

Para serte sincero, con la experiencia que tengo, me molesta a veces que me corrigas, como sobre lo de mover perfiles de hace unos días, porque yo tenía razón, pero... por no discutir tongue sticking out smiley No es que tu método no fuera realista, pero el mío no estaba desviado tongue sticking out smiley

Bueno, da igual, esta va por tí, desga:

necesito que te crees un prompt con acentos y signos de puntucación varios. Quiero que me digas si tienes este mismo error de caracteres invalidos porque creo que es un problema de que ahora la interfaz gráfica depende de una opción en las preferencias:


Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: desga2
Date: August 01, 2008 05:56AM

Quote
JohnHell
Para serte sincero, con la experiencia que tengo, me molesta a veces que me corrigas, como sobre lo de mover perfiles de hace unos días, porque yo tenía razón, pero... por no discutir. No es que tu método no fuera realista, pero el mío no estaba desviado.
Lo siento, tongue sticking out smiley pero no lo recuerdo si no me pones el link porque como escribo tropecientos post al día. Pudo ser que te me adelantaras y lo postearas mientras yo escribía mi respuesta. No te lo tomes como una correcció, pues no suele ser mi intención, es tan solo para completar la información que creo que puede ser de utilidad al que pregunta, nada más, no quiere decir que lo que ponías estaba mal. tongue sticking out smiley

Además, yo uso K-Meleon desde la versión 0.7, asi que un respeto a las canas. tongue sticking out smiley

Volviendo al tema, siento lo del post anterior, pero me quedé en la primera página, no había visto la segunda, por lo que si hubiera podido escribirtelo antes nos hubieramos ahorrado esta segunda página porque lo habrías arreglado a la primera. tongue sticking out smiley

A lo de tu problema con la interfaz, no es por eso creo yo.
Ahora con la versión 1.5 las macros en idiomas distintos del inglés deben guardarse en formato Unicode UTF8 para que te visualice bien los caracteres acentuados o propios del idioma como la "Ñ". Prueba a guardar el archivo de la macro con un editor de texto que soporte UTF8 como por ejemplo: Notepad++ o PSPad.

Si de esta forma sigues teniendo los mismos problemas me lo dices y veré que puedo hacer.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 08/01/2008 05:57AM by desga2.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: JohnHell
Date: August 01, 2008 06:18AM

Ah, pues no sabía que llevabas tanto tiempo jajajaja.

Yo lo he medido en que yo cuando ya andaba por los foros no te veía, de hecho, he hecho una búsqueda en el foro y aunque yo llevaba tiempo por aquí desde antes de mi primer mensaje, yo estaba por aquí desde un año antes que tú, como mínimo, en apariencia por lo menos.

Sobre lo otro, pues vaya chufla. Este tipo de cosas son las que me vuelven loco.

Lo he salvado como decías y no. Vale, ahora no sale el carácter extraño, pero no salen ni la e con acento ni la apertura del interrogante, o sea, que el formato en sí de ese archivo no tiene toda la culpa :S

Si tienes ideas no te cortes, en inglés o en español ;)

PERDONA, SÍ SE HA CORREGIDO, CAGÜEN, VAYA CHAPUZA DE CONVERSION HA HECHO EL NOTEPAD++

Ya que estamos, otra pregunta... ¿por qué cuando escribes, según a quién respondes etc, tus acentos y demás se ven con una interrogante?



Edited 3 time(s). Last edit at 08/01/2008 06:22AM by JohnHell.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: desga2
Date: August 01, 2008 07:38AM

Quote
JohnHell
Ah, pues no sabía que llevabas tanto tiempo jajajaja.
Remontemonos en la historia hasta aquellos maravillosos años...

Si buscas al traductor de la versión 0.7 no soy yo tongue sticking out smiley, pero fue mi primera versión y la volví a traducir corrigiendo los numerosos errores y mojorandola todo lo que pude, aunque no la llegué a publicar por respeto a los autores originales. tongue sticking out smiley
Las traducciones al español posteriores a la 0.7 son mias aunque en el foro no postee nada hasta la versión 0.9 creo. No recuerdo si fue por que no tenía nada que decir, porque era tímido o porque estaba demasiado cupado dando pedales a mi conexión de 56K sin tarifa plana. grinning smiley
(¡Qué tiempos aquellos! Menos mal que conservo mi mal inglés, solo que ahora ya no me da verguenza escribirlo) grinning smiley

Quote
JohnHell
PERDONA, SÍ SE HA CORREGIDO, CAGÜEN, VAYA CHAPUZA DE CONVERSION HA HECHO EL NOTEPAD++

Pues a mi personalmente me gusta más que el PSPad y funciona perfectamente pero se me olvidó comentarte que en todos los editores debes usar la que aparece como "UTF-8 sin BOM" (sin marca, sin firma o sin caractér de identificación, ...), en el caso de que aparezcan dos tipos de UTF-8. (En inglés lo he visto como "UTF-8 without signature")

Quote
JohnHell
Ya que estamos, otra pregunta... ¿por qué cuando escribes, según a quién respondes etc, tus acentos y demás se ven con una interrogante?

Podrás llevar más tiempo que yo posteando en el foro pero no has leido todos los post tongue sticking out smiley Se te ha debido pasar esta interesante conversación sobre esto.

P.D.: Aunque no me gusta vacilar, llevo posteados ya más de 1000 mensajes, lo que es 10 veces más que tu y llevo menos tiempo en el Foro. tongue sticking out smiley

@ All people:
Sorry for disturb this thread with this extended post in spanish and thanks to Max for his it-IT translation.
Congratulations to all K-Meleon italian users!

K-Meleon in Spanish



Edited 1 time(s). Last edit at 08/01/2008 07:43AM by desga2.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: JohnHell
Date: August 01, 2008 08:14AM

Quote
desga2
Quote
JohnHell
PERDONA, S� SE HA CORREGIDO, CAG�EN, VAYA CHAPUZA DE CONVERSION HA HECHO EL NOTEPAD++

...UTF-8...
Nada, lo he hecho con el notepad de toda la vida. No hace falta complicarse tanto xD

Quote
desga2
Quote
JohnHell
Ya que estamos, otra pregunta... �por qu� cuando escribes, seg�n a qui�n respondes etc, tus acentos y dem�s se ven con una interrogante?

Podr�s llevar m�s tiempo que yo posteando en el foro pero no has leido todos los post tongue sticking out smiley Se te ha debido pasar esta interesante conversaci�n sobre esto.

A ver, eso lo leí, sé que es la codificación, sé cuales son sus problemas. Lo que no entendí muy bien de ese hilo es el como lo dices o que pretendías decir. Yo lo único que sé es que yo lo tengo bien. Si te refieres a la configuración del navegador, te digo que no tengo problemas ni con las páginas en japones, ni en arabe, ni en hebreo, ni en cirílico... Si te refieres a la configuración del foro, no entiendo por qué no la cambiáis :-?

Si te soy sincero, lo que no entendí de ese hilo es lo que decías.

Quote
desga2
P.D.: Aunque no me gusta vacilar, llevo posteados ya m�s de 1000 mensajes, lo que es 10 veces m�s que tu y llevo menos tiempo en el Foro. tongue sticking out smiley

Serás vacilón... tongue sticking out smiley

No, a ver, lo que yo no soy un posteador compulsivo, nunca lo he sido en ningún foro y nunca lo seré. Yo suelo poner mensajes sólo cuando es necesario, como es el caso hoy al probar la versión 1.5. Si no es necesario decir nada, mejor callar, ¿o no crees tú eso? smiling smiley Además, en el 90% de los hilos en los que pueda participar, ya lo has hecho tú, así que para que molestarme. Sólo escribo algo si creo que te has dejado alguna cosa, como el hilo en el que preguntaba uno que quién revisaba el código.


GOING ON TOPIC YIHAAAAAA:

Where is the cookie manager in the 1.5 version?. I only found it under tools menu, but only to manage the sites, not the cookies.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: desga2
Date: August 01, 2008 05:06PM

@ JamesD:
Quote
JamesD
Where is the cookie manager in the 1.5 version?. I only found it under tools menu, but only to manage the sites, not the cookies.

Go to Tools -> Privacy -> View Data -> View Cookies

K-Meleon in Spanish

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: JohnHell
Date: August 01, 2008 06:11PM

I finally found this morning.

I need some like these http://ocularis.es/blog/pics/eye-glasses2.jpg

But would be helpful if, as DasFox said, all these options were in the preferences, not one here, this there... :/

Anyway, thanks.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: ra
Date: August 04, 2008 04:33AM

When I read about getting ready for 1.5 final, I'm wondering what's with the maximizing bug that was introduced (and reported) during 1.5 beta.

Example repro steps: Have several maximized windows open, choose File - Exit. Open K-M again (automatic session resume is off, but this is buggy in this aspect as well), make sure you have a maximized window, open Sessions - Load session - Previous session. Now all windows from the previous session are *not* maximized, although they should be.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: Dorian
Date: August 04, 2008 04:53PM

@ra: Mmmh, working fine here

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: ra
Date: August 04, 2008 06:27PM

Now that's strange. I've got that problem on four computers (2*XPSP3, 1*XPSP2, 1*Vista), each of them with 1.5RC. On three of them tabs are on, on my main computer they are off. Every system is set up to use a certain profile with profile.ini and every profile is from some earlier version (1.5a/b I think). The Privacy plugin is always disabled, update checker as well. Sometimes automatic session resume is on, sometimes off, that doesn't make a difference.

IIRC you couldn't reproduce the problem during the alpha (or beta?) time, either, so I'm wondering what might be different on your or my system(s)..?

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: kko
Date: August 04, 2008 06:34PM

@ra: This bug was reported for 1.5a1. Dorian marked it as fixed for 1.5a2. I verified it as fixed - as for Dorian, it's working correctly for me.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: ra
Date: August 05, 2008 04:54AM

Well, yes, there was a change, so the bug was partly fixed, but not completely. When I closed the browser maximized it comes back maximized, so that's fixed, but the windows won't be maximized if I load a session that had maximized windows before. Or if session resume is on, none (or only one? - need to re-check this) of the windows will be maximized...

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: desga2
Date: August 05, 2008 04:33PM

@ ra:
If you used tabs you haven't this problem of maximized windows in sessions loaded. tongue sticking out smiley

K-Meleon in Spanish

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: ra
Date: August 06, 2008 03:27AM

Yes and no. You have it if you have more than one window with tabs open - a scenario which isn't that unlikely. sad smiley

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: JamesD
Date: August 06, 2008 04:43AM

@ra

I cannot create the problem. I used 1.5RC and had one window with two tabs which was set to two thirds of the screen. I also had another window with three tabs which was maximized. I exited KM from the menu in the window which was two thirds the screen and then re-started KM. Loaded previous session and one window with two tabs was two thirds the screen and the window with three tabs was maximized. Seems like that is what was supposed to happen.

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: ra
Date: August 07, 2008 09:18PM

@JamesD

Thanks for trying to reproduce the problem. Can you please try again with maximized windows, only?

@all

Are there any particular setting (possibly) related to that behaviour that I could post here or set back to their original values (through deleting?)?

Options: ReplyQuote
Re: K-Meleon 1.1.6 and 1.5RC
Posted by: Dorian
Date: August 09, 2008 04:18PM

You should first try if you have the problem with a clean profile. If not, you'll have to find the pref triggering it. I don't have any particular setting in mind.

Options: ReplyQuote
Pages: Previous12
Current Page: 2 of 2


K-Meleon forum is powered by Phorum.