Re: K-Meleon 1.5Beta2
Posted by: JujuLand
Date: June 17, 2008 11:16PM

Can you give here the list of macros files?

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: K-Meleon 1.5Beta2
Posted by: RomeoWhite
Date: June 17, 2008 11:25PM

I made a screenshot last message ...

http://i007.radikal.ru/0806/10/735e739bca2b.png

Re: K-Meleon 1.5Beta2
Posted by: RomeoWhite
Date: June 17, 2008 11:56PM

sendto.rrr (renamed)
kmprefs.kmm
compat.kmm
accel.kmm
cfg.kmm
console2.kmm
docinfo.kmm
domcomplete.kmm
encoding.kmm
hotlink.kmm
ie.kmm
mail.kmm
main.kmm
mtypes.kmm
newsfox.kmm
proxy.kmm
reload.kmm
search.kmm
useragent.kmm
zoom.kmm
translate.kmm

Re: K-Meleon 1.5Beta2
Posted by: kko
Date: June 18, 2008 02:20AM

Quote
ra
Quote
kko
Quote
ra
If the dialog would clearly state that pages often won't look like they should with this user agent string, I don't see a problem in providing them, but benefits.

What dialog do you mean?

Paranoia-tab in preferences. Either write it directly near the user agent string or make a pop up dialog when someone chooses IE. Then there's no point anymore in removing the IE ua string IMO.

There is already such an annotation on the Paranoia tab. tongue sticking out smiley
IMO popup warnings are not better either. There is simply no time correlation between changing the UA string (seeing the popup warning) and the occurrence of problems. Inexperienced users who suddenly have trouble with a website will hardly recall a related popup warning that they have seen a couple of days (or even weeks) ago. Experienced users don't need a popup warning, to them it's just an annoyance...

Re: K-Meleon 1.5Beta2
Posted by: kko
Date: June 18, 2008 02:21AM

Quote
RomeoWhite


How to fix this problem?

Open Edit > Configuration > Macros. Open main.kmm in a text editor and paste the following lines (I suppose right at the beginning of the file):

$kLayers=getpref(BOOL,"kmeleon.plugins.layers.load");
$kLayersOnly=$kLayers*getpref(BOOL,"kmeleon.plugins.layers.catchOpen");

The error message is actually caused by one of your custom macros (Edit > Configuration > User-Defined Macros) that is using layers. Km 1.5 doesn't use layers anymore. But the above fix will be included in the next release to avoid this error message. This won't fix your custom macro, though...

Re: K-Meleon 1.5Beta2
Posted by: RomeoWhite
Date: June 18, 2008 03:33AM

kko, thanx a lot!It's all right!

Re: K-Meleon 1.5Beta2
Posted by: desga2
Date: June 22, 2008 12:51AM

Only a note about a bad visual effect;

When you do right click over a tab title button and after you do right over free space in tab bar context menu in delayed to hide (only part of context menu over tab bar) until tab bar in refresh (1 second aprox.)
(This is more noted when you do right click over active tab and after right click over a free space in tab bar)

In before versions 1.1.X this context menus (right click over layer title buttons) were displayed ever under layer bar (and not over it, this avoid this bad visual effect).

K-Meleon in Spanish

Re: K-Meleon 1.5Beta2
Posted by: Sutebenu
Date: June 26, 2008 07:54PM

Hey guys,

when I install the .exe version of this beta, everything seems to work fine for me, however, when I install the 7z version, I get an error message saying that k-meleon had encountered an error and it needs to close down.

The reason why this bugs me is because portableapps.com is making a portable version of k-meleon and it's based on the 7z version of this beta.

At first, when I open k-meleon.exe it asked me for two dll files (mfc71.dll and msvcr71.dll). After I downloaded them and put them in the system32 folder I get the above error message.

Do I perhaps need another dll file for the 7zip version to work?

Btw, I'm using windows xp home SP3 (I had the same problem using windows xp pro sp2).

Kind regards,
Sutebenu

Re: K-Meleon 1.5Beta2
Posted by: kko
Date: June 26, 2008 10:34PM

Quote
Sutebenu
At first, when I open k-meleon.exe it asked me for two dll files (mfc71.dll and msvcr71.dll). After I downloaded them and put them in the system32 folder I get the above error message.

Do I perhaps need another dll file for the 7zip version to work?

You may also need msvcp71.dll. msvcp71.dll and msvcr71.dll are included in the exe package, but not in the 7z package...

Re: K-Meleon 1.5Beta2
Posted by: Sutebenu
Date: June 26, 2008 11:35PM

Thanks for trying, but it still doesn't work.

After I start k-meleon.exe, the same error message pops up:

"K-meleon web browser encountered an error and needs to be closed. We're sorry for the inconvenience."

Any other ideas?

Right now, I've downloaded
- mfc71.dll
- msvcr71.dll
- msvcp71.dll

Re: K-Meleon 1.5Beta2
Posted by: Sutebenu
Date: June 26, 2008 11:39PM

Well how about that! The 7z version still doesn't work but the portable edition now does work. I guess my problem is (somewhat) solved...

I don't think I need any further help then. Keep up the good work, it's one of my favorite browsers!

Regards,
Sutebenu

Re: K-Meleon 1.5Beta2
Posted by: JujuLand
Date: June 27, 2008 12:29AM

Perhaps a broken profile. Try to delete it.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: K-Meleon 1.5Beta2
Posted by: Sutebenu
Date: June 27, 2008 07:48PM

Quote
JujuLand
Perhaps a broken profile. Try to delete it.

A+

It works now, I simply reinstalled it. Those three dll files did the trick. All the k-meleon versions I have (portable, beta, CCFME) work on my pc work now.

Thanks for the help!

Re: K-Meleon 1.5Beta2
Posted by: bill
Date: June 28, 2008 01:13AM

I also get the error "K-meleon web browser encountered an error and needs to be closed. We're sorry for the inconvenience."
By deleting "prefs.js" I can successfully restart k-meleon 1.5 everytime, but obviously I lose any "customisation" that I've done eg, enabling adblock/bookmarks/toolbars etc...

Re: K-Meleon 1.5Beta2
Posted by: desga2
Date: June 28, 2008 01:44AM

Try to use a profile.ini file in your K-Meleon install folder to created profile in this folder instead windows user profile folder.

K-Meleon in Spanish

Re: K-Meleon 1.5Beta2
Date: June 28, 2008 09:20AM

Hallo everyone. Most of the problems I've had with K-M lately, I've caused myself, and I'm not talking about them because I don't want anybody to get hurt from laughing too hard. But there is one that I'm sure I didn't do to myself, and that's the loss of the up-directory key command. No matter what I do, I can't make it work with 1.5anyBeta. The toolbar button works, but since I like a totally stripped interface, it is normally banished with the rest.

No problems with any other accelerators, or anything else that I use in daily browsing. But damn! I miss that quick key access to higher directories, especially when browsing local files.

Re: K-Meleon 1.5Beta2
Posted by: desga2
Date: June 28, 2008 04:31PM

@ Arual the Wyrd:

Up level directory button works fine in all betas.
If you like make an accelerator key to this button you can add it:
Edit -> Configuration -> Accelerators, and add this or similar line;

CTRL ALT U = macros(Go_Up)

This go up when you press Ctrl+Alt+U.

K-Meleon in Spanish

Re: K-Meleon 1.5Beta2
Posted by: bill
Date: June 28, 2008 06:47PM

@ desga2

If your "profile.ini" suggestion was for me....

I'm not using multi-user profiles... my profile is in my install directory (where I unpacked the 7zip version)

However, I'm looking now and there are 2 directories -
...\k-meleon1.5\defaults\profile
...\k-meleon1.5\Profiles\qss7xm37.default

Which takes precedence ? I've been assuming that qss7xm37.default was "in control".

Looking at the "Manage Profiles" option, I only have 1 profile - default.
Now I'm confused....

Re: K-Meleon 1.5Beta2
Posted by: desga2
Date: June 28, 2008 07:40PM

@ bill;

I think that your profile is corrupted.
Close all instances of K-Meleon, included Loader if this is loaded.
Delete "Profiles" subfolder in K-Meleon installation folder (or rename it as backup if you like preserve something) and restart K-Meleon to generated a new Profiles and profile folders.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 06/28/2008 07:41PM by desga2.

Re: K-Meleon 1.5Beta2
Posted by: gvgerman
Date: June 28, 2008 11:11PM

@bill

It appears you are using KM1.5 in the "portable" or "pocket" mode, i.e.- the profile directory is located in your install folder.

The profile file suggested by desga2 should indeed be in your install directory. You can create the file with a text program (Notepad, for instance) and then rename it to "profile.ini". This file tells K-M where to look for the profile directory; without this file, K-M may look at another location or may have problems when it starts and I believe this might be your problem.

There are indeed two profile directories as you found. The ...\Profiles\... is "your" profile; the ...\defaults\profile is what K-M uses to load the profile when the program is run the first time (after an install or to rebuild the profile).

As desga2 suggests, "Delete "Profiles" subfolder in K-Meleon installation folder (or rename it as backup if you like preserve something) and restart K-Meleon to generated a new Profiles and profile folders." If you have a lot of bookmarks, once you create a new profile, you can get the former bookmarks file from your renamed directory and replace the bookmarks file in the new Profiles directory if you'd like.

I think if you add the profile.ini file to your install directory and generate a new profile, everything should work for you.

Cheers,

Re: K-Meleon 1.5Beta2
Posted by: Glen
Date: June 29, 2008 02:13AM

Tour method for setting home page was excellent!

Re: K-Meleon 1.5Beta2
Date: June 30, 2008 09:14AM

I couldn't make the accelerator key. That was my problem. It always worked before. I've always used Ctrl + up-arrow, CTRL VK_UP = macros(up_directory)
I changed it to CTRL VK_UP = macros(Go_Up), and it refused to work.

For some reason it just decided to work today, so the problem no longer exists. I suppose all I had to do was make a fool of myself in public, that usually loosens up the software grinning smiley

CTRL ALT U would be useless, I'd have to use both hands! LOL One of the things I love about K-M is that I can use the Ctrl key instead of Alt for back and forward, because my hands are small. IE and Firefox make me stretch too far, it's like playing a guitar with a wide neck vs. one that's just my size.

K-Meleon is also the best for my eyes. Keep up the good work, guys. I'm at home in this browser.

Re: K-Meleon 1.5Beta2
Posted by: bill
Date: July 01, 2008 03:01AM

@ desga2 & gvgerman

Your tips to delete my "profiles" directory seems to have solved my problem.
I also have the "profile.ini" file in my k-meleon install directory.

Thanks very much... I was almost ready to give up !

Re: K-Meleon 1.5Beta2
Posted by: JujuLand
Date: July 01, 2008 03:20AM

if profile.ini is present in your k-meleon folder, you then locate your profile folder in profiles under k-meleon folder. If absent, your profile folder will then be located under C:\documents and setings\application data\k-meleon ...

profile.ini can also be used to change the profile folder by indicating it in the ini file.

In a normal way, there is no need of profile.ini, but it is a good to use it when you use more than one version of K-Meleon not to corrupt the profiles.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: K-Meleon 1.5Beta2
Posted by: guenter
Date: July 01, 2008 04:40AM

Todays rant:


I tried to run K-Meleon for the first time with VISTA Home Premium today.
Nothing Premium with Vista sad smiley

I know the ways - but I was red with anger for the OS that did not know the ways!

p.s. I started with win 3.1 and DOS - but this was sure madening.

IMHO there is A Commpany that sells OSes and piles support problems on
US. In this case = k-meleon community/Forum.


My message:

@BILLY the RICH - provider of my OS.
- guess it is easy to get rich - if U & employees do not do Your job properly!

DOS 7.x was made incompatible to alternatives - You payed compensation to NOVELL.

When will You pay me? I never received any compensation for past OS flaws - $ was only doled out to US companies and the citizens of e.g. California.

Today I used Ur brand new VISTA that was forcebly sold to me with my new hardware - I was hasseled and got only IE going instead of K-Meleon to the internet.

My Question: When do I get payed & reembursed by Microsoft for the design flaws of UR OSes & intentions/schemes of making old & alternative "software" incompatbile?

i ADVOCATE. EC officials sacking MS many $ and give it to us OR BETTER OUR DEVS

for ALL the support we do for his OS!



Edited 4 time(s). Last edit at 07/01/2008 05:06AM by guenter.

Re: K-Meleon 1.5Beta2
Posted by: Terry
Date: July 02, 2008 12:43AM

Looks like Bill Gates will not be on guenter's Christmas card list this year.

Re: K-Meleon 1.5Beta2
Posted by: ndebord
Date: July 02, 2008 09:17AM

Gunter,

I hate to suggest this, but do what I did. Buy a FULL copy of XP PRO and then downgrade to that OS. You can do it with Vista, but only with Dell I think. You have to pay extra for the privlege and I think you get what is called an OEM XP Pro.

N

Re: K-Meleon 1.5Beta2
Posted by: Cartaphilus
Date: July 02, 2008 11:38PM

I was tester Vista.
Vista put somebody out of the way 16bit applications.
expressly 64bit version.
It is good for nothing.
It get involved in trouble many soft.(ex winamp)
you wait Windows7 patient, me too.
But, I interesting Server2008 a little.:-)
one time,I used Server2003std.
But,now, I used old Server machine on XP Pro SP3.
--
Supermicro X5DAL-TG2
Xeon 3.06GHz*2 L3Cash-1MB
memory-ECCRegistered512MB*4=2GB
VGA HD3850 AGP DDR3 512MB
Sound M-AUDIO DeltaOMNIStudio
HDD WD RAPTOR 1500
--
http://www.erica.jp
(underconstruction)
Diary and blog.
http://d.hatena.ne.jp/ozanari3/



Edited 2 time(s). Last edit at 07/03/2008 01:52AM by Cartaphilus.

Re: K-Meleon 1.5Beta2
Posted by: guenter
Date: July 03, 2008 02:28AM

@Terry - You are right about my card list for this year grinning smiley

@ndebord - I could buy a system builder edition of Vista Professional or Ultimate and downgrade to Professional XP. If needed buy a XP CD also. MS always offered similar deals for companies. Dell is truly doing a great job offering it to all and not only to companies!

In my case I can IMHO also use the license/CD from an old retired PC (Gericon Laptop). I have already located all XP drivers for my new Fujitso Siemens Amilo Pa2510 - so I do not have to pay for an XP that I already own smiling smiley

But locating and downloading the drivers with IE instead of K-Meleon was testing my patience sad smiley


@Cartaphilus I truly admire Your patience with Vista ( working as tester ).
I decided to get drivers for older XP without much testing smiling smiley

I also downloaded test version of Server 2008.
That seems = like updated Vista without Vista's bad habits smiling smiley

The server only takes much configuration to become an OS for every day sad smiley

Greetings to the US and Nippon (.JP) from Germany (.DE)

Re: K-Meleon 1.5Beta2
Posted by: Cartaphilus
Date: July 03, 2008 04:35AM

I was recognition of microsoft beta tester.
Vista can not start 16bit application.
for example installer is 16bit can not install application.
I give up used Vista.

I keep using XP so far because the exchange of hardware is necessary, too, when Windows7 appears.

K-Meleon forum is powered by Phorum.