Re: K-Meleon 1.5a1
Posted by: ra
Date: November 12, 2007 06:31AM

@kko: I'll create one as soon as I have some time left (need to find an example, and so on), but I'm afraid it might take several days, I'm way to busy currently... :-(

What info do you need? When clicking on mpeg-links I'm prompted if I want to Open/Save/Cancel, with wmv-links there's no such prompt (it depends on the mime-type, if the file is to be downloaded there is a prompt, but not when it is to be played - but there should be one, just like with mpeg or avi. adding wmv to mime types to be downloaded as described somewhere here has no effect).

Re: K-Meleon 1.5a1
Posted by: guenter
Date: November 12, 2007 09:59PM

@ra I do not think that this is a K-Meleon problem.

When You set play with default content handler - Windows Media Player or System should prompt You whether You want to play or download smiling smiley

Re: K-Meleon 1.5a1
Posted by: kko
Date: November 13, 2007 02:07AM

@ra: This is a very specific problem, which may take us some posts to discuss it. I just don't want to do that in this 'general' K-Meleon 1.5a1 thread. Come over here when you've time. It's not urgent.

Thanks.

Re: K-Meleon 1.5a1
Posted by: dabiank
Date: November 13, 2007 05:30PM

I don't know if this is a bug, but when I click an external link another K-Meleon session is started, instead of opening a new tab within the current session.

Re: K-Meleon 1.5a1
Posted by: JamesD
Date: November 13, 2007 08:01PM

@ dabiank

I think that may be controlled by the code the web site presents. In my surfing I have found that some links open in the same window and others will start a new window. If you will give us the site that is doing the new window for you maybe I can tell by looking at their source code.

Re: K-Meleon 1.5a1
Posted by: guenter
Date: November 13, 2007 09:55PM

The HTML tag target="_blank" creates new windows - You can alter this behavior to open new tab/layer in advanced settings of 1.1.x.



Edited 1 time(s). Last edit at 11/13/2007 09:57PM by guenter.

Re: K-Meleon 1.5a1
Posted by: kko
Date: November 13, 2007 11:17PM

Quote
dabiank
I don't know if this is a bug, but when I click an external link another K-Meleon session is started, instead of opening a new tab within the current session.

Am I right that you are talking about "URLs passed from external applications" (a Window Diversion setting)? Can you tell us a bit more about your settings? (Since that is working for me.)

Re: K-Meleon 1.5a1
Posted by: dabiank
Date: November 14, 2007 06:16PM

Quote
kko
Quote
dabiank
I don't know if this is a bug, but when I click an external link another K-Meleon session is started, instead of opening a new tab within the current session.

Am I right that you are talking about "URLs passed from external applications" (a Window Diversion setting)? Can you tell us a bit more about your settings? (Since that is working for me.)

You're right, sorry for the confusion... and thanx for your help...

Re: K-Meleon 1.5a1
Posted by: JamesD
Date: November 15, 2007 11:56PM

I have created two temporaty macros to use with 1.5a1 version until the final preferences code is ready. One is for setting cache, disk and memory, size and the second is to toggle prefetch on or off.

Prefetch came from this thread http://kmeleon.sourceforge.net/forum/read.php?1,75738

I have the prefetch.kmm macro on my website at http://www.perigee.net/~jmd8421r/prefetch.htm

Cache came from this thread http://kmeleon.sourceforge.net/forum/read.php?1,75409

I have the Cache15a1.kmm on my website at http://www.perigee.net/~jmd8421r/Cache15a1.htm

The cache macro has been updated to re-read the pref value to verify that it worked.

Re: K-Meleon 1.5a1
Posted by: dabiank
Date: November 21, 2007 04:25PM

The following bug had already been reported for previous releases, and it's *** STILL *** here: after MANY closures and re-openings of K-Meleon, All custom settings (bookmarks, startup pages, and so on) are deleted, and the default ones are automatically restored. According to me, this is a very, very, VERY serious bug.

Re: K-Meleon 1.5a1
Posted by: kko
Date: November 21, 2007 07:21PM

Quote
dabiank
The following bug had already been reported for previous releases, and it's *** STILL *** here: after MANY closures and re-openings of K-Meleon, All custom settings (bookmarks, startup pages, and so on) are deleted, and the default ones are automatically restored. According to me, this is a very, very, VERY serious bug.

We can't fix what we can't reproduce. Are you sure that you are not deleting your profile yourself (inadvertently) ?

Re: K-Meleon 1.5a1
Posted by: desga2
Date: November 22, 2007 02:49AM

We more info for fixed this bug, we need a error patron to can reproduce it.
K-Meleon versión, Windows version, number of layers opened, number of times closed and open the browser, time between open-close & close-open.

I think that possiblement this is a memory manage bug. When you close the browser this save all preferences and settings in your profile, this need a little time, but if you try open the browser in this time profile files are unavailable to read it because K-Meleon try saved all configs (writing data in it). By default K-Meleon generate a new profile if none profile exist or if the set profile is busy or unaccessible.

Thanks and greetings.

Re: K-Meleon 1.5a1
Posted by: ra
Date: November 23, 2007 05:25AM

Can s.o. tell me what will happen to the native preferences? Will they be gone for good with 1.5, will the new dialog eventually made native (s.th. like cfg-based preferences) or is the plan to keep XUL preferences?

The new dialog is made nice, but I like the native one more. It's not only the speed (I can live with slow(er) preferences), but I just don't seem to find the options I'm looking for in the new one, much like in FireFox where you have loads of tabs and sub-sub-menus scattered all over the place.

And BTW I'm missing a Cancel-button to close the dialog without saving stupid stuff I did there. ;-)

Re: K-Meleon 1.5a1
Posted by: kko
Date: November 24, 2007 01:39AM

Quote
ra
Can s.o. tell me what will happen to the native preferences? Will they be gone for good with 1.5, will the new dialog eventually made native (s.th. like cfg-based preferences) or is the plan to keep XUL preferences?

The native panel is broken due to internal changes. There are currently no plans to repair it. Dorian is doing all the C++ development alone and there are simply more important things to do in the near future. XUL development can be done by me.


Quote
ra
And BTW I'm missing a Cancel-button to close the dialog without saving stupid stuff I did there. ;-)

There is no need for a Cancel button since your "stupid stuff" is saved immediately. ;-)

Re: K-Meleon 1.5a1
Posted by: kko
Date: November 24, 2007 01:40AM

Quote
desga2
We more info for fixed this bug, we need a error patron to can reproduce it.
K-Meleon versiï¿œn, Windows version, number of layers opened, number of times closed and open the browser, time between open-close & close-open.

I think that possiblement this is a memory manage bug. When you close the browser this save all preferences and settings in your profile, this need a little time, but if you try open the browser in this time profile files are unavailable to read it because K-Meleon try saved all configs (writing data in it). By default K-Meleon generate a new profile if none profile exist or if the set profile is busy or unaccessible.

In order to verify your thesis, you might want to play with the following batch file (adapt the path to your system):

@echo off
set km="C:\Program Files\K-Meleon\k-meleon.exe"

rem Enter as many of the following lines as you want:
start "" /wait %km%
start "" /wait %km%

K-Meleon version: shouldn't matter
Windows version: shouldn't matter
number of layers opened: shouldn't matter (km 1.5 doesn't have layers by the way)
number of times closed and open the browser: as many times as you like
time between open-close: shouldn't matter
time between close-open: approximately zero

Re: K-Meleon 1.5a1
Posted by: desga2
Date: November 25, 2007 04:11AM

I better your simple test program, you can download here:
Bugger

K-Meleon in Spanish

Re: K-Meleon 1.5a1
Posted by: kko
Date: November 25, 2007 11:45PM

And, any results already?

I don't know how your program is working. In case it is waiting for the current km instance to be closed before it is opening the new instance (like my batch file), you might also want to try the following macro, which is opening a new km instance while the current instance is beeing closed.

TEST{
exec("\"".getFolder(RootFolder)."\\k-meleon.exe\" -new");
}
$OnQuit=$OnQuit."TEST;";

Note: You have to disable the macro in order to break the loop.

(You might write another program to automatically close km every couple of seconds.)

Re: K-Meleon 1.5a1
Posted by: desga2
Date: November 26, 2007 04:06AM

Quote
kko
And, any results already?

None result yet.

Quote
kko
I don't know how your program is working. In case it is waiting for the current km instance to be closed before it is opening the new instance (like my batch file), you might also want to try the following macro, which is opening a new km instance while the current instance is beeing closed.

TEST{
exec("\"".getFolder(RootFolder)."\\k-meleon.exe\" -new");
}
$OnQuit=$OnQuit."TEST;";

I incorporeated your suggestion to this new release:
Bugger v.0.1

Quote
kko
Note: You have to disable the macro in order to break the loop.

This is not nedded in new release. Macro is automatically installed when Bugger start test (if this option is checked) and deleted when Bugger is closed (or start test with option uncheked).

Quote
kko
(You might write another program to automatically close km every couple of seconds.)

Added to this new release v.0.1 in option 'Only close.'

K-Meleon in Spanish

Re: K-Meleon 1.5a1
Posted by: dabiank
Date: November 27, 2007 02:46PM

Quote
desga2
We more info for fixed this bug, we need a error patron to can reproduce it.
K-Meleon versi�n, Windows version, number of layers opened, number of times closed and open the browser, time between open-close & close-open.

I think that possiblement this is a memory manage bug. When you close the browser this save all preferences and settings in your profile, this need a little time, but if you try open the browser in this time profile files are unavailable to read it because K-Meleon try saved all configs (writing data in it). By default K-Meleon generate a new profile if none profile exist or if the set profile is busy or unaccessible.

Thanks and greetings.

K-Meleon version: K-Meleon 1.5a1update2, but the version doesn't matter (I've ALWAYS had this problem, with ANY KM release)

Windows version: XP SP2

Number of opened layers: this is not important, it happens both with dozens of layers and with only one layer.

Numebr of closures end re-openings: some hundreds, keep in mind that I've to often reboot the system, every 3 or 4 hours, and this kills all running processes (including K-M).

I've always other browsers running, they are managed as K-M is, BUT this bug happens ONLY with K-M.

Re: K-Meleon 1.5a1
Posted by: Dorian
Date: November 27, 2007 05:32PM

KMeleon can't delete a profile. Maybe it doesn't have it anymore in its registry file (registry.dat) and created a new default one, but the old one should still be here in your appdata folder (or any other location you've set).

Now if your profile is effectivily overwritten by a new one, this is an issue with the seamonkey profile component. But I think it's enough safe for this to not happen.

Re: K-Meleon 1.5a1
Posted by: desga2
Date: November 27, 2007 07:06PM

I think that your really problem is this:
Quote
dabiank
Number of closures end re-openings: some hundreds, keep in mind that I've to often reboot the system, every 3 or 4 hours, and this kills all running processes (including K-M).

Why is the really reason for reboot the system 'every 3 or 4 hours'?
What is your needed; bad configuration, the system hang up or freezze?

Are you try K-Meleon Pro 1.1.2? I think that this version run better in XP SP2 system.

K-Meleon in Spanish

Re: K-Meleon 1.5a1
Posted by: kko
Date: November 28, 2007 11:09PM

Quote
dabiank
Numebr of closures end re-openings: some hundreds, keep in mind that I've to often reboot the system, every 3 or 4 hours, and this kills all running processes (including K-M).

Well, actually, shutting down your system (logging off) should properly close all running processes rather then 'killing' them. What might happen is that km is sometimes not properly shut down when you log off. In addition to what Dorian said about registry.dat, this may also result in a corrupt prefs.js file. This file is located in your profile directory and is storing all your settings. When this file is corrupt, km will recreate it the next startup resetting everything to their defaults.

I have closed and opened km probably several ten thousand times since I'm using it (in various versions) and I never lost my profile - as well as ten thousands of other km users. So, I tend to say that your problem is a very rare one - it maybe happens to one out of (ten?) thousand users. But since the affected users seem to experience this problem pretty frequently (here's another report), we should try to figure out what's causing it. As long as we don't know what's causing it, we can't do anything about it.

If you are willing to help us, I'd like to please you to do the following:
1) Copy your prefs.js (if not your entire profile) and your registry.dat to a safe location. prefs.js is located in your profile directory (Edit > Configuration > Profile Directory), registry.dat is located some directory levels above.
2) When the problem appears to happen again, you should repeat procedure 1) before doing anything else. Your copies of these files might help us to figure out what happened or even how you can restore your settings. Try to remember what you did last with km (did you log off with km running or did you close it before logging off? did you notice anything unusual? whatever you might find important...) and report that to us.

Re: K-Meleon 1.5a1
Posted by: caktus
Date: November 29, 2007 02:20AM

Quote
kko
What might happen

This was happening to me occasionally with 1.1.2 also. It [seemed] to be related to closing 1.1.2 without closing all active tabs. I wonder if also it may be related to having set a short ‘WaitToKillAppTimeout’ value and/or ‘HungAppTimeout’ value in the Windows registry. The defaults are 20000m/s and I have changed mine to 1000m/s for faster shutdown. Or perhaps it is related to "AutoEndTasks" being disabled.

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon 1.5a1
Posted by: kko
Date: November 29, 2007 02:54AM

Quote
caktus
I wonder if also it may be related to having set a short �WaitToKillAppTimeout� value and/or �HungAppTimeout� value in the Windows registry. The defaults are 20000m/s and I have changed mine to 1000m/s for faster shutdown.

Yes, of course. When you log off and any process isn't responding before timeout, the process is killed. This can result in data loss. The timeouts mustn't be set too short and the Windows shut down mustn't be forced (simply killing all processes). Generally, it's better to close all running apps before logging off.

Re: K-Meleon 1.5a1
Posted by: kko
Date: November 30, 2007 12:46AM

Quote
kko
If you are willing to help us, I'd like to please you to do the following:
1) Copy your prefs.js (if not your entire profile) and your registry.dat to a safe location. prefs.js is located in your profile directory (Edit > Configuration > Profile Directory), registry.dat is located some directory levels above.
2) When the problem appears to happen again, you should repeat procedure 1) before doing anything else. Your copies of these files might help us to figure out what happened or even how you can restore your settings. Try to remember what you did last with km (did you log off with km running or did you close it before logging off? did you notice anything unusual? whatever you might find important...) and report that to us.

I guess, that isn't necessary anymore.

See:
Bug 205120 – Lost Profile after Windows Crash (open)
Bug 132517 – prefs.js frequently truncated on exit or crash (fixed)

Workaround:
Make a backup of your registry.dat file. Restore registry.dat with the backup when your profile gets lost again.

Re: K-Meleon 1.5a1
Posted by: caktus
Date: November 30, 2007 03:46AM

Can someone please advise me how to prevent loading ad place holders such as THIS

I know how to do it through preferences in other KM's. But I don't know how to do it in 1.5a1.

Thanks

Charlie

~~If it ain't broke, why screw it up?~~


Re: K-Meleon 1.5a1
Posted by: dpcdpc11
Date: November 30, 2007 04:58AM

simple.. use AdBlock Plus dude...
here is adblock plus for K-Meleon:
http://adblockplus.org/en/kmeleon

Re: K-Meleon 1.5a1
Posted by: guenter
Date: November 30, 2007 02:14PM

Quote
caktus
I know how to do it through preferences in other KM's. But I don't know how to do it in 1.5a1.

1.) Rename a 1.1's or 1.1.3's K-Meleon.exe.
2.) Copy the renamed exe into Your 1.5 foldet.
3.) Start it to configure 1.5.

And use the 1.5 K-Meleon.exe for surfing smiling smiley



Edited 1 time(s). Last edit at 11/30/2007 02:14PM by guenter.

K-Meleon 1 .1.3 Turkish?
Posted by: Kaan fly
Date: November 30, 2007 03:33PM

hi
K-Meleon 1 .1.3 Turkish?
dowloand url :S

Re: K-Meleon 1 .1.3 Turkish?
Posted by: guenter
Date: November 30, 2007 10:47PM

1. Problem - No Turkish user translated it smiling smiley

K-Meleon forum is powered by Phorum.