Announcements :  K-Meleon Forum
 
Pages: Previous1234567Next
Current Page: 2 of 7
Re: K-Meleon 1.5a1
Posted by: guenter
Date: October 16, 2007 01:25AM

AFAIK msvcr71.dll is also needed ( by other parts of the application e. g. xpcom_core.dll ). The file is in old application folders or e.g. in Hao's latest release archive.



Edited 1 time(s). Last edit at 10/16/2007 01:33AM by guenter.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: JamesD
Date: October 16, 2007 02:14AM

Can anyone tell if the value for $kFavorites is being set? I am not seeing any error messages but I am also not seeing my addition to the menu. I added the line for the clipboard just to check and nothing is going to the clipboard either.

I am using Favorites and the checkmark is in the box in preferences to enable support for IE Favorites. I also have both updates loaded.

_FavRenAdd_ModMenu{
### add another option to Favorites menu if favorites plugin is active
$kFavorites==true?setclipboard("Favorites plugin equal true"):0;
$kFavorites==true?setmenu("F&avorites",macro,"&Rename-Add",_FavRenAdd_RenameAdd,1):0;

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: JamesD
Date: October 16, 2007 02:29AM

$kFavorites is OK now. Menu is working. Macro is working.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: JujuLand
Date: October 16, 2007 02:58AM

Do all the kplugins have $k{PluginName) variable ?

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr





Edited 1 time(s). Last edit at 10/16/2007 02:58AM by JujuLand.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: kko
Date: October 16, 2007 03:35AM

Quote
JujuLand
Do all the kplugins have $k{PluginName) variable ?

No, more or less only those of interest. See section "K-Meleon Plugins/Tabs" in main.kmm. (I guess, I could remove $kRebarmenu)

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: steve
Date: October 16, 2007 08:29AM

i have added both msvcr71.dll and msvcp71.dll to the kmeleon 1.5a1 folder...

k-meleon.exe fails to do anything, no errors, no actions...

is this a vista64 compatibility issue?
btw i have tried running it in xp sp2 compatibility mode, with the same results.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: jsnj
Date: October 16, 2007 10:46AM

Hey guys, KM looks great. Started playing with it again last few weeks after a year or so of mainly using FF. But as usual FF is getting more & more sluggish for some reason. The only thing I need FF for now is download helper for flv files. Orbit doesn't work on all the vid sites I go to. Anyway, few things I noticed about the 1.5a which seems quite stable so far. Forgive me if any of these have already been reported.

If tabs are enabled by default, then kmeleon.general.opengroup should be set to ID_OPEN_LINK_IN_NEW_TAB|ID_OPEN_LINK_IN_BACKGROUNDTAB by default. It gets set to that only after the first time SHIFT+ENTER is used. Found this out the first time I opened a folder group from the URL bar using ENTER. They opened in new windows.

Group/Session bug with 1.1 & 1.5a. In 1.1 if a group is set to open at startup and KM is opened from an external app, the group overrides the link once the link has loaded. In 1.5a, the link isn't overridden, but it opens in a separate window even if links are specified to open in new tabs in preferences/window diversion.

Selected link bug in 1.1 & 1.5a. No selected text context menu for selected links.

Old bug from 0.9. Not sure if it was ever officially reported. URL for Google - Browse By Name should be http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q=

Is there a tabs list like layers()? IE7 & FF have one by default. KM should have one too. Not solely for when the tab bar gets full. Should be available at all times for those who want it. Perhaps a chevron pref like the bookmark plugins. Sometimes it's just easier to see a list than to decifer the abbreviated tab titles.

Is there a kmeleon.plugins.layers.rebarBottom tabs equivalent?

For skinners/themers I assume tabs appearance customization is planned. Will there be an option for a tab loading image too :-)

Noticed a small bug concerning throbbers that probably has existed since the XP manifest. If the XP manifest is used, any black-based throbber will be converted to the color used in Windows Display Properties - Adv.Appearance - 3D Objects.

Glad to be using KM again. Forgot how much lighter it felt :-) ....Thanks for all the work.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: aimfiend
Date: October 16, 2007 01:30PM

i tried new build with update, when i open more than 2x blank tabs , kmeleon would be halted , no idea why it s like that, i remember prev. tab version would sendout warning when i reach 30 tabs?

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: Mala Okeh
Date: October 16, 2007 01:53PM

Tried yesterday all day to install NoScript and Adblock properly but without success: Adblock e.g. can get installed but there are no blockable items shown in the list nor does Adblock take over the image or frame link url automatically which it did in all other versions. Am I alone with these problemes?

Hope there is a solution for that as I like the innovations a lot.

Thx

Mala Okeh

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: guenter
Date: October 16, 2007 03:24PM

@Mala Okeh, NoScript needs update of kmm(AFAIK pending) and Chrome(done).
Version available at extension page is for 1.12. You are using K-Meleon Alpha 1.5X.

No idea about Adblock.

BTW: IMHO extensions and skins updates are the responsibility of all users of the particular extension/skin and possibly extension developers and maintainers.

@jsnj, Quote: "Orbit doesn't work on all the vid sites I go to."

AFAIK the only issue: K-Meleon extension page's kmm for Orbit cannot be pointed to help downloading from Flash-players and such items which are used to obscure URLs.

Try/Use Grab+ function of Orbit instead. Worked for me on all pages that I tried.

&welcome back from K-Meleon's heavier XUL-Clone aka Phoenix/Firebird/Firefox smiling smiley

@aimfiend - this build sure does not give warning, guenter at 70 open tabs smiling smiley



Edited 1 time(s). Last edit at 10/16/2007 06:38PM by guenter.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: kko
Date: October 16, 2007 10:59PM

Quote
steve
i have added both msvcr71.dll and msvcp71.dll to the kmeleon 1.5a1 folder...

k-meleon.exe fails to do anything, no errors, no actions...

is this a vista64 compatibility issue?

Looks like that, but nobody claimed it to be compatible...

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: kko
Date: October 16, 2007 11:02PM

Quote
Mala Okeh
Tried yesterday all day to install NoScript and Adblock properly but without success: Adblock e.g. can get installed but there are no blockable items shown in the list nor does Adblock take over the image or frame link url automatically which it did in all other versions. Am I alone with these problemes?

Hope there is a solution for that as I like the innovations a lot.

Responsible for third-party extensions are their respective authors, not the k-meleon developers. Tell them, not us.

I've informed Wladimir Palant (the author of Adblock Plus) about the new version.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: kko
Date: October 16, 2007 11:04PM

Hi jsnj! Nice to here from you!

Quote
jsnj
If tabs are enabled by default, then kmeleon.general.opengroup should be set to ID_OPEN_LINK_IN_NEW_TAB|ID_OPEN_LINK_IN_BACKGROUNDTAB by default. It gets set to that only after the first time SHIFT+ENTER is used. Found this out the first time I opened a folder group from the URL bar using ENTER. They opened in new windows.

I've overseen that, indeed.


Quote
jsnj
Selected link bug in 1.1 & 1.5a. No selected text context menu for selected links.

Known issue. :\ Don't click the selected link, click next to it.


Quote
jsnj
Old bug from 0.9. Not sure if it was ever officially reported. URL for Google - Browse By Name should be http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q=

Hmm, there is no difference for me between
1) Google - Browse by name: http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q=k-meleon
and
2) Google - I'm feeling lucky: http://www.google.com/search?btnI=1&q=k-meleon

However, there's a difference when replacing "k-meleon" with "Münsterkäse": 2) works correctly, 1) doesn't

So, maybe remove "Google - Browse by name" ?


Quote
jsnj
Is there a tabs list like layers()?

Nope. But the menu is already prepared for that, so I guess we'll get that. ;)


Quote
jsnj
Is there a kmeleon.plugins.layers.rebarBottom tabs equivalent?

No, AFAIK not (yet).


Quote
jsnj
For skinners/themers I assume tabs appearance customization is planned. Will there be an option for a tab loading image too :-)

We'll see, we've some plans for a new skin system anyway...


Quote
jsnj
Noticed a small bug concerning throbbers that probably has existed since the XP manifest. If the XP manifest is used, any black-based throbber will be converted to the color used in Windows Display Properties - Adv.Appearance - 3D Objects.

Never heard about that. I'll check it and file bug report.


Quote
jsnj
Thanks for all the work.

Thanks for your part in it.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: steve
Date: October 17, 2007 03:42AM

works on vista32 fine, still no go on vista64.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: jsnj
Date: October 17, 2007 04:05AM

Quote
guenter
Try/Use Grab+ function of Orbit instead. Worked for me on all pages that I tried.

Thanks. It worked. :-) Still not as easy as download helper but it'll do.


Quote
kko
So, maybe remove "Google - Browse by name" ?

Nah. It's still more discerning than I'm Feeling Lucky. Test each with digital cameras. I'm Feeling Lucky just goes to the 1st site found which isn't always desired. Pity Browse By Name doesn't handle umlauts. But that's no reason to get rid of it IMO. BTW, Keyword Autosearch doesn't work when URLs are set to open in a new tab (kmeleon.general.openurl = ID_OPEN_LINK_IN_NEW_TAB). KM 1.1 has the same bug with layers.

This alpha has yet to crash on me. Rock solid as default browser so far!

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: ra
Date: October 17, 2007 04:05AM

* Cookie prompt: The site ... wants to set a cookie - instead of the site's name there are only "boxes" visible.

* If you enter s.th. in a text box while a cookie prompt is open you'll write right to left... (just noticed that, dunno about 1.1)

* Not only the context menu, but also File and View menus show disabled or non-functional tab-entries. Please remove them if tabs are disabled - there are users that don't want tabs unfortunately.

* The browser doesn't remember its previous window size (maximized in my case, tabs are off) on startup and when using "undo last closed window". In the last case the opened window has to status maximized while it covers only a third of the screen, so you first have to restore it (to the exact same size) in order to correctly maximize it.



Edited 3 time(s). Last edit at 10/18/2007 04:16AM by ra.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: guenter
Date: October 17, 2007 06:09AM

Quote
jsnj
Quote
guenter
Try/Use Grab+ function of Orbit instead. Worked for me on all pages that I tried.

Still not as easy as download helper but it'll do.

Glad it works at all for You - and thx for feedback.

p. s.

Best we-all use the toolset that creates the best results.
If Firefox does it better - it is great news.
Firefox is a good clone after all smiling smiley

Guess I had to be stubborn on my oldish PC (a pentium 500 is too slow for a slow browser). I had no other choice. I even (ab)used Live HTTP Headers Firefox&K-Meleon Extension ( before another user found Orbit ) to get downloads of mp3/etc smiling smiley

BTW. I may have just found a Greasmonkey script that may / or may not help to improve our situation.

We will see. IMHO the most essential macro inprovement since 0.9 was possibly that not only the main macro coder but several PPL try to get one or the other maccro smiling smiley

And greetings from the old continent



Edited 2 time(s). Last edit at 10/17/2007 06:39AM by guenter.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: Long Time Favorites User
Date: October 18, 2007 04:21AM

As reported by several users with older builds the Favorites still do not work
with xp sp2 or even xp sp1.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: kko
Date: October 18, 2007 04:31AM

Quote
Long Time Favorites User
As reported by several users with older builds the Favorites still do not work
with xp sp2 or even xp sp1.

Get Dependency Walker, open the favorites.dll in km's kplugins folder and look whether any libraries are missing.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: Long Time Favorites User
Date: October 18, 2007 09:53AM

Thanks KKO. Can you decipher this for me? The same shows up on all my computers.
I see no difference in the ones that have KM Favorites and the ones that do not.
I assume this means I removed the microsoft java machine which I did. It is
below:



MSJAVA.DLL

Warning: At least one delay-load dependency module was not found.
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

Please let me know if I need to send more. Again Thanks

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: kko
Date: October 18, 2007 05:27PM

Quote
Long Time Favorites User
MSJAVA.DLL

Warning: At least one delay-load dependency module was not found.
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

That's all? I cannot imagine why km's favorites.dll should depend on msjava.dll (it doesn't on my systems).

Just in case I wasn't clear enough:

Start Dependency Walker, then open km's \kplugins\favorites.dll in Dependency Walker. Tell me whether any modules are missing (marked with a question mark in a yellow disc). Also tell me whether any modules are marked red.

Repeat the same procedure with k-meleon.exe.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: gvgerman
Date: October 18, 2007 11:08PM

In K-M 1.1.2, it was clear what the cache limit was set at. It's not clear at all - at least to me - how to adjust the cache settings in K-M 1.5a1. Can anyone kindly offer advice or clarification on this, please - Thank you.

Also, on a related topic of history settings - and this is not really a bug I suppose - the history settings are shown in two different locations in the browser preferences:

F2 > Browsing > History
F2 > Privacy & Security > History Tab

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: Terry
Date: October 19, 2007 12:30AM

@gvgerman - type about:config into the url bar then continue on after recieving the warning. The entries are alphabetical. You will be looking for browser.cache.disk.capacity (or you can type this value into the filter bar) and it will scroll to it. When you locate it, double click on it and change the value to size you want.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: gvgerman
Date: October 19, 2007 01:09AM

@Terry - re: browser.cache.disk.capacity - Thanks!

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: JamesD
Date: October 19, 2007 02:39AM

Had a situation happen just now and was able to repeat it. I had 1.5a1 open and then opened Outlook Express. I had a link within an e-mail. When I clicked on the link, I got an "Address not found" message. After trying some more links with the same failure, I concluded there was a problem. I closed the open KM 1.5a1 window and then when I opened the links they worked. I went back and opened KM again and the links from within e-mails failed with the address not found message. Lots of funny characters in the message window. A picture of the windows can be gotten at http://www.bestsharing.com/files/x8U4zDp350585/ANF.png.html
Click on the ANF.png file and open it.
I have KM 1.5a1 with two updates on XP SP2 fully updated

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: caktus
Date: October 19, 2007 04:04AM

Re: [www.bestsharing.com]

I keep getting that too. Looks like a problem with language/translation settings. But I've stopped working with the ALPHA release because for some reason I could not get the menus File, Edit, etc.to show up on the toolbar.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: kko
Date: October 19, 2007 04:55AM

Quote
JamesD
Had a situation happen just now and was able to repeat it. I had 1.5a1 open and then opened Outlook Express. I had a link within an e-mail. When I clicked on the link, I got an "Address not found" message. After trying some more links with the same failure, I concluded there was a problem. I closed the open KM 1.5a1 window and then when I opened the links they worked. I went back and opened KM again and the links from within e-mails failed with the address not found message. Lots of funny characters in the message window. A picture of the windows can be gotten at http://www.bestsharing.com/files/x8U4zDp350585/ANF.png.html
Click on the ANF.png file and open it.
I have KM 1.5a1 with two updates on XP SP2 fully updated

smiling smiley I made the same observation some weeks ago. Dorian had to explain me what's going on:

You have a km prior to 1.5 set as default browser. When you click a link, Windows starts your default browser (let's say km 1.1). Km 1.1 can't start up when km 1.5 is already running and thus redirects the link to km 1.5. The problem is that km 1.5 is a unicode build, prior versions aren't. That's why the link url is then corrupted and km 1.5 can't open it. This problem is solved by setting km 1.5 as the default browser. (It's no bug)

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: JamesD
Date: October 19, 2007 06:12AM

@ kko

Thanks, I have made ver 1.5 the default. Runs great now.

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: Long Time Favorites User
Date: October 19, 2007 08:41AM

KKO, I checked KM \kplugins\favorites.dll in Dependency Walker and k-meleon.exe
All have that same message and no other messages. It is the same on computers
where Favorites function in KM and where they do not. I do not know everything
about computers so I have to experiment. Anyone think it could help if I
remove my Sun Java Virtual Machine and reinstall the microsoft version? I have
downloaded the Microsoft JVM 5.0.3810 from www.oldversion.com as I am hoping
this is the newest. I did replace it out of security concerns. Anyone know if
I can do this instead of reinstalling my whole operating system? Thanks KKO

Options: ReplyQuote
Re: K-Meleon 1.5a1
Posted by: JamesD
Date: October 19, 2007 09:31AM

@ caktus

Quote

But I've stopped working with the ALPHA release because for some reason I could not get the menus File, Edit, etc.to show up on the toolbar.

In EDIT PREFERENCES GUI APPEARENCE TOOLBARS there is at item to check which will hide the menu bar. You might check to see if that is checked. If it is checked, un-check it. You have to re-start to make the change effective. You can get the EDIT menu by using ALT + E.

Options: ReplyQuote
Pages: Previous1234567Next
Current Page: 2 of 7


K-Meleon forum is powered by Phorum.