Re: K-Meleon 74 Beta 3
Posted by: ななし
Date: April 27, 2014 09:41AM

This bug's rather surreal... Clicking on the first separator under the "Tools" menu seems to refresh the page confused smiley

Also, clicking on the "Main Bar's" History icon with the left-mouse button doesn't seem to do anything for me either.

Re: K-Meleon 74 Beta 3
Posted by: guenter
Date: April 27, 2014 01:57PM

Quote
ななし
This bug's rather surreal... Clicking on the first separator under the "Tools" menu seems to refresh the page confused smiley

Also, clicking on the "Main Bar's" History icon with the left-mouse button doesn't seem to do anything for me either.

To Anonymous from Washington State. Your bug report is sureal also.

Bug reports need Windows Version including SP plus skin and K-Meleon Update or version tested as minimum info. We cannot send Dorian on wild goose chases with bugs that cannot replicated. You need to submit a receipe or something like it. Others must be able to test Your receipe.

Bug that appear on one or a very few machines are no bugs but glitches OF THAT MACHINE. Even the OS vendor called MS handles it that way.

Under XPSP3 with my own version of the Aura skin K-Meleon maually updated to last update: I can reproduce Your newly reported "sureal tools separator bug".

The history button bug You confirmed W4M. Maybe You use a skin that has not been updated or that You changed?



"sureal tools separator bug"

I tested back to 1.6bn, 1.5.4, 1.1.6 and 1.0! Versions prior to this do probabyl not share the code. The error can be reproduced for these versions on my machine. Nobody simply was clever enough to click on a separator to find such a weired bug - 1.0 that is since summer 2006.

Congratualtions. Probably Your priviledge to add such an old bug to the bug tracker.


Two me there is nothing unusual in the menus.cfg code. It does not seem to appear with the other separators I have tried.



Edited 2 time(s). Last edit at 04/27/2014 02:45PM by guenter.

Re: K-Meleon 74 Beta 3
Posted by: siria
Date: April 27, 2014 02:40PM

Quote
ななし
This bug's rather surreal... Clicking on the first separator under the "Tools" menu seems to refresh the page confused smiley

That's a fun one grinning smiley Actually it happens on my old KM16 too, and the function seems to be like hitting Return when the url field is activated (it opens a new tab with my settings, wouldn't happen for 'reload'). Never mind, nothing broken, just an additional 'feature', LOL!



Edited 1 time(s). Last edit at 04/27/2014 02:43PM by siria.

Re: K-Meleon 74 Beta 3
Posted by: guenter
Date: April 27, 2014 03:03PM

Quote
siria
Quote
ななし
This bug's rather surreal... Clicking on the first separator under the "Tools" menu seems to refresh the page confused smiley

That's a fun one grinning smiley ... Never mind, nothing broken, just an additional 'feature', LOL!

A lucky find - like a WW II vintage picture of a German T34 with an 8.8 Gun as extra feature. surprised smiley



Edited 1 time(s). Last edit at 04/27/2014 03:07PM by guenter.

Re: K-Meleon 74 Beta 3
Posted by: Leah
Date: April 28, 2014 04:07AM

ななし

Very sureal. Seems linked to display menu icons preference, maybe should be left unfixed if it doesn't affect other things? like an Easter egg.

Good catch!

Re: K-Meleon 74 Beta 3
Posted by: ISE-robo1
Date: April 29, 2014 01:37PM

:::To block JAVA in new K-Meleon:::

pref_ToggleJava{
macroinfo=_("Toggle Java support");
menuchecked=(getpref(INT,"plugin.state.java")=="0");
togglepref(INT,"plugin.state.java",0,2);
}

Re: K-Meleon 74 Beta 3
Posted by: Dorian
Date: May 01, 2014 04:33PM

Quote
Zero3K
What's the status of Beta 4?

Didn't work much on it lately.
Maybe next week.

Quote
Zero3K
1. I've been noticing another bug involving its Login Manager plugin. It doesn't work on the login forms on Webcams.com and Openmailbox.org.

Not a bug then.

Quote
Zero3K
2. When having tabs opening next to the current tab, opening multiple tabs via inputting a folder's nickname should open them in the order they are listed in (like how it does when they're opened when the option is set to opening tabs next to the last one).

Probably won't fix for now.

Quote
Zero3K
3. Using the "Reload Continuously" macro on http://www.doujinstyle.com/forum/index.php and http://www.streamate.com makes its favicon shown in the tab be changed to the default icon.

This is because on how the reload script work (using frame).
Websites implementing the icon correctly (with link tag) don't have this problem.

Quote
Zero3K
4. The default icon for a tab (when using the AuraAlpha skin) should be changed to a document looking one (like Opera 12's) instead of the circle it currently is showing.

dunno, just using the old one.

Quote
Zero3K
5. I am able to replicate the crash caused by K-Meleon.exe. To do so, go to http://www.youtube.com/user/GameGrumps, open one of the videos listed in a new tab, then close the new tab as its loading.
This one is fixed i think

Quote
Zero3K
6. Scrolling using the wheel on a mouse or the keyboard via the up/down arrows randomly doesn't work on mangas viewed via http://www.pixiv.net.

wfm, do you have anything else open?

Re: K-Meleon 74 Beta 3
Posted by: Dorian
Date: May 01, 2014 04:46PM

Oh, and i'm still waiting for spanish and russian translation

Re: K-Meleon 74 Beta 3
Posted by: guenter
Date: May 01, 2014 06:07PM

Happy 1. Mayday to all.


Quote
Dorian
Oh, and i'm still waiting for spanish and russian translation

And also for some de-DE.jar fixes and the new de installer translation. Mea culpa.

Sorry. I had other chores and forgot to resume my K-Meleon-Hobby work.

p.s. Zero3K it is custom since long to give translators some time.

Re: K-Meleon 74 Beta 3
Posted by: Zero3K
Date: May 01, 2014 11:26PM

Quote
Dorian
Quote
Zero3K
What's the status of Beta 4?

Didn't work much on it lately.
Maybe next week.

Quote
Zero3K
1. I've been noticing another bug involving its Login Manager plugin. It doesn't work on the login forms on Webcams.com and Openmailbox.org.

Not a bug then.

Quote
Zero3K
2. When having tabs opening next to the current tab, opening multiple tabs via inputting a folder's nickname should open them in the order they are listed in (like how it does when they're opened when the option is set to opening tabs next to the last one).

Probably won't fix for now.

Quote
Zero3K
3. Using the "Reload Continuously" macro on http://www.doujinstyle.com/forum/index.php and http://www.streamate.com makes its favicon shown in the tab be changed to the default icon.

This is because on how the reload script work (using frame).
Websites implementing the icon correctly (with link tag) don't have this problem.

Quote
Zero3K
4. The default icon for a tab (when using the AuraAlpha skin) should be changed to a document looking one (like Opera 12's) instead of the circle it currently is showing.

dunno, just using the old one.

Quote
Zero3K
5. I am able to replicate the crash caused by K-Meleon.exe. To do so, go to http://www.youtube.com/user/GameGrumps, open one of the videos listed in a new tab, then close the new tab as its loading.
This one is fixed i think

Quote
Zero3K
6. Scrolling using the wheel on a mouse or the keyboard via the up/down arrows randomly doesn't work on mangas viewed via http://www.pixiv.net.

wfm, do you have anything else open?

1. Why is it not a bug?
3. How do I make it not work as a frame then?
5. Fixed in what version? I'm also able to get the same crash by opening tabs and closing them quickly by double clicking on them.

Re: K-Meleon 74 Beta 3
Posted by: JohnHell
Date: May 02, 2014 12:34AM

Quote
Dorian
Oh, and i'm still waiting for spanish and russian translation

You would consider it bullshit but, being spanish as I I'm, I prefer english version (yes, quite egocentric).

Anyway, as I think I must do (no one would), I'll give it a try.

How are dlls to be translated?, with Resource Hacker maybe?

I'm so sorry, but I never translated K-meleon so I'll need a hint for where start from an what to translate (for example, all files in en.jar aren't translatable or suppose unnecesary as translations).

-----------------------------
If I'm required and I don't reply in a long time


Re: K-Meleon 74 Beta 3
Posted by: Zero3K
Date: May 02, 2014 09:40AM

Dorian: Maybe you could update the backend to the latest ESR since it seems to have fixed my issues (at least it fixed the issue with it crashing when opening/closing a new tab a few times at a quick pace).

Re: K-Meleon 74 Beta 3
Posted by: guenter
Date: May 02, 2014 03:56PM

Quote
JohnHell
Quote
Dorian
Oh, and i'm still waiting for spanish and russian translation

You would consider it bullshit but, being spanish as I I'm, I prefer english version (yes, quite egocentric).

Anyway, as I think I must do (no one would), I'll give it a try.

How are dlls to be translated?, with Resource Hacker maybe?

I'm so sorry, but I never translated K-meleon so I'll need a hint for where start from an what to translate (for example, all files in en.jar aren't translatable or suppose unnecesary as translations).

c-sanchez is on the way translating it. Maybe ask him first where he got stuck at the moment. If he gave a correct mail address we can perhaps contact him by mail.

Possibly he did not understand well that he can mine most Chrome strings from the Spanish FirefoxESR and much of the rest from Spanish K-Meleon 1.5.4. If he did not - he has huge work to do.

There are maybe 5 chrome menus/pages that have to be translated totally new.

The dll in locale/es are done with Resource Hacker. But You do not have to translate all. Even with the kmeleon.dll that is done new. You scavenge the strings from the 1.5.4 version and with bookmarks.dll You just as can just add the one missing string "add bookmark here" or so to the 1.5.4 version.

The kmeleon.kml is almost or totally the same. Old strings can be scavenged from 1.5.4 version using a script by koko. I will look where I got it if it is needed.

Dorian wants to have a new translation file for the new installer. I have not done that yet. Besides I much more like the old installer version, which is translated already. search.xml must be checked whether it provides all that is locally needed. Dorian fixed a encoding bug for search. But now search.xml is written in one long string by K-Meleon. sad smiley Again compare search.xml with the Spanish 1.5.4 version. That is what I did only with the German version. The same for default prefs.

Re: K-Meleon 74 Beta 3
Posted by: JohnHell
Date: May 02, 2014 10:52PM

Quote
guenter
c-sanchez is on the way translating it. Maybe ask him first where he got stuck at the moment. If he gave a correct mail address we can perhaps contact him by mail.

Oh, I didn't know someone was doing it. If he/she requests help, here I'm so.

Quote
guenter
Possibly he did not understand well that he can mine most Chrome strings from the Spanish FirefoxESR and much of the rest from Spanish K-Meleon 1.5.4. If he did not - he has huge work to do.
[...]

Indeed, but also I did a bit yesterday before noticing it LOL. It is a huge work, indeed if you do from scratch.

Quote

Dorian wants to have a new translation file for the new installer.

That's a tiny text file if we mean installer.nsh and I already translated it. It is two lines and one is a copy of the first one in the front page of "our site".

http://pastebin.com/BVCT4C4V (link changed)
(removed text to avoid forum stretching)

-----------------------------
If I'm required and I don't reply in a long time




Edited 3 time(s). Last edit at 05/02/2014 10:56PM by JohnHell.

Re: K-Meleon 74 Beta 3
Posted by: guenter
Date: May 02, 2014 11:52PM

Chose insert as code and break it. grinning smiley

p.s. I mailed the user. Lets hope the user gave correct details/info when creating an user account for the forum here.

Fail. A fake adress. sad smiley



Edited 2 time(s). Last edit at 05/03/2014 02:40PM by guenter.

Re: K-Meleon 74 Beta 3
Posted by: ESR 24.5
Date: May 05, 2014 04:24AM

Quote
Zero3K
Dorian: Maybe you could update the backend to the latest ESR since it seems to have fixed my issues (at least it fixed the issue with it crashing when opening/closing a new tab a few times at a quick pace).


Maybe install Mozilla and MS tools e.g. such as Such as June 2010 DirectX SDK, Windows 7 SDK, VC 10 Expess (free of charge!) or buy the professional version of VC 2010 and download esr24.5's source.

Then maybe configure and run: mach build.


If You are in luck?


In that case Your PC may tell You after a while that You've build K-Meleon74's GRE.


566 compiler warnings present.
We know it took a while, but your build finally finished successfully!
To take your build for a test drive, run: 

c:\esr24.5/.VC10E\dist\bin\firefox.exe

For more information on what to do now, see https://developer.mozilla.org/docs/Developer_Guide/So_You_Just_Built_Firefox

Dorian, SVP - Please - will You post Your current .mozconfig and the K-Meleon specific patches?


p.s. I would like to try to update K-Meleon's GRE Build Pages.

Re: K-Meleon 74 Beta 3
Posted by: ななし
Date: May 05, 2014 05:21AM

K-Meleon crashes if an invalid download path is saved and used from the previous download.

Steps:

1. Choose to download a file to a path that may or may not exist (let's call it Z:\temp for later on). Let K-Meleon save there or alternatively complain that it cannot.

2. Download something else (let's call this file x.txt). K-Meleon will remember you saved to Z:\temp last time you downloaded something and will suggest saving to "Z:\temp\x.txt" (in the File name area).

3. Let K-Meleon try to save "Z:\temp\x.txt", and it throws up an error rather than complaining that the place does not exist (Event Viewer reports "Faulting application k-meleon.exe, version 74.0.0.0, faulting module msvcr100.dll, version 10.0.30319.1, fault address 0x0008d635.")

Re: K-Meleon 74 Beta 3
Posted by: JohnHell
Date: May 05, 2014 09:07AM

What Windows version?

Because it sounds pretty similar to the problem it has in Windows 2000 I already reported. But that behavior only happened on Windows 2000, not XP or above, until you reported now and therefore it isn't/wasn't a problem of K-meleon itself.

Can you check if it does happen in these 2 different ways?:
1.- click on a download link and save where is prompted.
2.- Right click and choose save as.
(you can use the links at http://kmext.sourceforge.net/km74/)

In Windows 2000 it only comes to a crash in the first example.

Also, the error isn't related to any file, but a general visual c++ exception.

(Firefox does it too, it is not only K-meleon, but Firefox can be re-tried/resumed the download and doesn't crash).

-----------------------------
If I'm required and I don't reply in a long time


Re: K-Meleon 74 Beta 3
Posted by: thomase13
Date: May 06, 2014 02:16AM

Quote
JamesD
Quote
thomase13
I would like my current tab to stay in the foreground when I Ctrl-click to open a link in a new tab. There is an option which looks like it should do that, but the checkbox is greyed out!

You can use EDIT - CONFIGURATION - ACCELERATORS and add the following line.

CTRL LButton = ID_OPEN_LINK_IN_BACKGROUNDTAB

Save the file and restart KM.

Thanks James — that did the trick! smiling smiley

Quote
guenter
Quote
Leah
Quote
thomase13
[*] I am still having a problem with the Web search button.
I had used it to search with Google from the address bar in K-M 1.5.4, but now it will only search Wikipedia no matter what I change my settings to.

I think I know how to fix that. Search from addressbar uses your default search engine. Select a word in a page and right-click menu for Web Search and choose Google and then right-click again and with a check mark next to Google choose 'Use as Default Search Engine'. If Google isn't in the menu of Web Search then you will need to add it in K-meleon preferences/Finding websites/Web search.

That should do the trick. It does here update the entry in about:config.

Else You can change these keys via about:config?

kmeleon.general.searchEngine;http://duckduckgo.com/?q=

kmeleon.general.searchEngineName;DuckDuckGo

Thank you!
Changing settings from the Preferences dialog is also useless here, but the "about:config" method worked fine!

Quote
Dorian
Quote
thomase13
[*] YouTube comments do not work. I have explained this in detail a few posts above.

I have the same problem with firefox.

I have tried it in Firefox 28 and both comments and likes work perfectly!
I see the Help > About box says K-M is using Gecko 24.0
Does this mean that I should be testing with Firefox 24.0 ESR?
Are all K-M 74 betas so far using Gecko 24.0?

Quote
Dorian
Quote
thomase13
[*] Left-clicking the History toolbar button does nothing. It should open your history!

wfm

Since someone mentioned skins have an effect, I thought I would try left-clicking the History button with all of them:

Klassic Skin: Absolutely nothing happens.

Default Phoenicity Skin:


AuraAlpha Skin:


As you can see, History does come up in a window, though it won't display favicons.
Firefox 28 will display favicons for most History items.

tl;dr: The History button works, but only with the AuraAlpha skin. Right-clicking and Control-H both work though. I wonder what's wrong with the other skins!

Thanks,
Thomas

Re: K-Meleon 74 Beta 3
Posted by: JamesD
Date: May 06, 2014 04:17AM

@ thomase13

Regarding history, the code in your skin's "toolbars.cfg" file should look like this: For Klassic see line 106 or nearby.
	%ifplugin macros
	History{
	macros(Places_History)|Histor&y
	View History.
	toolhot.bmp[12]
	toolcold.bmp[12]
	tooldead.bmp[12]
	}
	%endif

That code calls this code in places.kmm in root/macros.
Places_History{
macroinfo=_("Open the history");
#$OpenURL="chrome://browser/content/history/history-panel.xul"; &OpenURL_InNewWindow;
$OpenURL="chrome://history/content/history.xul"; &OpenURL_InNewWindow;
}

Check to see if your skin and macros are up to date.

Re: K-Meleon 74 Beta 3
Posted by: thomase13
Date: May 07, 2014 01:44AM

Quote
JamesD
@ thomase13

Regarding history, the code in your skin's "toolbars.cfg" file should look like this: For Klassic see line 106 or nearby.
	%ifplugin macros
	History{
	macros(Places_History)|Histor&y
	View History.
	toolhot.bmp[12]
	toolcold.bmp[12]
	tooldead.bmp[12]
	}
	%endif

That code calls this code in places.kmm in root/macros.
Places_History{
macroinfo=_("Open the history");
#$OpenURL="chrome://browser/content/history/history-panel.xul"; &OpenURL_InNewWindow;
$OpenURL="chrome://history/content/history.xul"; &OpenURL_InNewWindow;
}

Check to see if your skin and macros are up to date.

That did it!

My toolbars.cfg (Klassic Skin) had
%ifplugin macros
	History{
	history(Places_History)|Histor&y
	View History. Right-click for more options.
	toolhot.bmp[12]
	toolcold.bmp[12]
	tooldead.bmp[12]
	}
	%endif
Thank you!


Also, I'd like to report that Disqus, which is quite popular for commenting systems on many sites, does not work in K-Meleon. When you sign in, a window pops up for a split second, and then nothing happens, similar to the YouTube comment deal.

As well, my favorites menu now comes out at a weird angle.



I swear it used to come straight down like the rest of them!

As you can also probably tell from the picture, the favicons in the favorites menu are dim. Their colours are dimmed out and this seems to happen to the favicons in the tab and address bars too. You can probably tell most easily from the Newegg favicons in the tab bar and the Windows favicon in the Favorites menu. Also, the icons in the Favorites bar dim when hovered over. This behaviour does not occur in other menus.

Of course these last few aren't the highest-priority issues, but I am just reporting them as they occur in case someone has an easy fix.



Edited 3 time(s). Last edit at 05/09/2014 05:15AM by thomase13.

Re: K-Meleon 74 Beta 3
Posted by: Zero3K
Date: May 09, 2014 10:11PM

Dorian: Is a new beta going to be available soon or not? Also, the forums could use an anti-spam plugin and an image resizing plugin.

Re: K-Meleon 74 Beta 3
Posted by: guenter
Date: May 09, 2014 11:29PM

Quote
Zero3K
Dorian: Is a new beta going to be available soon or not? Also, the forums could use an anti-spam plugin and an image resizing plugin.

The forum has toolz such as a ban list for forbidden words.

There are also moderators that can delete, edit/censor posts, update the ban list... I am one of them. jsnj has engaged me when there was a SPAM flood. If You have a problem e.g. find SPAM or hate flames that I have overlooked feel free to mail me.

There used to be more moderators. All American and Spanish are gone. Maybe Dorian could chose 2-3 new ones/replacements. JamesD is AFAIK from the US time Zones, JohnHell speaks Spanish and maybe panzer who haunts the OFF Topic Forum. That would make that SPAM is found easier and deleted earlier.

If he does not - it suits me as it is. We have no SPAM problem currently.
Just a few posts and some well hidden/invisble coded ones that try to grab link prestiege with Google.

Sorry. I do not understand the request with the resizing plugin.

Re: K-Meleon 74 Beta 3
Posted by: JohnHell
Date: May 10, 2014 12:11AM

Quote
guenter
There used to be more moderators. All American and Spanish are gone. Maybe Dorian could chose 2-3 new ones/replacements. JamesD is AFAIK from the US time Zones, JohnHell speaks Spanish and maybe panzer who haunts the OFF Topic Forum. That would make that SPAM is found easier and deleted earlier.

You missed today the dev subforum ;) (already reported) and the other day was the bugs one for almost a day hehe.

The forum is, in the past "couple" of days, having bit of spam flooding sad smiley

It's curious but I thought the same of Zero3k yesterday. Isn't a Phorum script with captcha available? Looks like there is, but for latest versions https://www.keycaptcha.com/phorum-captcha/

These are olders http://www.phorum.org/phorum5/read.php?16,11909

I'll stop going off topic now.

-----------------------------
If I'm required and I don't reply in a long time




Edited 1 time(s). Last edit at 05/10/2014 12:13AM by JohnHell.

Re: K-Meleon 74 Beta 3
Posted by: JamesD
Date: May 10, 2014 01:33AM

I hope we do not have to use captcha. I have given up trying to make that work. I am 72 years old and don't have the best eyesite. If the letters are not level, I cannot distinguish between uppercase and lowercase.

Re: K-Meleon 74 Beta 3
Posted by: JujuLand
Date: May 10, 2014 01:41AM

If I remember, Dorian was not ok to use cpatche.

But if there is spam, we aren't too much ennoyed by this.

I, as guenter, remove it when I find it but it's not a big job, compared to other forums.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:31.0) Gecko/20100101 Ubuntu/12.04 K-Meleon/75.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Re: K-Meleon 74 Beta 3
Posted by: guenter
Date: May 10, 2014 02:16AM

Quote
JujuLand
If I remember, Dorian was not ok to use cpatche.

But if there is spam, we aren't too much ennoyed by this.

I, as guenter, remove it when I find it but it's not a big job, compared to other forums.

A+

More admins spanned around the globe's time zones would be better than capchas that are hard to see. We always wanted a free Phorum without barriers.

But there must be censors theses days. sad smiley

Yes, but that is because of certain entries in the ban list and because there are no SPAM posts staying long which would indicate an unguarded place and attract even more SPAM flies.



Edited 1 time(s). Last edit at 05/10/2014 06:08AM by guenter.

Re: K-Meleon 74 Beta 3
Posted by: torbetron
Date: May 10, 2014 12:10PM

Hi, I had been using K-Meleon 1.6, but it fails to load many web pages properly, so I downloaded version 74. I have Windows XP, and I believe SP 2. Note, I'm just a user of the program, not a developer.

Anyway, I'd like to re-use my old Mozilla style bookmarks, which I had been keeping in My Documents. But, when I try to direct K-Meleon to use those bookmarks, it says in the preferences window that I need to re-start K-Meleon for it to take effect. Fair enough, I closed K-Meleon and re-started it. But then, it again has no bookmarks loaded, and the default location is Documents and Settings\Owner\Application Data\K-Meleon\randomname\bookmarks.html (I'm going by memory because I uninstalled K-Meleon).

Every time I try to change the bookmark file location and re-start K-Meleon, it keeps going back to this default. I actually copied my bookmarks file over to that default directory, and it still didn't load it!

Note I can save new bookmarks, and they get saved in "Recent" folder (not Application Data), which seems like some kind of temporary folder?

Anyway, I'm very confused, please help if you can! Thank-you!

Re: K-Meleon 74 Beta 3
Posted by: JohnHell
Date: May 10, 2014 10:52PM

Congratulations, torbetron, you found a new weird bug!!

Looks like, when you change the path, the preference kmeleon.plugins.bookmarks.bookmarkFile is "hardcoded" in user.js file instead prefs.js.

In user.js is wrote correctly, with full path, but when is passed to prefs.js, on restart of K-meleon, only the drive, not the full path, is written to kmeleon.plugins.bookmarks.bookmarkFile in prefs.js.

Therefore, if you set T:\bookmakrs.html as your file, in user.js is set:
user_pref("kmeleon.plugins.bookmarks.bookmarkFile", "T:\\bookmarks.html");
but in prefs.js is set:
user_pref("kmeleon.plugins.bookmarks.bookmarkFile", "T");

Also, the field in preference, keep unchanged with the default path.

A fix for you torbetron is to set in prefs.js file (editing by about:config too) the correct path to that pref. Or if you want to use the default file in the profile folder, just remove the pref from both files, user.js and prefs.js.

-----------------------------
If I'm required and I don't reply in a long time




Edited 2 time(s). Last edit at 05/10/2014 11:11PM by JohnHell.

Re: K-Meleon 74 Beta 3
Posted by: guenter
Date: May 10, 2014 11:28PM

Quote
torbetron
Hi, I had been using K-Meleon 1.6, but it fails to load many web pages properly, so I downloaded version 74. I have Windows XP, and I believe SP 2. Note, I'm just a user of the program, not a developer.
snip...


Every time I try to change the bookmark file location and re-start K-Meleon, it keeps going back to this default. I actually copied my bookmarks file over to that default directory, and it still didn't load it!

Note I can save new bookmarks, and they get saved in "Recent" folder (not Application Data), which seems like some kind of temporary folder?

Anyway, I'm very confused, please help if you can! Thank-you!

This thread is not developers only. You are right to post here.

Note that we test beta3 Update two. Best wait till others also tried it
- before we cry wolf.


Sounds like a new bug or a regression on XP SP3. I have the same version as You.
But maybe something went wrong with Your and my updates.


After You posted this I tried to direct the bookmarks plugin to an alternative bookmarks file. After the restart it said this new file was not created by the bookmarks plugin. Actually it is and old K-Meleon bookmarks install file - so that was odd. Then it started a new file - I do not know where it is located.

Then I tried to load the correct old bookmarks file in my profile because I got nervous to loose that. K-Meleon kept finding and loading only the newly created file. Same as with You.

So I set it to the correct location and pressed restore to default. That worked.

You best work with a backup of Your bookmarks file. And do the same.

Simply place Your bookmarks.html into the used profile. Go F2 > Preferences > Netscape Bookmarks. Press Browse & chose Profile folder with the bookmarks file to activate the return to default button and press it.

That should do the trick at Your PC also. A similar procedure worked with a recent bookmarks bug.

p.s. JohnHell You bet me. But I could not find anthing in my user.js that reset the path to offer first %APPDATA% folder or anything.



Edited 1 time(s). Last edit at 05/10/2014 11:32PM by guenter.

K-Meleon forum is powered by Phorum.