Improvement requests :  K-Meleon Forum
Use this forum to talk about a feature you're missing. Use the bug tracker to report it if necessary. 
My personal Issues with K-meleon
Posted by: bobthebuilder
Date: July 16, 2008 06:05PM

Don't get me wrong...I love K-meleon and will continue to use it, but...

I can't middle click my bookmarks to open in a new tab. I know I can set them to open in a new tab but I like to control it with middle click.

I can't drag and drop links, bookmarks and other objects around the toolbars. This probably isn't a big deal to most K-meleon users but coming off of firefox, I got spoiled.

I can't middle click the home button to open it in a new tab. Don't ask me why, but I did this all the time in firefox, I still try to middle click it at least 20 times a day on K-meleon...Cant seem to break the habbit.

Lastly this isn't a problem with K-meleon but the roboform extension. It works great except it can only load a blank page at startup. I like K-meleon to be my default browser and if I click an external link, it doesnt load it...very annoying.

The main reason I love K-meleon is how fast it loads...I click a lot of links from external applications...I was sick of the long load time for firefox so I searched for a faster default browser and thats how I found K-meleon. Im sure I could not use the roboform plugin but roboform is more imporant than the browser to me....been saving all my passwords in it for years. So this issue basically defeats the original purpose of me using K-meleon.

Does anyone know a fix for the roboform issue?

Oh yeah also...I installed greasemeleon in hopes of running some greasemonkey scripts but....and this might be a user error...but I can't seem to get any of them to execute when they are supposed to.

If any of this things are already possible in any way, PLEASE tell me how, otherwise I will patiently wait for future releases with my fingers crossed. I love K-meleon thanks all those involved in its development

Options: ReplyQuote
Re: My personal Issues with K-meleon
Posted by: bobthebuilder
Date: July 16, 2008 06:11PM

I should have said I am using K-Meleon 1.1.5...

...I just read the changelog for the latest beta...it added middle click support to the bookmarks toolbar..nice! Too bad I can't use roboform with v1.5.

Options: ReplyQuote
Re: My personal Issues with K-meleon
Posted by: guenter
Date: July 16, 2008 09:05PM

Did You try to set Mouse accels to SeaMonkey or Firefox via tools Mouse-shortcut (or so). That is the closest You can get without reconfiguring all.

K-Meleon 1.5 is a beta - & even @ Firefox project extension authors do not support beta.

Extensions, especially commercial extensions get no general K-Meleon dev support. The policy is that the extension author is responsible for K-Meleon support and that the K-Meleon devs do not help (not enough time to support each extension - no help unless a dev uses the extension himself). Interested K-Meleon users must do extension support themselves if the extension author does not support K-Meleon. Therefore alain and I hacked Roboform because we wanted to use it smiling smiley Now - I only use Roboform to log into my yahoo mail - I do not know whether alain still uses it at all. Looks = now YOU seem to be the interested user that does the support smiling smiley

BTW: Roboform blank startup is a workaround that is needed because the villains (Roboform devs) chose to exclude K-Meleon from support. There is an ancient forum thread (08 or 0.9 times) where someone from Roboform team flately declined to help aK-Meleon user. During late 1.0.x times I hacked a SeaMonkey adapter ( which is partially) made from XUL, then alain made the current macro later. The reason = You need to startup the XUL interface once so that Roboform works.

The startup makes that Roboform "thinks" it is serving a SeaMonkey tongue sticking out smiley.

First I found that Roboform works after the SeaMOnkey XUL interface was started once [ so I made a button to click/ which failed sometimes sad smiley ]- then alain made an improved macro that starts the extension's XUL at K-Meleon's start smiling smiley

So the odd "startup"is a needed workaround that saveguards against failure to connect to Roboform via Roboform's SeaMonkey adapter's XUL interface. IMHO the only thing that can change that we need to startup the XUL would be to place K-Meleon in the supported browser list - so that it is detected automatically.
Maybe mail Roboform support?


As far as I remember there is an old Forum topic about inserting user scripts into pages from K-Meleon (sorry, I only vaguely recall to have read it). The result was Greasemeleon Extensaion at K-Meleon Extensions.

Some extensions just can work and need a K-Meleon native solution.



Edited 2 time(s). Last edit at 07/18/2008 08:18PM by guenter.

Options: ReplyQuote
Re: My personal Issues with K-meleon
Posted by: JujuLand
Date: August 01, 2008 02:28AM

Yes, guenter,

I use it at work, to bypass thoses silly pages which clear the password saved and restored by the browser.

I use 1.1.5, but this evening I have made work 1.5.0 (with tabs instead of layers)

In fact, the determinant thing is the adaptator, the only that I have seen work is the one I use for the extension, and that you have made some modifications.

All the firefox adapters don't work, and the last seamonkey (6.9.91) too

I think the only one which works is the 6.9.86 or 6.9.87 (I'm not sure about the version) that you have modified

To make it work with 1.1.5, nothing special to do, just install the last version Roboform 6.9.90 and the extension I have packaged.

The extension, when activated (in Tools menu) launches the command to install the bar. then it closes automatically the layer, and robocop is ok.

With 1.5, the macro must be rewritten, because in this case, we can't close the tab (it crashes), we must first open a new tab, and then close the first one, in which we have launch the command (This works too in 1.1.x, but more complicated than just close it).

If you use it like I do, no problem, else, opening something in the first tab or the layer (in 1.1.x if launch manually), K-Meleon crashes hard, and often drwatson is called and block.

You can notice that in the tab or layer where the command is launched, the roboform toolbar is on the top of the window, and in the other layers or tab, it's on the bottom.

I personnally think, there is not a great job to do to make it work correctly with K-Meleon, but I'm not able to do it, and I haven't have rights for this, and it seems that Siber doesn't want to support it (they don't support Opera too)

As I have found a simply way not to crash with roboform and K-Meleon, I'll try to ask Siber to modify the adapter, and support K-Meleon.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr




Options: ReplyQuote
Re: My personal Issues with K-meleon
Posted by: guenter
Date: August 01, 2008 03:34AM

I fear the Roboform team will do nothing for us.
They declined to do so in the distant past when jsnj was still here often.

On my system the Adapter You have sent for test = crashes.
Best invest no more time, it works for You & I only use it at yahoo.mail.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.