Improvement requests :  K-Meleon Forum
Use this forum to talk about a feature you're missing. Use the bug tracker to report it if necessary. 
XPI-extentions will be supported ?
Posted by: Oleg Surfer
Date: July 28, 2006 07:22PM

K-Meleon 1.0 was released , some Firefox/Seamonkey extentions can be installed manualy , but they are not work properly.

K-Meleon is Gecko-based browser , so , will extensions be supported ?


Oleg , with regards.

Options: ReplyQuote
Re: XPI-extentions will be supported ?
Posted by: Fred
Date: July 28, 2006 08:57PM

K-Meleon is not entirely XUL based, as Firefox or Seamonkey,
so extensions could call up XUL files, that are not existant or
not functional in K-Meleon, which demands editing of every
wanted extension or creation of additional parts, and is often
simply not possible. On the other hand, many extension
have been replaced by the function of suitable macros in
K-Meleon's macro structure.

Fred

Options: ReplyQuote
Re: XPI-extentions will be supported ?
Posted by: guenter
Date: July 28, 2006 09:13PM

hi oleg
no, AFAIK FFox extensions will not generaly be supported.

reason: some extensions need chrome that we do not have / that we do not need.
If we add that chrome it will cause that k-meleon needs more resources;
and i do not think that our devs (especially Dorian & kko) want that.

what You can try if You badly need a certain extension?

use a bigger chrome with Your k-meleon. SeaMonkey chrome will work good.

FFox chrome will work for k-m if the chrome has SeaMonkey fashion *.rdf files
if an extension need that chrome.

another reason is that in some cases our plugins seem to block handles
so that the extension does not work, in this case i have nor idea what too do.

An xpi installer will probably not be added to k-meleon because ppl here feel that
the mechanism is not very secure.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.