Firefox required for mellon to run
Posted by: rbodell
Date: January 05, 2012 09:48PM

It would be really nice not to have to have firefox installed to makle mellon run properly. when I try to go to the login page of runescape.com, I get a message that I need a newer version of firefox installed on my computer. I installed it, buit I still get the same error message. If I have to do that I might as well just use firefox since firefox allows me to log in and play.

Re: Firefox required for mellon to run
Posted by: rodocop
Date: January 06, 2012 03:08AM

you really don't need Firefox anyway!
And no FF installation can affect you K-Meleon use.

Just use new version from here:
http://dl.dropbox.com/u/1522294/K-Meleon1.6.0_Beta2dot4_en-US.7z

or from my signature - and enjoy all the web!


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


Re: Firefox required for mellon to run
Posted by: guenter
Date: January 06, 2012 10:17AM

Quote
rbodell
It would be really nice not to have to have firefox installed to makle mellon run properly. when I try to go to the login page of runescape.com, I get a message that I need a newer version of firefox installed on my computer. I installed it, buit I still get the same error message. If I have to do that I might as well just use firefox since firefox allows me to log in and play.

K-Meleon installs its own HTML rendering engine and does not require a Firefox installation. Compare rodokop's answer.

For some sites You need to spoof Firefox' UserAgentString to get service.
If the Firefox version that You spoof is too old You get the message You quoted.
For some pages it is sufficient to spoof a newer Firefox version with K-Meleon 1.5.4.

Some sites do not work with K-Meleon 1.5.4 as pointed out by rodokop.
For these pages You need a newer K-Meleon version.


A good new spoof string: Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111008 Firefox/10.0a1

It works well with K-Meleon 1.6 betas and K-Meleon 1.7 alphas.



Edited 1 time(s). Last edit at 01/06/2012 10:17AM by guenter.

Re: Firefox required for mellon to run
Posted by: rbodell
Date: January 09, 2012 09:01AM

I didn't spoof anything, I don't even know what the word means. It installed just as it wanted to all by itself and it DEFINATELY said I needed to install a later version of Firefox. This came up in an error message EVERY TIME I tried to go to the login page of runescape.com.



Edited 1 time(s). Last edit at 01/09/2012 09:01AM by rbodell.

Re: Firefox required for mellon to run
Posted by: Chanson Yu
Date: January 09, 2012 03:39PM

@ rbodell

As the picture shows,just change the User Agent from default to Firefox 3.6,or you can custom a new spoof string,such as: Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111008 Firefox/10.0a1.



Re: Firefox required for mellon to run
Posted by: guenter
Date: January 09, 2012 03:49PM

Hey Texan rbodell,

if You are sure that it is not Your doing and do not know what is going on?

Spoof http://en.wikipedia.org/wiki/Spoof Means to send a false "User Agent String" in this context.

See the previous answer/post how too do spoofing with K-Meleon.

Does runescape.com/ by chance involve Java Applets for playing?

& Did You quote the error message completely?

IMHO You missed out on something.

Did not the message say the Java Plug-in requires an newer version of Firefox?

Something like the subsequent error/Fehler message on a German system?




Here You can read about a Java Plugin problem where the JAVA PLUGIN wrongly claims that You need to update K-Meleon to a new Firefox version!

An alternative to repairing the Oracle Java plugin that would help You if You have Windows 2000, XP or newer is to use the stable K-Meleon 1.6beta2en-Us and spoof a newer Firefox version.


Hope this post helps You.



Edited 3 time(s). Last edit at 01/10/2012 04:00AM by guenter.

Attachments: error.gif (6.1 KB)  
Re: Firefox required for mellon to run
Posted by: rodocop
Date: January 10, 2012 06:18AM

rbodell,
what version of K-Meleon you are using?

I think, it's very old one, because I can't reproduce your problem even on outdated 1.5.4 build.

And know please, that if some site says that you "need new Firefox" or something else - for example, that your PC is infected and you need to download something - it usually doesn't mean that you REALLY need this.

It's all about bad coding or some marketing or, worse, about hackers social engineering, not about real needs.

You see that Firefox installation didn't affect K-Meleon work - this is a little approvement of my words.

I also cannot find any java influence on site workability. It's highly javascripted but disabling Java don't affect page rendering.

So I think you just use old K-Meleon and probably your system misses some dll-files.
Quote

check you have this 3 files in windows/system32:
Windows\system32\mfc71.dll
Windows\system32\msvcp71.dll
Windows\system32\msvcr71.dll

Second option, you can try to put them in KM-folder

Inspect this and try to update your system and your K-Meleon not FireFox.

Try spoofing too.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


Re: Firefox required for mellon to run
Posted by: guenter
Date: January 10, 2012 12:12PM

Quote
rodocop
rbodell,
what version of K-Meleon you are using?

I think, it's very old one, because I can't reproduce your problem even on outdated 1.5.4 build.

And know please, that if some site says that you "need new Firefox" or something else - for example, that your PC is infected and you need to download something - it usually doesn't mean that you REALLY need this.
It's all about bad coding or some marketing or, worse, about hackers social engineering, not about real needs.
You see that Firefox installation didn't affect K-Meleon work - this is a little approvement of my words.

I also cannot find any java influence on site workability. It's highly javascripted but disabling Java don't affect page rendering.

So I think you just use old K-Meleon and probably your system misses some dll-files.
Quote

check you have this 3 files in windows/system32:
Windows\system32\mfc71.dll
Windows\system32\msvcp71.dll
Windows\system32\msvcr71.dll

Second option, you can try to put them in KM-folder

Inspect this and try to update your system and your K-Meleon not FireFox.

Try spoofing too.

1.) In the case of the Orcale Java bug You do not really need to know which version.

2.) All K-Meleon versions up to 1.5.4 are effected by the Oracle Java Plugin error

IF


Your Java Engine is updated above sub Version 21.

You can check this also with the lake applets on my site.

3.) Yes on the next points.

4.) rodocop, update Your Java and make sure that that You have not applied the system specific work arounds mentioned in the forum thread I pointed too.

That is the score on Windows XP SP3 anyway. I just tested it again!
Might be different when You use Vista/7? confused smiley

5.) K-Meleon 1.0 to 1.5.4 only need these two files


Windows\system32\msvcp71.dll
Windows\system32\msvcr71.dll.

Dorian compiled the MFC71 code statically into his custom build K-Meleon exes.

The 2 dll are in the installer version & only missing in the 7z archive. The 2 dll can be also installed in the K-Meleon install folders like You say. The dll update files for the later compilers (VC8 and VC9) need to be in Windows subfolders and distribute by MS vcredist because they need manifest files also.

rbodell probably uses older hardware. Firefox gobbles up many resources when it uses Java applets. That is why I also moved to use K-Meleon as default since 0.7/0.8. grinning smiley

6.) IMHO Yes. K-Meleon and system are not dependent on Firefox updates. smiling smiley



Edited 1 time(s). Last edit at 01/10/2012 12:15PM by guenter.

Re: Firefox required for mellon to run
Posted by: rodocop
Date: January 13, 2012 03:44AM

guenter,
thank you for your additions and clarifications about KM system requirements and architecture!


I've tried this on winXP SP3 with newest java available - build 30(?). No plugin workaround applied.

We don't know, but with 90% accuracy I can guess that rbodell gets not java-related message, but 'site message' that promotes new FF for 'correct rendering' when determines old Gecko engine of some outdated KM-version ;-)

It's the case we now are so frequently faced to... ;-)


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


Re: Firefox required for mellon to run
Posted by: guenter
Date: January 15, 2012 06:20PM

Quote
rodocop
I've tried this on winXP SP3 with newest java available - build 30(?). No plugin workaround applied.

We don't know, but with 90% accuracy I can guess that rbodell gets not java-related message, but 'site message' that promotes new FF for 'correct rendering' when determines old Gecko engine of some outdated KM-version ;-)

It's the case we now are so frequently faced to... ;-)

1.) 30 is correct, currently newest - I also tried with that.
Unlike some earlier versions it seems to recognize K-Meleon 1.6 GRE as adequate.
I only have to use a "work around" for older K-Meleons.

I have all major versions from 0.8 to 1.5.4 installed fot such checks.

2.) It would be real bad if sites started to sniff for the newest 1.9.x engines. sad smiley



Edited 1 time(s). Last edit at 01/15/2012 06:22PM by guenter.

Re: Firefox required for mellon to run
Posted by: rodocop
Date: January 16, 2012 03:07AM

Quote
guenter
2.) It would be real bad if sites started to sniff for the newest 1.9.x engines. sad smiley

They already do, unfortunately...

But so far we can usually cheat them in some way to get site workable for us.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


K-Meleon forum is powered by Phorum.