Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
tab navigation not working
Posted by: pep
Date: October 25, 2009 08:36AM

I'm using K-Meleon 1.5.3 spanish on windows XP:

Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.1.21) Gecko/20090331 K-Meleon/1.5.3

My problem is tab navigation. I use default mouse accelerator, and the problem is tabs get closed aleatory. When you open a new tab (left clicking a link) a left click on the new tab is supposed to just take it to foreground (active tab) while a middle click is supposed to close the tab. Well, sometimes a left click closes the tab, sometimes this is just after closing another tab pressing middle click and sometimes is a direct left click (not preceded by a previous middle click)

what I mean is something like this:

[ one tab ]

open link in new tab (left click on link)

[ one tab ] [ second ]

new tab left clicking a link again

[ one tab ] [ second ] [ third ]

now middle click on third tab, so it get closed (right behaviour)

[ one tab ] [ second ]

now left click on "tab one" just to make it active tab, but it get closed!

[ second ]

Another scenary, sometimes this behaviour simply occurs when first left click:

[ one tab ]

open link in new tab (right click on link and select "open new tab in backgroud" in popup menu)

[ one tab ] [ second ]

now left click on tab one just to make it active tab, but it get closed!

[ second ]

this behaviour is so weird and faulty!!!

I've also checked firefox mouse accelarator mode, this way the behaviour previosly discused seems to happen less times but it still happens. And another weirdy behaviur arises: in this mode when I middle click on a link (which is supposed to open the link in new tab in backgroud) I get 2 or 3 new tabs opened whith same content and when I middle click on tab to close it may 2 or 4 get closed...

too weird!!!!



Edited 1 time(s). Last edit at 10/25/2009 06:27PM by pep.

Options: ReplyQuote
Re: tab navigation not working
Posted by: siria
Date: October 25, 2009 05:01PM

Boy... confused smiley

Quote
pep
When you open a new tab (clicking a link) a right click on the new tab is supposed to just take it to foreground (active tab)

No seriously, can't imagine that... So perhaps this might be where you got something wrong: To take a tab to the foreground, just left click it, quite normally!
Perhaps you confused it with right-clicking on a LINK, not a tab....?

And take a look at the Preferences for the Tab Bar: There are four options for custimizing right clicks, but none of it says "activating"... The best option certainly is to set it to open the context menu. Might even be the default, can't remember smiling smiley
How to get there: F2 (or Edit/Preferences) / Toolbars / Tab Bar



Options: ReplyQuote
Re: tab navigation not working
Posted by: pep
Date: October 25, 2009 06:21PM

Quote
siria
Boy... confused smiley

Quote
pep
When you open a new tab (clicking a link) a right click on the new tab is supposed to just take it to foreground (active tab)

No seriously, can't imagine that... So perhaps this might be where you got something wrong: To take a tab to the foreground, just left click it, quite normally!
Perhaps you confused it with right-clicking on a LINK, not a tab....?

you're right, sadly I miswrote "right click" when I really mean "left click" (normal click). Maybe a kind of writting dislexia! ;) Properly edited right now

Anyway the problem is sometimes when activating a tab with a left click what you get is to close the tab just like if you middle-clicked it

And also, at least in firefox mode, when you middle-click on a link to open in new tab as backgroud you get several new tabs opened with exactly the same content, it seems like k-meleon is really registering several left-click mouse events in place of one single event.

I've also notticed sometimes when you left click on a tab which is loading the page (recycle arrows moving icon is shown in the tab) you get it closed.

I think this is a weird behaviour and thus a bug

Quote
siria
And take a look at the Preferences for the Tab Bar: There are four options for custimizing right clicks, but none of it says "activating"... The best option certainly is to set it to open the context menu. Might even be the default, can't remember smiling smiley
How to get there: F2 (or Edit/Preferences) / Toolbars / Tab Bar

thanks for your answer but I don't think it is related with the problem, it's not a matter of selecting action for right click (or left or middle click) but the way k-meleon reacts to a mouse click event



Edited 1 time(s). Last edit at 10/25/2009 06:28PM by pep.

Options: ReplyQuote
Re: tab navigation not working
Posted by: desga2
Date: October 25, 2009 06:39PM

Quote
pep
now right click on tab one just to make it active tab, but it get closed!

Usually right click is used to show tab context menu.

You are the first person I know that use right click to activated a tab. smiling smiley
Where learn you to use computers? tongue sticking out smiley
Have your mouse a left button? Why don't you use it in any moment?
Is your mouse broken, are you tried with other mouse?

Try to setting mouse behaviour as siria said in above post.

EDITED: test and results with "Mozilla/5.0 (Windows; U; Windows NT 5.0; es-ES; rv:1.8.1.21) Gecko/20090331 K-Meleon/1.5.3 IS NOT Firefox", using the default mouse accelerators.
* => asterisk mark the tab active
between double quotes your test actions => ""

[ one tab *]

"open link in new tab (left click on link)"
Sorry but left click not open in new tab, but open in current tab.
Middle click open the link in new tab in foreground.

[ one tab ] [ second *]

"new tab left clicking a link again"
Sorry but left click not open in new tab, but open in current tab.
Middle click open the link in new tab in foreground.

[ one tab ] [ second ] [ third *]

"now middle click on third tab, so it get closed (right behaviour)"
OK

[ one tab ] [ second *]

"now left click on "tab one" just to make it active tab, but it get closed!"
This not happend for me, right behaviour for me, left click in one tab do it the active tab.

"[ second ]"
[ one tab *] [ second ]

"Another scenary, sometimes this behaviour simply occurs when first left click:"

[ one tab *]

"open link in new tab (right click on link and select "open new tab in backgroud" in popup menu)"

[ one tab *] [ second ]

"now left click on tab one just to make it active tab, but it get closed!"
If you open the second tab in background, one tab continue as active tab.

"[ second *]"
[ one tab *] [ second ]

Please read this in FAQ about mouse accelerators configurations.

And remember that you can explain your problem in spanish.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 10/25/2009 07:05PM by desga2.

Options: ReplyQuote
Re: tab navigation not working
Posted by: pep
Date: October 25, 2009 06:56PM

Quote
desga2
Usually right click is used to show tab context menu.

You are the first person I know that use right click to activated a tab. smiling smiley
Where learn you to use computers? tongue sticking out smiley
Have your mouse a left button? Why don't you use it in any moment?
Is your mouse broken, are you tried with other mouse?

Try to setting mouse behaviour as siria said in above post.

Ok, quite funny you are. Now If you take the time to read my previous message and my edited first message, you will see it was a typing error and also you'll read about the real problem and bug, any idea to solve it or just a joking contribution?

Options: ReplyQuote
Re: tab navigation not working
Posted by: desga2
Date: October 25, 2009 07:10PM

OK, I was some joke, but I also edited my previous post. smiling smiley

Please, can you explain your problem in spanish to avoid english language problems?

Your problem isn't a bug is a bad configuration or corrupted profile or installation.

K-Meleon in Spanish

Options: ReplyQuote
Re: tab navigation not working
Posted by: siria
Date: October 25, 2009 07:31PM

Quote
pep
Anyway the problem is sometimes when activating a tab with a left click what you get is to close the tab just like if you middle-clicked it

Happened to me only when I had tab-close-buttons enabled, and accidentally clicked too close to one. Otherwise KM never closed a tab just when left-clicking it ONCE.
Anyone else...???
You don't happen to accidentally have double-clicked, or your mouse is set ultra-fast, or has a little loose contact ..? Or do you have close-buttons switched on...? And sorry, but why would you choose to set your options to "close tabs with double-click", if your mouse or finger may accidentally produce double-clicks?

Quote
pep
And also, at least in firefox mode, when you middle-click on a link to open in new tab as background you get several new tabs opened with exactly the same content

HUH??? Again no, it does not. I'm also set to firefox mode, and this never ever happens. Anyone else...???
(What in the world have you done to the poor system?? LOL! grinning smiley)

Quote
pep
I don't think it is related with the problem, it's not a matter of selecting action for right click (or left or middle click) but the way k-meleon reacts to a mouse click event

Err, you don't seriously claim now that "the way k-meleon reacts to a mouse click event" is in no way related to your "selected actions for clicks"??

Options: ReplyQuote
Re: tab navigation not working
Posted by: desga2
Date: October 25, 2009 08:40PM

I think he must setting his mouse:
Start -> Configuration -> Control Panel -> Mouse

He have possibly a very speed or sensible double click (he is doing double click instead a simple click) or setting the mouse to invert left and right buttons to left-hander users.

K-Meleon in Spanish

Options: ReplyQuote
Re: tab navigation not working
Posted by: pep
Date: October 29, 2009 08:38PM

After testing for a while the problem is several mouse click events are read when one single event is done.

I don't know if this is a problem of k-meleon (and thus a bug) or a problem of my mouse being a faulty one sending several events, but since I use several tabbed software (firefox, google chrome, notepad++, etc) and this behaviour ONLY happens with K-Meleon I have a suspect about k-meleon not handling mouse events properly

It was my fault not to test the situation enough prior to post it as a bug, but I'm still not sure about it being a bug or a faulty mouse problem (since a faulty mouse fails with every program not only with k-meleon as it do, a faulty mouse has not the ability to select the target application for running faulty). Anyway if the reaction to an announce of weird behaviour and a possible bug is to attack the messenger, seriously or joking, it is not what I consider a good attitude about bug hunting.



Quote
siria
Happened to me only when I had tab-close-buttons enabled, and accidentally clicked too close to one. Otherwise KM never closed a tab just when left-clicking it ONCE.
Anyone else...???

I have no tab-close-buttons enabled.

Quote
siria
You don't happen to accidentally have double-clicked, or your mouse is set ultra-fast, or has a little loose contact ..? Or do you have close-buttons switched on...? And sorry, but why would you choose to set your options to "close tabs with double-click", if your mouse or finger may accidentally produce double-clicks?

My mouse is set normal speed (default), I didn't double-clicked and sure not as often as k-meleon detects, my mouse seem not to have loose contacts and I don't have close-buttons switched on. The reason to set the options to "close tabs with double-click" is that is the default option, I haven't setted it. In fact it would be great I could set the options to "no action" in the screen you've posted to me, but there's no such option.

Quote
siria
Err, you don't seriously claim now that "the way k-meleon reacts to a mouse click event" is in no way related to your "selected actions for clicks"??

what I mean is the problem is not the action asociated to a mouse event but the way the event is registered. It seems k-meleon treats a single event as several consecutive events and this is not related to selected actions for clicks. Whatever selected action you have asociated to mouse click it always will treat it as several mouse click events.

Quote
desga2
I think he must setting his mouse:
Start -> Configuration -> Control Panel -> Mouse

He have possibly a very speed or sensible double click (he is doing double click instead a simple click) or setting the mouse to invert left and right buttons to left-hander users.

I have default normal settings for mouse options in control panel. Maybe I have a very sensible mouse or a faulty one, but it is very strange my mouse is only faulty or extra sensible when running k-meleon.



Edited 1 time(s). Last edit at 10/29/2009 08:40PM by pep.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.