Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
Any1 else having WinXP startup problem?
Posted by: bigD
Date: October 04, 2009 01:57PM

For the past month I've had a problem at startup time.
It happens just about every other day.

During startup... Windows stops and says... there is
disk inconsistency problem on my D: drive. And does
a check of the disk and always find no problem. Then
continues to startup normally. It's become real annoying.

The reason I'm wondering if "maybe" this is an issue
regarding K-Meleon is because... that's the drive that
I have K-Meleon installed on and I run consistently
everyday.

Could it be possible that either...
sometime during runtime or
maybe when I'm shutting down K-Meleon
a data file that's being written to is not being closed?

Maybe a (API version ->) Close.Handle(hFile) is missing
somewhere?

As a footnote... there is only one other program that I
use consistently everyday that's on my D: drive.
But I've already eliminated it as a possible suspect.

BigD

My Home Page:



Options: ReplyQuote
Re: Any1 else having WinXP startup problem?
Posted by: desga2
Date: October 04, 2009 06:31PM

You can try to check your disk with this command: (chkdsk /? => for command help)
chkdsk d: /f /r /x

K-Meleon in Spanish

Options: ReplyQuote
Re: Any1 else having WinXP startup problem?
Posted by: caktus
Date: October 05, 2009 08:20PM

@ bigD

Have you tried startup a couple days with out KM? You don't have to remove or uninstall KM. Just delete the KM root folder to the Recycle bin and if KM is not the culprit simply restore it from the rcycle bin. If your Recycle bin is set to erase then compress the KM root folder with a zip tool and delete the KM root folder and if KM is not the culprit just click on the KM zip folder to get it back. BTW, this KM zip file can be saved as a backup with all of your custom settings intact.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: Any1 else having WinXP startup problem?
Posted by: bigD
Date: October 08, 2009 05:45PM

desga2: Well... I tried the chkdsk using full options
and it did NOT solve the problem. I even ran a disk
scanner to see if maybe the hard drive was going bad.
The results showed that my hard drive is working just
fine.

I then tried...
Tools -> Privacy -> Clear Data -> Clear All
After which...
I ran Windows Defragmenter (WinXP SP3) and rebooted.

This "seemed" to have fixed the problem for a couple of days.

But... now it's back again.

Charlie: I'll try your idea next.
Although... I shiver at the thought of having to use an
alternative web browser (even if it's just for a few days).
Nearly all of them are memory hogs.
And the ones that aren't... I don't trust.
(I've heard rumors of some sending "unauthorized" info back
to their creators)

Keeping my fingers crossed that I can find a solution.

bigD
Home Page: http://burkleyd.ulmb.com



Options: ReplyQuote
Re: Any1 else having WinXP startup problem?
Posted by: siria
Date: October 16, 2009 02:58PM

Uhm, running a "bit" late, perhaps obsolete by now, but anyway... And not really any clue, just a few thoughts ;-)
You said you have different drives, so simply run KM from the other for awhile, just for testing... And if it's a closing problem, there might help this new foolproof extension for making sure that really everything gets killed at the end: http://kmeleon.sourceforge.net/forum/read.php?1,96068,96068#msg-96068
Or maybe it's something from a website you visit regularly, so clearing the cache every day can't harm...

Options: ReplyQuote
Re: Any1 else having WinXP startup problem?
Posted by: bigD
Date: October 20, 2009 08:08PM

Here's what I tried, and I think I may
have found the cause of my problem.

I stopped using K-Meleon for about a week.
My problem did not occur during that week.

I then starting using K-Meleon again and my
problem started up again.

I then tried siria's suggestion of installing
"Foolproof Terminator".

I did not leave it installed long enough to
find out if would work because...
Foolproof Terminator ERASED all my Bookmark
icons. I was NOT happy about that at all.
I removed it immediately.

While experimenting with different ideas to
solve my problem... I stumbled on something.

When my K-Meleon starts up... there is one
tab being shown.

And as long as I never "use" that very first
tab (the one on the far left) for anything...
my problem never occurs.

When I want to navigate to a web page... I open
a "New" tab and use it, instead of the first tab.

As long as I religiously stick to doing it this
way... everything is fine (no startup problem).

It seem like a small price to pay to avoid my
startup problem... so I don't mind doing it.

bigD



Options: ReplyQuote
Re: Any1 else having WinXP startup problem?
Posted by: desga2
Date: October 20, 2009 10:21PM

Do you have setting some Home web page or have you installed some Extension like Roboform?

You have a very interesting and strange problem.
Can you send me by mail your K-Meleon folder zipped to test with it in my system?

Thanks.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 10/20/2009 10:21PM by desga2.

Options: ReplyQuote
Re: Any1 else having WinXP startup problem?
Posted by: bigD
Date: October 23, 2009 01:58AM

No I do not have it set to load any "remote" web page.

It loads a "local" html file which is totally blank.
Such as...
<html>
<head>
<title></title>
</head>
<body></body>
</html>

And no... I do not have any extension like RoboForm installed.

I zipped the folder that K-Meleon is installed in (which is on my D:\ drive).

bigD's ZIP File
(can you post a message after you have downloaded it so that I can erase it)

If you need the user preference folder that's on my C:\ drive... you'll have to wait an undetermined amount of time.

I'm moving tomorrow (to a city about 900 miles north of my current location) and I honestly don't know when I'll have an internet connection again.

bigD



Options: ReplyQuote
Re: Any1 else having WinXP startup problem?
Posted by: desga2
Date: October 23, 2009 02:51AM

Thanks bigD, I already downloaded it.

Bon voyage.

K-Meleon in Spanish

Options: ReplyQuote


K-Meleon forum is powered by Phorum.