Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
Impossible to register to submit bug report
Posted by: Christopher Poole
Date: January 11, 2009 11:40AM

I registered and submitted a bug report about six months ago but didn't save my password anywhere I can find and there's no recover password function nor do I remember what email address I used.

So I went and tried registering dozens of times for an hour. Each time it made an account as it wouldn't let me re-use the same name or email again. Each time it sent no emails, but merely said "Bad username or password!" whenever I tried to log in.

The bug: The User-agent button on the privacy bar when you left click it, instead of getting the correct bar, it launches the "About K-Meleon" function. Only right clicking works and this is a pain.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: Cantregister1
Date: January 11, 2009 11:42AM

Okay well apparently the registration system that's supposed to work for bug reports http://kmeleon.sourceforge.net/bugs/index.php only works for this forum.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: Cantregister1
Date: January 11, 2009 11:43AM

Yes, it tells you to register but the registration is only for the forum and the login doesn't work for reporting bugs.

No wonder such obvious bugs never get noticed for years.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: Cantregister1
Date: January 11, 2009 11:44AM

I am logged in but login doesn't carry over for the bug reporting system and it doesn't find me logged in at all.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: Cantregister1
Date: January 11, 2009 11:45AM

Hmm the link on the bug report to register is http://kmeleon.sourceforge.net/bugs/createaccount.php

Then apache redirects it to http://kmeleon.sourceforge.net/forum/register.php?frombt

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: Cantregister1
Date: January 11, 2009 11:46AM

Redirect still happens on MSIE with javascript and meta refresh off.

Yup K-Meleon developers intentionally don't want to have to fix any bugs. No wonder the flashblock bug isn't even in the list of bugs for them to fix and nor have they fixed it.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: guenter
Date: January 11, 2009 04:01PM

Quote
Cantregister1
Redirect still happens on MSIE with javascript and meta refresh off.

Yup K-Meleon developers intentionally don't want to have to fix any bugs. No wonder the flashblock bug isn't even in the list of bugs for them to fix and nor have they fixed it.

1.) MSIE = Microsoft Internet Explorer!

2.) Read forum posts about flash block. There is a fix.
It seems to be little used only few noticed.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: desga2
Date: January 12, 2009 01:48AM

Quote
Christopher Poole
I registered and submitted a bug report about six months ago but didn't save my password anywhere I can find and there's no recover password function nor do I remember what email address I used.

So I went and tried registering dozens of times for an hour. Each time it made an account as it wouldn't let me re-use the same name or email again. Each time it sent no emails, but merely said "Bad username or password!" whenever I tried to log in.

The bug: The User-agent button on the privacy bar when you left click it, instead of getting the correct bar, it launches the "About K-Meleon" function. Only right clicking works and this is a pain.

I can access to Bug fine, with same user and pass that this forum.

And this isn't a bug, User-agent button on the privacy bar worked ever in this way since 1.1.x versions. What is it that "getting the correct bar" that you want?
You can change it in toolbars.cfg file in your skin folder.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 01/12/2009 01:49AM by desga2.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: bugreporter-x
Date: January 12, 2009 02:16AM

there does seem to be a 'bug' tongue sticking out smiley in registering to the bugs wiki with new accounts.

i created this account which logs in fine to the forum but fails on the bugs page.

christopher, i assure you this problem is unintentional.. but it seems to have happened when sf migrated their servers.. thanks for pointing it out. i believe gunter or enzajgyag can fix it.

gunter, to test:
username: bugreporter-x
password: bugger2009

email account used: kmeleontesters@gmail.com (pass: fuckdel2009)

(disrupted)

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: kko
Date: January 12, 2009 03:38AM

Quote
Christopher Poole
The bug: The User-agent button on the privacy bar when you left click it, instead of getting the correct bar, it launches the "About K-Meleon" function. Only right clicking works and this is a pain.

This button is working exactly as explained in its tooltip. So what is the bug?

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: kko
Date: January 12, 2009 03:39AM

Quote
bugreporter-x
there does seem to be a 'bug' tongue sticking out smiley in registering to the bugs wiki with new accounts.

I do have the same problems with my old account. I guess it has something to do with caching. When you logged in to the BTS, it may look as if you were not logged in although you actually are. Reload the page (several times if necessary or use Ctrl+F5). This can also happen when you've added a comment to report or when you created a new one...

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: guenter
Date: January 12, 2009 07:01AM

Since relocation fo SF servers and update of forum some things just hesitate to work sad smiley

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: Christopher Poole
Date: January 12, 2009 07:34AM

guenter,

After I tested it in K-Meleon, I tested it in MSIE as sometimes some websites only work for MSIE.

I did and I applied the fix before downgrading to 1.16 for another problem. As stated, the simple fix was done weeks ago and the build should have been updated with that fix but it appeared the devs never noticed it.


desga2,

http://kmeleon.sourceforge.net/bugs/createaccount.php does an Apache-like redirect to http://kmeleon.sourceforge.net/forum/register.php?frombt

Then logging in from a newly created name doesn't work at http://kmeleon.sourceforge.net/bugs/login.php says "Bad username or password!" and it only works at the forums which doesn't carry over to the bug area.

For the user-agent thing, just because the bug hasn't been fixed for many versions doesn't mean it's not a bug. It should also work for left click as well as right instead of being really annoying. All the other privacy bar buttons work for left click instead of right so a small fix and solve a big annoyance

I found that changing ub toolbars.cfg "ID_APP_ABOUT|&User Agent" to any variant of "|&User Agent" gets rid of the annoying popup from an accidental left click but anything like "&User Agent|&User Agent" doesn't fix it so it works for left click and I can't find anything in useragent.kmm that can fix this.




...

As for the login, clearing cache and force reload do not work.

I made an example account:

username: weiuweiurwerw
email: weiuweiurwerw@tempinbox.com
password: uwerwer87we


Loggined in to the forum with it (as logging in to the bug report area does not work ever) made these cookies:

apps.sourceforge.net FALSE /piwik/kmeleon/ FALSE 1547079388 piwik_visitor1 1%3DNmNiZDIzMTY2OTM3YWExZTAwZDQzOWVkZmYxNzkwMmE%3D%3A2%3DMTIzMTcxOTM5MQ%3D%3D%3A3%3DMTIzMTcxOTEzNg%3D%3D%3A4%3DMTcyMjEy%3A5%3DMjkzOTM%3D
kmeleon.sourceforge.net FALSE / FALSE 1234311386 phorum_session_v5 994%3A7aa744ffaa7bc8d93b796267fd9870cd



The login screen for loggin on on the forum made a session cookie called bb2_screener_ that contains "1231719388+127.0.0.1+[my IP address]" where "[my IP address]" is my IP address, but that was before login and I don't think it relates


I kind of suspected the problem was that http://kmeleon.sourceforge.net/bugs/createaccount.php does an Apache-like redirect to http://kmeleon.sourceforge.net/forum/register.php?frombt and here's the exact redirect that the server says:

HTTP/1.1 302 Found
Server: nginx/0.6.31
Date: Mon, 12 Jan 2009 00:31:55 GMT
Content-Type: text/html
Connection: close
X-Powered-By: PHP/5.2.6
Location: ../forum/register.php?frombt
Cache-Control: max-age=172800
Expires: Wed, 14 Jan 2009 00:31:55 GMT
Content-Length: 0



Oh and unrelated, PHP 5.2.8 is out and appears stable unlike 5.2.7.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: desga2
Date: January 12, 2009 09:17AM

If you are using same user in forum, this worked for me:
Log Out from forum, clear cache, delete K-Meleon cookie and tried again.

K-Meleon in Spanish

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: guenter
Date: January 12, 2009 07:10PM

Quote
Christopher Poole
guenter,

After I tested it in K-Meleon, I tested it in MSIE as sometimes some websites only work for MSIE.

I did and I applied the fix before downgrading to 1.16 for another problem. As stated, the simple fix was done weeks ago and the build should have been updated with that fix but it appeared the devs never noticed it.

1.) MSIE is a site design problem. IE 5-7 did not stick to web standards. Because IE was so common once some designers made MSIE only pages.

2.) It is the duty of all users to test, describe bugs, and support others via this forum. We users must be ready to do at least that if we want the project to continue. We users cannot help the devs with developing K-Meleon after all.

@desgas forum can make problems when You try to use identical (mail@) data.
If that is the case a moderator must try to reset or delete the ID.



Edited 1 time(s). Last edit at 01/12/2009 07:16PM by guenter.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: Christopher Poole
Date: January 16, 2009 06:00AM

Well I finally found the email associated with the account just now and it was getting all the emails. Unfortunately I have no idea what the password is and there's no "forgot password" function on the forum or on the bug report site.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: Christopher Poole
Date: January 16, 2009 06:02AM

I meant password to my account on the bug report site. I the email account just used the samea password I had on almost 100 email accounts I've used.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: guenter
Date: January 16, 2009 04:02PM

The pwd would not help You. It is the same as here.


Your problem:
SF moved Forum to a new server and broke some things in Forum.
All PPL that did not visit forum in time lost their old accounts and nicks.
The old pwd is lost PLUS they cannot use the old mail-id to get new pwd.

In this no go situation they need a moderator or admin sad smiley
I can search the user data & set a new pwd.

So i need Your old logging name (if I know You from old).

Or send me Your old mail address.
Plus I need a valid new mail address for the new pwd.

If neither is the case the account is lost.



Edited 1 time(s). Last edit at 01/16/2009 04:08PM by guenter.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Date: May 18, 2009 04:29AM

1.5.3 came out and this is still not fixed. Clearly devs never read these forums. It is also still impossible to register to submit a bug report and still no "forgot password" function exists to get access to an old account of mine (which after a year of looking I found the email address to) to file bug reports.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: guenter
Date: May 18, 2009 05:06AM

Post the Bug in a way that it can be repeated by others.

If it can be verified by others AND is a K-Meleon bug it will be submitted to bugs.
If You still want to complain that K-Meleon must render like IE or that certain things at SF do not works the way You want - just forget it.

Some things about Forum and the GRE are out of reach for the PPL here.
Some is SF tech that even devs cannot alter.

It is wrong that You seem demand that the devs must read anything & do not read.
kko is dev! Only moderators read almost every post.

p.s. Even if nobody noticed or read Your posts.
There is no reason to complain, all here are unpayed volunteers.



Edited 1 time(s). Last edit at 05/18/2009 05:21AM by guenter.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: Christopher Poole
Date: May 18, 2009 05:14AM

Quote
guenter
If You still want to complain that K-Meleon must render like IE just forget it.

I wasn't talking about that.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: guenter
Date: May 18, 2009 05:35AM

I need Your user name and a valid mail. If You want me to try to reset Your account.

Correct me if I am wrong, Your main complaint =

The bug: The User-agent button on the privacy bar when you left click it, instead of getting the correct bar, it launches the "About K-Meleon" function.

Left click is supposed to show You current settings which is done via about: page. Right click shows the context sensitive menu that lets You make changes. IMHO this is the technically correct action & I see no bug.



Edited 2 time(s). Last edit at 05/18/2009 05:38AM by guenter.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Date: May 18, 2009 05:50AM

OP here...


Quote
guenter
I need Your user name and a valid mail. If You want me to try to reset Your account.

I've made an account now and then found out why account making didn't work after a lot of tested and submitted a bug report for that.




Quote
guenter
Correct me if I am wrong, Your main complaint =

The main complaint for this thread was registering problems and no "forgot username"/"forgot password" stuff.



Quote
guenter
The bug: The User-agent button on the privacy bar when you left click it, instead of getting the correct bar, it launches the "About K-Meleon" function.

Left click is supposed to show You current settings which is done via about: page. Right click shows the context sensitive menu that lets You make changes. IMHO this is the technically correct action & I see no bug.

Okay, well that makes no sense to me.
1) The button is on the "privacy bar".
2) The button says "user agent". It does not say "About K-Meleon" or anything else. It says "user agent". So then lift clicking it, you'd expect something related to user agent.

Does that sound right to you?

Well I went in toolbars.cfg and I noticed it says "Check Browser Identity. Right-click to choose different User Agent." and then there's a tooltip of it. Well, I'll grant you that. However the function in toolbars.cfg is:

ID_APP_ABOUT|&User Agent

Well I tried this:
&User Agent|&User Agent
and then this:
User Agent|&User Agent
And:
&User Agent
and:
User Agent

And nothing seems to make it work to make it work left click, too. I don't know why that is.

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: desga2
Date: May 18, 2009 06:12PM

This must work:
&User Agent|&User Agent

Are you restart K-Meleon to changes take effect?

K-Meleon in Spanish

Options: ReplyQuote
Re: Impossible to register to submit bug report
Posted by: jsnj
Date: May 19, 2009 12:03PM

Quote
bugsnevrgetfixd

Well I tried this:
&User Agent|&User Agent
and then this:
User Agent|&User Agent
And:
&User Agent
and:
User Agent

And nothing seems to make it work to make it work left click, too. I don't know why that is.

If you haven't disabled the rebar menu plugin, then the following will provide a left-click menu for you:

User Agent{
rebarmenu(&User Agent)
Change User Agent
privhot.bmp[16]
privcold.bmp[16]
}

%endif

Options: ReplyQuote


K-Meleon forum is powered by Phorum.