Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
SetDefault in 1.5.2 fails to set most defaults to K-Meleon in Windows Vista.
Posted by: cowlitzron
Date: December 31, 2008 02:00PM

I have K-Meleon 1.5.2 on Windows Vista Home Premium. SetDefault does not set file types or protocals to open with K-Meleon. The defaults remain the previous defaults. The Internet Icon in the Start Menu is K-Meleon and if I click it, K-Meleon is launched. But, if I click a link in an email or click on an icon to an HTML page, the previous default browser is launched. Setting the default to K-Meleon worked well in the 1.1.x versions of K-Meleon.

Options: ReplyQuote
Re: SetDefault in 1.5.2 fails to set most defaults to K-Meleon in Windows Vista.
Posted by: disrupted(unlogged)
Date: December 31, 2008 07:43PM

it's a known issue because vista changed how programs associate in the registry:
please download and merge this regkey:
http://users.sosdg.org/~bruns/km/km-vista.reg
this key assumes default install location for k-meleon:
c:\program files\k-meleon\k-meleon.exe

if your installation path differs from above, then open the above key in notepad and change all km paths to your own paths

also check this thread:
http://kmeleon.sourceforge.net/forum/read.php?1,86335,86335#msg-86335

Options: ReplyQuote
Re: SetDefault in 1.5.2 fails to set most defaults to K-Meleon in Windows Vista.
Posted by: cowlitzron
Date: January 01, 2009 11:14AM

I downloaded and merged the regkey and with that I was able to make K-Meleon the default browser for web pages and links. Thank you for the suggestion.

Options: ReplyQuote
Re: SetDefault in 1.5.2 fails to set most defaults to K-Meleon in Windows Vista.
Posted by: JujuLand
Date: January 02, 2009 11:23PM

I have made new tests with a standard user under Vista Professional SP1.

All the registring things seems to be correctly made by setdefault.

I create a user without admin rights (Basique)
I launch K-Meleon 1.52 setup
Windows ask for me the password of a user having admin rights (Alain), it's normal
I install without error message
I put an html file on the desktop and double-click on it.
It's K-Meleon which opens as I want.
I haven't tried with other file types, but I beg it will be ok

I create a shortcut of K-Meleon website on the desktop, and double-click on it.
It's K-Meleon which opens as I want.

Can this be due to the Vista version. I haven't Home premium, and can't test it for now.

A+


Mozilla/5.0 (x11; U; Linux x86_64; fr-FR; rv:24.0) Gecko/20140105 Ubuntu/12.04 K-Meleon/74.0

Web: http://jujuland.pagesperso-orange.fr/
Mail : alain [dot] aupeix [at] wanadoo [dot] fr





Edited 1 time(s). Last edit at 01/02/2009 11:24PM by JujuLand.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.