Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here. But please, for confirmed bugs, use the bug tracker to report and give feedback on bugs.  
weird uncomprehensible rather superficial possible macro bug
Posted by: disrupted
Date: November 06, 2008 09:57PM

since version 1.1.4, i used a simple macro to send the system into standby through executing an automation standby program.. though i don't use this macro much but comes handy when i want to suspend(s3=suspend to ram) without leaving k-meleon and going through the traditional ways to standby.

today when i tried the macro, i go an error message.. i thought the program was actingup or something but when i ran the program directly, it worked fine.. anyway, i tried another suspenders but none would actually function when launched from the macro.. what's really strange is k-meleon's window isn't preventing standby.. when km is open and i try to standby, everything will work fine.. it just won't standby from the macro(menu command). previous kms(up to 1.5.0) execute the suspenders fine from the macro except for 1.5.1.. it's very strange and i wish i'd know why is that happening.. any ideas?

this is the macro i use:
# K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage)
#
# ---------- suspend system
#
# Dependencies : - lindt!
# Resources : -
# Preferences : -
# --------------------------------------------------------------------------------

_suspend_command{
exec("E:\\Applications\\apps-x\\assbadtools\\Loggedon2\\offers\\WinSus.exe");
}

_suspend_BuildMenu{
# file menu
setmenu("Close",macro,"Suspend System",_suspend_command,0);
}

# ------------------------------------------------------------------------------------------------------------------
$OnInit=$OnInit."_suspend_BuildMenu;";
$macroModules=$macroModules."suspender;";



the error message:



p.s. i tried several suspenders(from macro) to check for their error messages but thy just didn't send the system into standby although the taskmanager indicated that they did indeed execute..winsus was the only one that gave me an error message

UPDATE: when using the macro from the kmeleonw9x version on xp, standby was processed normally without errors. i tried other methods to understand what's the cause like executing the suspend tool indirectly from an autoit script and by stealing focus from km's window in case km window being active caused the interrupt but that didn't work.. so it doesn't seem related to km's window in anyway only with the macro with only k-meleon1.5.1.exe and not any other versions including the 1.5.1 w9x.. unicode??


Options: ReplyQuote
Re: weird uncomprehensible rather superficial possible macro bug
Posted by: disrupted(unlogged)
Date: November 07, 2008 12:10AM

update2: also affects shutdown and restart.. it appears the macro bug or conflict is with windows ACPI events. i.e. macro will not allow automation tools to function and execute properly when it's related to ACPI.. kinda reminds when you try to shutdown/restart a remote machine when you're not recognised as an administrator.

for testing. set of automation tools(shutdown..standby etc)


Options: ReplyQuote
Re: weird uncomprehensible rather superficial possible macro bug
Posted by: disrupted(unlogged)
Date: November 08, 2008 03:14AM

using the default windows command to hibernate/standby in this macro:

# K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage)
#
# ---------- suspend kmeleon
#
# Dependencies : - lindt!
# Resources : -
# Preferences : -
# --------------------------------------------------------------------------------

_suspend_command{
exec("c:\\windows\\System32\\rundll32.exe powrprof.dll,SetSuspendState");
}

_suspend_BuildMenu{
# file menu
setmenu("Close",macro,"Suspend System",_suspend_command,0);
}

# ------------------------------------------------------------------------------------------------------------------
$OnInit=$OnInit."_suspend_BuildMenu;";
$macroModules=$macroModules."suspender;";


failed to suspend the system.. testing with 1.5.0 and 1.1.6, the macro initiated standby normally. 1.5.1w9x version also worked..
also tested the shutdown and restart commands with sysinternal psshutdown.. so it's definitely a bug or conflict affecting 1.5.1 nt macros with ACPI events. i'll submit it as a bug.

Options: ReplyQuote
Re: weird uncomprehensible rather superficial possible macro bug
Posted by: Dorian
Date: November 08, 2008 06:31PM

That's not a bug. To improve security, kmeleon is running with less privileges since 1.5.1 when the OS support it.

1.5.2 will have an option to disable it.

Options: ReplyQuote
Re: weird uncomprehensible rather superficial possible macro bug
Posted by: disrupted(unlogged)
Date: November 08, 2008 10:47PM

that's good to know.. thanks. any chance of disabling it in 1.5.1 using a string in about:config?

Options: ReplyQuote


K-Meleon forum is powered by Phorum.