1.1.6 wasn't closed properly
Posted by: elkanguro
Date: July 30, 2008 12:45AM

Hi,

in version 1.1.6 every time I turn on my computer and launch a K-Meleon, it displays a window and there is written then K-Meleon wasn't closed properly. And the answer if I wuold like to open last session. It appears every time. I use K-Meleon loader and never closed the loader, but in previous versions it was OK.

Re: 1.1.6 wasn't closed properly
Posted by: Mati
Date: August 17, 2008 11:11AM

I have the same problem... I don't know what to do with it sad smiley

Re: 1.1.6 wasn't closed properly
Posted by: Paul Feakins
Date: May 18, 2009 06:03PM

Yep, same problem here. Very annoying.

Re: 1.1.6 wasn't closed properly
Posted by: desga2
Date: May 18, 2009 08:25PM

Try to update gecko.

This can be the embed_lite.dll problem.

K-Meleon in Spanish

Re: 1.1.6 wasn't closed properly
Posted by: reeko124
Date: May 19, 2009 01:29AM

I have that problem everytime i had the launcher enabled. So i disabled the launcher and have gone back to it taking more time to load then actual windows lol

Re: 1.1.6 wasn't closed properly
Posted by: melonhead
Date: March 13, 2010 01:10PM

I've been trying to live with this bug but it's getting old :-[

We're on v 1.5.4 now and still no fix?

Re: 1.1.6 wasn't closed properly
Posted by: desga2
Date: March 13, 2010 09:00PM

This isn't a K-Meleon problem, this happend because K-Meleon can't saved the profile because your system does not allow it.

What K-Meleon version and what Windows version are you using?
Are you using K-Meleon Loader? (Disable it)
Have your Windows user privileges to write in K-Meleon Profile folder (Edit -> Configuration -> Profile Directory)?

K-Meleon in Spanish

Re: 1.1.6 wasn't closed properly
Posted by: Heizkessel
Date: March 27, 2010 12:19AM

I have the same problem. it occours since k-meleon 1.5.3 in the middle of 2009. I have not changed the System in Firewall etc.. I'm a Admin User on WinXP always.

The K-Meleon starts not visible, in the Task-Manager i see the kmeleon.exe have 80-100% Overload and a Popup cames on " Want to start a new session....". I click "Yes" or "No" and it does nothing! The process has 99% Overload in TaskM.
As well in 30 minutes


Re: 1.1.6 wasn't closed properly
Posted by: Heizkessel
Date: March 27, 2010 12:42AM

THE NEW UPDATED VERSION(from 05.03.2010) 1.5.4 HAS FIXED THIS PROBLEM

Download it now its great. drool smiley

MANY THANKS MANY THANKS TEAM

Re: 1.1.6 wasn't closed properly
Posted by: Biber
Date: May 10, 2011 11:11PM

Sorry to ruin the party, but I just installed 1.5.4 with Loader, used K-meleon for a while, shut down my machine with K-Meleon still open, and on startup of the next Windows session got this same error. I installed it for my 88 year old father (probably the oldest user of K-Meleon in the world!) and it will confuse him smiling smiley
He is using an old Win XP Pro machine and am going to try the old workarounds above now.

Re: 1.1.6 wasn't closed properly
Posted by: ndebord
Date: May 12, 2011 09:27PM

Quote
Biber
Sorry to ruin the party, but I just installed 1.5.4 with Loader, used K-meleon for a while, shut down my machine with K-Meleon still open, and on startup of the next Windows session got this same error. I installed it for my 88 year old father (probably the oldest user of K-Meleon in the world!) and it will confuse him smiling smiley
He is using an old Win XP Pro machine and am going to try the old workarounds above now.

Biber,

Try it without the Loader and see how it works then.

N

Re: 1.1.6 wasn't closed properly
Posted by: siria
Date: June 14, 2011 04:58AM

Don't manage to reproduce that thing, neither on win98 nor XP, nor with the loader. Just no crash alert here! *confused* Perhaps it needs some special settings or extensions or combinations with systems and win-security stuff, no idea...

Anyway, if for some weird reason somebody still has that prob and doesn't mind to NEVER get that Crash-Restore-Question, not even after a real crash, you can suppress it with an automatic "not-crashed" declaration. Click

Edit > Configuration > User Settings (opens "user.js" in user profile)
Add this line at bottom:
user_pref("kmeleon.plugins.sessions.cleanShutdown", true);

This will make that the last session, crashed or not, will always be considered as "closed normally" at next start --> no questions about restoring. Now you can only restore a crash session manually, with menu
Sessions>Load Session>Previous session.

May be helpful for normal users who remember this, hey, perhaps actually quite useful to change some settings like blocking javascript before restoring a crashed session again?!
Then again, not sure if that's really much easier for beginners, who may not be bothered with confusing questions now, but in case of real crash have no idea how to get it back...

Technically this setting means for KM that at startup it can proceed to copy the "Last Session" to "Previous Session", and start a new "Last session" for the current one. Without this fake, if the browser was crashed last time, KM would keep the last "clean" session as "Previous Session". This makes much sense if the crash happened due to some messy website, because otherwise that page would crash again each time that session would be restored. But unfortunately no chance to keep the crashed session somehow for later testing, unless opening it instantly, but then it's too late to block javascript first or such.

By the way the session pages are all stored in the profile, among hundreds of other settings in "prefs.js"! Can also be checked and modified in "about:config", if typing "sessions".
A little trick for the curious: if you want to sort the sessions list differently, or insert line breaks or such (e.g. ,---,), open about:config and change manually the name order in the list (kmeleon.plugins.sessions2.list) cool smiley Close the browser without doing any other session stuff at the moment to avoid that your changes are overwritten again. At next start it should work.



Edited 1 time(s). Last edit at 06/14/2011 05:08AM by siria.

K-Meleon forum is powered by Phorum.