[1.1a2] Save as directory not remembered
Posted by: ra
Date: February 10, 2007 10:18PM

Hi,

is there an update in the meantime to fix

Quote

The save (image) as directory is not always remembered. In most cases it is, but not always. (With several windows open changing the directory in one window doesn't always change it for the others.). Update: Works flawlessly if the macros plugin is disabled.

as reported here http://kmeleon.sourceforge.net/wiki/KMeleon11?

This problem bugs me every day...

Thanks!

Re: [1.1a2] Save as directory not remembered
Posted by: kko
Date: February 11, 2007 07:07PM

WTF, why is this still listed in the macros section? I know I've moved it out there. This problem is not caused by any macro. And Dorian will hardly investigate issues entiteled as macro bugs...

Re: [1.1a2] Save as directory not remembered
Posted by: ra
Date: February 11, 2007 08:03PM

Well, it has to be a macros issue because it
Quote

Works flawlessly if the macros plugin is disabled.
.

Re: [1.1a2] Save as directory not remembered
Posted by: kko
Date: February 11, 2007 09:29PM

Well, in my terms, a macro bug is a bug in a piece of code written in the macro language. That's my responsibility. Dorian won't care until I assign such problems to him (e.g. in case the plugin needs to be fixed).

When I assign a bug to Dorian by moving it out of the macro section, you don't need to reassign the bug to me by moving it back. That's simply counter productive. Please ask here in the bugs forum before moving bugs around.

Have you found out more in the meantime? Can you say a bit more about the circumstances in which this problem appears?

Re: [1.1a2] Save as directory not remembered
Posted by: ra
Date: February 13, 2007 07:35AM

Well, in my terms, a macro bug is a bug in a piece of code written in the macro language. That's my responsibility. Dorian won't care until I assign such problems to him (e.g. in case the plugin needs to be fixed).

The wiki is not the BTS. Dorian asked to report bugs to the wiki. I categorized them. That's not assigning nor did Dorian say that he won't read the (two) reported macros bugs.

When I assign a bug to Dorian by moving it out of the macro section, you don't need to reassign the bug to me by moving it back. That's simply counter productive. Please ask here in the bugs forum before moving bugs around.

Very well then, it's a wiki!

Have you found out more in the meantime? Can you say a bit more about the circumstances in which this problem appears?

I have a bookmarks group with some 30+ bookmarks that I open daily. The first windows (I'm using windows mode, only, layers are not loaded) will be closed again before all of the others have finished loading. When I want to save an image, e.g. from a daily humor site I choose a directory to save the image to. After saving I close this window. Then I close another one or two that are unrelated, then I want to save an image from a second jokes site. Now I have to choose the directory *again*, because K-M didn't remember the last used directory. And so on.

This problem existed with some pre-1.0 builds as well and it was a pure macros bug (there were several save as paths for images, downloads and so on) back then, that was fixed by removing the corresponding save as diversity in 1.0 [might also have been 0.9 and previous?].

Re: [1.1a2] Save as directory not remembered
Posted by: kko
Date: February 14, 2007 01:48AM

Quote
ra
Well, in my terms, a macro bug is a bug in a piece of code written in the macro language. That's my responsibility. Dorian won't care until I assign such problems to him (e.g. in case the plugin needs to be fixed).

The wiki is not the BTS. Dorian asked to report bugs to the wiki. I categorized them. That's not assigning nor did Dorian say that he won't read the (two) reported macros bugs.

Alright, just remember WHY Dorian asked to report bugs to the wiki. To save his time! That implies that we only report bugs to the wiki that have to be fixed by him. Macro bugs do not belong to this category. That's why I've pleased everyone to report macro bugs (or what you hold for that) to the forum instead. This also saves my time. When you nevertheless report a macro bug to the wiki, I may not notice your report and thus may not fix the bug. And Dorian may not fix it either because he expects me fixing it...


I have a bookmarks group with some 30+ bookmarks that I open daily. The first windows (I'm using windows mode, only, layers are not loaded) will be closed again before all of the others have finished loading. When I want to save an image, e.g. from a daily humor site I choose a directory to save the image to. After saving I close this window. Then I close another one or two that are unrelated, then I want to save an image from a second jokes site. Now I have to choose the directory *again*, because K-M didn't remember the last used directory. And so on.

When a file is saved, the save as directory is not updated for other windows that have not finished loading their document at this time (at least in windows only mode).
Can we summ it up like this? Would this be correct?

Just to make sure: Does it really work correct when all documents in all windows have finished loading?

How is the behavior when you've renamed "main.kmm" in K-Meleon\macros\ but keep the macros plugin activated? (restart required, will deactivate all macros)


This problem existed with some pre-1.0 builds as well and it was a pure macros bug (there were several save as paths for images, downloads and so on) back then, that was fixed by removing the corresponding save as diversity in 1.0 [might also have been 0.9 and previous?].

Again: This is no macros bug and never was. Macros are not at all involved in saving documents and never were. Km 0.9 only had individual (and fixed!) save page/image/link as directories and macros to set the related prefs. This feature was removed during 1.0 development and the macros with it because this feature turned out to be more confusing then helpful. There was never anything wrong with these macros except that the save as functionality's redesign made them effectless.

Re: [1.1a2] Save as directory not remembered
Posted by: ra
Date: February 14, 2007 06:27AM

Quote
kko
Alright, just remember WHY Dorian asked to report bugs to the wiki. To save his time! That implies that we only report bugs to the wiki that have to be fixed by him. Macro bugs do not belong to this category. That's why I've pleased everyone to report macro bugs (or what you hold for that) to the forum instead. This also saves my time. When you nevertheless report a macro bug to the wiki, I may not notice your report and thus may not fix the bug. And Dorian may not fix it either because he expects me fixing it...

Alright, sounds logical. But remember that you added the request to report macros bugs to the forum to the wiki page after I had reported all my bugs, including some that I marked as "macros bugs (probably)"... smiling smiley


Quote

When a file is saved, the save as directory is not updated for other windows that have not finished loading their document at this time (at least in windows only mode) if the macros plugin is loaded in K-M 1.1a2.
Can we summ it up like this? Would this be correct?

With the addition of the bold text, that I added to the quote, it would probably be correct, although I'm not sure about the implication of the unfinished loading of the windows.

Quote

Just to make sure: Does it really work correct when all documents in all windows have finished loading?

I haven't said it would. It takes ages 'til all of them have finished loading, so I tried only your second suggestion for now, but I will check tomorrow if it works when all windows have finished loading.

Quote

How is the behavior when you've renamed "main.kmm" in K-Meleon\macros\ but keep the macros plugin activated? (restart required, will deactivate all macros)

That way the problem doesn't happen!


Quote

This problem existed with some pre-1.0 builds as well and it was a pure macros bug (there were several save as paths for images, downloads and so on) back then, that was fixed by removing the corresponding save as diversity in 1.0 [might also have been 0.9 and previous?].

Again: This is no macros bug and never was. Macros are not at all involved in saving documents and never were.
Macros don't save documents, that's correct. But they were involved in changing and storing the paths the documents were saved in, just like you elaborate now:
Quote

Km 0.9 only had individual (and fixed!) save page/image/link as directories and macros to set the related prefs.
Dealing with the path prefs accounts for an involvement in saving documents.

Re: [1.1a2] Save as directory not remembered
Posted by: kko
Date: February 15, 2007 02:04AM

Quote
ra
But remember that you added the request to report macros bugs to the forum to the wiki page after I had reported all my bugs, including some that I marked as "macros bugs (probably)"... smiling smiley

Probably... you try to fool me. smiling smiley Big Brother is watching you!


Quote
ra
Quote

Km 0.9 only had individual (and fixed!) save page/image/link as directories and macros to set the related prefs.
Dealing with the path prefs accounts for an involvement in saving documents.

You can use the Registry Editor to set the path of your Favorites folder. But you wouldn't call the Registry Editor "involved" in saving Favorites because of this, would you? smiling smiley


As far as your investigations are concerned, we are still at:

When a file is saved, the save as directory is not updated for other windows that have not finished loading their document at this time (at least in windows only mode).

...since the problem doesn't appear when the plugin is loaded but the kmm's are not. Let's see what your next test is bringing...


Say, the other problem that you reported with km hanging when a page is not responding, does this also happen under the same circumstances, when you open your 30+ pages at once?

Re: [1.1a2] Save as directory not remembered
Posted by: ra
Date: February 16, 2007 04:26AM

Quote
kko
Quote
ra
But remember that you added the request to report macros bugs to the forum to the wiki page after I had reported all my bugs, including some that I marked as "macros bugs (probably)"... smiling smiley

Probably... you try to fool me. smiling smiley Big Brother is watching you!

Hear, hear. So let's ask Big Brother who's trying to fool whom:

In Version 5 of the page I (ra) added the whole actual content of the page = the bugs, with more than a dozen of them, including three in a section called "Macros bugs (probably)".

In Version 6 you (kko) added comments on the relevance&validity in your opinion of some of these bugs.

In Version 7 you moved two of the three bugs reported as "Macros bugs (probably)" out of this section, you renamed the section to "Macros bugs" and you added the comment "Please report macro issues in the Bugs Forum (kko)" right after the section's title.


Quote
kko
Quote
ra
Quote

Km 0.9 only had individual (and fixed!) save page/image/link as directories and macros to set the related prefs.
Dealing with the path prefs accounts for an involvement in saving documents.

You can use the Registry Editor to set the path of your Favorites folder. But you wouldn't call the Registry Editor "involved" in saving Favorites because of this, would you? smiling smiley

No, as this comparison is weak.

But it's interesting that I had the same problem with the 1.0-betas before these macros were removed.


Quote

As far as your investigations are concerned, we are still at:

When a file is saved, the save as directory is not updated for other windows that have not finished loading their document at this time (at least in windows only mode).

...since the problem doesn't appear when the plugin is loaded but the kmm's are not.

Let's not forget about these additional two facts:

1.) The problem doesn't happen if the macros plugin is lot loaded.
2.) The problem doesn'T happen if main.kmm is renamed and the plugin is loaded.

Quote

Let's see what your next test is bringing...

So, I waited for all windows to finish loading (had a meal inbetween, just in case <g>): Problem was there.


Quote

Say, the other problem that you reported with km hanging when a page is not responding, does this also happen under the same circumstances, when you open your 30+ pages at once?

No, that's mainly with s.th. like three windows open, sometimes even with only one. But it might happen with more windows as well of course.

Re: [1.1a2] Save as directory not remembered
Posted by: kko
Date: February 16, 2007 05:59AM

Quote
ra
Hear, hear. So let's ask Big Brother who's trying to fool whom:

In Version 5 of the page I (ra) added the whole actual content of the page = the bugs, with more than a dozen of them, including three in a section called "Macros bugs (probably)".

In Version 6 you (kko) added comments on the relevance&validity in your opinion of some of these bugs.

In Version 7 you moved two of the three bugs reported as "Macros bugs (probably)" out of this section, you renamed the section to "Macros bugs" and you added the comment "Please report macro issues in the Bugs Forum (kko)" right after the section's title.

Yes, OK. But Big Brother didn't stop watching at Version 7. Why don't you mention what came after that? What about Version 9? ;)


Quote
ra
Let's not forget about these additional two facts:

1.) The problem doesn't happen if the macros plugin is lot loaded.
2.) The problem doesn'T happen if main.kmm is renamed and the plugin is loaded.

I don't forget so quickly. This is an important aspect.


Quote
ra
So, I waited for all windows to finish loading (had a meal inbetween, just in case <g>): Problem was there.

Aha, that's interesting! That's good to know since I didn't expect this. Thank you for waiting!


OK, ra, I think I have enough info to reproduce this. I will check whether this also happens with layers and maybe I can find out more. I will then report to Dorian. Can't promise that this will be fixed in the next alpha (expected soon)...

Thanks for your time and effort!

Re: [1.1a2] Save as directory not remembered
Posted by: ra
Date: February 16, 2007 06:54AM

Quote
kko
Quote
ra
Hear, hear. So let's ask Big Brother who's trying to fool whom:

In Version 5 of the page I (ra) added the whole actual content of the page = the bugs, with more than a dozen of them, including three in a section called "Macros bugs (probably)".

In Version 6 you (kko) added comments on the relevance&validity in your opinion of some of these bugs.

In Version 7 you moved two of the three bugs reported as "Macros bugs (probably)" out of this section, you renamed the section to "Macros bugs" and you added the comment "Please report macro issues in the Bugs Forum (kko)" right after the section's title.

Yes, OK. But Big Brother didn't stop watching at Version 7. Why don't you mention what came after that?

Why should I, I responded to "probably" and fooling.

Quote

What about Version 9? ;)

Mmh, what's the problem? I added the information "Update: Works flawlessly if the macros plugin is disabled." to my initial macros bug and moved it to the corresponding section (macros bugs), to the last macros bug you left there in version 7. Did this after I found out by testing that I don't experience this problem if the macros plugin is not loaded, just like I stated in the update (so, not anymore "probably", but rather sure a macros thing). For me that is or was a macros bug then. Now, if you come up with a new or different definition of a macros bug or if you get angry ("WTF" in your first reply) because I updated the bug-report and it's a wiki, then I'm sorry, but you can't - and therefore shouldn't - blame me for that. It's much more important that bugs get reported, looked into and *fixed* in the end, than who wrote what, where, why, did it match some definition of a word, and so on (IMO, but YMMV). So... Can we forget about that now and concentrate on the bug(s)? smiling smiley


Quote
kko
Quote
ra
Let's not forget about these additional two facts:

1.) The problem doesn't happen if the macros plugin is lot loaded.
2.) The problem doesn'T happen if main.kmm is renamed and the plugin is loaded.

I don't forget so quickly. This is an important aspect.

Yep.

Quote
kko
Quote
ra
So, I waited for all windows to finish loading (had a meal inbetween, just in case <g>): Problem was there.

Aha, that's interesting! That's good to know since I didn't expect this. Thank you for waiting!
Honestly, I didn't expect this, too. I suspected a message queue bug or s.th. like that, but K-M proved me wrong.

BTW: After the first file saved to directory x, the second save as dialog came up with the path from status quo, I changed it again to directory x. The third dialog showed x. Changed it again and it was remembered. Now I thought that it might just be the first two dialogs again, but later on K-M forgot to set the last path again...

Quote

OK, ra, I think I have enough info to reproduce this. I will check whether this also happens with layers and maybe I can find out more. I will then report to Dorian. Can't promise that this will be fixed in the next alpha (expected soon)...

Thanks for your time and effort!

Thank you for looking into it!

P.S.: I just had a look into my prefs.js. Why are there three prefs that look like they could be there for the same thing..?
kmeleon.download.saveDir - path x
kmeleon.download.lastDir - path x
kmeleon.general.saveDir - [empty]

And just in case, Dorian knows it anyway, I have set the following save options:
user_pref("kmeleon.download.disableContentSniffingOnSave", true);
user_pref("kmeleon.general.saveType", 2);
user_pref("kmeleon.general.saveUseFilenameOnly", true);

P.P.S.: Don't expect any new replies from me before Tuesday. smiling smiley

Re: [1.1a2] Save as directory not remembered
Posted by: kko
Date: February 23, 2007 03:34AM

Unfortunately, I couldn't reproduce the problem yet.

I can't spend more time on this at the moment. So, I've updated the information in the wiki for later investigation. Please report here in case you find out more.

In the meantime, you could try it with a newly generated, clean profile since you have some legacy settings in your prefs.js:

kmeleon.download.saveDir - path x
should be what you set in Preferences > Download: Save Folder
kmeleon.download.lastDir - path x
don't know, seems to have always the same value than the previous one
kmeleon.general.saveDir - [empty]
0.9 legacy, ineffective (not in the 1.02 source)

kmeleon.general.saveUseFilenameOnly
probably 0.9 legacy, ineffective (not in the 1.02 source)

K-Meleon forum is powered by Phorum.