09RC1
Posted by: PJ
Date: January 03, 2005 02:45AM

Still shutting down the wrong tab

PJ

Re: 09RC1
Posted by: ndebord
Date: January 03, 2005 11:02AM

Wonder about this blinking thing I'm hearing. I think I've encountered it too. (win98se on dialup)

Gotta say RC1 is faster than 0.9b3, which is what I was running. Also Aggreg8 works better now with some feeds builtin. Still looking for that ultimate RSS extensions, but this is definitely workable now.

Lots of stuff to look at. Will post more when I get around to digging into the innards.

Happy New Year All!

N

RC1 and betas
Posted by: Proxo's Proxy
Date: January 04, 2005 12:33PM

Go to
http://kmeleon.sourceforge.net/forum/read.php?f=1&i=17422&t=17422
When it finishes loading click the "Newer Topic" link.
What do you see at the bottom of the "Newer Topic" page?
I see part of the previous page.
Reload fixes it.
Windows98 first and second edition.
It happens on: the betas2-4, Wechselbalg, Ulf's bleading.
I don't have beta1, so I can't say.
Happens with layers and without.
K-Meleon 0.8.2 seems to be ok.
Sorry if this is old news.
The source looks like:
<html>
<head>
<title>K-Meleon</title>
</head>
<style tpe="text/css">
<snipped>
</style>
<body bgcolor=#ffffff text=#000000 link=#5998a8 alink=#5998a8 vlink=#5998a8>
<snipped>
</body>
</html>

<br>
</td>
</tr>
</table>
<table width="100%" cellspacing="0" cellpadding="0" border="0">
<tr>
<td width="100%"><FONT color='#000000' class="PhorumNav">&nbsp;</font></td>
</tr>
</table>
<a name="reply_17462"></a>
<table class="PhorumListTable" width="100%" cellspacing="0" cellpadding="2" border="0">
<tr>
<td bgcolor="#000080"><FONT class="PhorumTableHeader" color="#FFFFFF">&nbsp;Re: &gt;&gt;K-Meleon 0.8.2+ Wechselbalg is ready!&lt;&lt;</font></td>
</tr>
<tr>
<td bgcolor="#e0e0e0" valign="TOP"><table width="100%" cellspacing="0" cellpadding="5" border="0">
<tr>
<td bgcolor="#e0e0e0" width="100%" valign="top"><font class="PhorumMessage" color="#000000">
Author:&nbsp;Dorian&nbsp;(---.adsl.proxad.net

Re: 09RC1
Posted by: ndebord
Date: January 05, 2005 12:10AM

Running WIN98se and KM 0.9RC1 here and I see the problem too. I get part of the next page when I click on Newer Topic. This is what I get.

==============

<td>

Re: >>K-Meleon 0.8.2+ Wechselbalg is ready!<<
Author: Dorian (---.adsl.proxad.net

===============

N

Re: 09RC1
Posted by: Proxo's Proxy
Date: January 05, 2005 05:50AM

Having random problems with copy, paste, select all, arrow keys and clipboard,
when working inside text boxes. Win98 and Win98SE.

Example:
Go to the bottom of this page or to any page with a text box,
--Yahoo mail "reply"page etc.
Left click inside the text box or select some text.
Right click inside box:
--If "Paste" is not available, clicking on "Select All" may select everything outside
-----the box. Arrow keys may not work. You can't copy the url in the "URL Bar" but
-----you may be able to copy something on the page.
--If "Paste" is available, everything is usually ok.

My work around has been to copy something before
I try to copy inside the text box.
Unfortunately, this doesn't always work because the clipboard sometimes clears itself or will not fill.

I think I have narrowed it down to the layers dll because I have not seen this in
"windows only" mode yet.
I can't give instructions to reliably reproduce the problems but it will eventually
happen if I keep the clipboard empty and browse the K-Meleon forums.
Opening new layers may have something to do with it.
I will use "windows only" for a while and report back.

Never see this with Firefox, but I usually use K-Meleon.
Sorry if this is old news.

Re: 09RC1
Posted by: Andrew
Date: January 06, 2005 10:55AM

Proxo,

Please let us know if this is Layers-specific or not.

Re: 09RC1
Posted by: Proxo's Proxy
Date: January 06, 2005 01:12PM

Andrew,

I think I got it.
It is layers when combined with the "Full Screen" plugin.

To reproduce something:
Enable "Full Screen".
-No "Hide Rebar"
-No "Hide StatusBar"
-Yes "Enable at Startup"
**Yes I can live without the title;-)**
Restart Windows
Browse to the K-Meleon forums
Click "General"
Middle-click ">>K-Meleon 0.8.2+ Wechselbalg is ready!<<" to new tab.
Click in text box at bottom.
"Paste" should not be available, click on "Select All"
For me, everything outside the text box gets selected everytime.

We had an ice storm here so I was home using "windows only" all day.
I had no problems with copy, paste etc.

Will be "iced in" tomorrow too.
I will use layers without the "Full Screen" plugin and see what happens.
My guess is everything will be ok.
Will report back regardless.

Re: Layers-FS, Copy &amp; Paste, Selected Text
Posted by: jsnj
Date: January 06, 2005 02:31PM

Good catch. Might not be fixed by final. But I'm glad someone was able to find a way to reproduce it. This particular problem existed in v0.8.2, 'cause I remember getting it, but I never stayed in FS mode consistently enough to recognize the pattern.

Re: 09RC1
Posted by: Proxo's Proxy
Date: January 07, 2005 10:43AM

Andrew,

Did not get as much time with computer today.
Ice and trees equal chainsaw.:-(
But I am reasonably certain it is the "Full Screen" plugin complicating things.
I can not find any problems with copy, paste, et al without the "Full Screen" plugin.

jsnj,

I usually turn layers off, a toolbar at top, statusbar at bottom, hide the title, add "close window" to the right click menu, etc. So I probably did not see this problem in v0.8.2.

Using things I do not normally use now. I am chasing bugs.
When .9 is released I will probably go back to my old ways.

Proxo's Proxy

Re: 09RC1
Posted by: harveyvan
Date: January 09, 2005 12:01AM

I don't *think* I've got the full screen plug in -- I've certainly never run any browser in full screen mode -- but I see this behaviour all the time with 09RC1.

I'm not having the problem in the text box I'm typing in now, but it shows up when I'm logged in and writing replies in the Firefox "General" forum: I get no response whatever from the arrow keys, and have to edit using either the delete/backspace keys, or by moving the cursor around manually with the mouse.

I have the same problem when I'm logged in and composing replies to forums on this site: http://www.dvd.reviewer.co.uk/forums/default.asp?Forum=211.

Hope it gets cleared up, as I like K-Meleon a *lot* but this is, shall we say, an annoying feature!

Re: 09RC1
Posted by: Andrew
Date: January 09, 2005 02:31AM

Which OS are you running on harveyvan?

Re: 09RC1
Posted by: Proxo's Proxy
Date: January 09, 2005 02:38AM

Right click on this page.
Do you see a line "Full Screen F11" in the menu?
If you do, I think it is on.

To check for sure or turn it on/off:
-Under "Edit" click on "Preferences".
-In "Preferences" click on "Plugins"
-In "Plugins" click on "Fullsceen Plugin" and click "Enable/Disable"
-Click OK
-Close and restart K-Meleon.

Post your results.

HTH

Re: 09RC1
Posted by: harveyvan
Date: January 09, 2005 05:22AM

Answering Andrew, first:

OS is Win 98SE. I'll try Proxo's Proxy solution, and post the result. (FWIW -- and without trying that disabling -- I've lost the functionality of the arrow keys in this box at the moment....so I hope that solution works.)

Re: 09RC1
Posted by: harveyvan
Date: January 09, 2005 05:41AM

I checked, and the Full Screen plug-in was indeed enabled, so I disabled it and restarted the browser. Now when I right-click, the context menus doesn't show "Full Screen F11".

It's not entirely solved the problem, but it's part way there -- and I *think* it's possibly some sort of conflict within my system (Win98SE), rather than with K-Meleon.

When I first click into and enter type in the text boxes -- this one included, now -- the arrows are disabled. If I *right-click* on the taskbar, however, and then re-focus into the text box, the arrows are re-enabled.

(Maybe a mouse driver thing? I've just checked, though, and the same behaviour doesn't appear to occur when using Firefox.)

Re: 09RC1
Posted by: Proxo's Proxy
Date: January 09, 2005 06:29AM

Reboot the computer.

HTH

Re: 09RC1
Posted by: harveyvan
Date: January 09, 2005 06:02PM

Machine rebooted -- turned off overnight, actually -- and the behaviour's still there.

It's odd: when I first go into the text boxes, I have no arrow functionality. It remains "off" if I click outside the box while keeping focus on K-Meleon, but if I take the focus away from the browser (say by clicking on the taskbar), and then re-click within the box, the arrows suddenly start working again.

I can live with it now that I've discovered it disappears if I "unfocus/refocus" the K-Meleon window. but I've not encountered the behaviour Firefox.

A mystery; many thanks for making me test it and finding a work-round, though!

Re: 09RC1
Posted by: Proxo's Proxy
Date: January 09, 2005 11:43PM

Your 'work-around' appears to solve most of my problems with Fullscreen on... But at Yahoo mail, I tried copying some text from notepad to 'wake' things up, no joy. Surely that would have involved a change of focus.

So it looks like I can lose the title bar, if I click on the taskbar before I use text boxes.:-) Thanks.

All that is left for me is the clipboard. It did not always work when the Fullsceen plugin was on.

Neither solution solves the extra html problem that I posted above,
01-04-05 00:33. If that is a real problem. It also exists in MFCEmbed.

Re: 09RC1
Posted by: Proxo's Proxy
Date: January 10, 2005 08:34AM

<Quote>All that is left for me is the clipboard. It did not always work when the Fullsceen plugin was on.
</Quote>

Been using Fullscreen all day.
All my copy/paste problems today have been solved by simply left clicking the taskbar.

<Quote>
Unfortunately, this doesn't always work because the clipboard sometimes clears itself or will not fill.
</Quote>

Unless somebody else can report same, I think I was mistaken.
Perhaps something I did replaced the clipboards contents with nothing or
I simply lost track of my actions.

Will keep watch.

K-Meleon forum is powered by Phorum.