[.9beta4] disappearing / stability
Posted by: ra
Date: December 17, 2004 07:23AM

How's your experience in regards of the stability of the current beta?

I never had so many problems with K-M in any beta 3 upwards build, except the Dec. 7 one (beta4 seems to be based on it, grumbl).

K-M just simply disappeared for the fifth time today. It shut itself down, completely, no error message, no remaining task in taskmanager, nothing.

I had closed a few windows and wanted to continue surfing on the K-M forums (two windows open). K-M didn't react anymore and then, after two seconds, it was gone. (Clean install of beta 4, Win XP SP2, layers disabled.) Ouch!

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 17, 2004 07:41AM

Sixth time.

This time was a bit different, because *all* toolbars were *enabled* on the next start and every toolbar got a complete "line" for its own (even the single mail button), so only half of the screen was left for the actual browsing window content. Oh my...

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 17, 2004 08:09AM

7th, 8th, 9th and 10th time plus two real crashes (in com<something>.dll).

If all code changes were be in CVS I could do a diff and track the problem down...

Re: [.9beta4] disappearing / stability
Posted by: TransitMan
Date: December 17, 2004 10:39AM

WinXP SP1, beta4, layers disabled.
Have not been able to reproduce your crashes.

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 17, 2004 07:36PM

Are you only using few windows? Try surfing with around 30 windows open at the same time, switching fast between them and then close most of them (try to be fast), start scrolling in a remaining window, switch immediately to another one. K-M doesn't crash/disappear if I have only few windows open or if I'm really slow in using K-M.

I'm sorry I don't have detailed steps to crash K-M but beta 4 is definately unstable here, I've never had so many crashes (counting disappearing to them) in so little time with K-M. :-/ BTW: The DLL was comctl32.dll.

It can't be the Mozilla backend because that remained unchanged as far as I know.

If I use beta 3 or beta 3 with Dec. 1/2 test everything is alright, no crashes or any other problems. The instability started with the Dec. 7 build, although that one behaved a little bit different compared to beta 4.

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 17, 2004 09:52PM

K-M just crashed once again. I only hit [Ctrl]&[N] to open a new window. Nothing happened and after 2 seconds bang, error in k-meleon.exe.

Got "can't create browser frame" another time as well (only two windows were open) when I double-clicked the shortcut to open another window (never had problems with that in the past).

Re: [.9beta4] disappearing / stability
Posted by: Al.
Date: December 18, 2004 03:21AM

I'm sorry I don't have detailed steps to crash K-M but beta 4 is definately unstable here, I've never had so many crashes (counting disappearing to them) in so little time with K-M. :-/ BTW: The DLL was comctl32.dll.

That sounds like one of the "random" crash bugs which has been around since v0.8.x (and maybe even before then), mainly because comctl32.dll was mentioned a while back by a couple of others. As the crashes are random, then it's not easy to reproduce the steps and thusly file a bug report with those steps included.

btw as an aside to this, have you tried disabling the layers plugin and just go with the regular windows for a while to see if the problems keep occurring.

Re: [.9beta4] disappearing / stability
Posted by: Eyes-Only
Date: December 18, 2004 07:24AM

I know this is going to sound totally dumb and off-the-wall ra (and thus probably get deleted like some of my other posts) but have you just tried uninstalling that one and downloading a fresh one and installing that instead?

What I mean is this: When I used to be an avid Firefox/T-Bird tester there were times I'd install something, "take it out on the highway", and have all sorts of problems that I really couldn't attribute to any one cause. I'd do a complete uninstall, re-download the same build, re-install---and presto!---it'd work fine.

We'd be surprised sometimes how often a few databytes get jumbled in a transfer even though when we run a test on the file after download it reads fine! So it probably couldn't hurt trying. I would.

Amicalement,

Eyes-Only
"L'Peau-Rouge"

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 18, 2004 11:21PM

Al.,

I'm sorry I don't have detailed steps to crash K-M but beta 4 is definately unstable here, I've never had so many crashes (counting disappearing to them) in so little time with K-M. :-/ BTW: The DLL was comctl32.dll.

That sounds like one of the "random" crash bugs which has been around since v0.8.x (and maybe even before then),

Well, please note that I never had any stability problems or random crashes with K-M before beta 4 and the build from Dec. 7.

mainly because comctl32.dll was mentioned a while back by a couple of others.

The disappearing part, which is the main problem, doesn't mention any DLL of course. I doubt it has to do with comctl32.dll. BTW: I had crashes in k-meleon.exe, too.

I stopped counting the disappearing part at 40 times. That's *way* too much for only a few days of usage (and I did a completely clean install!). Not even 0.8.0 was so bad, although it crashed quite often (hence the 0.8.1 and 0.8.2 releases that fixed these problems).

As the crashes are random, then it's not easy to reproduce the steps and thusly file a bug report with those steps included.

Exactly, that's why I'm reporting them here in hope that s.o. might shed some additional light into it.

The interesting part is the fact that I don't have any crashes if I use the files from Dec. 1/2 anymore. Again: If the changes were in CVS I could track the problem down (it's no problem for me to build K-M, otherwise I wouldn't have nailed down bug 715). But alas they aren't.

btw as an aside to this, have you tried disabling the layers plugin and just go with the regular windows for a while to see if the problems keep occurring.

If you read my first post above you'll notice that I'm not using layers. In fact I never use them (I switch them only on to help others reproduce their problems).


Eyes-Only,

I know this is going to sound totally dumb and off-the-wall ra (and thus probably get deleted like some of my other posts) but have you just tried uninstalling that one and downloading a fresh one and installing that instead?

No, I never had to. But I'll give it a try, just in case, although I'm quite sure that is a change in K-M that's causing the problems (think of the Dec. 1/2 vs. Dec. 7 problems I reported).

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 21, 2004 06:20AM

FYI: Yesterday I disabled the favorites and bookmarks toolbars under preferences - plugins. I should probably knock on wood but K-M stopped disappearing. It didn't happen a single time since then.

Might the bookmarks toolbar still have problems with large bookmarks files (mine has between 500 and 600 KB)?

Re: [.9beta4] disappearing / stability
Posted by: jsnj
Date: December 21, 2004 06:51AM

This seems like an obvious question...but how about with just favorites plugin & no bookmarks plugin?

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 22, 2004 05:41AM

This seems like an obvious question...

Yeah, and these toolbars are now enabled by default (IIRC they have never been before)...

but how about with just favorites plugin & no bookmarks plugin?

I guess it's pretty much the same code in both (all three? - never used the hotlist plugin) plugins (copy'n paste rocks ;-) ) and I have only few favorites. So although I could test that, it wouldn't make a lot of sense to do so.

BTW: K-M still hasn't disappeared! :-)

If it's really the bookmarks (favorites) toolbar: All bookmarks that can be seen in the selected folder are added to the toolbar I think (I'm not 100 percent sure, so take that only as a guess). It would certainly be better to only add the amount of bookmarks that can be seen in a maximized (or full screen) window. Using the mouse the others can't be reached anyway. (If there are 1000 bookmarks in a folder all 1000 will currently be added to the toolbar in every window although only (e.g.) the first 25 can be seen...)

Re: [.9beta4] disappearing / stability
Posted by: jsnj
Date: December 22, 2004 06:51AM

these toolbars are now enabled by default (IIRC they have never been before)...

If the plugin is chosen during the install process then its toolbar is enabled but not visible. So all the user has to do is go to View-Toolbars to see it. We had a couple posts recently..."Where can I get my toolbar folder". Seems Tools-Bookmark Options-Settings was a bit too abstract for some. Also, they are enabled & visible by default in all the other browsers.


BTW: K-M still hasn't disappeared!

Beta 4 disappeared(closed at random) for me today for the 1st time. I had 30+ layers open. Disappeared when I commenced downloading a file. However when I restarted and loaded those 30+ layers and downloaded the same file, all was well, so I haven't been able to reproduce it agin yet.

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 22, 2004 11:28PM

these toolbars are now enabled by default (IIRC they have never been before)...

If the plugin is chosen during the install process then its toolbar is enabled but not visible. So all the user has to do is go to View-Toolbars to see it. We had a couple posts recently..."Where can I get my toolbar folder". Seems Tools-Bookmark Options-Settings was a bit too abstract for some. Also, they are enabled & visible by default in all the other browsers.


Yeah, no problem, I can understand that. But if it leads to such problems like I had (for all users with a lot of bookmarks / favorites), it might be better to leave them disabled instead of enabling the risk for a disappearing or crashing browser for all users by a feature that won't be used by all users..

Suggestion: How about using a *macro* under view - toolbars that first enables the desired toolbar and then shows it (if that requires a restart please add a OK-dialog that informs the user)?


Beta 4 disappeared(closed at random) for me today for the 1st time. I had 30+ layers open. Disappeared when I commenced downloading a file. However when I restarted and loaded those 30+ layers and downloaded the same file, all was well, so I haven't been able to reproduce it agin yet.

I had similar experiences, but K-M did that for over 40 times in three days... Now, after disabling the toolbars I'm still waiting for another one. ;-)

Re: [.9beta4] disappearing / stability
Posted by: Andrew
Date: December 28, 2004 10:23AM

Ra,

Can you run it for a while with the Favorites enabled so we can narrow that down to the Bookmarks?

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 28, 2004 10:57PM

Can you run it for a while with the Favorites enabled so we can narrow that down to the Bookmarks?

Quote from myself ;)
I guess it's pretty much the same code in both (all three? - never used the hotlist plugin) plugins (copy'n paste rocks ;-) ) and I have only few favorites. So although I could test that, it wouldn't make a lot of sense to do so.

If the problem has to do with the number of bookmarks in the toolbar folder or in general: While my bookmarks file holds a gazillion bookmarks I have only around two dozen favorites...

But I'm gonna try it with (only) the favorites toolbar enabled (but not shown, like it was before when K-M disappeared).

Oh, yeah, it could also be a parsing problem...

BTW: What do you guys think of my macro idea? That would not fix the bug but it would surely prevent any related crashes for all people that don't use these toolbar(s).

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 28, 2004 11:03PM

BTW: Why is max toolbar button size set to "-100"?

Re: [.9beta4] disappearing / stability
Posted by: jsnj
Date: December 29, 2004 12:27AM

If the problem has to do with the number of bookmarks in the toolbar folder or in general: While my bookmarks file holds a gazillion bookmarks I have only around two dozen favorites...

If you still have IE on your system you can go to File-Import and Export and add your bookmarks to favorites. Then 'Change Toolbar Folder' in KM to point to the correct folder if it's not 'Links'. That should make for a proper comparison. I haven't been able to reproduce the disappearance since the one I've reported even though I've been opening all my groups as one big startup group to test KM more strenuously.


BTW: What do you guys think of my macro idea? That would not fix the bug but it would surely prevent any related crashes for all people that don't use these toolbar(s).

I would just return to having the toolbars disabled at default if they are proven to be the cause of the instability. Tools-Bookmark Options or Edit-Preferences-Plugins are still available for users. Having another additional macro within View-Toolbars would result with 2 listings for the bookmarks toolbar when enabled which would be needless. I believe Carson enables his toolbar folder without the instability problems but I'm not sure how many bookmarks he has.


BTW: Why is max toolbar button size set to "-100"?

Don't know. It's not referenced in default prefs.

Re: [.9beta4] disappearing / stability
Posted by: ra
Date: December 29, 2004 02:50AM

If you still have IE on your system you can go to File-Import and Export and add your bookmarks to favorites. Then 'Change Toolbar Folder' in KM to point to the correct folder if it's not 'Links'. That should make for a proper comparison. I haven't been able to reproduce the disappearance since the one I've reported even though I've been opening all my groups as one big startup group to test KM more strenuously.

Ha, that was an easy one. ;->

- Imported my bookmarks using the IE import/export wizard (leading to around 230 favorites in the root folder including folders with "some" additional bookmarks/favorites).
- Set the favorites toolbar folder to the root ("\") folder, closed K-M, opened it again and wanted to open my daily bookmarks group with nearly 30 bookmarks. After four or five new windows K-M disappeared.

I can now only open 4 (yes, that's f-o-u-r) windows until K-M stops responding and closes itself when I switch from the active K-M window to another one (layers are disabled as always). It doesn't matter how or how fast the windows are opened. 100 percent repro. Favorites toolbar is enabled but not visible. XP SP2 beta 4.

I had the same problem with the bookmarks toolbar (see the test mentioned by Ulf here where I, too, could only open *4* windows until K-M closed itself. That problem was fixed. We now have a static toolbar folder, but it won't leak anymore.

It's likely that the favorites plugin has the same problem and so it's also likely that the same change in the code will fix it.

BTW: Please see also the message here.

Re: [.9beta4] disappearing / stability
Posted by: jsnj
Date: December 29, 2004 07:42AM

OK. I was able to produce the bug consistently when making the Favorites directory folder the designated toolbar folder. Takes 20 or so layers to produce it for me. I'm guessing I have less overall favorites than Ra. Most people probably haven't encountered this bug because they have Links as the toolbar folder for the Favorites plugin or Personal toolbar folder from Mozilla/FF/Netscape.

K-Meleon forum is powered by Phorum.