Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here. But please, for confirmed bugs, use the bug tracker to report and give feedback on bugs.  
Missing
Posted by: Jones
Date: September 28, 2001 10:43AM

"File" "Edit" & "View" plus all other menu items are missing from the toolbar.

Options: ReplyQuote
Re: Missing
Posted by: Brian
Date: September 28, 2001 10:55AM

did you have previous version of kmeleon? did you delete it before you installed .5?

what OS are you running? is it NT4?

Options: ReplyQuote
Re: Missing
Posted by: Erick
Date: September 28, 2001 04:15PM

I have exactly the same problem, using Win95, even with a first-time installation of K-meleon

Erick

Options: ReplyQuote
Re: Missing
Posted by: Brian
Date: September 29, 2001 12:40AM

what version of IE do you have? microsoft is really great (sarcasm) so to get some updated dlls, sometimes you have to install a new version of IE. I have 5.5 on my computer even though I never use it. I just installed it so I could get the dlls that come with it. to my knowlege there's no other way to get these dlls. (monopoly? what monopoly? microsoft doesn't use their dominance in the os market to push their browser at all!)

Options: ReplyQuote
Re: Missing
Posted by: Andrew
Date: September 29, 2001 02:04AM

Brian,

Can you tell us exactly what is the cause and the files that are missing?

Andrew

Options: ReplyQuote
Re: Missing
Posted by: mE123
Date: September 29, 2001 11:18PM

I had this problem with .4 but the workaround worked for me (rename/del rebarmenu.dll)

I tried this in .5 but it didn't work. I eventual got my menus by:
setting up a keyboard shortcut to the preferences menu (open up "accel.cfg" and add in a the line "CTRL W = ID_PREFERENCES", this makes Control-W a shortcut to the preferences)
then turning off the rebarmenu.dll plugin
re-start K-meleon and it should work (or at least it worked for me)

Options: ReplyQuote
Re: Missing
Posted by: Juha Paulavuo
Date: September 30, 2001 01:48AM

Thanx. Worked perfect for me too.

Options: ReplyQuote
Yep
Posted by: Sunit
Date: October 01, 2001 06:25AM

Yep, same problem, and this procedure worked for me as well.

Details: Windows 95B, Internet Explorer 3.02

Also, it may be interesting to note that I have ms's Visual Studio installed... I know that VS does wierd things to system dll's and the tlb's in the registry. Maybe that has something to do with it?

Hope that helps!

Options: ReplyQuote
Re: Yep
Posted by: Fulvio
Date: October 01, 2001 10:46AM

In Netscape6.1,I had a similar problem,and it was corrected by deleting Chrome in the Profile folder.This is in Windows/Application Data/Mozilla etc.I looked at K-meleon,and the similar folder had similar content,i.e. user-locales.rdf file.Why would this help beats me.Take it under advisement,the folder is rebuilt in Mozilla,and do not touch the Chrome folder in Program Files/K-meleon.You can always fish it out of the trash,if it does not help or harms things.This time,I do not think that it is Microsoft's fault.

Options: ReplyQuote
Re: Yep
Posted by: Brian
Date: October 02, 2001 02:29AM

This has nothing to do with the Chrome folder. The rebar menu uses new features that microsoft added to their common control library, but the only way to get the new common control library is to download the new version of IE. The reason you can see the menus by disabling rebarmenu is because kmeleon then uses normal, non-rebar menus, which don't need the new common control library.

Options: ReplyQuote
Re: Yep
Posted by: Jones
Date: October 02, 2001 10:17AM

No previous version of K-Meleon. Running MS Win 95 (4.00.950 B) and IE 4.0 (4.72.3612.1713).

Disabling the Rebar Menu plugin shows menus.

Sweet project. The options available in Preferences allow the user choose.

Options: ReplyQuote
Re: Yep
Posted by: Andrew
Date: October 03, 2001 08:57AM

For people having this problem, try downloading and installing this Common Control Library update from MS:

http://www.microsoft.com/msdownload/ieplatform/ie/comctrlx86.asp

Download the version for IE 5. Hopefully, that should fix your menu problems. Please let us know if that works.

Andrew

Options: ReplyQuote
Re: Yep
Posted by: Rolf Karlsson
Date: October 21, 2001 04:25AM

It worked (with "50comupd.exe")
(OS: NT4 SP6a no Ie4 or later)
(note: worked wo this patch on my Win98 lite (=no IE)

//Rolf

Options: ReplyQuote


K-Meleon forum is powered by Phorum.