Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here. But please, for confirmed bugs, use the bug tracker to report and give feedback on bugs.  
Rolloever images disappearing
Posted by: Alan Folsom
Date: July 05, 2001 04:18AM

I have a site with rollover buttons, where k-meleon seesm to destroy the button images, replacing them with the alt text. This does not seem to happen with the Netscape 6.1 prerelease, so I assume it's not a problem with mozilla. Any clues?

The sample site is http://www.folsoms.net/abington-qm/ with the button images being in the frame on the left.

Thanks,

Al Folsom

Options: ReplyQuote
Re: Rolloever images disappearing
Posted by: Brian
Date: July 05, 2001 05:27AM

they're not actually disappearing, what you're seeing is it's trying to flip to an image that's not loaded yet, so what it does is display the alt text while the image is loading. on a fast connection, you can't really tell, but on a modem, it's quite apparent. one way to fix this would be to use javascript to preload the images. you could do something like this:

<script>
var image1_on = new Image();
image1_on.src = 'images/int_on.gif';
var image1_off = new Image();
image1_off.src = 'images/int_on.gif';
</script>
<a href="intro.shtml" onmouseover="i1.src=image1_on.src" onmouseout="i1.src=image1_off.src" target="main">
<img src="images/int_off.gif" border="0" name="i1" alt="Intro">
</a>

Options: ReplyQuote
Re: Rolloever images disappearing
Posted by: Brian
Date: July 05, 2001 05:28AM

hmm, looks like the board ate the rest of the html, you can do a view source to see it.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.