Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
Trouble with deviantart (maybe (wyciwyg) )
Posted by: zzumn
Date: January 10, 2014 08:49AM

Hi everybody, I'm new with the K-Meleon explorer, and I have found a major problem while trying to use Deviantart. When I enter on the page, everything goes normal, but, if I want to see a Profile, all the info and "buttons" will rearrange vertically. Also, if I'm looking at a picture, and I go down to read the comments, the whole page will go all white, and nothing will be shown. Going to the last page will only show the page before that one, instead the one with the picture and the comments. I don't know if this has been posted before, I tried to search both manually and with the search bar, and nothing show up. Hope there is any help, I have been configuring it, and, while I haven't added extensions before this happened, I configures some of the other options D:
(btw, I think I have a problem with javascript preview and other kind of secondary windows, but I'll check that later)
Edit: I have done some test, and while sometimes the problems below won't show, other times the whole site will be rearranged. This does not only happens with the links for the artist and the picture, but for the whole site and many of it's own links.



Edited 2 time(s). Last edit at 01/20/2014 11:37AM by zzumn.

Options: ReplyQuote
Re: Trouble with deviantart
Posted by: guenter
Date: January 10, 2014 03:50PM

That page at deviantart.com/ does not support the Gecko rendering of 1.5.4 any more. There some 1.5.4 css fixes for some often used pages here at http://kmeleon.sourceforge.net/forum/read.php?1,115782,119008#msg-119008
but not for deviantart.com/.

Please use K-Meleon 1.6 beta or newer. I re-checked. I can access my own profile at deviantart.com/ with 1.6 - though they nag me that my browser is old and that I should individualize my profile so that they can paint a better picture.grinning smiley

I use this UserAgent string there: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.26) Gecko/20120128 Firefox/3.6.26 GTB7.1 This procedure makes sure that deviantart.com/ offers me a Firefox not an IE or Chrome version of the page.



Edited 1 time(s). Last edit at 01/10/2014 04:26PM by guenter.

Options: ReplyQuote
Re: Trouble with deviantart
Posted by: zzumn
Date: January 12, 2014 12:50AM

1.6 works better with deviantart, however, the page still goes all white when I go to the comments section, either on pictures or profiles....

Even the Tab will show the text, and, when the page goes white, the title (on tab) will disappear as well.

Options: ReplyQuote
Re: Trouble with deviantart
Posted by: siria
Date: January 12, 2014 01:14AM

Funny thing! And once it's white, I can't even seem to reload the page, it only does when opening it in a new tab again? Or is it only me?
(am using 1.6beta2.5)

Actually I wouldn't have noticed, since by default I keep javascript blocked, and then the page seems to work fine, no probs cool smiley
Do you have the privacy toolbar switched on? There's a very handy quick switch button for JS.

Options: ReplyQuote
Re: Trouble with deviantart
Posted by: zzumn
Date: January 15, 2014 11:57PM

I have tried deactivating javascript but the problem persist.
Also, I tried changing the User Agent so the page identifies K-Meleon as Opera Next, but it only worket to avoid the "update your browser" thing...

And gave another problem, when loading a picture, it will display it, then show the text "An error occurred while displaying this deviation

Please visit the deviation page to try again." . The words "deviation text" refreshes the page and I can see it... until it goes all white....

And yes, it can not refresh on the same tab, I gotta open it again from the last page...

Options: ReplyQuote
Re: Trouble with deviantart
Posted by: siria
Date: January 18, 2014 02:02AM

Which version do you use?
I tested with 1.6 and 1.5.4 and as long as javascript is blocked that blank-bug doesn't happen. Only with JS on.
Please try again and make sure in the privacy menu or by toolbar button that JS is blocked.
And you could try with the brandnew KM74beta, if your machine isn't stone age like mine ;-)

Options: ReplyQuote
Re: Trouble with deviantart
Posted by: BroderTuck
Date: January 19, 2014 08:23PM

Ah the dreaded 'refresh to a white screen' problem of K-meleon, seen mostly on deviantart, but also a few other sites as well.

In k-meleon 1.1, which I used for quite a long while, this white screen was accompanied with the url bar changing to wyciwyg:<old-url>

Options: ReplyQuote
Re: Trouble with deviantart (wyciwyg)
Posted by: siria
Date: January 19, 2014 10:18PM

Ah, good tip!
I was vaguely suspecting perhaps some "javascript:" code were invisibly added at the beginning, but now that you mention it, finally researched a bit more (in my current main version KM16b2.5). When right-clicking on the "Go" button, discovered there a menu entry for "Reset URL bar". And that actually reveals it! When scrolling further down, a random test page turned into
wyciwyg://85/http://laticis.deviantart.com/art/....

Now that sure is something that can be worked-around by a macro, at least when reloading again. But of course that's a bug that should really be fixed. Does it still happen in the latest KM1.8/74??

Or another workaround: Instead of clicking the Reload-Button, click the Go-Button. Then the visible URL is opened again.
Little catch: Have my profile set to open typed URLs in a new tab, so a second tab is still opened. (Check setting in F2 / Browsing / Typed URLs)
Or if a site is know as problematic, and works well enough despite blocked JS, add the site to the blocked JS domains?

Oh, seems to be (has been?) a long time mozilla bug, FF had it too:
http://support.mozilla.org/de/questions/941738
Quote

The problem is caused by document.write not working in FF as the other browsers: in FF it should be used only at load time, not later.
So the problem has 2 solutions: - if you have no control over the javascript remove extra characters in the address bar - if this is your javascript, try to replace your document.write by creating a div with an id and use document.getElementById('the_id') += 'the_text'
...
or add document.close() after the doment.write() call.

Can't help thinking now about macro workarounds... e.g. create a little onLoad-macro, that checks the site URL for wyciwyg, and if necessary cuts it and reloads again? Hmm, could work... But of course nothing of the sort can fix the page suddenly going blank while scrolling down, that's real developer stuff. At most a new workaround-macro could automatically block JS for the time of reloading, so that clueless users at least have a chance to see what they miss ;-) Then at the next reload JS would be ON again... talk about confusing users, LOL!
Then again - what if someone is just really using the cache?? Would the macro also have to check the offline+cache settings? Oh well, gets more and more complicated

PS: perhaps add "(wyciwyg)" to thread title?



Edited 7 time(s). Last edit at 01/19/2014 11:38PM by siria.

Options: ReplyQuote
Re: Trouble with deviantart (wyciwyg)
Posted by: siria
Date: January 20, 2014 05:24AM

Am confused now (again).
Seems to happen on deviantart only when scrolling with the mouse wheel, but not when using the scrollbar?!

And a workaround-macro isn't quite as trivial as first thought, KM does funny things, goes on endless reloading frenzy ;-)

Options: ReplyQuote
Re: Trouble with deviantart (wyciwyg)
Posted by: zzumn
Date: January 20, 2014 11:36AM

Blocking javascript does some other things. The "Preview" feature doesn't seems to work while writing comments, but blocking/unblocking might help (I did some test, but sometimes it can show preview, sometimes it doesn't, seems like using F7 and blocking from the "Tool/Privacy" makes it go weird too...

D: !

Options: ReplyQuote


K-Meleon forum is powered by Phorum.