address bar auto completion doesn't work
Posted by: Kirill
Date: June 19, 2012 03:48AM

Address bar auto completion doesn't work in any of the 3 latest releases (including 1.7 beta), and re installing doesn't help either... I tried to disable and enable back this option in preferences but doesn't help either...

Re: address bar auto completion doesn't work
Posted by: JamesD
Date: June 19, 2012 05:53AM

Do you have history enabled?

Re: address bar auto completion doesn't work
Posted by: Kirill
Date: June 19, 2012 06:18AM

I do...

Re: address bar auto completion doesn't work
Posted by: JamesD
Date: June 19, 2012 06:36PM

I am using the beta 2.4 version of KM which you can find here: https://dl.dropbox.com/u/1522294/K-Meleon1.6.0_Beta2dot4_en-US.7z

In preferences under finding websites, url bar, url bar autocompletion, I have both items checked. I just tested and when I typed a w into the url bar, my list changed to show all the items with w as the first letter. When I added an e the list changed again to show only items with we as the first two letters. When I added an a the list changed to show only the one item that had wea as the first three letters.

Re: address bar auto completion doesn't work
Posted by: Kirill
Date: June 19, 2012 09:16PM

That's the thing, it always worked, but now it doesn't. I have those two options on... I'm thinking maybe uninstall with some advanced uninstaller and then reinstall...

Re: address bar auto completion doesn't work
Posted by: JamesD
Date: June 19, 2012 10:49PM

One final thing to check. Do you have write authority to your profile? Is your history getting written? Did you try my beta 2.4? If you have that one loaded, look under HELP - TROUBLESHOOTING - CHECK PRIVILEGE.

Re: address bar auto completion doesn't work
Posted by: Kirill
Date: July 24, 2012 01:23AM

I figured it out. In order, I had to delete the program, wiping couple of leftover dlls in the folder. If I'd leave those 3 dlls, the problem sticks for the next install. So I solved it first by deleting 1.6 beta and going back to a stable, but a stable is too outdated (interestingly why) so I had to go to 1.6 beta doing the same thing (reinstalling and deleting the dlls).

Now there's a new bug... I have my home page set to the hotmail (live.com), and whenever I open up a message, it gets a seizure and jumps to the 'write new' window back and forth. The same problem also started to occur in 1.7 beta...

Any help would be appretiated.

KM is my favorite by far browser because it's the lightest and the most efficient (I really don't like the heaviness and visual gliding effects of all popular browsers which you can't turn off)... so I go with KM...

Re: address bar auto completion doesn't work
Posted by: rodocop
Date: July 24, 2012 07:12PM

Try to set modern UserAgent string, for example:
Mozilla/5.0 (Windows NT 6.0; rv:1.9.2.29) Gecko/20120126 Firefox/3.6.29
(set Windows version corresponding to yours own)

In any case, there is something wrong with your system, not KM, if you have permanent problems.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!



Edited 1 time(s). Last edit at 07/24/2012 07:14PM by rodocop.

Re: address bar auto completion doesn't work
Posted by: JamesD
Date: July 24, 2012 07:21PM

Quote
Kirill
I figured it out. In order, I had to delete the program, wiping couple of leftover dlls in the folder. If I'd leave those 3 dlls, the problem sticks for the next install. So I solved it first by deleting 1.6 beta and going back to a stable, but a stable is too outdated (interestingly why) so I had to go to 1.6 beta doing the same thing (reinstalling and deleting the dlls).

Which dlls are you changing? If they are in the components folder, it may be necessary to delete the files "compreg.dat" and "xpti.dat". They get rebuilt upon next run of KM.

Re: address bar auto completion doesn't work
Posted by: Kirill
Date: July 25, 2012 09:06PM

I can't recall now because I already reinstalled but the 3 that remain in a folder after you uninstall, they were causing the problem...

Re: address bar auto completion doesn't work
Posted by: rodocop
Date: July 25, 2012 11:33PM

I think they were msvcp71.dll msvcr71.dll etc.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74.0 for test and feedback! Get it there!


Re: address bar auto completion doesn't work
Posted by: JamesD
Date: July 26, 2012 02:55AM

I think the files used in 1.6 beta and 1.7 beta are msvcp80.dll and msvca80.dll.

K-Meleon forum is powered by Phorum.