Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here. But please, for confirmed bugs, use the bug tracker to report and give feedback on bugs.  
K-Meleon being unresponsive...
Posted by: Mr. Cooper
Date: November 04, 2011 11:21AM

Background:
I'm running KM 1.6.0 beta 2 on Windows 7 x64. Due to the wonderful world of wireless internet, I didn't have internet access all summer. I uninstalled KM. Once I got my internet back, I reinstalled KM (I keep my installers) and did a bunch of Windows updates.

Issue:
Now I'm noticing that KM is kind of unresponsive, and it wasn't that way before as far as I know. Often, when I click on a menu (like Bookmarks or the right-click menu) and click on an item, KM just doesn't register the click. It waits as if I did nothing. I know it's not the mouse - this only happens in KM. If I open a menu and wait a moment or two then click, it'll work fine.

I have no idea when this behavior started as I've only gradually become aware of it. (The first number of times just get forgotten and written of as slightly odd.) Has anyone else experienced this behavior? A search of the forum hasn't turned up anything about it.

Options: ReplyQuote
Re: K-Meleon being unresponsive...
Posted by: JamesD
Date: November 04, 2011 06:41PM

I have had same problem on both XP and Win 7 32 bit. I found that a very fast click with mouse sometimes did not get things moving right away. I began to do my clicks a little slower and that fixed it most of the time. Instead of a (tap) click I would do a (push - release) click. Not a much longer click because that gets into some other actions.

Options: ReplyQuote
Re: K-Meleon being unresponsive...
Posted by: Mr. Cooper
Date: November 04, 2011 11:37PM

Forgot to say before - this isn't confined to the mouse. It affects the keyboard too. If I quickly type Ctrl+G (to do a Google search), type in a string, and hit Enter before much time has passed, Windows plays its Default Beep noise and doesn't search. The search box would still be open, so I just wait a second and then press Enter. It's very annoying...

Options: ReplyQuote
Re: K-Meleon being unresponsive...
Posted by: Raf Lopez
Date: May 27, 2012 06:10PM

I have the same issue. I'm running K-Meleon 1.6.0 b2 under Win7, but had had the same bit of experience with beta1, too. I use the address bar a lot to enter search engine query strings, but I've found that Ctrl-G only registers after repeatedly doing the maneuver 3-n times. It doesn't happen only with Ctrl-G apparently. Same goes for other keys like Ctrl-T, Ctrl-W, et al. I thought it may have had been a macro engine, but apparently others are getting it too.

I switched to kmeleon as my primary workhorse browser because of its small memory footprint and stability + addt'l gui niceties (as per beta2), and I'd love to see this keyboard bug resolved smiling smiley

Options: ReplyQuote
Re: K-Meleon being unresponsive...
Posted by: rodocop
Date: May 27, 2012 07:48PM

First:
some unresponsibility of GUI (user interface) is the native feature of Gecko engine.
However, it can be minimized by tweaking KM preferences
  1. Close KM
  2. Find your profile folder and open prefs.js from there
  3. find the next strings and set their values as shown below:
      
    • user_pref("content.interrupt.parsing", true);
    • user_pref("content.max.tokenizing.time", 450000);
    • user_pref("content.maxtextrun", 2048);
    • user_pref("content.notify.backoffcount", 10);
    • user_pref("content.notify.interval", 150000);
    • user_pref("content.notify.ontimer", true);
    • user_pref("content.switch.threshold", 300000);
  4. if they are not present there - just copy the peace of code above somewhere in prefs file
  5. save and close prefs.js - and run KM

You'll see notable shortening of time when KM's GUI is not responding on mouse input.

You can edit numbers to find optimal values, but it's recommended to read about these settings in Mozillazine Knowledge Base to understand what you do.
content.max.tokenizing.time is recommended to be the multiple of content.notify.interval

content.notify.backoffcount may be changed in wide range from 5 to 30 and more, but remember: decreasing this value fastens GUI response speed but increases the time of page rendering - choose your optimal balance by trial and error method.

NB! You can take CommMeleon from my signature - it's already optimized this way. And more optimizations are made there.

Second:
you don't need to Ctrl+G for fast Google search.

Just go to
Preferences -> Browsing -> Finding Websites

Toggle off Domain Autocompletion
Toggle on Keyword Autosearch and choose Google as 'Search Engine'

Now you can open new tab and write something in urlbar - then press Enter. Wuala!

Third:
the lack of keyboard reaction isn't defeated by me till now. So I only can join you in finding out why KM frequently needs 2 or more pressing of hotkeys to have them working.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!



Edited 2 time(s). Last edit at 05/27/2012 07:53PM by rodocop.

Options: ReplyQuote
Re: K-Meleon being unresponsive...
Posted by: JamesD
Date: May 27, 2012 10:12PM

@ rodocop

Many thanks for the research. I have added the user prefs and will observe to see any change in my KM 1.6.0 beta 2.4 on win 7 (32 bit).

Options: ReplyQuote
Re..
Posted by: km2
Date: May 29, 2012 12:13AM

nglayout.initialpaint.delay Synchronize with content.notify.interval for best performance.

Options: ReplyQuote
Re: Re..
Posted by: rodocop
Date: May 29, 2012 01:37PM

I see no reason to do this, km2.
AFAIK, nglayout.initialpaint.delay is connected with small waiting time at start of rendering and must be set to possible minimum in case of KM.

I have set it to 0.

UPD.: I've got deeper in the problem of nglayout.initialpaint.delay and can say that it''s just the question of taste:

• some people like heavy pages to be shown as soon as they are rendered - by small parts added and added continuously - they should set this setting to minimal values.

• other people like to have much of page been rendered previous to first painting - they can tweak the value up to 1000 (milliseconds = 1 sec).

On the FF forums they say that initial delay makes rest of heavy pages to render faster, but I can't perceive it really. Obviously, an effect depends on hardware specs and network connection speed, so optimal values would be different for every PC.

The FF default is 250.
But we must add this parameter as it isn't present by default.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!



Edited 2 time(s). Last edit at 05/29/2012 02:36PM by rodocop.

Options: ReplyQuote
Re: Re..
Posted by: rodocop
Date: May 29, 2012 04:15PM

But I really don't understand why KM is so uncertainly reacting on keyboard hotkeys input.

As I remember this wasn't a problem till 1.6 branch. Something had gone wrong?


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


Options: ReplyQuote
Re: Re..
Posted by: rodocop
Date: June 21, 2012 03:19AM

IMPORTANT!

It seems like I've found the reason of keyboard unresponsibility, and - a shame for me - one part of this follows from my own recommendations sleepy smiley

So now I give you corrected settings.

  • user_pref("content.interrupt.parsing", true);
  • user_pref("content.max.tokenizing.time", 600000);
  • user_pref("content.maxtextrun", 2048);
  • user_pref("content.notify.backoffcount", 10);
  • user_pref("content.notify.interval", 120000);
  • user_pref("content.notify.ontimer", true);
  • user_pref("content.switch.threshold", 900000);
The last one is the key. When I've reduced it to 300000 (0.3 sec) KM simply started to get into low frequent interruption mode (unresponsive while parsing pages) too quickly, so the time between pressing first and second button in hotkey combinations (like Ctrl + F4, for example) became generally bigger than this interval (0.3 sec).

So, I recommend to increase it up to 900000 (0.9 sec) or slightly more - and key response gets back!

And one more clarification about settings:
user_pref("javascript.options.jit.chrome", false);
user_pref("javascript.options.jit.content", true);
Both are default settings (if they exist in your config) and you should check these are set so.

jit settings are controlling TraceMonkey - js-engine, appeared in FF 3.x.
jit.chrome option controls using this engine in GUI rendering.
jit.content - in content rendering respectively.

KM doesn't use slow XUL GUI of FF, so this option (jit.chrome) must be set at false.
I think, this also speeds up UI response.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!



Edited 1 time(s). Last edit at 06/21/2012 03:22AM by rodocop.

Options: ReplyQuote
Re: Re..
Posted by: panzer
Date: June 26, 2012 03:29PM

I did what you told me and it still isn't perfect, but it is much, much better than before ...

Btw, I do not have these two in my config file ...
user_pref("javascript.options.jit.chrome", false);
user_pref("javascript.options.jit.content", true);

... but if I enter them, save the file and then restart Km, they are gone from the file ...

Options: ReplyQuote
Re: Re..
Posted by: rodocop
Date: June 26, 2012 04:32PM

Yes, KM still freezes from using hotkeys while heavy js are running on a page. This seems to be Gecko's feature.

And what file did you mean - prefs.js?


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


Options: ReplyQuote
Re: Re..
Posted by: panzer
Date: July 03, 2012 02:07PM

Yes.

Options: ReplyQuote
Re: Re..
Posted by: rodocop
Date: July 03, 2012 02:35PM

try to add them into default kmprefs.js or create them inside loaded KM through about:config.


Try K-Meleon-1.6db+NS by dugbug // KM-16-S2014 by Fred // 1.6beta2.6 by JamesD

K-Meleon Twin+ Download for modern browsers =//= Download for old ones =//= Discuss it!!!

New KM74 for test and feedback! Get it there!


Options: ReplyQuote


K-Meleon forum is powered by Phorum.