Beta Proxy Password Problem
Posted by: shadeclan
Date: September 07, 2011 07:31PM

I was having trouble viewing certain sites with version 1.5.4 of K-Meleon and posted it on the forum. JamesD suggested that I get the beta version (1.6.0), which I did. It renders the website correctly now but a new problem has arisen.

I use a secure proxy server at work. The old version asked me for a password (which I complained about here). The new version doesn't ask me for my password but neither does it have any place to put a password in the proxy settings. I tried adding the information to the proxy string in the format username/password@proxy but that didn't work. Anybody have a solution to this?

Re: Beta Proxy Password Problem
Posted by: JamesD
Date: September 07, 2011 08:20PM

Did the prior version of KM have a place for password in the proxy configuration?

Re: Beta Proxy Password Problem
Posted by: adodupan
Date: September 07, 2011 08:35PM

Your machine is probably part of the local intranet network. The quick solution of your problem is this for km15. After installation, first read the readme file.

Re: Beta Proxy Password Problem
Posted by: shadeclan
Date: September 08, 2011 07:46PM

Quote
JamesD
Did the prior version of KM have a place for password in the proxy configuration?

No, but at least it asked me for the password. The beta version doesn't.

Re: Beta Proxy Password Problem
Posted by: shadeclan
Date: September 08, 2011 08:02PM

Quote
adodupan
Your machine is probably part of the local intranet network. The quick solution of your problem is this for km15. After installation, first read the readme file.

Wasn't really interested in going back to the stable version as the beta version correctly renders the website I mentioned in my earlier post.

Re: Beta Proxy Password Problem
Posted by: JamesD
Date: September 09, 2011 07:04AM

@ shadeclan

I don't use a proxy so I have no firsthand knowledge. I assume that the URL of the proxy leads to a page which should ask for the password. Is there an ID associated with the password? Does the page at the proxy require Javascript to operate correctly?

Re: Beta Proxy Password Problem
Posted by: shadeclan
Date: September 09, 2011 07:47PM

Quote
JamesD
@ shadeclan

I don't use a proxy so I have no firsthand knowledge. I assume that the URL of the proxy leads to a page which should ask for the password. Is there an ID associated with the password? Does the page at the proxy require Javascript to operate correctly?

No, that's not how it works. I'm no expert but there's some sort of handshaking going on not related to Javascript but is imbedded right in the TCP/IP protocol. Something in the stable version recognized it but has been removed from the beta.

Re: Beta Proxy Password Problem
Posted by: shadeclan
Date: September 16, 2011 12:42AM

Found the problem! It was yet another PEBKAC problem - I set up the proxy but didn't implement it. It asks for the password properly now. Still, the developers may wish to add username / password capabilities to the proxy setup.

Perhaps I should refrain from reporting problems until my Lyme-induced haze clears ...tongue sticking out smiley

Re: Beta Proxy Password Problem
Posted by: JamesD
Date: September 16, 2011 02:11AM

Quote
shadeclan
Perhaps I should refrain from reporting problems until my Lyme-induced haze clears ...tongue sticking out smiley

Can't be any worse than my age-induced haze. Post when you have a question.

K-Meleon forum is powered by Phorum.