Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
K-Meleon not uninstalling!
Posted by: Richard
Date: September 04, 2011 12:47PM

Every time I start up my computer, it says "K-Meleon was not closed properly. Resume last session?" regardless of whether or not the program is run. Then, every time I attempt to uninstall the program, the uninstaller freezes/never progresses.

Options: ReplyQuote
Re: K-Meleon claims at startup it were crashed / Not uninstalling
Posted by: siria
Date: September 04, 2011 02:23PM

Oops... sorry for the trouble sad smiley
KM isn't so complicated really, there's just this kinda stupid bug:
If you don't close KM manually, but instead have the operating system close it automatically when shutting down, the browser thinks next time it had been crashed!
(Not sure if that's only in the new beta version or also in KM154 already. Anyway, someone (deadlock?) found the reason recently and posted a fix, that will hopefully be included in the next version)

Now if someone has the *Loader* enabled, that means he wants the system to automatically pre-load parts of the engine at startup. Or perhaps you even have the browser fully added to your autostart programs. Then KM opens automatically at each system start and BANG - if it wasn't closed manually last time, there you have the mess, a false crash alert at each system start...

Am no expert, but suspect that in such configurations, uninstalling is hanging because parts of the KM engine are already running in the background??

- - - - - - - - - - - - - -
Guess you have those possibilities now:

- To only stop that annyoing crash alert:
add a special line to your config as a workaround to suppress that alert box (even if it really crashed last time),
or manually close the browser each time before shutting down the system (bothersome),
or disable the sessions plugin (F2/KM-Plugins) (but then your previous sessions are never remembered)

- Or uninstall it:
You have to first kill the stuff that's seems running in background yet: Use the taskmanager to kill it / OR disable the automatic loader or automatic autostart of KM (by far most systems are fast enough anyway for manual starts).

Basically KM is very simple, it only exists of its program folder and of the profile folder. You can just as well delete those two folders manually, but that certainly would "hang" as well if you don't close first your automatic startup stuff.



Edited 4 time(s). Last edit at 09/04/2011 03:12PM by siria.

Options: ReplyQuote
Re: K-Meleon claims at startup it were crashed / Not uninstalling
Posted by: siria
Date: September 04, 2011 03:40PM

As for the workaround mentioned above in blue, there are several possibilities to add it. All are simple and work, but which is 'best' for a certain user depends on his writing rights on the own machine (man, how things were so much easier back in the good old win98 times tongue sticking out smiley)
________________________________________
Version-1 (most simple?):
Open browser, click Edit > Configuration > User Settings

Add this as last line and save:
user_pref("kmeleon.plugins.sessions.cleanShutdown", true);
Then lets hope you have writing rights at least in your profile folder. If not, open the folder ...programs.../K-Meleon, delete the file "profile.ini", then restart the system.
Catch: This solution is only stored in the user profile, that means if creating a new default profile, the fix will not be there. Could be copied over, but needs remembering it. And if keeping the "fixed" profile for use the next KM version, which hopefully has the bug fully fixed, the workaround isn't necessary anymore but still blocks ALL crash alerts, incl. the real ones.

________________________________________
version-2:
Add this code to a default macro like "main.kmm". It's in folder ...programs.../K-Meleon/macros. Open it with notepad and add at top or bottom:
# Bug-workaround: Suppress all "K-Meleon wasn't closed properly"-alerts at browser start:
setpref(BOOL,"kmeleon.plugins.sessions.cleanShutdown","true"); 
This is stored for all profiles in the current KM installation. Future KM versions (which hopefully are fixed) will not wrongly 'inherit' that old workaround, since old default macros are always overwritten with new versions. The only prob: The user needs writing rights in the programs folder, or know how to get it.

________________________________________
version-3:
Add a separate macro with that fix: Open notepad to create a new document. Add same lines again as above:
# Bug-workaround: Suppress all "K-Meleon wasn't closed properly"-alerts at browser start:
setpref(BOOL,"kmeleon.plugins.sessions.cleanShutdown","true"); 
Now things get "difficult" (today one is called 'advanced' to know how to find notepad or store files with it ;-)
Okay, now store it as "crash_falsealert_bugfix.kmm" into one of the macros folders. Make sure there is no ".txt" ending added automatically, store it with the option "all files *.*" or such. Preferably into folder programs/K-Meleon/macros, so it works in ALL profiles. If writing rights are a prob, then into the user profile folder /macros.
This separate macro can later be found and switched on/off in
Edit > Preferences > K-Meleon Plugins > Macro Extension

Perhaps a mod can post that kmm-file as attachment here, to make things easier? And encoded "UTF-8 with BOM" flag, in case a user may add notes with special characters ;-) Thank you!



Edited 2 time(s). Last edit at 09/04/2011 09:34PM by siria.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.