Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
userscript not applied (KM 1.6b2 / Win7 x64)
Posted by: DannyD
Date: July 26, 2011 12:30PM

Hi there!

Finally I made a new attempt to upgrade from KM 1.5.4 to 1.6b2. I knew from earlier experiments that GreaseMeleon would not work, but found "Greasify" some time ago in this post: http://kmeleon.sourceforge.net/forum/read.php?1,68178,114212#msg-114212.

I downloaded Greasify and installed it as described on
I.e. I called "Set Userscripts Directory" and then "Addd User Script To The Repository". That seemed to work; if I now select "Show Userscripts In Repository" my script shows up.

However, the script is never applied. If I go to the site that I want altered, nothing happens. Selecting "Show Actively Applied Scripts" brings up an empty pop-up.

I have tried "Toggle Greasify On/Off", "Apply Greasify Now", Disable/"Re-Enable A Script" and Clear/"Generate Includes and Excludes" (and I have restarted KM, of course), but nothing helped. I also tried all the other toggles in the "Advanced" submenu.

My script works in KM 1.5.4 (with GreaseMeleon) and also in FF (Greasemonkey) and Chrome (Blank Canvas Script Handler). So the script is OK, as far as I can say. It does not do anything fancy, it just adds a few more options to an existing <select> drop-down.

I have made the following observations. Maybe this helps to tackle the issue:

  1. If I go on "View Script Source In Browser", my script is shown. However, right below my script code, "<html><body><div>" is displayed. I do not know where that is coming from; it is not in my script, of course.
  2. The "GreasifyTB" toolbar has got no icon (but it is possible to right-click on the blank button). Is that a sign of wrong/incomplete install?
  3. The Error Console is showing the error "setting a property that has only a getter - InjectJS". But this happens on all pages, not only the one that is supposed to execute the userscript. However, this error does not occur when I disable the Greasify macro from KM's preferences.

Can anybody advise?

Is somebody else running userscripts successfully on KM 1.6 under Win7/x64?

Thank you

Options: ReplyQuote

K-Meleon forum is powered by Phorum.