Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
Problem with scrolling by using 'middle click'. Doesn't reset.
Posted by: santamaria
Date: June 28, 2011 01:47AM

I've noticed this problem for a long time, but just idly thought it would be fixed soon.

The version is 1.6 beta 2.

When I click the mouse's scroll wheel, which results in a middle-click, the four-arrowed scroll cursor is enabled as expected. Scrolling in all directions also works as normal.

However, as the page is scrolling, when you perform any sort of click, the scroll-mode does not reset and the page just keeps on scrolling. To reset, I have to bring the mouse carefully back to its neutral position, that is, the point on the screen at which I initiated the middle-click, and THEN left-click or middle-click to disable scroll. And even THIS doesn't work sometimes, leading to me having to close the tab.

It should be a very simple fix, right?

Options: ReplyQuote
Re: Problem with scrolling by using 'middle click'. Doesn't reset.
Posted by: siria
Date: June 28, 2011 02:07AM

Me too, nice that for once they can't blame my trusty old system grinning smiley
But guess that's already in the bug tracker, saw it just the last days...

That whole scrolling thing really drives me crazy, when I accidentally hit it. Haven't figured it out yet, when escaping works and when not. Sometimes it seemed that I best click at the side of a page, at any rate outside of linked areas, to "escape". But then, not always. And often it seems that slowly clicking a few times in the same place helps.
And hopping tabs (clicking another and then right back) seems to help too, just sometimes...
Find no way to disable it, but have a long time ago stumbled across a setting like that in the general windows settings. Perhaps there's the culprit, will have to search again...



Edited 3 time(s). Last edit at 06/28/2011 02:27AM by siria.

Options: ReplyQuote
Re: Problem with scrolling by using 'middle click'. Doesn't reset.
Posted by: santamaria
Date: June 28, 2011 03:30AM

Hm, I doubt it's something in the settings. I _vaguely_ remember that this wasn't a problem in some 1.5.x version. But I can't be certain since I only used that version for like an hour, then moved since to this version.

Didn't know it was in the bug tracker though, thanks. Hope it gets fixed real soon </psychological prod to devs>



Edited 1 time(s). Last edit at 06/28/2011 03:31AM by santamaria.

Options: ReplyQuote
Re: Problem with scrolling by using 'middle click'. Doesn't reset.
Posted by: jsnj
Date: June 28, 2011 04:54AM

Filed a bug on it a couple days ago

http://kmeleon.sourceforge.net/bugs/viewbug.php?bugid=1323

It's inconsistent. On the page I gave as an example in the bug report right now I have no problem undoing autoscroll, but I usually do have problems on that page. I think it's usually heavily-coded pages so to speak with JS, flash etc...



Edited 1 time(s). Last edit at 06/28/2011 04:58AM by jsnj.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.