Adblock doesn't work - at all!!
Posted by: k-meleon-user
Date: June 02, 2011 10:27PM

Hi, I've downloaded and installed K-meleon 1.5.4, and downloaded and unzipped Adblock Plus 1.02 (version that should work with K-meleon 1.5 as stated on Adblock hompage)into the K-meleon folder..... NOTHING HAPPENED! Absolutely nothing...

And...

I've downloaded and installed K-meleon 1.6.0, and downloaded and unzipped Adblock Plus (1.3.8 - the official version on Adblock homepage) into the K-meleon main folder. Guess what... NOTHING HAPPENED!!... Absolutely nothing... What am I doing wrong?? sad smiley <- and why is smiley green? confused smiley

Re: Adblock doesn't work - at all!!
Posted by: MXB
Date: June 03, 2011 03:19AM

Quote
k-meleon-user
Hi, I've downloaded and installed K-meleon 1.5.4, and downloaded and unzipped Adblock Plus 1.02 (version that should work with K-meleon 1.5 as stated on Adblock hompage)into the K-meleon folder..... NOTHING HAPPENED! Absolutely nothing...

And...

I've downloaded and installed K-meleon 1.6.0, and downloaded and unzipped Adblock Plus (1.3.8 - the official version on Adblock homepage) into the K-meleon main folder. Guess what... NOTHING HAPPENED!!... Absolutely nothing... What am I doing wrong?? :( <- and why is smiley green? :s

Smiley can be turned off by ticking Disable smileys for this message. :-)

--
P2 400 MHz, 128 MB, Win 98 SE

Re: Adblock doesn't work - at all!!
Posted by: disrupted
Date: June 04, 2011 05:27AM

your extracting program is probably creating a separate folder inside k-meleon and instead of extracting to designated folders it's sending all files to that new folder, make sure that files are copied to their corresponsing folders.
e.g adblockplus.kmm goes into the macros folder, the dll goes to the k-plugins folder and components to the corresponding folder. it's important to extract while k-meleon is closed and delete those 2 files from the components folder:
compreg.dat
xpti.dat

and restart k-meleon

in case you're installing adp 1.0.2 (km 1.5) on windows xp or below, you might face a locked statusbar icon creating own toolbar, in that case you should install adblockplus version without the k-plugin available at http://kmext.sf.net/ext1.htm

Re: Adblock doesn't work - at all!!
Posted by: k-meleon-user
Date: June 04, 2011 10:52PM

Hello, and thanks for your answer. I used 7zip to unzip files, and I specified K-meleon main folder as the target folder. I see adblockplus.js among many other files in the K-meleon main folder. Yet Adblock doesn't work.

Re: Adblock doesn't work - at all!!
Posted by: disrupted
Date: June 05, 2011 05:41AM

that's wrong the adblockplus.js i ssume either the pref or components js should not be in the main folder..it should be in the components or defaults\pref folder. nothing should be in the main folder, everything must go into a specified folder in kmeleon's folder

for 1.5 abp 1.0.2:

in the chrome folder: k-meleon\chrome
adblockplus.jar
adblockplus.manifest

in the components folder: k-meleon\components
nsadblockplus.js

in the pref folder: k-meleon\defaults\pref
adblockplus.js
adblockplus_extra.js

for macros folder: k-meleon\macros
adblockplus.kmm

for k-plugins folder: k-meleon\kplugins
adblockplus.dll


-------------
for km 1.6 adp 1.3.x

same as above except for: typeaheadfind.xpt for the components folder

and additional folder modules: k-meleon\modules
copy entire adblockplus folder with the modules (*.jsm files) in the modules folder


if those files are not extracted specifically to the folders indicated above the extension will not work and you must delete compreg.dat and xpti.dat after extraction

7zip by default extracts properly to assigned folders, check your settings,
you can use the extensions manager to install 7z(not zip)extensions
http://kmext.sourceforge.net/kem.htm

but then you will need to extract it manually first..

a quick indication to know if adp was installed/extracted properly, if that's the first time you installed it, you will get a prompt 'a new plugin was found:adblockplus.dll' after you restart kmeleon, click ok.. if you don't get that prompt then either extraction has failed or.. if you are using the loader.exe, you must close it first as well just like closing k-meleon.



Edited 1 time(s). Last edit at 06/05/2011 05:44AM by disrupted.

K-Meleon forum is powered by Phorum.