Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here. But please, for confirmed bugs, use the bug tracker to report and give feedback on bugs.  
Error on site
Posted by: Alex.Tarantul
Date: February 24, 2011 08:45PM

Colleagues, asking for help to you. Using K-Meleon 1.6beta. In version 1.5.4 the problem was not, and was due to a 1.6. See screencast, we'll see two error messages. The fact that the problem arose on the site of a solid company. The bottom line is that the client can not send a request to technical support company. You can reproduce the error. To do this, use K-Meleon 1.6beta2 and go to the site www.net-angel.ru. In the upper left corner, click the button and see the error. Need to fill in all fields marked with an asteriskUsername: test Password: testpass. Try yourself to repeat the action, as seen in the screencast.

Screencast here: http://bit.ly/gW7ToS

My blog about K-Meleon
http://kmeleon-ru.blogspot.com/

Options: ReplyQuote
Re: Error on site
Posted by: Alex.Tarantul
Date: February 27, 2011 09:33PM

First error message

second error message

Remember: its Kmeleon 1.6beta. What does it mean? Outdated Gecko?

My blog about K-Meleon
http://kmeleon-ru.blogspot.com/

Options: ReplyQuote
crappy written site
Posted by: watch the...
Date: February 27, 2011 10:16PM

I get the same error with Ff 3.5 UA and SM 2.0 UA. No problems using Ff 3.5.

Mozilla 1.3 Alpha - Released December 13, 2002. Seriously??? http://www-archive.mozilla.org/releases/old-releases-1.1-1.4rc3.html

Conclusion: crappy written site.

Options: ReplyQuote
Re: Error on site
Posted by: ndebord
Date: February 28, 2011 09:32PM

Alex,

Don't speak the language but do not get that error message running XP PRO SP3 and K-Meleon 1.6 beta 1. Login w/ no problem using agent switcher and default user agent

N



Edited 1 time(s). Last edit at 02/28/2011 09:33PM by ndebord.

Options: ReplyQuote
Re: Error on site
Posted by: what the...
Date: February 28, 2011 10:22PM

ndebord,

Click one of those 2 items (I don't remember which one) under "service desk plus" in the left upper corner, you can see them on Alex' 1st screenshot.

Options: ReplyQuote
Re: Error on site
Posted by: ndebord
Date: March 01, 2011 02:42AM

Quote
what the...
ndebord,

Click one of those 2 items (I don't remember which one) under "service desk plus" in the left upper corner, you can see them on Alex' 1st screenshot.

what the,

THanks.... took a little bit of hunt and peck to figure out what to click on to get the error message, but I got there. Gecko 1.3 required.... HA!

N

Options: ReplyQuote
Re: Error on site
Posted by: desga2
Date: March 13, 2011 05:50AM

This is a Javascript problem in the website code.
If you test it blocking Javascript (F7) not show any error message and works fine but is bad displayed.
The site is checking bad the UA string in this script code:
http://www.net-angel.ru/scripts/IncludeSDPScripts.js?build=8007

_editor_url="./";
_editor_lang="en";
var agt=navigator.userAgent.toLowerCase();
var is_ie=((agt.indexOf("msie")!=-1)&&(agt.indexOf("opera")==-1));
var is_opera=(agt.indexOf("opera")!=-1);
var is_mac=(agt.indexOf("mac")!=-1);
var is_mac_ie=(is_ie&&is_mac);
var is_win_ie=(is_ie&&!is_mac);
var is_gecko=(navigator.product=="Gecko");
var buildNumber="7013";
function getJsInc(_1){var _2=navigator.appVersion;
if(_2.indexOf("5.0")>=0&&_2.indexOf("MSIE")){return "<script src='"+_1+"?"+buildNumber.substring(3)+"' type='text/javascript'></script>";
}else{return "<script src='"+_1+"?"+buildNumber+"' type='text/javascript'></script>";
}}function getCssInc(_3){var _4=navigator.appVersion;
if(_4.indexOf("5.0")>=0){return "<link type='text/css' rel='stylesheet' href='"+_3+"'>";
}else{return "<link type='text/css' rel='stylesheet' href='"+_3+"?"+buildNumber+"'>";
}}function includeSDPScripts(_5,_6,_7,_8){if(_8!=null){_editor_lang=_8.toLowerCase();
}var _9="";
if(_7!=null){buildNumber=_7;
}if(fromIframe==null){fromIframe="false";
}if(parent["JS_INCLUDED"]!=null&&fromIframe=="false"){return;
}_9+=getJsInc(_5+"/scripts/thirdparty.js");
_9+=getJsInc(_5+"/scripts/servicedesk.js");
_9+=getJsInc(_5+"/scripts/ajax.js");
_9+=getJsInc(_5+"/framework/javascript/framework.js");
_9+=getJsInc(_5+"/components/javascript/components.js");
_9+=getJsInc(_5+"/lang/en.js");
_9+=getJsInc(_5+"/lang/"+_editor_lang+".js");
document.writeln(_9);
parent["JS_INCLUDED"]="true";
parent["MC_JS_INCLUDED"]="true";
fromIframe=="false";
}function includeSDPStyle(_a,_b,_c,_d){if(_b!=null){_editor_lang=_b.toLowerCase();
}var _e="<link rel='SHORTCUT ICON' href='/images/favicon.ico'/>";
if(fromIframe==null){fromIframe="false";
}if(parent["CSS_INCLUDED"]!=null&&fromIframe=="false"){return;
}if(_b!=null&&_b.indexOf("zh")>=0){_e+=getCssInc(_a+"/style/style_zh.css");
}else{if(_d=="RTL"){_e+=getCssInc(_a+"/style/style_rtl.css");
_e+=getCssInc("/style/cal_style.css");
_e+=getCssInc("/style/cal_style_RTL.css");
}else{_e+=getCssInc(_a+"/style/style.css");
_e+=getCssInc("/style/cal_style.css");
}}_e+=getCssInc("/custom/style/custom_style.css");
_e+=getCssInc("/style/htmlarea.css");
_e+=getCssInc("/style/dashboard.css");
document.writeln(_e);
parent["CSS_INCLUDED"]="true";
fromIframe=="false";
}function includeScripts(_f){var _10="";
if(fromIframe==null){fromIframe="false";
}if(parent["JS_END_INCLUDED"]!=null&&fromIframe=="false"){return;
}document.writeln(_10);
parent["JS_END_INCLUDED"]="true";
fromIframe=="false";
}

In Firefox 3.5 and Seamonkey 2 work fine but not in K-Meleon.
This is because the JS code detect a Gecko browser but unknown the version.
I'm working to fix this problem.

K-Meleon in Spanish



Edited 2 time(s). Last edit at 03/13/2011 08:50AM by desga2.

Options: ReplyQuote
Re: Error on site
Posted by: desga2
Date: March 13, 2011 10:40PM

If you save the web page complete you can look a file named thirdparty.js.
In this file is checked the next JS code:
HTMLArea.checkSupportedBrowser=function(){
  if(HTMLArea.is_gecko){
    if(navigator.productSub<20021201){
      alert("You need at least Mozilla-1.3 Alpha.\n"+"Sorry, your Gecko is not supported.");
      return false;
    }
    if(navigator.productSub<20030107){
      alert("Mozilla < 1.3 Beta is not supported!\n"+"I'll try, though, but it might not work.");
    }
  }
  return HTMLArea.is_gecko||HTMLArea.is_ie;
};

navigator.productSub is lost in 1.6 betas.
You only add the next new entry string type in about:config url (or Edit -> Configuration -> Browser Configuration)
general.useragent.productSub   20101123


I'll fixed this in next release.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 03/13/2011 10:41PM by desga2.

Options: ReplyQuote
Re: Error on site
Posted by: JamesD
Date: March 16, 2011 05:45AM

@ desga2

I found where to fix the config for general release. That was in kmeleon.js file.
pref("general.useragent.vendor", "K-Meleon");
pref("general.useragent.vendorSub", "1.6.0");
pref("general.useragent.productSub", 20101123);

Is there a way to fix the default user agent string?

Options: ReplyQuote
Re: Error on site
Posted by: Alex.Tarantul
Date: May 22, 2011 06:19PM

desga2
JamesD
Thank you for help.
Now site work properly. I add pref("general.useragent.productSub", 20101123);
and now all right smiling smiley

My blog about K-Meleon
http://kmeleon-ru.blogspot.com/



Edited 1 time(s). Last edit at 05/22/2011 06:20PM by Alex.Tarantul.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.