Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here.  
location url in history changes when activated
Posted by: WinME
Date: November 02, 2010 02:06AM

I'm using the new K-Meleon on an unsupported system with KernelEX so this may not be applicable to current development. It's the oddest thing: When I choose a previously used url from the location window drop down list, and click on it it goes to an error page on my isp and says 'www.o.com' or 'www.m.com' (for opermail and yahoo mail respectively) cannot be found. Meaning, the urls I always use for these websites are reduced to a single letter (the first letter of the domain following www. apparently) upon choosing. If I type the same exact url as it appears in the location windows drop-down box, it works fine and goes to the website expected. Have no idea...

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: siria
Date: November 02, 2010 02:23AM

That's a known bug, mentioned somewhere in the KM1.6 alpha or preBeta threads ;-) And guess it wasn't only on our old systems, so there's hope it will get fixed in the stable version cool smiley At the moment it's still only preBeta, and the URL bar has some really big problems. Also something with copy/paste, depending how it's used or something. Guess has to do with the major changes Mozilla did in gecko 1.9 compared to gecko 1.8, but not sure.

Anyway, to choose an addy from the URL bar dropdown list in the alpha/preBeta versions, there's a workaround: Don't use the mouse for clicking on it, only hover over the addy, then use the cursor keys (up/down) to choose it again (now it will show that addy in the URL bar) and then hit Enter smiling smiley



Edited 3 time(s). Last edit at 11/02/2010 02:32AM by siria.

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: desga2
Date: November 05, 2010 04:34AM

Sorry, this url bar problem not happend in WinXP, I think this is a Win9x/KernelEX problem not a K-Meleon bug.
Are you using Mouse Gestures plugin? Try to disable it for discard a plugin problem.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 11/05/2010 04:36AM by desga2.

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: siria
Date: November 05, 2010 05:07AM

Oops... not XP? So I confused it with that copy/paste bug in URL bar of gecko1.9, of that one I'm sure. Who knows, when this one will be fixed some day, perhaps that "first-letter-bug" in win98 may suddenly work too again? grinning smiley

Have restarted without gestures plugin, and still same result...

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: desga2
Date: November 06, 2010 03:41AM

I don't remember URL bar copy/paste bug that you are refering.
I tried and copy/paste work fine in URL bar (KM 1.6.x).
It's possible that in some first alpha version of KM 1.6 exist this problem (I remember something about this) but was fixed at less for WinXP.
Can you test it in Win9x? If you have problem with copy&paste in URL bar must be a Win9x/KernelEX problem.

K-Meleon in Spanish

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: siria
Date: November 06, 2010 04:08AM

It was only under certain conditions, had something to do with macro commands involving copying not working anymore in url bar, and that I remember for sure was not only for old systems... Ctrl+C/V did work yes... but Would have to dig through all the alpha pages uaah... cool smiley
Try this: Right-click Go button and "Paste and Go"
Hmm, I guess that was also in the bug tracker... but of course don't find it now, argh!! ;-)



Edited 2 time(s). Last edit at 11/06/2010 04:13AM by siria.

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: siria
Date: November 06, 2010 05:49AM

Regarding that drop-down list again:
When typing at least one letter in the URL bar, the history list pops up automatically, and THEN it works to choose another entry with the mouse!
The problem happens only when opening the URL history by clicking with the mouse on the "down" arrow, without typing *anything* manually...
But works again, if using the cursor keys to choose a list entry! Up/Down/Left/Right, all those keys copy the current entry into the URL bar automatically while stepping up/down, without hitting Enter yet.

No idea but I wonder if it may have anything to do with highlighted stuff in the URL bar. It seems that highlighting happens automatically when typing there directly, and when using cursor keys for the list, but all highlighting in the URl bar vanishes when clicking the "down" arrow.



Edited 4 time(s). Last edit at 11/06/2010 06:03AM by siria.

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: siria
Date: November 06, 2010 09:52PM

Hmm, that's funny...

Regarding "Paste and Go", that depends how the clipboard was copied!

If I copy anything from a URL bar, or copy a LINK target, I can paste it into other programs without probs, but in KM16cp4 "Paste and Go" only creates a completely empty URL bar and stops there.

But if the clipboard content was copied from another program, or was copied from selected text inside a KM page, then "Paste and Go" works normal.

I know my stuff here is getting more and more chaotic, sorry can't help it, find it confusing myself ;-)

Those are the macros that don't catch the clipboard anymore:
-----
Go_Paste{
macroinfo=_("Open Clipboard contents as URL");
$URLBAR=getclipboard();
id(ID_NAV_GO);
}
----
minimacros_GoPasteNew{
macroinfo="Get Clipboard and open as URL in New Page";
$OpenURL=getclipboard();
&OpenURL_InNew;
}
----

Hmm, could it be that "getclipboard()" doesn't work anymore??
(In gecko1.9 on win9x cool smiley) Then again, it only doesn't work if clipboard was copied with "Copy Link URL" or a manual copy inside a URL bar, too crazy, I'm confusing myself more and more, LOL! tongue sticking out smiley)

(PS: "Copy Link Target" would IMHO be easier to understand as "Copy Link URL", but the opinions may vary of course)



Edited 6 time(s). Last edit at 11/06/2010 10:18PM by siria.

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: desga2
Date: November 07, 2010 05:01AM

Quote
siria
-----
Go_Paste{
macroinfo=_("Open Clipboard contents as URL");
$URLBAR=getclipboard();
id(ID_NAV_GO);
}
----

This is the default code in main.kmm and work fine to me in WinXP.
Please try with a new profile or new installation for discard bad/old macros problem.

If problem continue, we need someone that can confirmed it in Win9x with KernelEX.
(Isn't a K-Meleon bug, is a Win9x/KernelEX problem/bug)
Or someone that can confirmed the problem happend in WinXP. (Is a K-Meleon bug)

Quote
siria
(PS: "Copy Link Target" would IMHO be easier to understand as "Copy Link URL", but the opinions may vary of course)

NO! (uff! ... yes!, I can do it!, I can say NO. tongue sticking out smiley)

K-Meleon in Spanish

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: siria
Date: November 07, 2010 05:35AM

No prob grinning smiley

Oh yes it sure would be helpful to get a few more people check this:
Start KM16preBeta (cp4) and open a few different tabs.
Copy a part of a URL bar, or copy a link target, then activate another tab and right-click Go-button > "Paste and Go".
Does it work on your system (and which system)?


I did try on a default profile actually (test-profile), and unlike KM154 have placed in KM16cp4 almost all my non-native macros into my personal user-macros-folder, so the test-profile should hopefully be clean. And hardly anything in the components folder, except the cachefixer, if I'm not mistaken...



Edited 2 time(s). Last edit at 11/07/2010 05:37AM by siria.

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: JamesD
Date: November 07, 2010 08:09PM

@ siria

I just opened 4 additional tabs and copied a URL from a page in one of the tabs. I then clicked on the new tab button for another tab. Then I did the right click on the go button and did 'paste and go'. The copied URL did open correctly in the new tab.

This was done on KM 1.6.0a4 on XP-SP3.

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: siria
Date: November 07, 2010 08:53PM

Okay, then it really must be a win9x prob only - good for KM grinning smiley

But that prob with the 1st-letter pages from the URL bar dropdown list was really driving me CRAZY now! Am I nuts?!? Because it DID work recently to choose an entry with the cursor keys, and now it suddenly doesn't anymore, and for the life of me don't manage to figure out the reason!!

But anyway, now I've made a little macro that creates an alternative menu, accessible in History Menu or Go-Button. If anyone wants to try, open Notepad and copy&paste the following text, then save as "urlbar-history-fix_UMRU.kmm" (or whatever name you wish, but make sure it has no .txt ending only .kmm) into a 'macros' folder, then restart browser.



#ß K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage2)

# ---------- urlbar-history-fix_UMRU --------------------------------
# Version : 1.0 (2010-11-11)
# Author : siria
# System : K-Meleon 1.6beta on Windows9x/ME
# Menu : "URL Bar History (fix)" in History menu, or right- or long-click on Go-Button
# Options : F2>Browsing: "Typed URLs" + "History" + "Finding Websites"
# -----------------------------------------------------
# Okay, not really a fix just a win9X workaround, but better than nothing ;-)
# KM1.6 uses a gecko 1.9x engine, and therefore is NOT supported anymore for old systems
# like windows9x/ME. It runs anyway, thanks to KernelEx tool, but with a few minor bugs.
# E.g. on my machine the URL bar history doesn't work right if opened with the little dropdown
# *ARROW* in the URL bar. Always opens only the 1st character and forgets the rest.
# Note that all works fine if you start *TYPING* something in the URL bar!


UMRU_open{
$OpenURL=getpref(STRING,"kmeleon.MRU.URL".$ARG);
&OpenURL_Typed;
&_UMRU_UpdMenu;
}

UMRU_UpdOpenMenu{
macroinfo="Open page from the URL bar history list. OPTIONS: F2>Browsing / 'Typed URLs' + 'History' + 'Finding Websites'";
&_UMRU_UpdMenu;
plugin(rebarmenu, "URL Bar History (fix9x)");
}

_UMRU_BuildMenu{
setmenu("_Go",separator,-1);
setmenu("_Go",macro,"URL Bar History (fix9x)","UMRU_UpdOpenMenu",-1);
setmenu("Histor&y",macro,"URL Bar History (fix9x)","UMRU_UpdOpenMenu",3);
# &_UMRU_UpdMenu;
}

_UMRU_UpdMenu{
$_UMRU_max=getpref(INT,"kmeleon.MRU.maxURLs");
$_nr=0; while($_nr < $_UMRU_max) &_UMRU_MenuLoop;
}
_UMRU_MenuLoop{
$_UMRUstring=getpref(STRING,"kmeleon.MRU.URL".$_nr);
setmenu("URL Bar History (fix9x)",macro,$_UMRUstring,"UMRU_open(".$_nr.")",-1);
$_nr=$_nr+1;
}

$OnInit=$OnInit."_UMRU_BuildMenu;";
$macroModules=$macroModules."urlbar-history-fix_UMRU;";




Edited 4 time(s). Last edit at 11/12/2010 03:57PM by siria.

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: JamesD
Date: November 08, 2010 01:20AM

Have you tested the macro commands $TEXT = getclipboard(); and setclipboard( TEXT ); to see if they work correctly in Win98?

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: siria
Date: November 14, 2010 08:34AM

There's definitely something fishy with the formats... cool smiley

Okay, finally figured something out, in Notepad2 (KM1.6/wi98se with unicode):
EMAIL addies from "Copy Link URL" in KM1.6 can only be pasted into files that are in UTF-8 code. When trying to paste into ANSI files, even the paste command is grayed out.

I suppose it has something to do with the clipboard format... Have read somewhere (wikipedia?) that stuff that's put into into the clipboard is automatically stored there in multiple formats...

To avoid misunderstandings, I can write and edit in both formats without any probs in my editors! Just not paste email addies that were *copied* from a KM link. Funnily, copying links to other pages works fine, also copying just some normal selected text from a page, also if that text contains an @ character.
My test page is the "General" sub forum here, it contains a few link addies by posters.



Edited 3 time(s). Last edit at 11/14/2010 08:43AM by siria.

Options: ReplyQuote
Re: location url / URL bar dropdown list prob in KM1.6 alpha
Posted by: siria
Date: November 16, 2010 03:12AM

Quote
JamesD
Have you tested the macro commands $TEXT = getclipboard(); and setclipboard( TEXT ); to see if they work correctly in Win98?

Yes, you're exactly right, setclipboard is the problem.
Have now opened a new thread for this Clipboard stuff:
http://kmeleon.sourceforge.net/forum/read.php?2,112227

Options: ReplyQuote


K-Meleon forum is powered by Phorum.