Youtube Problems
Posted by: Ralf F.
Date: April 08, 2010 04:09PM

Youtube updated the page at beggining of april. Since then youtube i have troubles with the display of the youtube page. For example i cant see the video descriptions. U can see that on my picture. The column of the desctription is very thin.

Do u have same problems? How to solove this problems?



Re: Youtube Problems
Posted by: disrupted(unlogged)
Date: April 08, 2010 08:46PM

this is a gecko 1.8 bug or rather youtube no longer supports gecko 1.8 so this class is displayed properly in km 1.6 or gecko 1.9 browsers but generally even there it has other bugs and overlapping text even in firefox 3.5 a browser they 'support'. the older design was much cleaner both in code and in design.

i'll try to fix that bug with a stylesheet

Re: Youtube Problems
Posted by: disrupted
Date: April 08, 2010 10:04PM

if you use the stylish extension, create a new user style or simply go to edit menu>configuration>user-defined stylesheet or custom

this will open usercontent.css add this to it:

@namespace url(http://www.w3.org/1999/xhtml);

@-moz-document url-prefix(http://www.youtube.com)
{
*[class^="watch-expander-head"] { width: 304px !important; }
}


save and restart kmeleon

this css fixes the youtube hidden description class in kmeleon 1.5 and gecko 1.8 in general

does anyone know the song in this vid:
http://www.youtube.com/watch?v=H0MlBVxENgQ&feature=popular

Re: Youtube Problems
Posted by: Ralf F.
Date: April 09, 2010 06:54AM

I really like k-meleon and most time i use it. but why does k-meleon use that old mozilla gecko engine code. version 1.8.1 is from 2006 and since 2008 there is version 1.9. more and more pages dont work correctly sad smiley

Re: Youtube Problems
Posted by: guenter
Date: April 09, 2010 01:04PM

Quote
Ralf F.
I really like k-meleon and most time i use it. but why does k-meleon use that old mozilla gecko engine code. version 1.8.1 is from 2006 and since 2008 there is version 1.9. more and more pages dont work correctly sad smiley

Der Eigentümer von Youtube gibt selbst einem Browser raus.
Ist doch schön als negative Werbung, wenn man andere Browser ausbremst.

Man mißachtet dabei, dass etliche Millionen Leute mit Win9x auf GRE 1.8 angewiesen sind. Aber vielleicht will man die gar nicht als Besucher - wer sowas noch nutzt, ist als Kunde nicht interessant.

The owner of Youtube also issues a browser - nice if You can provide others with negative user experience.

They only neglect that some million ppl with win 9x still rely on 1.8 GRE currently. But maybe they do not want them as vistiors - PPL that use that still are not interesting customers.

& Maybe You should update Your K-Meleon - if Your version is from 2006. tongue sticking out smiley

K-Meleon 1.5.4 (2010-03-05)

Update to latest Mozilla code 1.8.1.24

source http://kmeleon.sourceforge.net/download.php

GRE 1.8 was developed by Mozilla.org until 2010! smiling smiley

Else use 1.6alpha that uses GRE 1.9x.


The change to 1.6 to embed GRE 1.9 needs considerable effort.

BTW. Some projects already changed to another HTML rendering engine (e.g. webkit) or chose another from the start because of the constant extra work that is needed to embed new engines after a Gecko update.



Edited 3 time(s). Last edit at 04/09/2010 07:02PM by guenter.

Re: Youtube Problems
Posted by: siria
Date: April 10, 2010 03:01AM

K-Meleon 1.6 with gecko 1.9 is on its way, just in alpha state yet.
I understand there were some rather fundamental changes from gecko18 to gecko19, which caused some real hard problems on how to exchange it again, that new code that added to that bloat in Firefox 3.x that everyone complains about, though I don't really have own experiences with ;-)

Personally I didn't have problems so far with current KM, but now that certain big companies start boycotting other browsers by exchanging perfectly functioning gecko18 code with versions that only work in gecko19, the update starts getting a bit urgent :-/

Quote
disrupted
open usercontent.css add this to it:
@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document url-prefix(http://www.youtube.com)
{
*[class^="watch-expander-head"] { width: 304px !important; }
}


save and restart kmeleon

Yeah, thanks! They aren't getting rid of KM that easily, hehe!

Now I took that code and added some height:

/* ########### YOUTUBE descriptions gone for gecko 18 #############*/

@-moz-document url-prefix(http://www.youtube.com) {
.watch-expander-head { width: 304px !important; height: 120px !important;}
}


Not sure if that works for all countries, may be that e.g. french people may need need to add lines for fr.youtube.com etc.

usercontent.css certainly is the right place for it, but since changes need restarts, I'm 'abusing' a bit the adblock.css for collecting such stuff cool smiley
That only needs a short switching off/on to update changes, one can test different settings easily to find the best, and if 'off' one can always check how the site looks in the original state. But of course, one should remember this, if it's 'misplaced' tongue sticking out smiley

Re: Youtube Problems
Posted by: disrupted
Date: April 10, 2010 04:27AM

yes, epiphany abandoned gecko after 1.9 and opted for webkit which i think is very sad because it was one of the best geckos for linux.. much better than galeon in my opinion. dorian can also tell you, another factor is lack of proper documentation provided by mozilla and their devs for their trunks which doesn't make it easy for outside devs to use the trunks in their private builds which made people like epiphany devs get fed up... so much for 'open source'

Re: Youtube Problems
Posted by: siria
Date: May 08, 2010 04:13PM

I'm sitting here after nearly falling off my chair... surprised smiley
You guys know what???

Youtube is now giving that infamous "Get a new browser loser"-Message only to FIREFOX-2, but K-Meleon 1.5.4 works fine!! Despite the same gecko version in both User Agent strings!

Noticed that accidentally while checking something in KM16a, but it's the same in KM154:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.24pre) Gecko/20091010 K-Meleon/1.5.4
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.24pre) Gecko/20091010 Firefox/2.0.0.20
Same string except for browser name, but only FF gets the warning!
(The vendor seems to have no influence)
I tried to find a newer FF2 string to check (from http://www.useragentstring.com/pages/Firefox/ ) , but FF...20 seems to have been one of the last.

Re: Youtube Problems
Posted by: guenter
Date: May 08, 2010 07:16PM

I say thx to You for finding it and thx to Youtube for supporting K-Meleon 1.5.4.


p.s. You can still compile Firefox 2 pres.

One I did in 2009.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.22pre) Gecko/20090615 Firefox/2.0.0.22pre (.NET CLR 3.5.30729)

So the UserAgentString would be now like:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.24pre) Gecko/20091010 Firefox/2.0.0.24pre or higher like 25pre

I already checked the string above. Same result as You. I got the same warning.

They seem to have blacklisted Firefox 2 and whitelisted K-Meleon 1.5.4+.
It would have been better to go by Gecko version but it is good enough for me smiling smiley



Edited 1 time(s). Last edit at 05/08/2010 08:10PM by guenter.

K-Meleon forum is powered by Phorum.