Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here. But please, for confirmed bugs, use the bug tracker to report and give feedback on bugs.  
VERY strange mouse behaviour
Posted by: Mr. Cooper
Date: April 02, 2010 02:02AM

OS: Windows 7 Professional x64-bit
KM: K-Meleon 1.5.4

Issue: K-Meleon screws with the mouse. When selecting text or "drawing" (mouse-dragging on a flash element), the browser interprets the mouse as starting about 4cm higher than it actually is.

Effect: When selecting text, the text is highlighted starting several lines about the mouse cursor. When "drawing" on flash (for exmaple, using www.skrbl.com to draw) a roughly vertical line is drawn ~3cm above the mouse down to the current position, then drawing works as it should (until the mouse-click is released). If the mouse is moving sideways quickly, the "vertical" line becomes slanted. Holding Shift while drawing seems to correct this for flash. To correctly select text I must click where I want to begin selecting, then hold shift and click the end of the selection.

Has anyone else experienced this issue? It ONLY occurs in K-Meleon so I am sure it is somehow caused by K-Meleon.

Options: ReplyQuote
Re: VERY strange mouse behaviour
Posted by: desga2
Date: April 02, 2010 02:28AM

Your problem sound like this Bug 1159.
But this bug was fixed in K-Meleon 1.5.4 version, are you sure you are using 1.5.4 version?
It's possible this bug isn't fixed for 64 bits version.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 04/02/2010 02:30AM by desga2.

Options: ReplyQuote
Re: VERY strange mouse behaviour
Posted by: Mr. Cooper
Date: April 02, 2010 08:23AM

I'm positive I'm using 1.5.4, but the bug tracker doesn't say anything about x64 bit. How do we look into that?

Options: ReplyQuote
Re: VERY strange mouse behaviour
Posted by: desga2
Date: April 02, 2010 05:59PM

You can open a new bug with the especification Windows 7 64 bits and referencing the before fixed bug in 32 bits.
But I'm not sure this can be fixed because currently developers haven't 64 bits system to test it.

K-Meleon in Spanish

Options: ReplyQuote
Re: VERY strange mouse behaviour
Posted by: Matt
Date: April 02, 2010 06:55PM

Yes, I can reproduce the bug but only with aero enabled (same OS and K-M version). At least mouse gestures don't have an influence on that.

Options: ReplyQuote
Re: VERY strange mouse behaviour
Posted by: Mr. Cooper
Date: April 06, 2010 06:04AM

Okay, I've just submitted it as bug 1206.

Options: ReplyQuote
Re: VERY strange mouse behaviour
Posted by: Mr. Cooper
Date: April 09, 2010 12:32AM

Erm... Someone closed it saying it's a duplicate of 1159. It's not. 1159 affected Win32 and this affects Win64. Should I re-open it, or what would be the next best step?

EDIT: Also, I was 'watching' the bug, but I didn't receive an email notification that it was closed. What's the best way to check that I'm getting email?



Edited 1 time(s). Last edit at 04/09/2010 12:37AM by Mr. Cooper.

Options: ReplyQuote
Re: VERY strange mouse behaviour
Posted by: Me2
Date: April 09, 2010 11:20AM

Quote
Mr. Cooper
Erm... Someone closed it saying it's a duplicate of 1159. It's not. 1159 affected Win32 and this affects Win64. Should I re-open it, or what would be the next best step?

Looks like Dorian and kko see a dup of 1159.

http://kmeleon.sourceforge.net/bugs/viewbug.php?bugid=1159

Quote
Dorian
Looks like 1.5.4 still has the problem but not 1.6a
Probably fixed with gecko 1.9
[Changed Target from "1.5.4" to "1.6a"]

I see no need to re-open since we haven't been forgotten but is there a "Status: Probably fixed"? ;-)

Hope it's fixed by 1.9 and soon.

Thanks to all.

Options: ReplyQuote
Re: VERY strange mouse behaviour
Posted by: Mr. Cooper
Date: April 09, 2010 09:30PM

Ah, thanks Me2. I didn't notice that before.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.