Bugs :  K-Meleon Forum
You can talk about issues with k-meleon here. But please, for confirmed bugs, use the bug tracker to report and give feedback on bugs.  
Can't set K-Meleon as default browser
Date: March 05, 2010 04:37AM

Three times I've run the configuration process to make KMeleon mydefault browser, but Firefox still opens all links. I'm running XP.

When I open "preferences" it says that K-Meleon is the default browser for html, for htm, and for everything else. I've restarted the computer several times since setting K-Meleon as the default browser, but no joy.

Thanks for any useful suggestions.

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: desga2
Date: March 05, 2010 05:31AM

Try Defaulter extension in this KM Extensions page.

K-Meleon in Spanish



Edited 1 time(s). Last edit at 03/05/2010 05:32AM by desga2.

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: siria
Date: March 05, 2010 11:25AM

Just a thought, could it be that your FF has some setting like "check if FF is the default browser" that automatically resets it all the time...?

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: crabboy
Date: March 05, 2010 08:25PM

Quote
desga2
Try Defaulter extension in this KM Extensions page.

I had the same problem (again recently!). Defaulter (above) works like a charm.



Edited 1 time(s). Last edit at 03/05/2010 08:27PM by crabboy.

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Date: March 06, 2010 03:33AM

I can switch default browsers between Firefox and Windows Explorer, and neither countermands the other. This seems specific to K-Meleon.

Thanks, maybe I'll try the defaulter, but I'm beginning to wonder if I want to after all. I'm also having trouble setting it so that iGoogle always requires a password to open the page. This works with Firefox and Windows Explorer, but so far, K-Meleon happily opens it without my logging in.

By the way, if you need an extension to make K-Meleon the default browser, why does the configuration dialog have that big button that begs you to press it?

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: SoerenB
Date: March 06, 2010 04:25AM

Hi, Barbara,

Quote

I'm also having trouble setting it so that iGoogle always requires a password to open the page.

Did you untick "Remember login data" in the "General" tab of ->Edit -> Preferences ->Privacy & Security?
This should switch off this behaviour.
That is for all logins, then - if there is a way to handle this on a per-site basis, maybe
someone else is so kind to enlighten us?

The "big button" and the defaulter - I think that works, IF you use BOTH by invoking
the defaulter from the button, after having placed the kmdefaulter.exe in the K-M folder.
That worked here, and I admit: I found out by trying. The documentation may be
accurate about this, but I agree: this is not obvious. The text in the box near
the button doesn't tell you anything about that, after all...

Cheers
SoerenB

is: I'm back, on wine in some (!) linuxes - speaking of addiction ...

was: No more own machines, because of addiction.
Don't know when I'll be back to normal ...

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: siria
Date: March 06, 2010 05:09AM

The logins depend from the settings for saving passwords and also those for saving cookies, so guess it's probably just different default settings for the different browsers, a matter of customizing...

The defaulter, oh well yes, it's known that it could use some updating ;-)
But for me that's a minor thing, and I don't complain now, after a very long break it's finally visible again, since a couple weeks, that the browser gets developed again, Dorian seems to be working like crazy at it right now smiling smiley smiling smiley From what I understand there were some rather fundamental problems to solve first with the new gecko engine, and in exchange K-Meleon 1.6 will be lightning fast in version 1.6, from which the first alpha versions are now available grinning smiley



Edited 2 time(s). Last edit at 03/06/2010 06:10AM by siria.

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: desga2
Date: March 06, 2010 08:12AM

Quote
Barbara Vaughan
By the way, if you need an extension to make K-Meleon the default browser, why does the configuration dialog have that big button that begs you to press it?

This button work (or worked) to the majority of the systems, but some strange configurations in Windows XP (SP3) and Vista/Seven have problems with the user privileges and the button not work.

K-Meleon in Spanish

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: Barbara Vaughan
Date: March 07, 2010 03:45AM

Quote

Did you untick "Remember login data" in the "General" tab of ->Edit -> Preferences ->Privacy & Security?
This should switch off this behaviour.
That is for all logins, then - if there is a way to handle this on a per-site basis, maybe
someone else is so kind to enlighten us?

I have "remember login data" unticked. It can't be picking the preferences up from another browser, because it works correctly on Firefox and Internet Explorer. I don't mind if it turns off remembering all logins from this computer, because it's a little netbook I carry around with me quite a lot, and should I lose it, I really don't want anyone to be able to log in to anything.

Using Firefox, on this netbook computer, I have iGoogle set as my default page, but it always opens to the login page, because I have it set not to remember the login information. I like Firefox quite a lot and am only thinking of using K-Meleon instead because it's much leaner. In fact, K-Meleon never freezes for 30 seconds or more, as Firefox often does. However, I'm getting the impression that maybe K-Meleon's not ready yet for the big world(?)

Thanks for helping, Barbara

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: siria
Date: March 07, 2010 02:16PM

Barbara, I still think it must be your cookies. The settings are on the same privacy tab as the "login" setting. Take a look there, click on "currently stored cookies" and try to find it. Remember its name, then click on cookies "Exceptions" and add it there, mark it as "session only". You probably want to change the general settings for cookies too, on the right side.
Just hope google hasn't sneaked that in as a flash cookie, that would be a bit more difficult to handle.
I'd also recommand to switch on the privacy bar (View>Toolbars), it prevents lots of stuff from getting stored secretly when enabling cookies and javascript only if really needed.

Frankly, KM does occasionally need some digging for certain settings and a bit perseverance, but really not as often as it may look to you at the moment. And it's worth it, if one basically likes it - or if one is really frustrated with 30sec waits in other browsers ;-)
And of course not every browser is everyone's cup of tea. Sometimes I'm rather envious of FFx's easy drag-n-drop configuration and the half-automatic addon-system with a great search, lots of very helpful comments and ratings etc. But all-in-all, KM has other advantages that matter more to me, in some regards it is actually easier to customize. Just one example, I absolutely love my nice sunrise toolbar background, and all it took me to use it, years ago when I just started using KM, was to throw a look into the skins folder and discover the "back.bmp" there, then exchange it with any photo or graphics. And I like to be able to add almost any menu as a right-click on toolbar buttons, and other things. Recently I was bothered with a bunch of links that someone posted that started with "ttp:", but I was able to write my own little macro there that now adds that missing "h" automatically (or a third "w"), if a link is incomplete.
So no matter how envious I sometimes may be of other aspects in other browser, as soon as I open KM again, I just love it all over again and feel a certain relief to be 'home' again, where everything works as I want it, even if the one or other setting took some learning and digging, and even if once in a few weeks I need to use FF or Opera for a moment smiling smiley



Edited 1 time(s). Last edit at 03/07/2010 02:35PM by siria.

Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: caktus
Date: March 09, 2010 01:39AM

@ Barbara Vaughan

I too and many folks have experienced this problem regardless what browser KM/IE/NN/etc. is set as the default browser. I used to think it may be caused by User's personal OS/Browser settings but more and more over the years I have come to believe FF is at fault.

Charlie

~~If it ain't broke, why screw it up?~~


Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: disrupted
Date: March 09, 2010 09:35AM

http://club.myce.com/f3/firefox-default-browser-bug-fixes-104741/

https://bugzilla.mozilla.org/show_bug.cgi?id=246078

ironically the browser with bugs that have not been addressed properly since 2004 is the one that's "ready for the world", it's the same reason why some soccer mums think they are better off driving a pointless gas-guzzler thinking it's safe for their children.. not aware-with their false sense of security.. that in a real-life collision; the poor handling will make it impossible to steer away from a crash and more likely to roll-over and that the sheer weight of that truck will crush them inside.

honestly ..some people will never be ready for kmeleon or for decent programming for that matter, like sheep following whatever the other sheep are using.

i even doubt if that person even knows what making a browser default is about.. for most , it won't make much difference whether the browser is default or launching it from a shortcut. registering protocols is mainly for external apps and developing.. for most people they won't even know if a browser is default or not since they will always be executing it from a desktop shortcut.. but why does making it default becomes so important to some? they believe that as long as another browser is default then they are not getting the full potential of the other browser or that they are vulnerable since another browser is the protocol registrar.. the same way they think they really need a land cruiser for school carpooling.

you don't really need to make kmeleon or any browser default to be using it fully unless you are a web developer/designer which i doubt.. and the only bug you have is that you have made firefox default with its dde messages that have messed up your registry.

here's how to fix all your problems:
http://www.mozilla.com/firefox/



Options: ReplyQuote
Re: Can't set K-Meleon as default browser
Posted by: ndebord
Date: March 24, 2010 07:13AM

Barbara,

So long as you have administrator rights, you can permanently pick your default browser by using programs like setbrowser.

http://www.pc-tools.net/win32/setbrowser/

P.S. When I upgraded from IE6 to IE8, it decided it was the default browser and even though I told it it wasn't, it insisted and KM couldn't change that setting. But Setbrowser did straighten it out.

As KM is a Netscape offshoot, your choices are:


Netscape
Internet Explorer
Opera/Other

You choose Netscape then Specify Location and you should be good to go.

P.S. SetBrowser changes your registry settings and that overrides other methods.

N



Edited 1 time(s). Last edit at 03/24/2010 08:49PM by ndebord.

Options: ReplyQuote


K-Meleon forum is powered by Phorum.