Development :  K-Meleon Forum
K-Meleon development related discussions. 
RestartKM & KM1.5.3
Posted by: jsnj
Date: May 10, 2009 04:33AM

I'm having problems w/restartkm and km1.5.3. It doesn't work and it also removes some macro menu items such as the search engines. Works fine in 1.5.2. I thought it may be the add toolbutton/bar bug fix that I believe is in 1.5.3, but having commented out that part of the macro and just leaving the menu item, it still doesn't function. Anyone else?

Options: ReplyQuote
Re: RestartKM & KM1.5.3
Posted by: disrupted
Date: May 10, 2009 07:00AM

that's very strange.. i'm using it without problems, make sure to use one macro only for restart km..either the one without the toolbar button or the macro for the toolbar button, both will add the same menu command.. and make sure restartkm.exe is saved in tools folder (k-meleon\tools)

menu entries disappearing is due to conflict between macros or a badly written macro(perhaps missing a semicolon) and the restart macro is error-free..so it's probably a conflict or other bad macro; did you add new macros recently?

incase of a conflict i uplodaed this macro with slight changes (instead of restart restarter11:more unique)

test with this one and hopefully it will work:
http://kmeleon.swiftfree.net/tests/restart.kmm
(this is without toolbar button)

for restart with toolbar button..i don't know how it works and desga will check it

Options: ReplyQuote
Re: RestartKM & KM1.5.3
Posted by: jsnj(unlogged)
Date: May 10, 2009 07:48AM

My bad!... an easy to miss uncommented ____________________ under the description area was the cause. Sometimes it's the stupidest things. Thanks for the comparison file.

Options: ReplyQuote
Re: RestartKM & KM1.5.3
Posted by: disrupted
Date: May 10, 2009 11:43AM

no worries.. an uncommented line can easily go unnoticed, i'm always doing worse things like missing semicolons everywhere.. glad you've sorted it outsmiling smiley

Options: ReplyQuote


K-Meleon forum is powered by Phorum.