Running fails - GRE not found
Posted by: Yakobom
Date: February 03, 2008 12:15PM

Hi,
quired?
I compiled the K_Meleon sources, but I'm unable to run it since i get a message saying the GRE cannot be found. Anyone has any idea about how to solve this? I cannot debug it, since from some reasons VS cannot find the relevant symbols...
Also - can someone shed some light about the way GECKO is embedded in K_Meleon?
I saw that XPCOMGlue is used - what GECKO runtime dll/libs are really required?
I know that XUL.dll is required when embedding using the 'regular' way that is recommended on Mozilla's articles, but I saw K-MELEON is not using it.

Thanks in advance,
yakobom

Re: Running fails - GRE not found
Posted by: guenter
Date: February 03, 2008 02:09PM

you do not expect me 2 write the list? sad smiley
from old build how2s: put your exe into a k-meleon install. else send it to me i will make an installer. i have the install builder. you can teach me to built an exe in return. drool smiley



Edited 2 time(s). Last edit at 02/03/2008 02:11PM by guenter.

Re: Running fails - GRE not found
Posted by: desga2
Date: February 03, 2008 07:47PM

@ Yakobom:
You were compiled a K-Meleon build, but you need a Gecko engine to run it.
You can compile a Gecko engine from source or use a Gecko engine already compiled, for example in some K-Meleon release or a bruns update Gecko engine:
http://kmeleon.sourceforge.net/forum/read.php?1,76504

K-Meleon in Spanish

Re: Running fails - GRE not found
Posted by: Yakobom
Date: February 03, 2008 08:15PM

desga2:
I am familiar with GECKO engine, I have it here and still couldn't make it work
Can you kindly explain what files exactly K-Meleon is looking for?

Thanks,
yakobom

Re: Running fails - GRE not found
Posted by: guenter
Date: February 03, 2008 10:50PM

use ab old k-meleon install. that will have all needed gecko and config files.



Edited 1 time(s). Last edit at 02/03/2008 10:50PM by guenter.

K-Meleon forum is powered by Phorum.