Development :  K-Meleon Forum
K-Meleon development related discussions. 
Pages: 12Next
Current Page: 1 of 2
K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: August 18, 2006 06:09PM


I've installed and tried every activeX solution there is but no one is working correctly.
So this is a wish that the activeX solution in K-M 0.9.13 will be back in the next release of K-Meleon. But for now I wonder how to get that solution to work with K-M 1.0. Can someone help me with that please?

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: August 18, 2006 07:30PM

My updated version 0.9.13-ud2-1.8.0.5 is basically a KM 1.0
and has Active X Support for Firefox 1.5 included.
Download the .zip at:

http://rapidshare.de/files/27286556/K-Meleon0.9.13-ud2-1.8.0.5.zip.html

and look if it works for you.
You could use the same files at the same place in KM 1.0 .
Ifr you don't need the switch in the menu, you could rename
npmozax.dll in the plugins folder manually, when you don't
need Active X to _npmozax.dll .

Take the files nsAxSecurityPolicy.js
from the components folder and put it
into the components folder of KM 1.0.
Then delete the two files compreg.dat and xpti.dat
in the components folder. They will be recreated afterwards.

Then take the file activex.js from the folder defaults/pref
and put it int defaults(pref of KM 1.0 .

Finally take _npmozax.dll from the plugins folder
(or npmozax.dll, when it was active), and put it
into the plugins folder of KM 1.0. Rename it to
npmozax.dll, to activate it.

If you want more (also more dangerous) Active X controls
working, adjust in activex.js the number in

pref("security.xpconnect.activex.global.hosting_flags",9);

Then restart the browser, and Active X should work,
as long as you don't rename the plugin.

Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: August 18, 2006 08:36PM


I've done that but it still won't work properly. It only works halfway, the mediaplayer way works but not the activeX inbedded way work if you understand what I mean.
I need the whole package from 0.9.13, activeX controls and macros for it to work with K-Meleon 1.0 you see it worked perfectly in K-M 0.9.13 without changing useragent from K-Meleon to something else so that is why I want it back in the next version or release of K-Meleon.

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: alain aupeix chez wanadoo fr
Date: August 18, 2006 09:02PM

Perhaps due to chrome.

If the mozilla version is the same, I think that 1.0 has lighter chrome (and perhaps components) than 0.9.13

A+

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: guenter
Date: August 18, 2006 09:08PM

You need the FFox 1.5 files for 1.0 (except this: activex.js).

Download page: http://www.iol.ie/~locka/mozilla/plugin.htm

Remember to delete: compreg.dat and xpti.dat in components / this is a must.
Place files like Fred did in 0.9.x.
But best use the the whitelisting activex.js that Fred used in 9.12/9.13.
btw. I do not think that that You really need the macros as long as You whitelist.

The described error can come from wrong html code - try what works here:

http://home.htp-tel.de/sterntaler/test.html

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: August 29, 2006 08:57PM


Well I'm really desperate now! I've tried everything and still ActiveX isn't working as it should. I've been surfing on several sites that has embedded clips or audiofiles but it just want play for me. I followed all the install tips that are available and ActiveX want work anyhow. So either I have done something wrong when I installed or there is something missing. I've got WMP9.0 something and K-meleon1.0 installed on my win98 computer. I also has all the needed codecs installed for it to work but it just don't work. So I sudgest that k-m 0.9.13 -ActiveX will be inplanted in the next release of K-Meleon. I personal think that the missing parts in K-M1.0 is the adblock and noscript parts and that is why ActiveX is not working properly in K-M1.0.

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: August 30, 2006 01:25AM


I have discovered my problem. I can't activate ActiveX that is why it wont work for me.
I've tried everything now so I will appreciate some help with this please.

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: August 30, 2006 03:33AM

A possibility to make embedded links of a webpage
visible is to use Proxomitron, which includes a filter
called something like "Turn streams to links".
You could then open these by doubleclick or by
right click that would start a macro that starts the
player with the given address.
Proxomitron is not just an adblocker, but you can
change almost everything of a website, including
blocking of certain dangerous javascript commands.
The creator of Proxomitron has unfortunately died
and cannot develop the program any further.
If you need an english version, it is still available
at the german Proxomitron site.
Download at :
http://www.buerschgens.de/Prox/Seiten/Download/Proxomitron4.51-Original.zip

But if you can manage a german version, I would
recommend this one. Many new filters have been added.
I will give the link in the following post, as only
one link per post is allowed.

Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: August 30, 2006 03:39AM

The much improved german "Professional" version is at :

http://www.buerschgens.de/Prox/Seiten/Download/Proxomitron4.51-P-1.2.1.zip

Before I knew the new ActiveX plugin, I always used the
visible links, created by Proxomitron, although not
everything might be accessible in this way.
Regards
Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: kko
Date: August 30, 2006 04:22AM

Are you sure you're using the correct version of the ActivX plugin? K-M 1.0 is no longer based on Mozilla 1.7, it's based on Mozilla 1.8. Maybe try the plugin for Firefox 1.5?

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: August 30, 2006 04:34AM


Yes kko I'm using Firefox plugin 1.5. Thanks for the tips Fred.

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: August 30, 2006 04:34AM


Yes kko I'm using Firefox plugin 1.5. Thanks for the tips Fred.

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: August 30, 2006 06:39PM


This is how it looks right now:
http://kmeleon.sourceforge.net/wiki/index.php?binary=internal%3A%2F%2Fba6ca4982a9d0c7c08f690bded3daa76.png
I've implanted this from K-M 0.9.13 but it didn't help. As I told above I can't activate ActiveX. I've tried all the ways that is possible when I discoverd that ActiveX was not installed due to mozillazines testpage. I tried the testpage and all I got was an error saying that ActiveX is not correctly installed try to install it again. That is why I tried to inplant the ActiveX from K-M 0.9.13 because that workes perfectly with my Win98SE system. The reason I did that is because I like K-M 1.0 so much.
Can someone help me finish the macro so it will be correct. This is how my Macro.cfg looks like:

# ----- Tech Demos

Active_X_Support{
alert("Active X Support is now by default enabled, but only for Windows Media Player");
}

# ----- External Applications

Active_X{
$plug="npmozax.dll";
$reload = true;
&toggleplug;
}
toggleplug{
$plugpath = "plugins\\";
$plug_activ = getpref(BOOL,"kmeleon.netplug.".$plug);
$plug_activ ? $verb = "to disable " : $verb = "to enable ";
$plug_activ ? $action = "disabling " : $action = "enabling ";
$plug_activ ? $from = $plugpath . $plug : $from = $plugpath . "_" . $plug;
$plug_activ ? $to = $plugpath . "_" . $plug : $to = $plugpath . $plug;
$x = pluginmsg(utils, "rename", $from, $to);
togglepref(BOOL,"kmeleon.netplug.".$plug);
&Sync;
$msg = "You have to close and restart K-Meleon " . $verb . "the plugin " . $plug
$reload ? alert($msg,$action."of a Netscape plugin") : 0;
}

And this is how my menus.cfg looks like:

# ----- Privacy

P&ermissions{
macros(Filters,Content &Filters)
macros(JavaScript,&JavaScript)
#macros(Active_X_Support, Active X Support)
macros(Active_X, Active X Support)
-

Please tell me what's wrong with this!!!!

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: August 31, 2006 01:12PM

The macros have only functions of a switch and are not necessary,
as long as you turn Active X on and off manually by renaming
the npmozax plugin.
I had a close (time-consuming) look at it, and found out
that in the folder components some files are missing and
others not reacting to get the plugin to work.
So I added files from my earlier 0.9.13-ud2 version, and decided
to prepare a K-Meleon 1.0.1-ax version for you to try.
It may be a little unstable, but if you are satisfied I would
also offer it to others to try.

This is a 1.0.1 version, updated to
Mozilla 1.8.0.6 using Gecko/20060730
with by default enabled Active X Support
for Windows Media Player.
Active X Support :
# is by default preset only for comparatively safe Active x controls,
as for example Windows Media Player.
# To turn it off, rename the plugin npmozax.dll in the
folder plugins to _npmozax.dll .
# To allow less safe Active X controls, read the explanation in activex.js
in the folder defaults/prefs, opening it with an editor.
# As this can be dangerous, I do not recommend it.

Download at Rapidshare:

http://rapidshare.de/files/31402058/K-Meleon1.0.1-ax.zip.html

I hope that you like it.

Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: August 31, 2006 07:03PM


Well Fred I tested it and yes it's a little unstable but it works.

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: August 31, 2006 07:26PM


The reason why ActiveX is not working with my K-Meleon1.0 is the fact that there is no Adblock pref available in K-Meleon1.0. That is why it's not working properly in K-Meleon1.0. So for it to work it has to be implnted in K-Meleon1.0. That has to be it in my case.

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: guenter
Date: August 31, 2006 10:19PM

@Rapido,
AFAIK there are files in "components" folder that do not work well with activeX.
( @ least 2 dll files )

That is how far i am with a solution for my system.
Use Dorian´s gklayout.dll - that is the only one patched for us - the other files can be taken from any corresponding Mozilla-SM issue/version e. g. from Fred´s version.

kill the compreg.dat and xpti.dat before next restart ( i always tend to forget that :-)

I am sorry that i did not get any further ( since it would be nice to know which dll in components have a tendency to break or not work well ) & about my mistake with the other post. greetings to SE from Hannover

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: August 31, 2006 11:46PM

@ Guenter
It already works quite well, but not with the latest .exe, which makes
it crash easily.
@ Rapido
Have you enabled css adblocking in Advanced Preferences ? It
filters out most things.

Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: September 01, 2006 01:10AM


Yes and that don't work either.

Yours: Rapido

Greetings from Sundsvall SE to Hannover DE

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: September 01, 2006 03:16AM

I have made a second version now, with enabling/disabling
Active X Support from Tool-->Active X Support, and have
added a button for enabling/disabling of javascript.
Links on page of General Forum.

Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: September 01, 2006 05:03AM


Where is the link?

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: September 01, 2006 06:26AM

K-Meleon1.0.1-ax (2nd version) as selfextracting .exe here :

http://rapidshare.de/files/31470573/K-Meleon1.0.1-ax.exe.html

or as

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: September 01, 2006 06:28AM

zip file (2nd version) here :

http://rapidshare.de/files/31471222/K-Meleon1.0.1-ax.zip.html

only one link per post is allowed.

Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: guenter
Date: September 01, 2006 07:43AM

try more - if need make h-space into post ...& i will send mail - i will catch fault later via admin surface.

Try latest exe with what i tried to say that we must do for activexX
.
I have no soundcard in online pc.That is why i am late/vague with activeX questions.
& on off-line pc i do all kinds of things - without a look at security.

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: September 01, 2006 08:00AM

In K-Meleon1.0.1-ax I found a little bug, that closes the browser whenever
you close a tab. This happens only in "layers only" browsing mode.
Go to Edit-->Preferences-->Tabs and change there at the top
from "Layers only" to "Layers and Windows", to make it work
as usual.

Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: September 01, 2006 01:00PM

As I found many bugs, I have made a 3rd version of
K-Meleon1.0.1-ax.
Download as .zip at :

http://rapidshare.de/files/31514893/K-Meleon1.0.1-ax.zip.html

or as

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: September 01, 2006 01:04PM

or as self-extracting .exe download at :

http://rapidshare.de/files/31514447/K-Meleon1.0.1-ax.exe.html

Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: September 01, 2006 01:04PM

or as self-extracting .exe download at :

http://rapidshare.de/files/31514447/K-Meleon1.0.1-ax.exe.html

Fred

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Rapido
Date: September 03, 2006 07:37PM


Well Fred the favorites bug is still there so that would be fixed don't you think?

Yours: Rapido

Options: ReplyQuote
Re: K-M 0.9.13 ActiveX In K-M 1.0
Posted by: Fred
Date: September 04, 2006 12:40AM

@ Rapido

Thank you for drawing my attention to a problem with
loading the favorites plugin. There are in all three dlls
necessary, which you have to have in your system or
in the K-Meleon main folder. As I already had them, I
did not recognize, that they could be missing on
someone other's computer, although I myself mentioned
them before, when bringing out KM 0.9.13-ud2-1.8.0.5.
I only realized it finally, when trying this version on Linux
with wine. Enaitz Jar already had mentioned the problem
before, but as I found the kplugin included, I thought
everything was o.k.
These are the same files, that were needed for
K-Meleon 0.8.2+, the so-called "Wechselbalg", and can
still be found for downloading and installing on the
download page for KM 0.8.2+, as "dll-installer" (707kB).
Download and install them from here ;

http://www.lontronics.nl/index.php?m=0006

Then the favorites can be enabled in Preferences-->Plugins,
and should appear after a restart of the browser.

Regards
Fred

Options: ReplyQuote
Pages: 12Next
Current Page: 1 of 2


K-Meleon forum is powered by Phorum.