BugMeNot Macro (Q&A)
Posted by: jsnj
Date: March 01, 2005 06:41AM

Post any comments or questions you may have pertaining to the BugMeNot macro in this thread.

Re: BugMeNot Macro (Q&A)
Posted by: SlideRule
Date: March 01, 2005 07:27AM

jsnj:

I like it . . . just wondering if you think it might be helpful to assign an 'accelerator' key to this macro . . . for ease of use.

Perhaps, CTRL VK_F12 (or any other of accelerator key of your choice).

I do not have the knowledge, but, it would be nice for this macro, if someone could write a 'small javascript' to place in the macro . . . that would display a small screen, perhaps 400 x 350 as a 'popup' . . . I hope you know what I mean, that way, the 'answer' from bugmenot.com would be visibile, as well as the screen (layer) from the requested site.

And, I would like to personally thank you, and, the rest of the K-Meleon team, for the great work. I really appreciate it.

SlideRule

Re: BugMeNot Macro (Q&A)
Posted by: yo
Date: October 08, 2007 07:51AM

Maybe i am really noob, but i dont know how this macro works.
I had bugmenot extension on ff and i just have to press right click on mouse and the n click "log me with bugmenot". What should i do here? bugmenot macro apears on macro list but i dont know how to make it works.

Re: BugMeNot Macro (Q&A)
Posted by: yo
Date: October 08, 2007 07:59AM

Oh well, i just finally found how it works xD.
Just had to go to menu "send page to" its a little diferent from firefox, but it works smiling smiley

Re: BugMeNot Macro (Q&A)
Posted by: kmeleon_user
Date: June 14, 2010 04:42AM

well, i'm messing around trying to learn macros, and wanted to edit this one. my changes DO NOT AFFECT the operation of this macro at all.
If i delete the macro from the macros folder, it is gone, but if i edit it to look like:
# K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage)

# ---------- BugMeNot ----------------------------------------------------------------------------------------------
#
# Dependencies : main.kmm (OpenURL), sendto.kmm (menus)
# Resources    : -
# Preferences  : -
#
# ------------------------------------------------------------------------------------------------------------------

BugMeNot{
}

# ----- PRIVATE

_BugMeNot_BuildMenu{
index($macroModules,";SendTo;")>-1?setmenu($_SendTo_Page,macro,"&BugMeNot",BugMeNot): setmenu(DocumentOpenExternal,macro,"&BugMeNot",BugMeNot);
}
$OnInit=$OnInit."_BugMeNot_BuildMenu;";

# ------------------------------------------------------------------------------------------------------------------
$macroModules=$macroModules."BugMeNot;";
it functions normally...
how can that be????
there is no code in the macro, but it still works...
i restarted kmeleon and my computer. still the macro opens a window to bugmenot WITHOUT ANY CODE in the macro !?!?!?

Re: BugMeNot Macro (Q&A)
Posted by: siria
Date: June 14, 2010 04:49AM

I know the feeling grinning smiley
But it really can't work grinning smiley
Do an explorer search in your two macros folders, "BugMeNot{" must be contained also in another macro ;-)

Re: BugMeNot Macro (Q&A)
Posted by: kmeleon_user
Date: June 14, 2010 05:14AM

finding a "word or phrase in the file" for all files in and under the kmeleon directory turns up:
  • bugmenot.kmm - my edited version (NO CODE)
  • bugmenotauto.kmm - uses the macro: bmnauto
  • bugmenotauto.ini - not relevant
  • cookies.txt - bugmenot is a login name to some site

it actually finds nothing when i search for: BugMeNot{
which is weird.
but there are NO other macros named BugMeNot defined anywhere...
i even created a new profile and tried it with my blank macro - still works just fine.

does kmeleon cache these somewhere? maybe keep a "compiled" version somewhere that it uses if the new one has an error?

i don't get it either; i know it shouldn't work. i can try to make a video of it, because i am sure no one will believe me, but this IS HAPPENING and it is ticking me off.

Re: BugMeNot Macro (Q&A)
Posted by: kmeleon_user
Date: June 14, 2010 05:22AM

i'm not registered so I can't edit but here is some more info:

the file bugmenot.kmm is only in my k-meleon\macros folder. i have 2 profiles, bothe of which's \macros folder is empty. no other macro or anything defines a BugMeNot{} macro.

i am guessing that when the macros are parsed, they are stored somewhere. and if parsing fails for some reason, that storage location is not updated - leaving the last "correct" or "successful" version as the one that gets executed. i would like to clear that location, if possible.

Macro miracles ;-)
Posted by: siria
Date: June 14, 2010 05:45AM

cool smiley I'm sure there IS a rational explanation for it cool smiley grinning smiley
And from everything I read and from own struggles too I'm pretty sure there is no hidden "cache" for macros that would survive a browser restart, and certainly not a windows restart.

Really, no matter how weird, when writing macros I quite often run into such situations, that things happen that are just NOT possible, and it drives me NUTS! But still, each time, after searching like crazy and doubting my sanity, sooner or later the reason is finally found - and usually completely embarassing... Oops..! grinning smiley

Okay, thinking hard, this is what I'd perhaps try:
1) Rename "bugmenotauto.kmm" to "bugmenotauto_kmm", to be 100% sure it's disabled. Restart browser (and loader if used)...
Does it still work??

If yes:
2) set a line
alert("test","test bugmenot");
into your own macro. Restart. Does the alert show?? Let me guess: No...?

Oh, another thought:
How do you actually use this macro, which menu? Look up in explorer the menu text, it might be duplicate...
And you sure you're searching in the correct installation folder for the running version...? Sorry, but not that many ideas remaining, and all "tried" myself already ;-)



Edited 1 time(s). Last edit at 06/14/2010 05:48AM by siria.

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 14, 2010 06:01AM

renaming the bugmenotauto does not fix it.
putting in a line: alert("blah","blah");
does nothing - it still opens a new window and performs normally
it is in the right click on page -> send to menu
yes i am in the right directory, because if i delete the file, the macro disappears from the menu.

Re: Macro miracles ;-)
Posted by: siria
Date: June 14, 2010 06:19AM

So your buildmenu-macro is active, but not the BugMeNot-macro...
Okay, now replace all "BugMeNot" occurances inside your own file to "BugMeNotMine", rename also the kmm file this way, and restart (still keep that alert line to check when that macro turns active)...

Oh, BTW, do you occasionally check the Error Console...?
And do you have an editor with kmm syntax hightlighting...?

Oh, and yet another thought:
You could rename the kmm file to ZZZbugmenot, then the alert should work at any case... (in theory cool smiley)



Edited 2 time(s). Last edit at 06/14/2010 06:24AM by siria.

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 14, 2010 07:08AM

have seen nothing in error console relating to bugmenot.kmm - although it shows a ton of errors for another macro I just installed (getjetmail.kmm)

i have no editor with syntax highlighting (notepad)

renamed file to zzz* - alert worked
renamed it back - original behavior

relabeled all occurrences of bugmenot to bugmenotmine as well as file - alert worked

now have bugmenot and bugmenotmine - both identical except for every occurrence of bugmenot = bugmenotmine in other file

bugmenot (with alert) - original behavior (opens new tab...)
bugmenotmine (with alert) - alert box

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 14, 2010 07:19AM

i relabeled every bugmenot to bugmenotyou in bugmenot.kmm (kept the same filename) - alert worked. renamed them back - back to original macro behavior.

how can it continue to do the action from the original macro which does not exist anymore?

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 14, 2010 07:34AM

if i edit the bugmenotmine macro, leaving the filename and macro name the same, it changes operation. why doesn't that happen with the bugmenot macro?

Re: Macro miracles ;-)
Posted by: jsnj
Date: June 14, 2010 08:51AM

Quote
kmeleon_user
well, i'm messing around trying to learn macros, and wanted to edit this one. my changes DO NOT AFFECT the operation of this macro at all.
If i delete the macro from the macros folder, it is gone, but if i edit it to look like:
# K-Meleon Macros (http://kmeleon.sourceforge.net/wiki/index.php?id=MacroLanguage)

# ---------- BugMeNot ----------------------------------------------------------------------------------------------
#
# Dependencies : main.kmm (OpenURL), sendto.kmm (menus)
# Resources    : -
# Preferences  : -
#
# ------------------------------------------------------------------------------------------------------------------

BugMeNot{
}

# ----- PRIVATE

_BugMeNot_BuildMenu{
index($macroModules,";SendTo;")>-1?setmenu($_SendTo_Page,macro,"&BugMeNot",BugMeNot): setmenu(DocumentOpenExternal,macro,"&BugMeNot",BugMeNot);
}
$OnInit=$OnInit."_BugMeNot_BuildMenu;";

# ------------------------------------------------------------------------------------------------------------------
$macroModules=$macroModules."BugMeNot;";
it functions normally...
how can that be????
there is no code in the macro, but it still works...
i restarted kmeleon and my computer. still the macro opens a window to bugmenot WITHOUT ANY CODE in the macro !?!?!?

I've run into situations where sometimes K-M just doesn't like a certain file for some reason that's above my paygrade. Whether it be some sort of encoding issue or whatever. Sometimes copying the contents from the kmm file at issue and pasting into another blank file & saving it there replacing the original can resolve things. Worth a try if you haven't already. Can't hurt.

Quote

Really, no matter how weird, when writing macros I quite often run into such situations, that things happen that are just NOT possible, and it drives me NUTS! But still, each time, after searching like crazy and doubting my sanity, sooner or later the reason is finally found - and usually completely embarassing... Oops..! grinning smiley

LOLOL...been there MANY times.

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 14, 2010 09:24AM

just want to say thanks for the help before i call it a day. i really appreciate you taking the time to help me out.

Re: Macro miracles ;-)
Posted by: siria
Date: June 14, 2010 02:50PM

Quote
jsnj
LOLOL...been there MANY times.

LOL! Good to know I'm not the only one, and far more experienced people still have that little prob too grinning smiley Oh yes, the encoding, cannot count how many gray hairs that stuff has cost me already!! Who would have thought that a special character in a *comment* line would get KM choking?! Guess that was in a CSS file, but not sure anymore. Bad combination at any rate that I'm often using german special characters in kmm and my editor doesn't use UTF-8 automatically, so tend to forget to switch - oops ;-)

Quote
kmeleon_user
i relabeled every bugmenot to bugmenotyou in bugmenot.kmm (kept the same filename) - alert worked. renamed them back - back to original macro behavior.
how can it continue to do the action from the original macro which does not exist anymore?

Simply because it does not, but keeps getting overwritten by another macro grinning smiley In my eyes clearly proven by your renaming results: if *your* macro has another name, it is NOT overwritten and the alert works. If it has the same name, it's overwritten by the other macro. The key must be in your explorer search! Do it again, this time simply with "BugMeNot", allow all cases, search in whole KM and whole c:/users/KM/profiles folder (folder depending on OS), then disable/rename all hits... Perhaps it has a blank before the {, or perhaps it's still another folder, but it MUST be there and you'll find it grinning smiley

PS: What a fitting name for this - bugmenot! LOL!!

Re: Macro miracles ;-)
Posted by: desga2
Date: June 17, 2010 03:30AM

Are you sure that you aren't using the Loader?
Did you checked if macro is disabled in Preferences (F2) -> Macros?
Are you sure you are modifying in corrected K-Meleon installation and profile; Edit -> Configuration -> Profile Directory?
Did you checked you have using local profiles in K-Meleon folder (profile.ini) or multiprofiles in %appdata% folder?
Did you search "&BugMeNot" in .kmm files in K-Meleon folder and subfolders, sure menu is showed "BugMeNot", with B underlined?

Try to change the name to menu and macro function.

K-Meleon in Spanish

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 20, 2010 01:29AM

well, thanks you guys. i found it. it finally clicked in my head that moving the file would (obviously) kill the menu entry, but the other macro would still be defined.
an explorer search for "a word or phrase in file" didn't find it, but
O:\Programs\Apps\KMeleon\macros>find /i "bugmenot" *.kmm
found the bugmenot macros in the servers.kmm file from the "Extra Servers" extension. mad smiley

so my problem is now with Explorer's search for "a word or phrase in file" capability. it is weird that it didn't show up at all; both files are plain ASCII text files. does disabling the Indexing Service mean you can't search in files? i just ran a couple of tests and the search for a word or phrase in files is only matching filenames...

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 20, 2010 02:13AM

so how do i report that the "Extra Servers" extension has a naming conflict with the BugMeNot one? i searched, but didn't find a thread for it like this one has.

Re: Macro miracles ;-)
Posted by: SoerenB
Date: June 20, 2010 02:29AM

Hi,

maybe a good starting point for using a different file manager?
I use freeCommander, which has a well structured GUI for such a task - and many others.

Cheers
SoerenB

No more own machines, because of addiction.
Don't know when I'll be back to normal ...

Re: Macro miracles ;-)
Posted by: siria
Date: June 20, 2010 03:15AM

WHOW. Who would have suspected something like this???
How I hate Vista/Win7, argh....
*DoingAQuickPrayerForMyTrustyWin98Box* cool smiley

Please post if another filemanager really helped...

Now that the problem is finally identified you can easily change the name yourself in one of the macros. If you need both ;-)

Unfortunately such double names will happen quite often with macros that have the same purpose sad smiley On the other hand it's 'usually' easy to cure for users, and there don't exist that many same-purpose-macros yet for KM... ;-)
Now if one of the two bugmenot macro authors will change their code, no idea. I'm with you that such problems should and could be prevented, once they are noticed, but seeing that in THIS case both commands most likely do the same thing anyway, this doesn't give any real problem. Uhm, usually cool smiley

But what a bad luck you tried experimenting just with such a case, and then your explorer search didn't work - that's really an incredible combination, wow!! All that struggle and frustration...

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 20, 2010 05:17AM

yeah tell me about it.

i already renamed one and it is working fine now. all this because the macro uses bugmenot's old interface (which redirects to the new one and still works fine) and i just HAD to update the URL, lol.

i find bugmenot very usefull, so i have all the macros/extensions that i found for it (part of my problem lol). i also have a bugmenot bookmarklet, but i have to allow popups for that to work. it seems that javascript in a bookmarklet or typed into the address bar is considered as "while the page is loading" so it cannot open a new window when popups are disabled.

thanks for the link to free commander, that looks pretty cool. i'm going to give it a try.

Re: Macro miracles ;-)
Posted by: SoerenB
Date: June 20, 2010 05:38AM

one way to use bookmarklets in K-M

Cheers
SoerenB

No more own machines, because of addiction.
Don't know when I'll be back to normal ...

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 20, 2010 06:41AM

i want to use
javascript:window.open();
which will not work in the URL bar, as a bookmark, or as a hotlink if the pop-up blocker is turned on. But i just press F8 and it works fine in any of those places. it is not a big hassle, just odd.

thanks for reminding me about the hotlinks, i had forgotten. now i have 6 7 ways of using bugmenot, lol

Re: Macro miracles ;-)
Posted by: siria
Date: June 20, 2010 06:48AM

7?! LOL! grinning smiley grinning smiley
Hmm... I think I've seen somewhere a js code that executes key presses, perhaps works for F8/code/F8, but no idea ;-)

Re: Macro miracles ;-)
Posted by: kmeleon_user
Date: June 20, 2010 08:07AM

being able to execute keypresses in the context of the browser would be a major security hole. nevertheless, i tried - to no avail. and, coming the other way, i found out that F6-F9, being used by the browser, don't get passed into the page at all.

K-Meleon forum is powered by Phorum.