Development :  K-Meleon Forum
K-Meleon development related discussions. 
Pages: Previous12
Current Page: 2 of 2
Re: K-Meleon 0.9 Beta for TESTING
Posted by: Fast Sjonny
Date: October 19, 2004 03:57AM

Sorry, have to learn reading better. Jsnj noted the bmp-menu 'bug' (disabled in the new build because of misalignment). But other point still unclear to me...

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: ra
Date: October 19, 2004 04:30AM

Clicking on a mp(e)g-link just starts downloading, no prompt, where to save the file (it will be saved in the users temp folder!) and the file will be opened after the download has finished. Looks like I'm not happy with this change... ;-/ BTW: Doesn't happen with wmv-files.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: jsnj
Date: October 19, 2004 04:52AM

When using the layer-close button with the right-mouse-button in the default and phoenix-themes I get a pop-down menu with 6 options.
The last three options are focus-options.
When using my own skin, they are gone but I can't find the difference in all pref-files as toolbars.cfg etc..


Check your toolbars file, make sure the CloseButton menu is referenced:

Close{
%ifplugin macros
macros(Close)|CloseButton


Clicking on a mp(e)g-link just starts downloading, no prompt, where to save the file (it will be saved in the users temp folder!) and the file will be opened after the download has finished. Looks like I'm not happy with this change... ;-/ BTW: Doesn't happen with wmv-files.

This must be because of the mimeTypes file, but it hasn't changed since the first beta. It's based on the one from the W build since we can't get a decent mimeType handler to work with the betas. Most users complained during 0.8.2 that files didn't automatically open, so most media files are opened automatically with that default mimeTypes file. I'll check on the wmv problem.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: Fast Sjonny
Date: October 19, 2004 02:17PM

Thanks jsnj ;-))

Jan

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: ra
Date: October 19, 2004 06:36PM

This must be because of the mimeTypes file, but it hasn't changed since the first beta.

Yeah, you caught me surfing only occasionally with .9beta. *g*

It's based on the one from the W build since we can't get a decent mimeType handler to work with the betas. Most users complained during 0.8.2 that files didn't automatically open, so most media files are opened automatically with that default mimeTypes file.

Oh my... I hate it if a browser starts downloading 'things', saving them 'somewhere' and loading programs to launch those things without prompting me! I want to save files that can't be opened within the browser 95% of the time (first). There are security aspects as well.

But well, maybe other users want it that way...

I'll check on the wmv problem.

For me it is the way I expect K-M to behave, so it's no problem. :-)

But I agree that it is better to have a consistent experience.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: rmn
Date: October 19, 2004 06:56PM

- I hate it if a browser starts downloading 'things', saving them 'somewhere' and loading programs to launch those things without prompting me!
- But well, maybe other users want it that way...

Agreed on both. I can still use Save Link As.

Of course, ideally, we should have a dialog box asking what to do. Is it in BTS yet?

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: ra
Date: October 19, 2004 07:00PM

Agreed on both.

:-)

I can still use Save Link As.

Not always. There are sites that are very strict in referer checking.

Of course, ideally, we should have a dialog box asking what to do.

Yeah, that would be really nice.

Is it in BTS yet?

Dunno?

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: Martin
Date: October 19, 2004 07:44PM

I found two little bugs in the toolbar. The button for the pop-up blocker has only one image (the version 0.82 had an image for the active pop-up blocker and an image for the inactive pop-up blocker, 0.9b has only the image for the inactive pop-up blocker).
The second problem is the search button. The button don't work here. Ctrl+G works, also when I go over the menu.
Another thing is that Ctrl+C, Ctrl+V and Ctrl+X are not activated. I had to do that by hand in the accelerators menu.

Just for the look, would it possible to put the search button back to the main toolbar?

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: Martin
Date: October 19, 2004 07:49PM

The homepage button also don't work here in version 0.9b, sorry forget that in my post before.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: ra
Date: October 20, 2004 01:38AM

Martin,

which beta are you using and did you install in an empty directory?

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: LeVito
Date: October 20, 2004 01:54AM

I like the new beta! Still as fast as the 0.82 but far more comfortable to use. But there is a problem that was already there in earlier versions:

If I open a new window and press F11 to make it fullscreen, then close it with Alt+F4, K-Meleon will open every new link from the first window in fullscreen mode.

But nevertheless, great work, guys! Can't wait until 0.9 release!!

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: jsnj
Date: October 20, 2004 03:11AM

Of course, ideally, we should have a dialog box asking what to do. Is it in BTS yet?

I don't think so, but Ulf & Andrew know about it, and when we were trying to get the XUL mimeType handler to work in the betas it was posted in the dev list. But it's a good idea to formally file an RFE.


I found two little bugs in the toolbar. The button for the pop-up blocker has only one image (the version 0.82 had an image for the active pop-up blocker and an image for the inactive pop-up blocker, 0.9b has only the image for the inactive pop-up blocker).
The second problem is the search button. The button don't work here. Ctrl+G works, also when I go over the menu.


Couple questions: Which skin are you using? Also did you try & import your 0.8.2 cfg files into the beta build? If so, that may be where the problem is.


Another thing is that Ctrl+C, Ctrl+V and Ctrl+X are not activated. I had to do that by hand in the accelerators menu.

This would suggest that you're using the first beta which had issues with some files in the res folder. Should be fixed in the latest available beta.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: Martin
Date: October 20, 2004 10:37PM

I'm using beta2 with the standard skin.
I had my profile left in the K-Meleon directory, the rest of the folder was empty when I installed the the new version.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: Martin
Date: October 21, 2004 02:46AM

I installed K-Meleon now new in an empty folder and then I copied my bookmark file in the new profile folder.
Now all buttons are working, but I had to activate Ctr+C, +V, +X again by hand.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: ra
Date: October 21, 2004 02:49AM

Please install in a new or completely empty directory. There sadly will be such problems if you use an old profile.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: jsnj
Date: October 21, 2004 04:58AM

but I had to activate Ctr+C, +V, +X again by hand.

Hmm...what OS are you using? I'm on Win2k SP4 and can't reproduce.

Is anyone else having problems with those accelerators at default with beta 2? If so, please report what OS you may be using, just in case it matters.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: Martin
Date: October 23, 2004 03:46AM

I'm using Win2k with SP4, too.

I don't what happend a few minutes ago, but I never had such a behaviour by K-Meleon. Maybe someone has an idea.
I was browsing with two open K-Meleon windows, suddenly K-Meleon didn't load any images from the sites. I closed all windows, started K-Meleon again, but still no images. Then I take a look in the option and there was under privacy "Do not laod images" activated. I use "Accept all images". I don't know how the options where changed during browsing, all I know, that I didn't change that.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: ndebord
Date: October 23, 2004 04:26AM

Martin,

M>>I was browsing with two open K-Meleon windows, suddenly K-Meleon didn't load any images from the sites. I closed all windows, started K-Meleon again, but still no images. Then I take a look in the option and there was under privacy "Do not laod images" activated. I use "Accept all images". I don't know how the options where changed during browsing, all I know, that I didn't change that.

And here I thought I had done something wrong. I had the exact same experience. Suddenly the default setting was "Do not load images" and I had to change it back manually.


N
Win98se

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: jsnj
Date: October 23, 2004 06:05AM

Might have something to do with the accelerator, F7. Did either of you click it for some reason? Maybe in an attempt to get to the URL Bar w/F6? Perhaps I shouldn't assign those as default accelerators for popups F8 & images F7.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: Martin
Date: October 23, 2004 09:06PM

I used F5 to reload the website, but not F6 or F7.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: ra
Date: October 23, 2004 11:00PM

Is this now a clean setup? Without any files (including your old profile) from prior km-versions?

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: Martin
Date: October 24, 2004 01:21AM

This is a new install in an empty folder.

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: ndebord
Date: October 26, 2004 10:40AM

jsnj,

<<Might have something to do with the accelerator, F7. >>

Didn't hit any function keys. Just browsing and using the normal back and forward buttons and clicking on layer URLs. And this is that clean install I did after I mucked up the cache settings with changes.

N

N

Options: ReplyQuote
Re: K-Meleon 0.9 Beta for TESTING
Posted by: someguy
Date: October 29, 2004 01:53PM

link broken, so i cant download so fix it or let us know its not working or something

Options: ReplyQuote
Pages: Previous12
Current Page: 2 of 2


K-Meleon forum is powered by Phorum.