Development :  K-Meleon Forum
K-Meleon development related discussions. 
submenu hotkeys don't work ?
Posted by: old joe
Date: October 15, 2002 03:20AM

Hi. I tried out beta .65 after a long absence and was blown away by the improvements. !
With .6 I used to have problems with netscape bookmarks.Now I see Kmeleon
does Opera and Netscape bookmarks.
Plus you can use first letter selection to jump to the bookmark items without
having to "arrow key" all the way down to the target item.

That _alone_ makes Kmeleon preferred to Mozilla for me.
This is a must have feature and Kmeleons got it.
yeah !

speaking of keyboard hotkeys ,the Menu Bar's top level hotkeys work,
ie Alt +E , drops down Edit menu from the Menu Bar.
However the Submenu itmes on that menu don't, ie I can't press
P and have it open the preferences menu.
(I have rebar disabled).
Is this a bug , or is there a trick I am missing ?

Thanks to any who can shed light on this.

ps love that throbber animation.

Options: ReplyQuote
Re: submenu hotkeys don't work ?
Posted by: po
Date: October 15, 2002 06:30AM

the only light i can shed is that it works for me on win98se... what environment are you using?

Options: ReplyQuote
Re: submenu hotkeys don't work ?
Posted by: po
Date: October 15, 2002 06:49AM

...and, on further investigation, i can activate the menu items with the accel keys even with the rebar menu enabled, if i activate the top-level menu with the mouse first... go figure.

Options: ReplyQuote
solved !
Posted by: old joe
Date: October 15, 2002 08:10PM

> what environment are you using?

win95b gutted with ieradicator.
No trace of IE on my machine. (my windows directory is only 42 mb -was 39 on install til I started adding my apps in - I think xp windows folder is over 1 GB. ).
I have, though, run 50comupd to install latest version of comctl32.dll tho (ver 5.8),
as well as a new version of mfc42.dll and mscvrt.dll.

Solved ! smiling smiley
I found a workaround.
Turns out if I disable the "bitmapped menu" plugin then all the menu and submen
hotkeys work perfectly.

The only submenus that did work before with the bitmapped menus implemented were the "Go" submenu history itmes, ie, 0 , 1, 2, 3, etc.

Also, I was only able to "first letter" menu select my way through the bookmark
dropdowns _after_ I had added a new bookmark.
Now with bitmapped menus disable it works right from a fresh launching of Kmeleon.

I compared menu.cfg files before and after disabling bitmapped menus and could see no difference. The bitmapping on my system interferes with hotkeys somehow , I guess.

Anyway it works great now.
Thank you, Po, for responding.


Options: ReplyQuote

K-Meleon forum is powered by Phorum.